Objektmodelle der Microsoft Office Web Components

Wählen Sie ein Objektmodell aus der folgenden Liste aus.

Objektmodell des Diagrammarbeitsbereichs

Objektmodell des Datenquellen-Steuerelements

Objektmodell der PivotTable-Liste

Objektmodell der Kalkulationstabelle


Microsoft Office-Diagrammarbeitsbereiche: Beispiele

Erstellen von datengebundenen Diagrammen

Erstellen eines Diagramms unter Verwendung von Daten, die als Matrix angegeben werden

Erstellen eines Diagramms unter Verwendung von Daten, die als Zeichenketten angegeben werden

Erstellen eines Diagramms unter Verwendung von Daten aus einer ADO-Datensatzgruppe

Erstellen eines Diagramms unter Verwendung von Daten aus einer Microsoft Office-Kalkulationstabelle

Erstellen eines Diagramms unter Verwendung von Daten aus einem Microsoft Office-Datenquellensteuerelement

Verwenden von Diagrammen

Ermitteln einer bestimmten Achse eines Diagramms

Erstellen eines Diagramms, das mehr als einen Diagrammtyp enthält

Weshalb gibt es eine Diagrammsammlung?

Weshalb weisen mehrere Diagramme in einem Diagrammarbeitsbereich dieselben Rubriken auf?


Deklarieren und Verwenden von Ereignisprozeduren in VBScript

Sie deklarieren Ereignisprozeduren in Visual Basic unter Verwendung der Private und ByVal-Schlüsselwörter und Argumente mit expliziten Typdeklarationen, wie es im nachfolgenden Beispiel gezeigt wird.

Private Sub ChartSpace1_Click(ByVal ChartEventInfo As OWC.WCChartEventInfo)

Diese Prozedurendeklaration funktioniert in VBScript nicht, weil VBScript diese Schlüsselwörter nicht verwendet und weil alle Argumente als Variant übergeben werden. Stattdessen deklarieren Sie Ereignisprozeduren in VBScript, indem Sie Ereignisname und Argumentname verwenden, wie es im nachfolgenden Beispiel gezeigt wird.

Sub ChartSpace1_Click(ChartEventInfo)

Der Name des Arguments selbst stellt lediglich eine Konvention in einem beliebigen Container dar. Standardmäßig wird das Argument in den vorausgehenden Beispielen als ChartEventInfo bezeichnet, obwohl Sie einen beliebigen Argumentnamen verwenden könnten.

Vorsicht Einige Skripteditoren (einschließlich Microsoft Script Editor) füllen die Argumentliste nicht auf, wenn Sie eine Ereignisprozedur erstellen. Um sicherzustellen, dass Ihre Ereignisprozedur einwandfrei ausgeführt wird, beachten Sie den Objektbrowser oder das Thema zum entsprechenden Ereignis in der Hilfe, und vervollständigen Sie die Argumentliste selbständig.


Verwenden von benannten Konstanten in VBScript

Sie können in VBScript-Code keine benannten Konstanten verwenden. Das nachfolgende Beispiel funktioniert in Visual Basic, nicht aber in VBScript.

Set valueAxis = ChartSpace1.Charts(0).Axes(chAxisPositionLeft)

VBScript betrachtet die benannte Konstante chAxisPositionLeft als eine beliebige, nichtinitialisierte Variable, deshalb beträgt ihr Wert 0 (Null). Weil der aktuelle Wert von chAxisPositionLeft -3 beträgt, funktioniert dieser Code in VBScript nicht erwartungsgemäß.

Die Constants-Eigenschaft gibt ein Objekt zurück, das es VBScript-Programmierern gestattet, benannte Konstanten zu verwenden. Diese Eigenschaft ist bei allen Toplevel-Containerobjekten vorhanden (CharSpace, DataSourceControl,PivotTable und Spreadsheet). Sie gibt ein Objekt zurück, das alle benannten Konstanten enthält, die in der Webkomponenten-Typenbibliothek für Microsoft Office verfügbar sind (unabhängig davon, welchem Objekt die Constants-Eigenschaft zugewiesen wird, gibt diese immer den vollständigen Satz der benannten Konstanten zurück).

Um benannte Konstanten in VBScript zu verwenden, können Sie eine Objektvariable für das Objekt erstellen, das von der Constants-Eigenschaft zurückgegeben wurde, und anschließend dieses Objekt dazu verwenden, die benannten Konstanten in Ihrem Code zu qualifizieren, wie es im nachfolgenden Beispiel gezeigt wird.

Set c = ChartSpace1.Constants
Set valueAxis = ChartSpace1.Charts(0).Axes(c.chAxisPositionLeft)

Sie können die Constants-Eigenschaft auch direkt in einem Ausdruck verwenden, wenn Sie nur eine Konstante verwenden, wie es im nachfolgenden Beispiel gezeigt wird.

Spreadsheet1.ActiveSheet.Export "sstest.xls", Spreadsheet1.Constants.ssExportActionNone

Anmerkung Sie können die Constants-Eigenschaft in Visual Basic verwenden. Dies ist jedoch weder erforderlich noch empfehlenswert. Das Verwenden der Constants-Eigenschaft in Containern, wenn dies nicht erforderlich ist, führt zu einer deutlich langsameren Ausführung Ihres Codes.


Verwenden von Microsoft Office Web Components in Formularen

Sie können die Microsoft Office Web Components genauso in ein Formular aus Microsoft Visual Basic oder Visual Basic für Applikationen einfügen, wie Sie auch beliebige andere ActiveX-Steuerelemente in ein Formular integrieren. Denken Sie daran, dass die Eigenschaftentoolbox einer Microsoft Office-Webkomponente in einem modalen Formular nicht angezeigt werden kann. Wenn der Benutzer eines modalen Formulars auf die Schaltfläche Eigenschaftentoolbox auf der Symbolleiste einer Microsoft Office-Webkomponente oder auf den Befehl Eigenschaftentoolbox im Kontextmenü klickt, wird eine Fehlermeldung angezeigt. In Visual Basic und in Visual Basic für Applikationen können Sie die ShowModal-Eigenschaft verwenden, um ein Formular zur Laufzeit modusfrei zu machen. Die gleiche Überlegung gilt auch für modale Formulare, die in einer anderen Entwicklungsumgebung als Microsoft Visual Basic und Microsoft Office erstellt wurden.


BeforeCollapse-Ereignis

Tritt ein, wenn die Reduzierschaltfläche auf einer Datenseite angeklickt wird.

Syntax

Private Sub DataSourceControl_BeforeCollapse(DSCEventInfo as DSCEVENTINFO)

DSCEventInfo Das DSCEventInfo-Objekt, welches Informationen über das Ereignis enthält.


BeforeCommand-Ereignis

Tritt ein, wenn vor dem Ausführen des standardmäßigen Befehls ein Tabellenblattbefehl verwendet wird. Dieses Ereignis gibt Ihnen die Möglichkeit, den Befehl programmseitig abzubrechen oder zu verändern.

Syntax

Private Sub Spreadsheet_BeforeCommand(SpreadsheetEventInfo as SpreadsheetEventInfo)

SpreadsheetEventInfo Das SpreadsheetEventInfo-Objekt, welches Informationen über das Ereignis enthält.

Bemerkungen

Setzen Sie bei dem SpreadsheetEventInfo-Objekt die ReturnValue-Eigenschaft auf False, um zu verhindern, dass die angegebene Änderung eintritt.

Verwenden Sie die Command-Eigenschaft, um den Befehl zu identifizieren, der das Eintreten des Ereignisses verursacht hat. Die Command-Eigenschaft gibt eine der SheetCommandEnum-Konstanten zurück. Beachten Sie, dass die ssHelp-Befehlskonstante nicht unterstützt wird.

Bemerkungen

Informationen über das Verwenden von Ereignissen in VBScript finden Sie im Abschnitt Deklarieren und Verwenden von Ereignisprozeduren in VBScript


BeforeExpand-Ereignis

Tritt immer dann ein, wenn auf einer Datenseite die Schaltfläche Erweitern angeklickt wird.

Syntax

Private Sub DataSourceControl_BeforeExpand(DSCEventInfo as DSCEVENTINFO)

DSCEventInfo Das DSCEventInfo-Objekt, welches Informationen über das Ereignis enthält.


BeforeFirstPage-Ereignis

Tritt ein, bevor die erste Gruppe von Datensätzen auf einer Seite mit angefügten Daten angezeigt wird.

Syntax

Private Sub DataSourceControl_BeforeFirstPage(DSCEventInfo as DSCEVENTINFO)

DSCEventInfo Das DSCEventInfo-Objekt, welches Informationen über das angegebene Ereignis enthält.


BeforeLastPage-Ereignis

Tritt ein, bevor die letzte Gruppe von Datensätzen auf einer Seite mit angefügten Daten angezeigt wird.

Syntax

Private Sub DataSourceControl_BeforeLastPage(DSCEventInfo as DSCEVENTINFO)

DSCEventInfo Das DSCEventInfo-Objekt, welches Informationen über das angegebene Ereignis enthält.


BeforeNextPage-Ereignis

Tritt ein, bevor die nächste Gruppe von Datensätzen auf einer Seite mit angefügten Daten angezeigt wird.

Syntax

Private Sub DataSourceControl_BeforeNextPage(DSCEventInfo as DSCEVENTINFO)

DSCEventInfo Das DSCEventInfo-Objekt, welches Informationen über das Ereignis enthält.


BeforePreviousPage-Ereignis

Tritt ein, bevor die vorherige Gruppe von Datensätzen auf einer Seite mit angefügten Daten angezeigt wird.

Syntax

Private Sub DataSourceControl_BeforePreviousPage(DSCEventInfo as DSCEVENTINFO)

DSCEventInfo Das DSCEventInfo-Objekt, welches Informationen über das Ereignis enthält.


ButtonClick-Ereignis

Tritt immer dann ein, wenn der Benutzer auf eine Navigationsschaltfläche klickt.

Syntax

Private Sub RecordNavigationControl_ButtonClick(navButton as navButtonEnum)

navButton Gibt die Schaltfläche an, die bei Anklicken das ButtonClick-Ereignis auslöst. Kann eine der navButtonEnum-Konstanten sein.

Anmerkungen

Informationen über das Verwenden von Ereignissen in VBScript finden Sie im Abschnitt Deklarieren und Verwenden von Ereignisprozeduren in VBScript.


Calculate-Ereignis

Tritt ein, wenn die angegebene Kalkulationstabelle neu berechnet wird.

Syntax

Private Sub Spreadsheet_Calculate(EventInfo as SpreadsheetEventInfo)

EventInfo Das SpreadsheetEventInfo-Objekt enthält Informationen über das Ereignis.

Anmerkungen

Informationen über das Verwenden von Ereignissen in VBScript finden Sie im Abschnitt Deklarieren und Verwenden von Ereignisprozeduren in VBScript.


CancelEdit-Ereignis

Tritt immer dann ein, wenn der Benutzer den Bearbeitungsmodus abbricht.

Syntax

Private Sub Spreadsheet_CancelEdit(SpreadsheetEventInfo as SpreadsheetEventInfo)

SpreadsheetEventInfo Das SpreadsheetEventInfo-Objekt, welches Informationen über das Ereignis enthält.

Anmerkungen

Informationen über das Verwenden von Ereignissen in VBScript finden Sie im Abschnitt Deklarieren und Verwenden von Ereignisprozeduren in VBScript.


Change-Ereignis

Tritt immer dann ein, wenn sich Daten in einer oder mehreren Zellen ändern. Sowohl Bearbeitungs- als auch Kopieren/Einfügen-Operationen führen zum Eintreten dieses Ereignisses .

Syntax

Private Sub Spreadsheet_Change(SpreadsheetEventInfo as SpreadsheetEventInfo)

SpreadsheetEventInfo Das SpreadsheetEventInfo-Objekt, welches Informationen über das Ereignis enthält.

Anmerkungen

Dieses Ereignis tritt nach dem EndEdit-Ereignis ein. Zu diesem Zeitpunkt sind die Daten bereits geändert, und die Änderung kann nicht abgebrochen werden.


Click-Ereignis

Tritt immer dann ein, wenn der Benutzer auf das angegebene Steuerelement klickt.

Syntax

Private Sub Object_Click(EventInfo)

Object Ein ChartSpace, PivotTable oder Spreadsheet-Objekt.

EventInfo Das SpreadsheetEventInfo oder WCChartEventInfo-Objekt, dass Informationen über das Ereignis enthält. Sie können dieses Argument nicht für das PivotTable-Objekt verwenden.

Anmerkungen

Informationen über das Verwenden von Ereignissen in VBScript finden Sie im Abschnitt Deklarieren und Verwenden von Ereignisprozeduren in VBScript.


Click-Ereignis: Beispiel

Diese Prozedur wird immer dann ausgeführt, wenn der Benutzer mit der Maus klickt und der Zeiger sich über dem Steuerelement mit dem Namen ChartSpace1 befindet.

Sub ChartSpace1_Click(chinfo)
    If chinfo.AltKey then
        ' Handle alt case here.
    End If
End Sub


Command-Ereignis

Tritt ein, sobald ein Spreadsheet-Befehl mit dem Ausführen fertig ist. Verwenden Sie das BeforeCommand-Ereignis, wenn Sie dazu in der Lage sein möchten, die standardmäßige Befehlsaktion abzubrechen.

Syntax

Private Sub Spreadsheet_Command(SpreadsheetEventInfo as SpreadsheetEventInfo)

SpreadsheetEventInfo Das SpreadsheetEventInfo-Objekt, welches Informationen über das Ereignis enthält.

Anmerkungen

Verwenden Sie die Command-Eigenschaft, um den Befehl zu identifizieren, der das Eintreten des Ereignisses verursacht hat. Die Command-Eigenschaft gibt eine der SheetCommandEnum-Konstanten zurück. Beachten Sie, dass die ssHelp-Befehlskonstante nicht unterstützt wird.

Anmerkungen

Informationen über das Verwenden von Ereignissen in VBScript finden Sie im Abschnitt Deklarieren und Verwenden von Ereignisprozeduren in VBScript.


Current-Ereignis

Tritt ein, wenn ein Datensatz zum aktuellen Datensatz wird.

Syntax

Private Sub DataSourceControl_Current(DSCEventInfo as DSCEVENTINF)

DSCEventInfo Das DSCEventInfo-Objekt, welches Informationen über das Ereignis enthält.


DataError-Ereignis

Tritt immer dann ein, wenn sich ein Datenfehler ereignet.

Syntax

Private Sub DataSourceControl_DataError(DSCEventInfo as DSCEVENTINFO)

DSCEventInfo Das DSCEventInfo-Objekt, welches Informationen über das Ereignis enthält.


DataPageComplete-Ereignis

Tritt ein, wenn die angegebene Datenseite das Laden abgeschlossen hat.

Syntax

Private Sub DataSourceControl_DataPageComplete(DSCEventInfo as DSCEVENTINFO)

DSCEventInfo Das DSCEventInfo-Objekt, welches Informationen über das angegebene Ereignis enthält.


DataSetChange-Ereignis

Tritt immer dann ein, wenn ein Diagrammarbeitsbereich datengebunden ist und die Datengruppe sich verändert - beispielsweise dann, wenn eine Filteroperation stattfindet. Dieses Ereignis tritt ebenfalls auf, wenn Ausgangsdaten aus der Datenquelle verfügbar sind.

Syntax

Private Sub ChartSpace_DataSetChange()

Anmerkungen

Informationen über das Verwenden von Ereignissen in VBScript finden Sie im Abschnitt Deklarieren und Verwenden von Ereignisprozeduren in VBScript.


DblClick-Ereignis

Tritt immer dann ein, wenn der Benutzer auf das angegebene Steuerelement doppelklickt.

Syntax

Private Sub Object_DblClick(EventInfo)

Object Ein ChartSpace, PivotTable oder Spreadsheet-Objekt.

EventInfo Das SpreadsheetEventInfo oder WCChartEventInfo-Objekt, das Informationen über das Ereignis enthält. Dieser Parameter wird nicht für das PivotTable-Objekt verwendet.

Anmerkungen

Informationen über das Verwenden von Ereignissen in VBScript finden Sie im Abschnitt Deklarieren und Verwenden von Ereignisprozeduren in VBScript.


EndEdit-Ereignis

Tritt immer dann ein, wenn der Benutzer den Bearbeitungsmodus für die angegebene Kalkulationstabelle verlässt.

Syntax

Private Sub Spreadsheet_EndEdit(SpreadsheetEventInfo as SpreadsheetEventInfo)

SpreadsheetEventInfo Das SpreadsheetEventInfo-Objekt, welches Informationen über das Ereignis enthält.

Anmerkungen

Setzen Sie bei dem SpreadsheetEventInfo-Objekt die ReturnValue-Eigenschaft auf False, um zu verhindern, dass die angegebene Änderung eintritt.

Informationen über das Verwenden von Ereignissen in VBScript finden Sie im Abschnitt Deklarieren und Verwenden von Ereignisprozeduren in VBScript.


KeyDown-Ereignis

Tritt immer dann ein, wenn der Benutzer eine Taste auf der Tastatur drückt. Wenn der Benutzer die Taste gedrückt hält, wiederholt sich dieses Ereignis selbständig gemäß dem Tastatur-Wiederholungsintervall, das auf dem Computer des Benutzers festgelegt wurde. Tastaturereignisse treten in der folgenden Reihenfolge ein: KeyDown, KeyPress, KeyUp.

Syntax

Private Sub Object_KeyDown(EventInfo)

EventInfo Das SpreadsheetEventInfo oder WCChartEventInfo-Objekt, welches Informationen über das Ereignis enthält.

Anmerkungen

Informationen über das Verwenden von Ereignissen in VBScript finden Sie im Abschnitt Deklarieren und Verwenden von Ereignisprozeduren in VBScript.


KeyPress-Ereignis

Tritt immer dann ein, wenn der Benutzer eine Taste auf der Tastatur drückt und loslässt. Die Tastaturereignisse treten in der folgenden Reihenfolge ein: KeyDown, KeyPress, KeyUp.

Syntax

Private Sub Object_KeyPress(EventInfo)

EventInfo Das SpreadsheetEventInfo oder WCChartEventInfo-Objekt, welches Informationen über das Ereignis enthält.

Anmerkungen

Informationen über das Verwenden von Ereignissen in VBScript finden Sie im Abschnitt Deklarieren und Verwenden von Ereignisprozeduren in VBScript.


KeyUp-Ereignis

Tritt immer dann ein, wenn der Benutzer eine Taste auf der Tastatur loslässt. Die Tastaturereignisse treten in der folgenden Reihenfolge ein: KeyDown, KeyPress, KeyUp.

Syntax

Private Sub Object_KeyUp(EventInfo)

EventInfo Die SpreadsheetEventInfo oder WCChartEventInfo-Objekte, welche Informationen über das Ereignis enthalten.

Anmerkungen

Informationen über das Verwenden von Ereignissen in VBScript finden Sie im Abschnitt Deklarieren und Verwenden von Ereignisprozeduren in VBScript.


MouseDown-Ereignis

Tritt immer dann ein, wenn der Benutzer eine Maustaste drückt, während der Zeiger sich über einer Kalkulationstabelle oder einem Diagrammarbeitsbereich befindet.

Syntax

Private Sub Object_MouseDown(EventInfo)

EventInfo Das SpreadsheetEventInfo oder WCChartEventInfo-Objekt, welches Informationen über das Ereignis enthält.

Anmerkungen

Informationen über das Verwenden von Ereignissen in VBScript finden Sie im Abschnitt Deklarieren und Verwenden von Ereignisprozeduren in VBScript.


MouseMove-Ereignis

Tritt immer dann ein, wenn der Benutzer den Mauszeiger über den Diagrammarbeitsbereich bewegt.

Syntax

Private Sub ChartSpace_MouseMove(ChartEventInfo as WCChartEventInfo)

ChartEventInfo Das WCChartEventInfo-Objekt, welches Informationen über das Ereignis enthält.

Anmerkungen

Informationen über das Verwenden von Ereignissen in VBScript finden Sie im Abschnitt Deklarieren und Verwenden von Ereignisprozeduren in VBScript.


MouseOut-Ereignis

Tritt immer dann ein, wenn der Benutzer den Mauszeiger aus einer Zelle in einer Kalkulationstabelle herausbewegt.

Syntax

Private Sub Spreadsheet_MouseOut(SpreadsheetEventInfo as SpreadsheetEventInfo)

SpreadsheetEventInfo Das SpreadsheetEventInfo-Objekt, welches Informationen über dieses Ereignis enthält. Verwenden Sie die Range-Eigenschaft dieses Objekts, um die Zelle zurückzugeben, aus welcher der Zeiger herausbewegt wurde.

Anmerkungen

Informationen über das Verwenden von Ereignissen in VBScript finden Sie im Abschnitt Deklarieren und Verwenden von Ereignisprozeduren in VBScript.


MouseOver-Ereignis

Tritt immer dann ein, wenn der Benutzer den Mauszeiger auf eine Zelle in der angegebenen Kalkulationstabelle verschiebt.

Syntax

Private Sub Spreadsheet_MouseOut(SpreadsheetEventInfo as SpreadsheetEventInfo)

SpreadsheetEventInfo Das SpreadsheetEventInfo-Objekt, welches Informationen über dieses Ereignis enthält. Verwenden Sie die Range-Eigenschaft dieses Objekts, um die Zelle zurückzugeben, in die der Zeiger hineinbewegt wurde.

Anmerkungen

Informationen über das Verwenden von Ereignissen in VBScript finden Sie im Abschnitt Deklarieren und Verwenden von Ereignisprozeduren in VBScript.


MouseUp-Ereignis

Tritt immer dann ein, wenn der Benutzer eine Maustaste loslässt, während der Zeiger sich über einer Kalkulationstabelle oder dem Diagrammarbeitsbereich befindet.

Syntax

Private Sub Object_MouseUp(EventInfo)

EventInfo Das SpreadsheetEventInfo oder WCChartEventInfo-Objekt, welches Informationen über das Ereignis enthält.

Anmerkungen

Informationen über das Verwenden von Ereignissen in VBScript finden Sie im Abschnitt Deklarieren und Verwenden von Ereignisprozeduren in VBScript.


PivotTableChange-Ereignis

Tritt immer dann ein, wenn ein PivotTable-Listenfeld, eine Feldgruppe oder eine Summe hinzugefügt oder gelöscht wird.

Syntax

Private Sub PivotTable_PivotTableChange(Reason as PivotTableReasonEnum)

Reason Gibt an, wie sich die PivotTable-Liste geändert hat. Es kann sich um eine der PivotTableReasonEnum-Konstanten handeln.


Query-Ereignis

Tritt immer dann ein, wenn eine PivotTable-Listenabfrage erforderlich wird. Diese Abfrage wird möglicherweisen nicht sofort ausgeführt. Sie wird möglicherweise verschoben, bis die neuen Daten angezeigt werden.

Syntax

Private Sub PivotTable_Query(Reason as PivotQueryReasonEnum)

Reason PivotQueryReasonEnum erforderlich. Gibt den Grund der Abfrage an.


QueryComplete-Ereignis

Tritt auf, nachdem eine PivotTable-Listenabfrage ausgeführt wurde.

Syntax

Private Sub PivotTable_QueryComplete()

Anmerkungen

Weitere Informationen über Verwenden von Ereignissen mit VBScript, finden Sie unter Deklarieren und Verwenden der Ereignisprozeduren in VBScript.

Während der Bearbeitung des QueryComplete-Ereignisses sollten Sie die Requery-Methode (oder jede andere Methode, durch die eine Abfrage ausgelöst wird) nicht verwenden.


SelectionChange-Ereignis

Tritt immer dann ein, wenn der Benutzer eine neue Auswahl trifft. Der Benutzer kann dieses Ereignis nicht abbrechen.

Syntax

Private Sub Object_SelectionChange(SpreadsheetEventInfo as SpreadsheetEventInfo)

Object Ein ChartSpace, PivotTable, oder Spreadsheet-Objekt.

SpreadsheetEventInfo Das SpreadsheetEventInfo-Objekt, das Informationen über das Ereignis enthält. Dieses Argument kann nur mit dem Spreadsheet-Objekt angewendet werden.

Anmerkungen

Information über das Verwenden von Ereignissen in VBScript finden Sie im Abschnitt Deklarieren und Verwenden von Ereignisprozeduren in VBScript.

Sie können die Selection-Eigenschaft verwenden, um den Objekttyp der aktuellen Auswahl zu bestimmen, wie im folgenden Beispiel gezeigt wird.

Private Sub PivotTable_SelectionChange()
    If TypeName(PivotTable.Selection) = "PivotTotal" Then
        'Handle selection of a total here
    End If
End Sub


SelectionChanging-Ereignis

Tritt immer dann ein, wenn der Benutzer den Mauszeiger bewegt, während er oder sie einen Bereich auswählt. Dieses Ereignis tritt nicht ein, wenn der Benutzer einen Bereich unter Verwendung der Tastatur auswählt. Der Benutzer kann dieses Ereignis nicht abbrechen.

Syntax

Private Sub Spreadsheet_SelectionChanging(SpreadsheetEventInfo as SpreadsheetEventInfo)

SpreadsheetEventInfo Das SpreadsheetEventInfo-Objekt, das Informationen über das Ereignis enthält.

Anmerkungen

Informationen über das Verwenden von Ereignissen in VBScript finden Sie im Abschnitt Deklarieren und Verwenden von Ereignisprozeduren in VBScript.


StartEdit-Ereignis

Tritt immer dann ein, wenn der Benutzer in den Bearbeitungsmodus wechselt, während der Mauszeiger sich in einer Zelle befindet. Setzen Sie die ReturnValue-Eigenschaft des SpreadsheetEventInfo-Objekts auf False, um so zu verhindern, dass der Benutzer in den Bearbeitungsmodus wechselt.

Syntax

Private Sub Spreadsheet_StartEdit(SpreadsheetEventInfo as SpreadsheetEventInfo)

SpreadsheetEventInfo Das SpreadsheetEventInfo-Objekt, das die Informationen über das Ereignis enthält.

Anmerkungen

Informationen über das Verwenden von Ereignissen in VBScript finden Sie im Abschnitt Deklarieren und Verwenden von Ereignisprozeduren in VBScript.


ViewChange-Ereignis

Tritt immer dann ein, wenn der Benutzer eine andere PivotTable-Liste öffnet oder die Kalkulationstabellenansicht ändert.

Syntax 1 (PivotTable-Objekt)

Private Sub PivotTable_ViewChange(Reason as PivotViewReasonEnum)

Reason Die PivotViewReasonEnum-Konstante, die angibt, auf welche Weise die Ansicht verändert wurde.

Syntax 2 (Spreadsheet-Objekt)

Private Sub Spreadsheet_ViewChange(SpreadsheetEventInfo as SpreadsheetEventInfo)

SpreadsheetEventInfo Das SpreadsheetEventInfo-Objekt, das die Informationen über das Ereignis enthält.

Anmerkungen

Informationen über das Verwenden von Ereignissen in VBScript finden Sie im Abschnitt Deklarieren und Verwenden von Ereignisprozeduren in VBScript.


Add-Methode

Fügt ein Objekt zu einer Auflistung hinzu. Um weitere Informationen darüber zu erhalten, wie dies bei einer bestimmten Auflistung funktioniert, klicken Sie auf den Namen dieser Auflistung in der nachfolgenden Liste.

Criteria

ElementExtensions

GroupingDefs

GroupLevels

LookupRelationships

PageFields

ParameterValues

RecordsetDefs

SchemaFields

SchemaParameters

SchemaRelatedFields

 SchemaRelationships

SchemaRowsources

SublistRelationships

WCAxes

WCCharts

WCDataLabelsCollection

WCDataSources

WCErrorbarsCollection

WCSeriesCollection

WCTrendlines


Add-Methode (Criteria-Objekt)

Fügt ein AutoFilter-Kriterium hinzu.

Syntax

Ausdruck.Add(Criterion)

Ausdruck Ein Ausdruck, der ein Criteria-Objekt zurückgibt.

Criterion String erforderlich. Gibt das neue Kriterium an.


Add-Methode (Criteria-Objekt): Beispiel

In diesem Beispiel wird der AutoFilter für den Bereich A1:J22 aktiviert. Anschließend werden Filter für die Spalten 1 und 3 festgelegt und angewendet.

Spreadsheet1.Range("a1:j22").AutoFilter
Set af = Spreadsheet1.ActiveSheet.AutoFilter
Set filterColumnOne = af.Filters(1)
Set filterColumnThree = af.Filters(3)
filterColumnOne.Criteria.Add "blue"    ' Don't show blue in column 1.
filterColumnOne.Criteria.Add "green"    ' Don't show green in column 1.
filterColumnThree.Criteria.Add "yellow"    ' Don't show yellow in column 3.
af.Apply


Add-Methode (ElementExtensions-Auflistung)

Erstellt ein neues ElementExtension-Objekt.

Syntax

Ausdruck.Add(ElementID, FailIfThere)

Ausdruck Ein Ausdruck, der eine ElementExtensions-Auflistung zurückgibt.

ElementID String erforderlich. Gibt das ID-Tag eines HTML-Elements an, das mit dem neuen ElementExtension-Objekt erweitert wird.

FailIfThere Optionaler Boolean. Wenn dieses Argument auf True festgelegt ist und das in ElementID angegebene Objekt bereits über eine Elementerweiterung verfügt, schlägt die Add-Methode fehl. Wenn dieses Argument auf False festgelegt ist (oder nicht angegeben wurde), wird die vorhandene Elementerweiterung ersetzt.


Add-Methode (GroupingDefs-Auflistung)

Erstellt eine neue Gruppierungsdefinition. Gibt ein GroupingDef-Objekt zurück.

Syntax

Ausdruck.Add(GroupingDefName, GroupingFieldName, PageFieldName, Index)

Ausdruck Ein Ausdruck, der ein GroupingDefs-Objekt zurückgibt.

GroupingDefName String erforderlich. Gibt den Namen der neuen Gruppierungsdefinition an.

GroupingFieldName String erforderlich. Gibt den Namen des Gruppierungsfeldes an, das zum Erstellen der neuen Definition verwendet wird.

PageFieldName String erforderlich. Gibt den Namen des Seitenfeldes an, das zum Erstellen der neuen Definition verwendet wird.

Index Variant optional. Gibt die Reihenfolgeposition, den Namen oder den aktuellen Objektbezug für die Gruppierungsdefinition an, vor der die neue Gruppierungsdefinition hinzugefügt wird. Wenn Sie dieses Argument nicht angeben, wird die neue Gruppierungsdefinition an das Ende der Auflistung angefügt.

Anmerkungen

Eine Datensatzgruppendefinition, die eine Gruppierungsebene repräsentiert, verfügt über den GroupingDef-Typ, der aus dem RecordsetDef-Objekt abgeleitet wird, das die Datensatzgruppendefinition darstellt. In Bezug auf die Steuerungsbindung verhält sich eine Datensatzgruppe, die durch ein GroupingDef-Objekt definiert ist, genauso wie eine Datensatzgruppe, die durch ein RecordsetDef-Objekt definiert ist.


Add-Methode (GroupLevels-Auflistung)

Erstellt eine neue Gruppenebene. Gibt ein GroupLevel-Objekt zurück.

Syntax

Ausdruck.Add(RecordSource, FailIfThere)

Ausdruck Ein Ausdruck, der ein GroupLevels-Objekt zurückgibt.

RecordSource String erforderlich. Gibt den Namen der Datensatzquelle für die neue Gruppenebene an.

FailIfThere Optionaler Boolean. Wenn dieses Argument auf True festgelegt ist und die neue Gruppenebene bereits vorhanden ist, schlägt die Add-Methode fehl. Der Standardwert ist False.


AddIn-Methode

Fügt der angegebenen Kalkulationstabelle ein Add-In hinzu.

Syntax

Ausdruck.AddIn(AddIn)

Ausdruck Ein Ausdruck, der ein Spreadsheet-Objekt zurückgibt.

AddIn Erforderliches Objekt. Gibt das Add-In an.


AddNew-Methode

Erstellt eine neue Schemazeilenquelle und eine Datensatzgruppendefinition. Gibt ein RecordsetDef-Objekt zurück.

Syntax

Ausdruck.AddNew(Source, RowsourceType, Name)

Ausdruck Ein Ausdruck, der ein RecordsetDefs-Objekt zurückgibt.

Source String erforderlich. Gibt den Befehlstext für eine neue Schemazeilenquelle des Typs dscCommandText oder dscCommandFile oder für den Namen einer Tabelle, einer Ansicht oder einer gespeicherten Prozedur an, die als Schemazeilenquelle hinzugefügt werden soll. Weitere Informationen finden Sie im Hilfethema der CommandText-Eigenschaft.

RowsourceType Variant optional. Gibt den Typ der neuen Schemazeilenquelle an. Es kann sich um eine der dscRowsourceTypeEnum-Konstanten handeln. Die Standardkonstante ist dscCommandText.

Name Variant optional. Gibt den Namen von Datensatzgruppendefinition, Seitenzeilenquelle und Schemazeilenquelle an, die unter Verwendung der AddNew-Methode erstellt worden sind. Wenn Sie dieses Argument nicht angeben und der Wert des RowsourceType-Arguments dscTabel, dscView oder dscProcedure lautet, ist der neue Name identisch mit dem Namen, der im Source-Argument angegeben wurde (wobei automatisch Ziffern angehängt werden, um dies eindeutig zu machen, falls erforderlich). Wenn Sie dieses Argument nicht angeben und der Wert des RowsourceType-Arguments dscCommandText oder dscCommandFile ist, lautet der neue Name CommandN, wobei N für eine oder mehrere angehängte Ziffern steht.

Anmerkungen

Seitenfelder werden normalerweise mit Namen erstellt, die innerhalb der Seitendatendefinition eindeutig sind. Wenn aber ein Seitenfeld einer Datensatzgruppendefinition hinzugefügt wird, dessen primäre Seitenzeilenquelle den Typ dscProcedure, dscCommandText oder dscCommandFile aufweist, muss der Seitenfeldname mit dem Schemafeldnamen identisch sein. Dies kann zu mehreren Seitenfeldobjekten mit dem gleichen Namen in der AllPageFields-Auflistung führen. Um zwischen Objekten mit dem gleichen Namen zu unterscheiden, können Sie den Ausdruck AllPageFields("RecordsetdefName.PagefieldName") verwenden. Dabei steht RecordsetdefName für den Namen der Datensatzgruppendefinition und PagefieldName für den Namen des Seitenfeldes. Beachten Sie, dass Seitenfeldnamen keine Punkte enthalten können.


AddTotal-Methode

Erstellt eine neue Summe.

Syntax 1

Ausdruck.AddTotal(GroupingDefName, GroupingFieldName, PageFieldName, TotalType, Index)

Ausdruck Ein Ausdruck, der ein GroupingDefs-Objekt zurückgibt.

GroupingDefName String erforderlich. Gibt das GroupingDef-Objekt an, das zum Erstellen der Summe verwendet werden soll.

GroupingFieldName String erforderlich. Gibt das Gruppierungsfeld an, das zum Erstellen der Summe verwendet werden soll.

PageFieldName String erforderlich. Gibt das PageField-Objekt an, das zum Erstellen der Summe verwendet werden soll.

TotalType Erforderliches dscTotalTypeEnum-Objekt. Gibt die Funktion an, die zum Erstellen der Summe verwendet werden soll.

Index Variant optional. Gibt an, an welcher Stelle die neue Summe in die Auflistung eingefügt wird.

Syntax 2

Ausdruck.AddTotal(Name, Field, Function)

Ausdruck Ein Ausdruck, der ein PivotView-Objekt zurückgibt.

Name String erforderlich. Gibt den Namen der Summe an.

Field Erforderliches PivotField-Objekt. Gibt das Feld an, das zum Erstellen der Summe verwendet werden soll.

Function Erforderliches PivotTotalFunctionEnum-Objekt. Gibt die Funktion an, die zum Erstellen der Summe verwendet werden soll.


AddTotal-Methode: Beispiel

In diesem Beispiel wird die Gesamtsumme der PivotTable-Liste in der aktiven Ansicht hinzugefügt.

Set view = PivotTable1.ActiveView
Set c = PivotTable1.Constants
Set newTotal = view.AddTotal("myTotal", view.FieldSets("Freight").Fields(0), c.plFunctionSum)
view.DataAxis.InsertTotal newTotal


Apply-Methode

Wendet den angegebenen AutoFilter an.

Syntax

Ausdruck.Apply

Ausdruck Ein Ausdruck, der ein AutoFilter-Objekt zurückgibt.

Anmerkungen

Normalerweise verwenden Sie die AutoFilter-Methode, um den AutoFilter zu aktivieren und ihm ein oder mehrere Kriterien hinzuzufügen. Anschließend können Sie die Apply-Methode verwenden, um den neuen Filter anzuwenden. Weitere Informationen finden Sie beim Beispiel zu diesem Thema.


Apply-Methode: Beispiel

In diesem Beispiel wird AutoFilter für den Bereich A1:J22 aktiviert, es werden Filter für die Spalten 1 und 3 festgelegt, und anschließend werden die Filter angewendet.

Spreadsheet1.Range("a1:j22").AutoFilter
Set af = Spreadsheet1.ActiveSheet.AutoFilter
Set filterColumnOne = af.Filters(1)
Set filterColumnThree = af.Filters(3)
filterColumnOne.Criteria.Add "blue"    ' Don't show blue in column 1.
filterColumnOne.Criteria.Add "green"    ' Don't show green in column 1.
filterColumnThree.Criteria.Add "yellow"    ' Don't show yellow in column 3.
af.Apply


AutoFilter-Methode

Zeigt die AutoFilter-Dropdownpfeile an oder blendet sie aus.

Syntax

Ausdruck.AutoFilter

Ausdruck Ein Ausdruck, der ein Range-Objekt zurückgibt.

Anmerkungen

Verwechseln Sie diese Methode nicht mit der AutoFilter-Eigenschaft. DieseMethode gilt für ein Range-Objekt und aktiviert den AutoFilter, während die AutoFilter-Eigenschaft das AutoFilter-Objekt für eine gegebene Tabelle zurückgibt.

Normalerweise verwenden Sie dieseMethode, um den AutoFilter zu aktivieren und ihm ein oder mehrere Kriterien hinzuzufügen. Anschließend können Sie die Apply-Methode verwenden, um den neuen Filter anzuwenden. Weitere Informationen finden Sie beim Beispiel zu diesem Thema.


AutoFilter-Methode: Beispiel

In diesem Beispiel wird AutoFilter für den Bereich A1:J22 aktiviert, es werden Filter für die Spalten 1 und 3 festgelegt, und anschließend werden die Filter angewendet.

Spreadsheet1.Range("a1:j22").AutoFilter
Set af = Spreadsheet1.ActiveSheet.AutoFilter
Set filterColumnOne = af.Filters(1)
Set filterColumnThree = af.Filters(3)
filterColumnOne.Criteria.Add "blue"    ' Don't show blue in column 1.
filterColumnOne.Criteria.Add "green"    ' Don't show green in column 1.
filterColumnThree.Criteria.Add "yellow"    ' Don't show yellow in column 3.
af.Apply


AutoFitColumns-Methode

Ändert die Breite der Spalten im angegebenen Bereich, um eine optimale Breite zu erreichen.

Syntax

Ausdruck.AutoFitColumns

Ausdruck Ein Ausdruck, der ein Range-Objekt zurückgibt.


AutoFitColumns-Methode: Beispiel

In diesem Beispiel werden Zeilenhöhe und Spaltenbreite im Bereich A1:B5 der Kalkulationstabelle verändert, um eine optimale Anpassung für die Daten des Bereich zu erzielen.

Spreadsheet1.Range("a1:b5").AutoFitColumns
Spreadsheet1.Range("a1:b5").AutoFitRows


AutoFitRows-Methode

Ändert die Höhe der Zeilen im angegebenen Bereich, um eine optimale Anpassung zu erreichen.

Syntax

Ausdruck.AutoFitRows

Ausdruck Ein Ausdruck, der ein Range-Objekt zurückgibt.


AutoFitRows-Methode: Beispiel

In diesem Beispiel werden Zeilenhöhe und Spaltenbreite im Bereich A1:B5 der Kalkulationstabelle verändert, um eine optimale Anpassung für die Daten des Bereich zu erzielen.

Spreadsheet1.Range("a1:b5").AutoFitColumns
Spreadsheet1.Range("a1:b5").AutoFitRows


AutoLayout-Methode

Setzt die angegebene PivotTable-Liste auf die Standardansichtskonfiguration zurück.

Syntax

Ausdruck.AutoLayout(MaxDataFields)

Ausdruck Ein Ausdruck, der ein PivotView-Objekt zurückgibt.

MaxDataFields Optionales Long. Gibt die maximale Anzahl der Felder an, die einer Datenachse hinzugefügt werden kann, wenn es sich bei dem Datenmitglied um eine Datensatzgruppe handelt. Wenn das Argument nicht angegeben wurde oder 0 (null) ist, gibt es keine Grenze für die Anzahl der Felder, die hinzugefügt werden.

Anmerkungen

Wenn die PivotTable-Liste an eine Datensatzgruppe gebunden ist, wird der Datenachse für jedes Feld in der Datensatzgruppe eine Feldgruppe hinzugefügt.

Wenn der Anbieter multidimensional ist, werden alle Feldgruppen von den Achsen entfernt. Dadurch wird die aktuelle Ansicht vollständig gelöscht.


AutoLayout-Methode: Beispiel

In diesem Beispiel wird die aktuelle Ansicht der PivotTable-Liste zurückgesetzt.

PivotTable1.ActiveView.AutoLayout


BeginUndo-Methode

Gibt den Anfang eines Undo-Blocks an. Dies bedeutet, dass alle Anweisungen, die zwischen diesem Aufruf und der zugehörigen EndUndo-Methode liegen, durch einen einzigen Aufruf der Undo-Methode rückgängig gemacht werden. Dadurch wird es für Sie möglich, komplette Makros mit einer Anweisung zu kombinieren, die leicht rückgängig gemacht werden kann. Undo-Blöcke können geschachtelt werden.

Syntax

Ausdruck.BeginUndo

Ausdruck Ein Ausdruck, der ein ChartSpace oder Spreadsheet-Objekt zurückgibt.


BeginUndo-Methode: Beispiel

In diesem Beispiel wird ein Undo-Block erstellt, der Code enthält, mit dem Zahlenformat und Schriftart der aktiven Zelle festgelegt werden.

Spreadsheet1.EnableUndo = True
Spreadsheet1.BeginUndo
    Set ac = Spreadsheet1.ActiveCell
    ac.NumberFormat = "0.###"
    ac.Font.Color = "blue"
    ac.Font.Name = "times new roman"
Spreadsheet1.EndUndo


Calculate-Methode

Führt dazu, dass das angegebene Tabellenblatt neu berechnet wird.

Syntax

Ausdruck.Calculate

Ausdruck Ein Ausdruck, der ein Worksheet-Objekt zurückgibt.


Calculate-Methode: Beispiel

In diesem Beispiel wird eine Neuberechnung des aktuellen Tabellenblattes in der Kalkulationstabelle veranlasst.

Spreadsheet1.ActiveSheet.Calculate


Clear-Methode

ChartSpace-Objekt: Löscht alle Diagramme im Diagrammarbeitsbereich und setzt alle Formatierungen auf die Standardwerte zurück. Löscht alle Datenquellen in der WCDataSources-Auflistung.

Range-Objekt: Löscht alle Formatierungen und Daten im angegebenen Bereich.

Syntax

Ausdruck.Clear

Ausdruck Ein Ausdruck, der ein ChartSpace oder Range-Objekt zurückgibt.


ClearContents-Methode

Löscht alle Daten im angegebenen Bereich.

Syntax

Ausdruck.ClearContents

Ausdruck Ein Ausdruck, der ein Range-Objekt zurückgibt.


ClearContents-Methode: Beispiel

In diesem Beispiel werden alle Daten in Spalte 2 des aktiven Tabellenblattes gelöscht.

Spreadsheet1.ActiveSheet.Columns(2).ClearContents


ClearFormats-Methode

Löscht alle Formatierungen im angegebenen Bereich.

Syntax

Ausdruck.ClearFormats

Ausdruck Ein Ausdruck, der ein Range-Objekt zurückgibt.


ClearFormats-Methode: Beispiel

In diesem Beispiel wird die Formatierung in allen Zellen des aktuellen Tabellenblattes gelöscht.

Spreadsheet1.ActiveSheet.Cells.ClearFormats


Collapse-Methode

Bewirkt ein Reduzieren des angegebenen Abschnitts.

Syntax

Ausdruck.Collapse

Ausdruck Ein Ausdruck, der ein Section-Objekt zurückgibt.


Copy-Methode

Kopiert den angegebenen Bereich in einen anderen Bereich oder in die Zwischenablage.

Syntax

Ausdruck.Copy(RangeDest)

Ausdruck Ein Ausdruck, der ein Range-Objekt zurückgibt.

RangeDest Variant optional. Wenn Sie dieses Argument nicht angeben, wird der Quellbereich in die Zwischenablage kopiert. Wenn dieses Argument ein Range-Objekt ist, wird der Quellbereich in den angegebenen Bereich kopiert.


Copy-Methode: Beispiel

In diesem Beispiel wird die Zelle C3 in die Zelle G5 des aktuellen Tabellenblattes kopiert.

Set sht = Spreadsheet1.ActiveSheet
sht.Range("c3").Copy sht.Range("g5")


Cut-Methode

Schneidet den angegebenen Bereich aus und verschiebt ihn entweder in die Zwischenablage oder fügt ihn in einen angegebenen Zielbereich ein.

Syntax

Ausdruck.Cut(RangeDest)

Ausdruck Ein Ausdruck, der ein Range-Objekt zurückgibt.

RangeDest Variant optional. Wenn Sie dieses Argument nicht angeben, wird der angegebene Bereich an die Zwischenablage gesendet. Wenn dieses Argument ein Range-Objekt ist, wird der Quellbereich in den angegebenen Bereich verschoben.


Cut-Methode: Beispiel

In diesem Beispiel werden Formel, Daten und Formatierung von Zelle A3 nach Zelle G7 auf dem aktiven Tabellenblatt verschoben.

Set sht = Spreadsheet1.ActiveSheet
sht.Range("a3").Cut sht.Range("g7")


Delete-Methode

Hyperlink-Objekt (Syntax 1): Löscht den angegebenen Hyperlink.

Beliebige Auflistung in der Gilt für-Liste (Syntax 2): Löscht ein einzelnes Objekt aus der angegebenen Auflistung.

Syntax 1

Ausdruck.Delete

Ausdruck Ein Ausdruck, der ein Hyperlink-Objekt zurückgibt.

Syntax 2

Ausdruck.Delete(Index)

Ausdruck Ein Ausdruck, der eine der Auflistungen in der Gilt für-Liste zurückgibt.

Index Variant erforderlich. Gibt den Namen oder die Zahl des zu löschenden Objekts an.


DeleteColumns-Methode

Löscht die angegebene Anzahl von Spalten im angegebenen Bereich.

Syntax

Ausdruck.DeleteColumns(NumberOfColumns)

Ausdruck Ein Ausdruck, der ein Range-Objekt zurückgibt.

NumberOfColumns Optionales Long. Gibt die Anzahl der zu löschenden Spalten an. Wenn Sie dieses Argument nicht angeben, werden alle Spalten innerhalb des angegebenen Bereichs gelöscht.


DeleteColumns-Methode: Beispiel

Die gelöschten Spalten schließen den angegebenen Bereich ein. In diesem Beispiel werden die Spalten A und B im aktuellen Tabellenblatt gelöscht.

Spreadsheet1.ActiveSheet.Range("a1").DeleteColumns 2

In diesem Beispiel wird nur Spalte C gelöscht.

Spreadsheet1.ActiveSheet.Range("c3:d3").DeleteColumns 1

In diesem Beispiel werden die Spalten C und D gelöscht.

Spreadsheet1.ActiveSheet.Range("c3:d3").DeleteColumns


DeleteRecord-Methode

Löscht einen Datensatz aus der angegebenen Datenseite.

Syntax

Ausdruck.DeleteRecord

Ausdruck Ein Ausdruck, der ein DataPage-Objekt zurückgibt.


DeleteRows-Methode

Löscht die angegebenen Zeilen.

Syntax

Ausdruck.DeleteRows(NumberOfRows)

Ausdruck Ein Ausdruck, der ein Range-Objekt zurückgibt.

NumberOfRows Optionales Long. Gibt die Anzahl der zu löschenden Zeilen an. Wenn Sie dieses Argument nicht angeben, werden alle Zeilen innerhalb des angegebenen Bereichs gelöscht.


DeleteRows-Methode: Beispiel

Die gelöschten Zeilen schließen den angegebenen Bereich ein. In diesem Beispiel werden die Zeilen 2 und 3 im aktuellen Tabellenblatt gelöscht.

Spreadsheet1.ActiveSheet.Range("b2").DeleteRows 2

In diesem Beispiel wird nur Zeile 2 gelöscht.

Spreadsheet1.ActiveSheet.Range("b2:f5").DeleteRows 1

In diesem Beispiel werden die Zeilen 3 und 4 gelöscht.

Spreadsheet1.ActiveSheet.Range("b3:f4").DeleteRows


DeleteTotal-Methode

Löscht ein PivotTotal-Objekt aus der PivotTotals-Auflistung. Sie können nur benutzerdefinierte Summen löschen.

Syntax

Ausdruck.DeleteTotal(Total)

Ausdruck Ein Ausdruck, der ein PivotView-Objekt zurückgibt.

Total Variant erforderlich. Gibt Name oder Zahl der Summe an.


EndUndo-Methode

Gibt das Ende eines Undo-Blocks an. Dies bedeutet, dass alle Anweisungen, die zwischen diesem Aufruf und der zugehörigen BeginUndo-Methode liegen, durch einen einzigen Aufruf der Undo-Methode rückgängig gemacht werden. Dadurch wird es für Sie möglich, komplette Makros mit einer Anweisung zu kombinieren, die leicht rückgängig gemacht werden kann. Undo-Blöcke können geschachtelt werden.

Syntax

Ausdruck.EndUndo

Ausdruck Ein Ausdruck, der ein ChartSpace oder Spreadsheet-Objekt zurückgibt.


EndUndo-Methode: Beispiel

In diesem Beispiel wird ein Undo-Block erstellt, der Code enthält, mit dem Zahlenformat und Schriftart der aktiven Zelle festgelegt werden.

Spreadsheet1.EnableUndo = True
Spreadsheet1.BeginUndo
    Set ac = Spreadsheet1.ActiveCell
    ac.NumberFormat = "0.###"
    ac.Font.Color = "blue"
    ac.Font.Name = "times new roman"
Spreadsheet1.EndUndo


Eval-Methode

Berechnet einen Ausdruck und gibt das Ergebnis zurück.

Syntax

Ausdruck.Eval(Formula)

Ausdruck Ein Ausdruck, der ein Worksheet-Objekt zurückgibt.

Formula String erforderlich. Zu berechnender Ausdruck.


Eval-Methode: Beispiel

In diesem Beispiel wird eine Variable auf die Summe der Werte im Bereich A1:A10 gesetzt.

s = Spreadsheet1.ActiveSheet.Eval("=sum(a1:a10)")


Execute-Methode

Gibt eine Recordset-Objekt zurück, das die Datensatzgruppe repräsentiert, die aus einer Datensatzgruppendefinition oder einer Gruppierungsdefinition resultiert. Wenn die Datensatzgruppe Teil einer Hierarchie aus angeordneten Datensatzgruppen ist, erstellt das Datenquellensteuerelement die vollständige Hierarchie und gibt die angeforderte Datensatzgruppe aus der Hierarchie zurück.

Syntax

Ausdruck.Execute(RecordsetName, ExecuteOption, FetchType)

Ausdruck Ein Ausdruck, der ein DataSourceControl-Objekt zurückgibt.

RecordName String erforderlich. Der Name der Datensatzgruppendefinition oder Gruppierungsdefinition.

ExecuteOption Optionales ExecuteOptionEnum-ADO. Gibt an, wie die Abfrage durchgeführt wird. Der Standardwert lautet adOptionUnspecified.

FetchType Optionales dscFetchTypeEnum-Objekt. Wenn die angegebene Datensatzgruppendefinition eine Unterliste mit untergeordneten Datensatzgruppendefinitionen enthält, bewirkt das Festlegen dieses Arguments auf dscFull, dass jedes Mal alle Datensätze abgerufen werden, wenn die Execute-Methode aufgerufen wird. Wenn Sie dieses Argument nicht angeben oder es auf dscParameterized festlegen, werden Datensätze aus untergeordneten Datensatzgruppen nur dann abgerufen, wenn die untergeordnete Datensatzgruppe für die betroffene übergeordnete Datensatzgruppe geöffnet worden ist. Wennn Sie beispielsweise die übergeordnete Datensatzgruppe Customers mit der untergeordneten Datensatzgruppe Orders besitzen, und dieses Argument auf dscFull festgelegt worden ist, werden alle Datensätze für sämtliche Kunden zur Laufzeit abgerufen. Wenn dieses Argument auf dscParameterized festgelegt worden ist, werden die Datensatzgruppen für Kunden mit der Kunden-ID ANTAR nur dann abgerufen, wenn die Customers-Datensatzgruppe auf diese Kunden-ID positioniert wurde und die untergeordneten Orders-Datensatzgruppen geöffnet sind.


Expand-Methode

Bewirkt ein Erweitern des angegebenen Abschnitts.

Syntax

Ausdruck.Expand

Ausdruck Ein Ausdruck, der ein Section-Objekt zurückgibt.


Export-Methode

PivotTable-Objekt (Syntax 1): Speichert die angegebene PivotTable-Liste in einer Datei und öffnet diese wahlweise in Microsoft Excel.

Worksheet-Objekt (Syntax 2): Speichert das angegebene Tabellenblatt in einer Datei und öffnet diese wahlweise in Excel.

Syntax 1 (PivotTable-Objekt)

Ausdruck.Export(FileName, Action)

Ausdruck Ein Ausdruck, der ein PivotTable-Objekt zurückgibt.

FileName String optional. Gibt den Dateinamen der gespeicherten Datei an. Wenn Sie dieses Argument nicht angeben, wird im Temp-Ordner des Benutzers eine temporäre Datei erzeugt.

Action Optionale PivotExportActionEnum-Konstante. Gibt an, was geschieht, nachdem die PivotTable-Liste in einer Datei gespeichert wurde. Wenn Sie dieses Argument nicht angeben, wird die PivotTable-Liste in Excel geöffnet. Wenn Excel auf dem Computer des Benutzers nicht installiert ist, wird eine Warnung angezeigt.

Syntax 2 (Worksheet-Objekt)

Ausdruck.Export(FileName, ExportAction)

Ausdruck Ein Ausdruck, der ein Worksheet-Objekt zurückgibt.

FileName String optional. Gibt den Namen der gespeicherten Datei an. Wenn Sie dieses Argument nicht angeben, wird im Temp-Ordner des Benutzers eine temporäre Datei erzeugt. Sie müssen dieses Argument angeben, wenn das ExportAction-Argument auf ssExportActionNone gesetzt worden ist.

ExportAction Optionale SheetExportActionEnum-Konstante. Gibt an, ob dieses Tabellenblatt in einer Datei gespeichert wird oder nicht. Wenn Sie dieses Argument nicht angeben, wird das Tabellenblatt in Excel geöffnet. Wenn Excel auf dem Computer des Benutzers nicht installiert ist, wird eine Warnung angezeigt.


ExportPicture-Methode

Speichert den angegebenen Diagrammarbeitsbereich oder eine PivotTable-Liste als Grafikdatei.

Syntax

Ausdruck.ExportPicture(FileName, FilterName, Width, Height)

Ausdruck Ein Ausdruck, der ein ChartSpace oder PivotTable-Objekt zurückgibt.

FileName String optional. Gibt den Namen der gespeicherten Datei an. Wenn Sie dieses Argument nicht angeben, lautet der standardmäßige Name "Chart.gif" für einen Diagrammarbeitsbereich oder "Pivot.gif" für eine PivotTable-Liste.

FilterName String optional. Gibt den Namen des verwendeten Grafikfilters an. Beachten Sie, dass "GIF" der einzige unterstützte Filtername ist.

Width Optionales Long. Gibt die Breite der Grafik in Pixel an. Sie müssen dieses Argument bei serverbasierten Diagrammen angeben.

Height Optionales Long. Gibt die Höhe der Grafik in Pixel an. Sie müssen dieses Argument bei serverbasierten Diagrammen angeben.


ExportPicture-Methode: Beispiel

In diesem Beispiel wird der Diagrammarbeitsbereich als Grafikdatei gespeichert.

ChartSpace1.ExportPicture "sales.gif", width:=320, height:=240


Find-Methode

Sucht nach spezifischen Informationen innerhalb eines angegebenen Bereichs und gibt ein Range-Objekt zurück, das die erste Zelle darstellt, in der sich die Informationen befinden. Gibt Nothing zurück, wenn keine Übereinstimmungen gefunden werden. Wirkt sich nicht auf Auswahl oder aktive Zelle aus.

Syntax

Ausdruck.Find(What, After, FindLookIn, FindLookAt, SearchOrder, SearchDirection, MatchCase)

Ausdruck Ein Ausdruck, der ein Range-Objekt zurückgibt.

What Variant erforderlich. Die Daten, nach denen gesucht werden soll.

After Variant optional. Gibt die Zelle an, hinter der die Suche beginnt. Wenn dieses Argument nicht angegeben wird, beginnt die Suche hinter der aktuellen Zelle.

FindLookIn Optionale SheetFindLookInEnum-Konstante. Der Standardwert lautet ssValues.

FindLookAt Optionale SheetFindLookAtEnum-Konstante. Die Standardkonstante lautet ssPart.

SearchOrder Optionale SheetSearchOrderEnum-Konstante. Die Standardkonstante lautet ssByRows.

SearchDirection Optionale SheetSearchDirectionEnum-Konstante. Die Standardkonstante lautet ssNext.

MatchCase Optionaler Boolean. Der Standardwert lautet False.


Find-Methode: Beispiel

In diesem Beispiel wird jedes Auftreten der Zahl 3 im Bereich A1:F10 gefunden. Diese Zellen werden fett formatiert.

Set c = Spreadsheet1.Constants
Set findRange = Spreadsheet1.Range("a1:f10")
Set foundCell = findRange.Find(3, Spreadsheet1.Range("a1"), c.ssValues, c.ssWhole)
Do While Not foundCell Is Nothing
    foundCell.Font.Bold = True
    Set foundCell = findRange.Find(3, foundCell)
Loop


FlipHorizontal-Methode

Spiegelt die ganze Reihe im angegebenen Diagramm horizontal.

Syntax

Ausdruck.FlipHorizontal

Ausdruck Ein Ausdruck, der ein WCPlotArea-Objekt zurückgibt.


FlipHorizontal-Methode: Beispiel

Dieses Beispiel spiegelt die ganze Reihe im angegebenen Diagramm horizontal.

ChartSpace1.Charts(0).PlotArea.FlipHorizontal


FlipVertical-Methode

Spiegelt die ganze Reihe im angegebenen Diagramm vertikal.

Syntax

Ausdruck.FlipVertical

Ausdruck Ein Ausdruck der ein WCPlotArea-Objekt zurückgibt.


FlipVertical-Methode: Beispiel

Dieses Beispiel spiegelt die ganze Reihe im angegebenen Diagramm vertikal.

ChartSpace1.Charts(0).PlotArea.FlipVertical


Follow-Methode

Zeigt ein zwischengespeichertes Dokument an, das bereits gedownloadet worden ist. Andernfalls löst diese Methode den Hyperlink auf, downloadet das Zieldokument und zeigt dieses Dokument anschließend an.

Syntax

Ausdruck.Follow(NewWindow)

Ausdruck Ein Ausdruck, der ein Hyperlink-Objekt zurückgibt.

NewWindow Optionaler Boolean. True (Wahr) zeigt das >Zieldokument in einem neuen Fenster an. Der Standardwert lautet False (Falsch).


Follow-Methode: Beispiel

In diesem Beispiel wird der Hyperlink in Zelle B15 des aktiven Tabellenblattes aufgelöst, das Zieldokument wird gedownloadet, und anschließend wird das Dokument angezeigt.

Spreadsheet1.ActiveSheet.Range("b15").Hyperlink.Follow


FreezePanes-Methode

Fixiert die Fenster, die den angegebenen Bereich umgeben.

Syntax

Ausdruck.FreezePanes(FreezeDirection)

Ausdruck Ein Ausdruck, der ein Range-Objekt zurückgibt.

FreezeDirection Erforderliche SheetFreezePanesEnum-Konstante.


FreezePanes-Methode: Beispiel

In diesem Beispiel wird das Tabellenblattfenster in Zeile 5 geteilt, und das Fenster oberhalb der Teilung wird fixiert.

Set c = Spreadsheet1.Constants
Spreadsheet1.Range("b5").FreezePanes c.ssFreezeTop


GetContainingSection-Methode

Gibt den umgebenden Abschnitt für das angegebene HTML-Element zurück.

Syntax

Ausdruck.GetContainingSection(Element)

Ausdruck Ein Ausdruck, der ein DataSourceControl-Objekt zurückgibt.

Element Erforderliches Objekt. Stellt das angegebene HTML-Element dar.


GetValue-Methode

Gibt einen Datenwert für den angegebenen Punkt zurück.

Syntax

Ausdruck.GetValue(Dimension)

Ausdruck Ein Ausdruck, der ein WCPoint-Objekt zurückgibt.

Dimension Erforderliches ChartDimensionsEnum-Objekt. Gibt für den angegebenen Punkt den Typ der zurückzugebenden Daten an.


InsertColumns-Methode

Fügt eine festgelegte Anzahl von Spalten auf die rechte Seite des angegebenen Bereiches ein.

Syntax

Ausdruck.InsertColumns(NumberOfColumns)

Ausdruck Ein Ausdruck, der ein Range-Objekt zurückgibt.

NumberOfColumns Optional Long. Legt die Anzahl der Spalten fest, die eingefügt werden sollen. Wenn Sie dieses Argument nicht festlegen, wird nur eine Spalte eingefügt.


InsertColumns-Methode: Beispiel

In diesem Beispiel wird ein Spalte rechts neben Spalte C sowie zwei Zeilen unterhalb von Zeile 3 eingefügt.

Spreadsheet1.Range("c3").InsertColumns
Spreadsheet1.Range("c3").InsertRows 2


InsertFieldSet-Methode

Fügt eine Feldgruppe auf der angegebenen Achse ein.

Syntax

Ausdruck.InsertFieldSet(FieldSet, Before, Remove)

Ausdruck Ein Ausdruck der ein PivotAxis-, PivotDataAxis-, PivotFilterAxis- oder PivotGroupAxis-Objekt zurückgibt.

FieldSet Erforderliches PivotFieldSet-Objekt. Gibt die einzufügende Feldgruppe an.

Before Variant optional. Gibt den Index der Feldgruppe an, vor der das eingefügte Feld platziert wird.

Remove Optionaler Boolean. Dieses Argument ist für zukünftige Verwendungen vorgesehen und der Wert beträgt stets True . Wird die Feldgruppe der angegebenen Achse hinzugefügt, wird das Argument von allen anderen Achsen entfernt.


InsertRows-Methode

Fügt die angegebene Anzahl von Zeilen direkt unterhalb des angegebenen Bereichs ein.

Syntax

Ausdruck.InsertColumns(NumberOfRows)

Ausdruck Ein Ausdruck, der ein Range-Objekt zurückgibt.

NumberOfRows Optionales Long. Gibt die Anzahl der einzufügenden Zeilen an. Wenn Sie dieses Argument nicht angeben, wird nur eine Zeile eingefügt.


InsertRows-Methode: Beispiel

In diesem Beispiel wird ein Spalte rechts neben Spalte C sowie zwei Zeilen unterhalb von Zeile 3 eingefügt.

Spreadsheet1.Range("c3").InsertColumns
Spreadsheet1.Range("c3").InsertRows 2


InsertTotal-Methode

Fügt der PivotTotals-Auflistung ein PivotTotal-Objekt hinzu.

Syntax

Ausdruck.InsertTotal(Total, Before)

Ausdruck Ein Ausdruck, der ein PivotDataAxis-Objekt zurückgibt.

Total Erforderliches PivotTotal-Objekt. Gibt die einzufügende Summe an.

Before Variant optional. Gibt den Index der Summe an, vor der die eingefügte Summe platziert wird. Wenn Sie dieses Argument nicht angeben, wird die Summe am Ende der Auflistung eingefügt.

Anmerkungen

Wenn das PivotTotal-Objekt derzeit ein Bestandteil der PivotTotals-Auflistung ist, wird das Objekt zuerst aus dieser Auflistung entfernt und anschließend erneut darin eingefügt. Dies ändert die Anzeigereihenfolge, weil Summen nach ihrer Reihenfolge in der Auflistung angezeigt werden.


Intersect-Methode

Gibt ein Range-Objekt zurück, das die rechteckige Schnittmenge zweier angegebener Bereiche darstellt.

Syntax

Ausdruck.Intersect(Range1, Range2)

Ausdruck Ein Ausdruck, der ein Spreadsheet-Objekt zurückgibt.

Range1, Range2 Erforderliche Range-Objekte. Die sich überschneidenden Bereiche.


Intersect-Methode: Beispiel

Die Funktion in diesem Beispiel gibt True (Wahr) zurück, wenn sich die übertragene Zelle innerhalb des sichtbaren Bereichs befindet.

Function IsCellVisible(testCell)
    Set vr = Spreadsheet1.ActiveSheet.VisibleRange
    Set ir = Spreadsheet1.Intersect(testCell, vr)
    'if the testCell is not in the visible range,
    'the intersection will be nothing
    IsCellVisible = Not ir Is Nothing
End Function


IsButtonEnabled-Methode

Gibt True (Wahr) zurück, wenn die angegebene Navigationsschaltfläche aktiviert ist.

Syntax

Ausdruck.IsButtonEnabled(navbtn)

Ausdruck Ein Ausdruck, der ein RecordNavigationControl-Objekt zurückgibt.

navbtn Erforderliches navButtonEnum-Objekt. Gibt die Navigationsschaltfläche an.


Load-Methode

Lädt XML-Diagrammdaten aus einem URL oder einer lokalen Datei. Die Datei darf nur aus Diagramm-XML bestehen und kann kein vorgestelltes HTML enthalten. Die Zeichenkette muss mit <script language="XML"> beginnen und mit </script> enden.

Syntax

Ausdruck.Load(FileName)

Ausdruck Ein Ausdruck, der ein ChartSpace-Objekt zurückgibt.

FileName String erforderlich. Gibt die Datei ein, die XML-Diagrammdaten enthält.


LoadText-Methode

Lädt und analysiert den angegebenen Text als neuen Bereich oder neues Tabellenblatt.

Syntax

Ausdruck.LoadText(File, Delimiters, ConsecutiveDelimAsOne, TextQualifier)

Ausdruck Ein Ausdruck, der ein Range oder Spreadsheet-Objekt zurückgibt.

File String erforderlich. Gibt den Namen der Textdatei an.

Delimiters String optional. Gibt die Feldtrennzeichen an.

ConsecutiveDelimAsOne Optionaler Boolean. Der Wert True (Wahr) bewirkt, dass aufeinander folgende Trennzeichen als ein einziges Trennzeichen betrachtet werden. Der Standardwert lautet False (Falsch).

TextQualifier String optional. Gibt das Textbegrenzungszeichen an. Der Standardwert ist das doppelte Anführungszeichen.


LoadText-Methode: Beispiel

In diesem Beispiel wird eine durch Tabs getrennte Textdatei geladen.

Spreadsheet1.LoadText "tabfile.txt", Chr$(9)


MakeCurrent-Methode

Macht den angegebenen Abschnitt zum aktuellen Abschnitt.

Syntax

Ausdruck.MakeCurrent

Ausdruck Ein Ausdruck, der ein Section-Objekt zurückgibt.


Merge-Methode

Erstellt eine verbundene Zelle aus einem angegebenen Bereich.

Syntax

Ausdruck.Merge

Ausdruck Ein Ausdruck, der ein Range-Objekt zurückgibt. Diese Methode schlägt fehl, wenn der Bereich eine zuvor verbundene Zelle nur teilweise einschließt.

Anmerkungen

Wenn Sie eine verbundene Zelle erstellen, wird der Wert in der oben links gelegenen Zelle des angegebenen Bereichs als Wert für die verbundene Zelle verwendet. Alle übrigen Zellenwerte in der verbundenen Zelle werden ignoriert.


Merge-Methode: Beispiel

In diesem Beispiel wird eine verbundene Zelle aus dem Bereich B2:C5 erstellt. Die verbundene Zelle wird mit einer breiten, roten Rahmenlinie umgeben.

Set c = Spreadsheet1.Constants
Spreadsheet1.Range("b2:c5").Merge
Spreadsheet1.Range("b2").MergeArea.Borders.Color = "red"
Spreadsheet1.Range("b2").MergeArea.Borders.Weight = c.owcLineWeightThick


MoveFirst-Methode

Wechselt zum ersten Datensatz in der Datensatzgruppe auf der Datenseite. Diese Methode schlägt fehl, wenn der aktuelle Datensatz der erste Datensatz in der Datensatzgruppe ist.

Syntax

Ausdruck.MoveFirst

Ausdruck Ein Ausdruck, der ein DataPage-Objekt zurückgibt.


MoveLast-Methode

Wechselt zum letzten Datensatz in der Datensatzgruppe auf der Datenseite. Diese Methode schlägt fehl, wenn der aktuelle Datensatz der letzte in der Datensatzgruppe ist.

Syntax

Ausdruck.MoveLast

Ausdruck Ein Ausdruck, der ein DataPage-Objekt zurückgibt.


MoveNext-Methode

Wechselt zum nächsten Datensatz in der Datensatzgruppe auf der Datenseite. Diese Methode schlägt fehl, wenn der aktuelle Datensatz der letzte Datensatz in der Datensatzgruppe ist.

Syntax

Ausdruck.MoveNext

Ausdruck Ein Ausdruck, der ein DataPage-Objekt zurückgibt.


MovePrevious-Methode

Wechselt zum vorherigen Datensatz in der Datensatzgruppe auf der Datenseite. Diese Methode schlägt fehl, wenn der aktuelle Datensatz der erste Datensatz in der Datensatzgruppe ist.

Syntax

Ausdruck.MovePrevious

Ausdruck Ein Ausdruck, der ein DataPage-Objekt zurückgibt.


NewRecord-Methode

Fügt der Datensatzgruppe auf einer Datenseite einen neuen Datensatz hinzu. Diese Methode schlägt fehl, wenn die Datensatzgruppe nicht aktualisiert werden kann.

Syntax

Ausdruck.NewRecord

Ausdruck Ein Ausdruck, der ein DataPage-Objekt zurückgibt.


Offset-Methode

Gibt ein Range-Objekt zurück, das einen Bereich darstellt, der vom angegebenen Bereich versetzt ist.

Syntax

Ausdruck.Offset(NumberOfRows, NumberOfColumns)

Ausdruck Ein Ausdruck, der ein Range-Objekt zurückgibt.

NumberOfRows Optional Long. Die Anzahl der Zeilen (Positiv, Negativ oder Null (0)), durch die der Bereich abgesetzt werden soll. Der Standardwert ist Null.

NumberOfColumns Optional Long. Die Anzahl der Spalten (Positiv, Negativ oder Null), durch die der Bereich abgesetzt werden soll. Der Standardwert ist Null.


Offset-Methode: Beispiel

In diesem Beispiel wird die Schriftart für die Inhalte der Zelle festgelegt, die sich eine Spalte weiter rechts neben der aktiven Zelle befindet.

Spreadsheet1.ActiveCell.Offset(0, 1).Font.Bold = True


ParseText-Methode

Analysiert die angegebene Textzeichenkette und platziert das Ergebnis im angegebenen Bereich.

Syntax

Ausdruck.ParseText(Text, Delimiters, ConsecutiveDelimAsOne, TextQualifier)

Ausdruck Ein Ausdruck, der ein Range-Objekt zurückgibt.

Text String erforderlich. Gibt die zu analysierende Zeichenkette an.

Delimiters String optional. Gibt die Feldtrennzeichen an.

ConsecutiveDelimAsOne Optionaler Boolean. Der Wert True (Wahr) bewirkt, dass aufeinander folgende Trennzeichen als ein einziges Trennzeichen betrachtet werden. Der Standardwert lautet False (Falsch).

TextQualifier String optional. Gibt das Textbegrenzungszeichen an. Der Standardwert ist das doppelte Anführungszeichen.


ParseText-Methode: Beispiel

In diesem Beispiel wird die angegebene Zeichenkette innerhalb des Bereichs ausgehend von Zelle A1 analysiert.

Spreadsheet1.Range("a1").ParseText "name, address, city, state", ","


Paste-Methode

Fügt den Inhalt der Zwischenablage in den angegebenen Bereich ein.

Syntax

Ausdruck.Paste

Ausdruck Ein Ausdruck, der ein Range-Objekt zurückgibt.


Paste-Methode: Beispiel

In diesem Beispiel wird der Inhalt von Zelle A1 in die Zellen A3, A5 und A7 eingefügt .

Spreadsheet1.Range("a1").Copy
For rw = 3 To 7 Step 2
    Spreadsheet1.Cells(rw, 1).Paste
Next


RangeFromPoint-Methode

Gibt das am genauesten bestimmte Objekt am angegebenen Ort innerhalb eines Diagrammarbeitsbereichs zurück. Wenn Sie zum Beispiel die X- und Y-Koordinaten eines Punktes angeben, wird das entsprechende WCPoint-Objekt zurückgegeben, obwohl auch eine Reihe mit diesen Koordinaten existiert.

Syntax

Ausdruck.RangeFromPoint(X, Y)

Ausdruck Ein Ausdruck, der ein ChartSpace-Objekt zurückgibt.

X Erforderlicher Integer. Erforderliche X-Koordinate des Objekts.

Y Erforderlicher Integer. Erforderliche Y-Koordinate des Objekts.


Refresh-Methode

Aktualisiert das angegebene Objekt (lädt die Quelldaten neu oder überträgt das Format für das Objekt neu).

Syntax

Ausdruck.Refresh

Ausdruck Ein Ausdruck, der ein Objekt in der Gilt für-Liste zurückgibt.


Refresh-Methode: Beispiel

Durch dieses Beispiel wird der Diagrammarbeitsbereich aktualisiert.

ChartSpace1.Refresh

In diesem Beispiel wird ein Diagramm, das an ein Datenquellen-Steuerelement gebunden ist, zum erneuten Laden seiner Daten aufgefordert.

ChartSpace1.ChartDataSources(0).Refresh


RemoveFieldSet-Methode

Entfernt eine Feldgruppe von der angegebenen Achse.

Syntax

Ausdruck.RemoveFieldSet(FieldSet)

Ausdruck Ein Ausdruck, der ein PivotDataAxis, PivotFilterAxis oder PivotGroupAxis-Objekt zurückgibt.

FieldSet Variant erforderlich. Gibt die zu entfernende Feldgruppe an. Dabei kann es sich um ein PivotFieldSet-Objekt, einen Feldgruppennamen oder die Indexzahl einer Feldgruppe handeln.


RemoveTotal-Methode

Entfernt eine Summe aus der angegebenen Datenachse.

Syntax

Ausdruck.RemoveTotal(Total)

Ausdruck Ein Ausdruck, der ein PivotDataAxis-Objekt zurückgibt.

Total Variant erforderlich. Gibt die zu entfernende Summe an. Dabei kann es sich um ein PivotTotal-Objekt, den Namen einer Summe oder die Indexzahl einer Summe handeln.


Requery-Methode

Führt die Abfrage aus, die den Datensatz und alle dazugehörigen Datensätze für das angegebene Objekt zurückgegeben hat.

Syntax

Ausdruck.Requery

Ausdruck Ein Ausdruck, der ein Objekt in der Liste "Bezieht sich auf" zurückgibt.


RotateClockwise-Methode

Dreht alle Reihen des angegebenen Diagramms im Uhrzeigersinn jeweils in 90-Grad-Inkrementen.

Syntax

Ausdruck.RotateClockwise

Ausdruck Ein Ausdruck, der ein WCPlotArea-Objekt zurückgibt.


RotateClockwise-Methode: Beispiel

In diesem Beispiel werden alle Reihen des angegebenen Diagramms im Uhrzeigersinn um 90 Grad gedreht.

ChartSpace1.Charts(0).PlotArea.RotateClockwise


RotateCounterClockwise-Methode

Dreht alle Reihen des angegebenen Diagramms gegen den Uhrzeigersinn jeweils in 90-Grad-Inkrementen.

Syntax

Ausdruck.RotateCounterClockwise

Ausdruck Ein Ausdruck, der ein WCPlotArea-Objekt zurückgibt.


RotateCounterClockwise-Methode: Beispiel

In diesem Beispiel werden alle Reihen des angegebenen Diagramms gegen den Uhrzeigersinn um 90 Grad gedreht.

ChartSpace1.Charts(0).PlotArea.RotateCounterClockwise


Save-Methode

Speichert den aktuellen Datensatz in der Datenbank, die mit der Datenseite verknüpft ist.

Syntax

Ausdruck.Save

Ausdruck Ein Ausdruck, der ein DataPage-Objekt zurückgibt.


Scroll-Methode

Führt einen Bildlauf des Tabellenblattes durch, um die angegebene Zelle oder den angegebenen Bereich von Zellen in die links oben gelegene Ecke des sichtbaren Bereichs zu verschieben. Wenn das Tabellenblatt fixierte Fenster enthält, wird diese Methode nur auf das bildlauffähige Fenster angewendet.

Syntax

Ausdruck.Scroll(Range)

Ausdruck Ein Ausdruck, der ein Worksheet-Objekt zurückgibt.

Range Erforderliches Range-Objekt. Gibt die anzuzeigende Zelle oder den anzuzeigenden Zellenbereich an.


Scroll-Methode: Beispiel

In diesem Beispiel wird ein Bildlauf des aktiven Tabellenblattes bis Zelle Z100 angezeigt.

Spreadsheet1.ActiveSheet.Scroll Spreadsheet1.ActiveSheet.Range("z100")


Select-Methode

Wählt das angegebene Objekt aus.

Syntax

Ausdruck.Select

Ausdruck Ein Ausdruck, der ein Objekt in der Gilt für-Liste zurückgibt.


Select-Methode: Beispiel

In diesem Beispiel wird eine Zelle ausgewählt, die sich eine Spalte weiter rechts und in der gleichen Spalte wie die aktive Zelle befindet.

Spreadsheet1.ActiveCell.Offset(0, 1).Select


SetData-Methode

Legt die Daten für das angegebene Diagrammobjekt fest.

Syntax

Ausdruck.SetData(Dimension, DataSourceIndex, DataReference)

Ausdruck Ein Ausdruck, der ein WCChart, WCErrorBars oder WCSeries-Objekt zurückgibt.

Dimension Erforderliches ChartDimensionsEnum oder ChartErrorBarCustomValuesEnum-Objekt. Gibt die festzulegende Datendimension an.

DataSourceIndex Erforderliches Long. Gibt die Datenquelle als Index für die WCDataSources-Auflistung an oder gibt chDataLiteral an, um Daten aus einer Literalquelle zu verwenden. Beim WCChart-Objekt können Sie chDataLiteral nur dazu verwenden, Namen für Reihen und Rubriken festzulegen.

DataReference Variant optional. Bei WCChart und WCSeries-Objekten geben diese Argumente die Datenverweise als Bereichsverweise im Excel-Format (zum Beispiel A1:D4) oder als Spaltenname einer Zeilengruppe an. Wenn das DataSourceIndex-Argument auf chDataLiteral eingestellt ist, können Sie DataReference auf ein eindimensionales Array oder eine durch Tabulatoren getrennte Zeichenkette setzen. Bei WCErrorBars-Objekten legt dieses Argument ein Array aus Double- oder String-Werten fest, das Sie für Fehlerindikatorenwerte verwenden können. Beachten Sie, dass Sie dieses Argument nur für angepasste Fehlerindikatoren verwenden können (die Type-Eigenschaft eines Fehlerindikators muss auf chErrorBarTypeCustom gesetzt sein).


SetData-Methode: Beispiel

In diesem Beispiel wird ein Diagramm unter Verwendung von Datenarrays mit Literalen erstellt.

Dim seriesNames(1)
Dim categories(7)
Dim values(7)

seriesNames(0) = "Satisfaction Data"

categories(0) = "Very Good"
categories(1) = "Good"
categories(2) = "N/A"
categories(3) = "Average"
categories(4) = "No Response"
categories(5) = "Poor"
categories(6) = "Very Poor"

values(0) = 10
values(1) = 22
values(2) = 6
values(3) = 31
values(4) = 5
values(5) = 14
values(6) = 12

Set cht = ChartSpace1.Charts.Add
Set c = ChartSpace1.Constants
cht.Type = c.chChartTypeColumnClustered

cht.SetData c.chDimSeriesNames, c.chDataLiteral, seriesNames
cht.SetData c.chDimCategories, c.chDataLiteral, categories
cht.SeriesCollection(0).SetData c.chDimValues, c.chDataLiteral, values

In diesem Beispiel wird ein Diagramm erstellt, das an ein Tabellenblatt gebunden ist. Der Serienname befindet sich in Zelle B1, die Rubrikennamen befinden sich in den Zellen B2:B28, und die Werte befinden sich in den Zellen B2:B28.

Set c = ChartSpace1.Constants
Set ChartSpace1.DataSource = Spreadsheet1
ChartSpace1.Charts.Add
ChartSpace1.Charts(0).Type = c.chChartTypeLineMarkers
ChartSpace1.Charts(0).SetData c.chDimSeriesNames, 0, "b1"
ChartSpace1.Charts(0).SetData c.chDimCategories, 0, "a2:a28"
ChartSpace1.Charts(0).SeriesCollection(0).SetData c.chDimValues, 0, "b2:b28"


Show-Methode

Führt einen Bildlauf im Fenster des Tabellenblattes durch, bis der angegebene Bereich ins Bild kommt.

Syntax

Ausdruck.Show

Ausdruck Ein Ausdruck, der ein Range-Objekt zurückgibt.

Remarks

Verwenden Sie die Scroll-Methode, um einen Bereich in die obere linke Ecke der Kalkulationstabelle zu verschieben.


ShowAllData-Methode

Macht alle ausgefilterten Zeilen des angegebenen Tabellenblattes sichtbar und setzt sämtliche Filter auf Alle anzeigen.

Syntax

Ausdruck.ShowAllData

Ausdruck Ein Ausdruck, der ein Worksheet-Objekt zurückgibt.


ShowAllData-Methode: Beispiel

In diesem Beispiel werden alle gefilterten Zeilen des aktiven Tabellenblattes sichtbar, und sämtliche Filter werden auf Alle anzeigen gesetzt.

Spreadsheet1.ActiveSheet.ShowAllData


Sort-Methode

Sortiert den angegebenen Bereich.

Syntax

Ausdruck.Sort(ColumnKey, Order, YesNoGuessHeader)

Ausdruck Ein Ausdruck, der ein Range-Objekt zurückgibt. Wenn der Bereich nur eine Zelle enthält, wird der aktuelle Bereich sortiert.

ColumnKey Optionales Long. Die Zahl der ersten Sortierspalte. Der Standardwert ist 1.

Order Optionales SheetSortOrderEnum-Objekt. Die Sortierreihenfolge. Der Standardwert ist ssAscending.

YesNoGuessHeader Optionale SheetYesNoGuessEnum-Konstante. Verwenden Sie ssYes, falls die erste Zeile Kopfzeilen enthält, ssNo, wenn die erste Zeile keine Kopfzeilen enthält, oder ssGuess, um die Methode feststellen zu lassen, ob die erste Zeile Kopfzeilen enthält oder nicht. Der Standardwert ist ssNo.


Sort-Methode: Beispiel

In diesem Beispiel wird der Bereich A1:F10 in absteigender Reihenfolge auf Grundlage von Zeile 2 sortiert.

Set c = Spreadsheet1.Constants
Spreadsheet1.Range("a1:f10").Sort 2, c.ssDescending


Undo-Methode

Macht die letzte einzelne Aktion oder den letzten Makroblock, der von BeginUndo- und EndUndo-Methodenaufrufen umgeben ist, für die ChartSpace- und Spreadsheet- Objekte rückgängig.

Führt die Datenzugriffseite für das DataPage-Objekt bei nicht erfolgter Speicherung der Änderungen auf den Stand zurück, bevor der Datensatz bearbeitet wurde.

Syntax

Ausdruck.Undo

Ausdruck Ein Ausdruck, der ein ChartSpace-, DataPage- oder Spreadsheet-Objekt zurückgibt.


Undo-Methode: Beispiel

In diesem Beispiel wird die letzte Aktion rückgängig gemacht oder ein Meldungsfeld angezeigt, wenn die Aktion nicht rückgängig gemacht werden kann.

If Spreadsheet1.CanUndo Then
    Spreadsheet1.Undo
Else
    MsgBox "can't undo last action"
End If


Union-Methode

Gibt ein Range-Objekt zurück, das den kleinsten rechteckigen Bereich darstellt, den eine Verbindung aus zwei angegebenen Bereichen einschließt.

Syntax

Ausdruck.Union(Range1, Range2)

Ausdruck Ein Ausdruck, der ein Spreadsheet-Objekt zurückgibt.

Range1 Erforderliches Range-Objekt.

Range2 Erforderliches Range-Objekt.

Anmerkungen

Die Union-Methode gibt stets einen rechteckigen Bereich zurück. Wenn Sie beispielsweise A1:A5 und F1:F10 angeben, besteht der Rückgabewert aus dem rechteckigen Bereich A1:F10. Außerdem können Sie diese Methode nicht dazu verwenden, einen Bereich zu erstellen, der unzusammenhängende Bereiche enthält.


Union-Methode: Beispiel

In diesem Beispiel wird eine Variable auf den kleinsten rechteckigen Bereich gesetzt, der den Bereich A1:A5 und den Bereich F1:F10 enthält.

Set r1 = Spreadsheet1.Range("a1:a5")
Set r2 = Spreadsheet1.Range("f1:f10")
Set ur = Spreadsheet1.Union(r1, r2)


UnMerge-Methode

Teilt den angegebenen verbundenen Bereich in getrennte Zellen auf.

Syntax

Ausdruck.UnMerge

Ausdruck Ein Ausdruck, der ein Range-Objekt zurückgibt.

Anmerkungen

Wenn Sie einen verbundenen Bereich aufteilen, wird der Wert im verbundenen Bereich in einer Zelle in der linken oberen Ecke des Bereichs platziert. Alle übrigen Zellen werden gelöscht.


UnMerge-Methode: Beispiel

In diesem Beispiel wird der verbundene Bereich getrennt, der die Zelle A1 enthält.

Spreadsheet1.Range("a1").UnMerge


UpdatePropertyToolbox-Methode

Aktualisiert die Eigenschaft Toolbox des derzeit ausgewählten Objekts.

Syntax

Ausdruck.UpdatePropertyToolbox

Ausdruck Ein Ausdruck, der ein Spreadsheet-Objekt zurückgibt.


AllGroupingDefs-Auflistungsobjekt

Enthält sämtliche GroupingDef-Objekte des Datenquellen-Steuerelements.

Verwenden der AllGroupingDefs-Auflistung

Die AllGroupingDefs-Eigenschaft des DataSourceControl-Objekts gibt ein AllGroupingDefs-Objekt zurück.


AllPageFields-Auflistungsobjekt

Enthält sämtliche PageField-Objekte des Datenquellen-Steuerelements.

Verwenden der AllPageFields-Auflistung

Die AllPageFields-Eigenschaft des DataSourceControl-Objekts gibt ein AllPageFields-Objekt zurück.


AutoFilter-Objekt

Stellt den AutoFilter-Container dar. Das AutoFilter-Objekt enthält eine Filters-Auflistung, die Filters-Auflistung enthält ein Filter-Objekt für jede Spalte im gefilterten Bereich. Jedes Filter-Objekt enthält ein Criteria-Objekt.

Verwenden des AutoFilter-Objekts

Die AutoFilter-Eigenschaft des Worksheet-Objekts gibt das AutoFilter-Objekt für das angegebene Tabellenblatt zurück.


Border-Objekt

Stellt den Rahmen eines Objekts dar. Die Line-Eigenschaft gibt ein Border-Objekt zurück, das als Container für die Linienformatierungseigenschaften von Diagrammachsen, Fehlerindikatoren, Gitternetzlinien, Reihen und Trendlinien verwendet wird.

Bei Range-Objekten ist das Border-Objekt Teil der Borders-Auflistung.

Verwenden des Border-Objekts

Die folgenden Eigenschaften geben ein Border-Objekt zurück.

Die Item-Eigenschaft des Borders-Objekts

Die Border-Eigenschaft des ChartSpace-Objekts

Die Line-Eigenschaft des WCAxis-Objekts.

The Border-Eigenschaft des WCChart-Objekts

Die Border-Eigenschaft des WCDataLabels-Objekts

Die Line-Eigenschaft des WCErrorBars-Objekts

Die Line-Eigenschaft des WCGridlines-Objekts

Die Border-Eigenschaft des WCLegend-Objekts

Die Border-Eigenschaft desWCPlotArea-Objekts

Die Border-Eigenschaft des WCPoint-Objekts

Die Border-Eigenschaft des WCSeries-Objekts

Die LineEigenschaft des WCSeries-Objekts

Die Border-Eigenschaft des WCTitle-Objekts

Die Line-Eigenschaft des WCTrendline-Objekts


Borders-Auflistungsobjekt

Eine Auflistung aus vier Border-Objekten, welche die vier Rahmen eines Tabellenblattbereichs darstellen.

Verwenden der Borders-Auflistung

Die Borders-Eigenschaft des Range-Objekts gibt eine Borders-Auflistung zurück.


ChartSpace-Objekt

Stellt den Diagrammarbeitsbereich dar. Beim Diagrammarbeitsbereich handelt es sich um den Diagramm-Container der obersten Ebene. Er kann mehr als ein Diagramm enthalten, wobei jedes einzelne Diagramm durch ein WCChart-Objekt repräsentiert wird. Wenn ein Diagrammarbeitsbereich erstellt wird, ist er zunächst leer (er enthält keine Diagramme). Verwenden Sie die Add-Methode des WCCharts-Objekts, um ein neues Diagramm zu erstellen.

Verwenden des ChartSpace-Objekts

Sie können entweder die CreateObject-Methode oder das New-Schlüsselwort verwenden, um ein neues ChartSpace-Objekt zu erstellen.

Die Objekt-ID eines Diagramm-Steuerelements auf einer HTML-Seite oder in einem Visual Basic-Formular geben ein ChartSpace-Objekt zurück.

Der programminterne Bezeichner des ChartSpace-Objekts lautet CLSID:0002E500-0000-0000-C000-000000000046. Im nachfolgenden Beispiel wird auf einer HTML-Seite ein Diagrammarbeitsbereich mit dem Namen "ChartSpace1" erstellt.

<object id=ChartSpace1 classid=CLSID:0002E500-0000-0000-C000-000000000046 style="width:100%;height:350"></object>


Criteria-Objekt

Enthält das vollständige Array der AutoFilter-Kriterien. Jedes Kriterium ist ein String-Wert. Das AutoFilter-Objekt enthält eine Filters-Auflistung, die Filters-Auflistung wiederum enthält ein Filter-Objekt für jede Spalte im gefilterten Bereich. Jedes Filter-Objekt enthält ein Criteria-Objekt.

Verwenden des Criteria-Objekts

Die Criteria-Eigenschaft des Filter-Objekts gibt das Criteria-Objekt für den angegebenen Filter zurück.


DataPage-Objekt

Stellt eine Kombination von Abschnitten dar, die auf einer Datenzugriffsseite gezeigt werden, wenn die Schaltfläche Erweitern angeklickt wird. Diese Abschnitte enthalten in einem einzigen übergeordneten Datensatz einen Überschriftsabschnitt, einen Gruppenkopfzeilen- und einen Gruppenfußzeilenabschnitt für jeden Datensatz sowie einen Navigationsabschnitt für die Gruppe der sichtbaren Datensätze einer Datensatzgruppe.

Das DataPage-Objekt ist Mitglied der DataPages-Auflistung.

Verwenden des DataPage-Objekts

Die folgenden Eigenschaften geben ein DataPage-Objekt zurück:

Item-Eigenschaft des DataPages-Objekts

DataPage-Eigenschaft des Section-Objekts


DataPages-Auflistungsobjekt

Enthält sämtliche DataPage-Objekte des Datenquellen-Steuerungselements.

Verwenden der DataPages-Auflistung

Die DataPages-Eigenschaft des DataSourceControl-Objekts gibt ein DataPages-Objekt zurück.


DataSourceControl-Objekt

Repräsentiert ein Datenquellen-Steuerelement. Das Datenquellen-Steuerelement ist im Datenmodell der Container der obersten Ebene.

Verwenden des DataSourceControl-Objekts

Sie können entweder die CreateObject-Methode oder das Schlüsselwort New verwenden, um ein neues DataSourceControl-Objekt zu erstellen.

Die Objekt-ID eines Datenquellen-Steuerelements auf einer HTML-Seite gibt ein DataSourceControl-Objekt zurück. Der programminterne Bezeichner des DataSourceControl-Objekts lautet CLSID:0002E530-0000-0000-C000-000000000046. Im nachfolgenden Beispiel wird ein Datenquellen-Steuerelement mit Namen "MOSDSC" auf einer HTML-Seite erstellt.

<object id=MSODSC classid=CLSID:0002E530-0000-0000-C000-000000000046></object>


DSCEventInfo-Objekt

DSCEventInfo-Objekt

Enthält Informationen über das angegebene Datenquellen-Steuerelementereignis.

Verwenden des DSCEventInfo-Objekts

Die folgenden Datenquellen-Steuerelemente verwenden ein DSCEventInfo-Objekt als einzigen Parameter:

Das BeforeCollapse-Ereignis

Das BeforeExpand-Ereignis

Das BeforeFirstPage-Ereignis

Das BeforeLastPage-Ereignis

Das BeforeNextPage-Ereignis

Das BeforePreviousPage-Ereignis

Das DataError-Ereignis

Das DataPageComplete-Ereignis


ElementExtension-Objekt

Fügt HTML-Elementen datenbezogene Eigenschaften wie Textfelder und Dropdownlistenfelder hinzu. Elementerweiterungen verknüpfen Datensatzgruppe und Gruppierungsdefinitionsobjekte, z. B. Seitenfelder, mit einem Element auf der HTML-Seite, das an deren Ergebnisdaten gebunden werden kann.

Das ElementExtension-Objekt ist Mitglied der ElementExtensions-Auflistung.

Verwenden des ElementExtension-Objekts

Die nachfolgende Methode und Eigenschaft gibt ein ElementExtension-Objekt zurück:

Die Add-Methode des ElementExtensions-Objekts

Die Item-Eigenschaft des ElementExtensions-Objekts


ElementExtensions-Auflistungsobjekt

Enthält die ElementExtension-Objekte für das angegebene Datenquellen-Steuerelement.

Verwenden der ElementExtensions-Auflistung

Die ElementExtensions-Eigenschaft des DataSourceControl-Objekts gibt ein ElementExtensions-Objekt zurück.


ExpandControl-Objekt

ExpandControl-Objekt

Repräsentiert ein Expand-Steuerelement.

Verwenden des ExpandControl-Objekts

Sie können entweder die CreateObject-Methode oder das Schlüsselwort New verwenden, um ein neues ExpandControl-Objekt zu erstellen.

Die Objekt-ID eines Datenquellen-Steuerelements auf einer HTML-Seite gibt ein ExpandControl-Objekt zurück. Der programminterne Bezeichner des ExpandControl-Objekts lautet CLSID:0002E532-0000-0000-C000-000000000046. Im nachfolgenden Beispiel wird ein Expand-Steuerelement mit Namen "Expand1" auf einer HTML-Seite erstellt.

<object id=Expand1 classid=CLSID:0002E532-0000-0000-C000-000000000046></object>


Filter-Objekt

Repräsentiert einen einzelnen Filter, der mit AutoFilter verwendet wird. Das Filter-Objekt ist Mitglied der Filters-Auflistung. Das AutoFilter-Objekt enthält eine Filters-Auflistung, die Filters-Auflistung enthält ein Filter-Objekt für jede Spalte des gefilterten Bereichs. Jedes Filter-Objekt enthält ein Criteria-Objekt.

Verwenden des Filter-Objekts

Die Item-Eigenschaft des Filters-Objekts gibt ein Filter-Objekt zurück.


Filters-Auflistungsobjekt

Repräsentiert die Auflistung von Filtern, die mit AutoFilter verwendet werden. Jeder Filter wird durch ein Filter-Objekt dargestellt. Das AutoFilter-Objekt enthält eine Filters-Auflistung, die Filters-Auflistung enthält ein Filter-Objekt für jede Spalte im gefilterten Bereich. Jedes Filter-Objekt enthält ein Criteria-Objekt.

Verwenden des Filters-Objekt

Die Filters-Eigenschaft des AutoFilter-Objekts gibt ein Filters-Objekt zurück.


GroupingDef-Objekt

Repräsentiert eine Gruppierungsdefinition. Eine Gruppierungsdefinition ist ein Spezialtyp der Datensatzgruppendefinition. Wie bei den RecordsetDef-Objekten können Sie den Namen einer Gruppierungsdefinition für die Execute-Methode sowie die RecordSource-Eigenschaft einer Erweiterung auf Gruppenebene oder einer Elementerweiterung verwenden.

Eine Gruppierungsdefinition definiert eine ADO-Gruppierung aus Datensatzgruppen, die als übergeordnetes Objekt der enthaltenen Datensatzgruppen in der von einer Seite produzierten Hierarchie oder für die von ihr produzierten Datensatzgruppen angezeigt wird. Sämtliche Daten für die enthaltene Datensatzdefinition werden zur Laufzeit abgerufen, bevor die Gruppierung der Datensatzgruppe erstellt wird.

Verwenden des GroupingDef-Objekts

Die nachfolgenden Methoden und Eigenschaften geben ein GroupingDef-Objekt zurück:

Die Add-Methode des GroupingDefs-Objekts

Die AddTotal-Methode des GroupingDefs-Objekts

Die Item-Eigenschaft des GroupingDefs-Objekts


GroupingDefs-Auflistungsobjekt

Repräsentiert die Auflistung von GroupingDef-Objekten, die übergeordnete Gruppierungen zu den Detaildatensätzen in einer Datensatzgruppendefinition erstellen. Die Reihenfolge ist wichtig: Je niedriger der Index, desto höher die Gruppierungsebene. Index 0 (null) ist die niedrigste Gruppierungsebene.

Verwenden der GroupingDefs-Auflistung

Die GroupingDefs-Eigenschaft des RecordsetDef-Objekts gibt ein GroupingDefs-Objekt zurück.


GroupLevel-Objekt

Repräsentiert die Menge sämtlicher Datensätze auf einer bestimmten Ebene in der Hierarchie der Datenseiten. Das GroupLevel-Objekt ist Mitglied der GroupLevels-Auflistung.

Verwenden des GroupLevel-Objekts

Die nachfolgende Methode und Eigenschaft gibt ein GroupLevel-Objekt zurück:

Die Add-Methode des GroupLevels-Objekts

Die Item-Eigenschaft des GroupLevels-Objekts


GroupLevels-Auflistungsobjekt

Repräsentiert die Auflistung der GroupLevel-Objekte für das angegebene Datenquellen-Steuerelement. Jedes GroupLevel-Objekt steht für die Menge sämtlicher Datensätze auf einer bestimmten Ebene in der Hierarchie der Datenseiten.

Verwenden der GroupLevels-Auflistung

Die GroupLevels-Eigenschaft des DataSourceControl-Objekts gibt ein GroupLevels-Objekt zurück.


Hyperlink-Objekt

Repräsentiert einen Hyperlink.

Verwenden des Hyperlink-Objekts

Die Hyperlink-Eigenschaft des Range-Objekts gibt ein Hyperlink-Objekt zurück


Interior-Objekt

Repräsentiert das Innere eines Objekts.

Verwenden des Interior-Objekt

Die nachfolgenden Eigenschaften geben ein Interior-Objekt zurück.

Die Interior-Eigenschaft des ChartSpace-Objekts

Die Interior-Eigenschaft des Range-Objekts

Die Interior-Eigenschaft des TitleBar-Objekts

Die Interior-Eigenschaft des WCChart-Objekts

Die Interior-Eigenschaft des WCDataLabels-Objekts

Die Interior-Eigenschaft des WCLegend-Objekts

Die Interior-Eigenschaft des WCPlotArea-Objekts

Die Interior-Eigenschaft des WCPoint-Objekts

Die Interior-Eigenschaft des WCSeries-Objekts

Die Interior-Eigenschaft des WCTitle-Objekts


LookupRelationships-Auflistungsobjekt

Repräsentiert die Auflistung von PageRelationship-Objekten, die eine Nachschlage-/Verknüpfungsbeziehung mit einer Seitenzeilenquelle definieren. In dem Objektdiagramm, das in diesem Thema gezeigt wird, stellt das erste PageRowsource-Objekt (oberhalb der LookupRelationships-Auflistung) das Objekt auf der "n"-Seite der 1:n-Beziehung dar. Das zweite PageRowsource-Objekt (unterhalb der Auflistung) bildet das Objekt auf der "1"-Seite.

Verwenden der LookupRelationships-Auflistung

Die LookupRelationships-Eigenschaft des PageRowsource-Objekts gibt ein LookupRelationships-Objekt zurück.


LookupSchemaRelationships-Auflistungsobjekt

Repräsentiert die Auflistung von SchemaRelationship-Objekten, bei denen eine einzige Schemazeilenquelle als "n"-Seite der 1:n-Beziehung auftritt.

Verwenden der LookupSchemaRelationships-Auflistung

Die LookupSchemaRelationships-Eigenschaft des SchemaRowsource-Objekts gibt ein LookupSchemaRelationships-Objekt zurück.


OWCFont-Objekt

Enthält die Zeichenformatierungen (Schriftartenname, Schriftgrad, Farbe usw.) eines Objekts, das in einem Diagrammarbeitsbereich oder in einer Kalkulationstabelle verwendet wird. Zeichenformatierungen für Objekte, die in Zusammenhang mit PivotTable-Listen verwendet werden, sind in den PivotFont-Objekten enthalten.

Verwenden des OWCFont-Objekts

Die nachfolgenden Eigenschaften geben ein OWCFont-Objekt zurück.

Die Font-Eigenschaft des Range-Objekts

Die Font-Eigenschaft des TitleBar-Objekts

Die Font-Eigenschaft des WCAxis-Objekts

Die Font-Eigenschaft des WCDataLabel-Objekts

Die Font-Eigenschaft des WCDataLabels-Objekts

Die Font-Eigenschaft des WCLegend-Objekts

Die Font-Eigenschaft des WCLegendEntry-Objekts

Die Font-Eigenschaft des WCTitle-Objekts


PageField-Objekt

Repräsentiert ein Feld in einer Datensatzgruppe oder in einer Gruppierungsdefinition. Der Seitenfeldname wird von einem Steuerelement auf einer Datenseite verwendet, um eine Verbindung zu Daten aus einer Datensatzgruppe herzustellen.

Es gibt drei Typen von PageField-Objekten:

  • Output. Dieser Typ stammt direkt aus einem Schemafeld in einer Schemazeilenquelle. Bei Schemazeilenquellen des Table oder View-Typs besagt dies, dass das Feld in der SELECT-Liste der SQL-Anweisung aufgeführt wird, die vom Datenmodell generiert wird. Bei Schemazeilenquellen des Text oder Stored Procedure-Typs werden alle Schemafelder als Ausgabe angezeigt, und der Feldname muss mit dem Schemafeldnamen identisch sein.

  • Calculated. Hierbei handelt es sich um eine lokal berechnete Spalte, die einer Datensatzgruppe hinzugefügt wird. Die Ausdruckssyntax von Visual Basic for Applications wird unterstützt. Ausdrücke können innerhalb derselben Datensatzgruppendefinition oder Gruppierungsdefinition auf Seitenfelder des dscOutput oder dscGrouping-Typs verweisen. Ausdrücke können auch auf HTML-Elemente verweisen, indem sie das Dokumentenobjektmodell verwenden (z. B. =Quantity*UnitPrice*document.all("Text0").Value). Berechnete Felder werden jedes Mal neu berechnet, wenn die Seite aktualisiert oder die Resync-Methode der Datensatzgruppe aufgerufen wird.

  • Grouping. Ein Gruppierungsfeld oder Aggregatfeld, das an ein GroupingDef oder RecordsetDef-Objekt angebunden ist.

Das PageField-Objekt kann Mitglied der AllPageFields, GroupingFields, OutputFields oder PageFields-Auflistung sein.

Verwenden des PageField-Objekts

Die nachfolgenden Eigenschaften und Methoden geben ein PageField-Objekt zurück:

Die Item-Eigenschaft des AllPageFields-Objekts

Die Add-Methode des PageFields-Objekts

Die Item-Eigenschaft des PageFields-Objekts

Die ManySide-Eigenschaft des PageRelatedField-Objekts

Die OneSide-Eigenschaft des PageRelatedField-Objekts


PageFields-Auflistungsobjekt

Die Auflistung von PageField-Objekten (welche die Felder beschreiben, die in der Datensatzgruppe vorhanden sind), die von der Datensatzgruppendefinition produziert wird. Diese Felder stellen eine Kombination von Ausgabefeldern aus den Seitenzeilenquellen dar, die dieser Auflistung hinzugefügt werden. Die Reihenfolge innerhalb dieser Auflistung ist unwichtig, weil alle Steuerelemente über den Namen und nicht über ihre Reihenfolgenbeziehung eine Verbindung zu Feldern in der Ausgabedatensatzgruppe herstellen.

Verwenden des PageFields-Auflistungsobjekts

Das PageFields-Eigenschaft des RecordsetDef-Objekts gibt ein PageFields-Objekt zurück.


PageRelatedField-Objekt

Repräsentiert eine Seiteninstanz der Spaltenpaarungen, die eine Seitenbeziehung bilden. Die Namen dieser Felder werden beim Erzeugen von Verknüpfungsklauseln in SQL sowie beim Erstellen eines Verweises von einer übergeordneten Datensatzgruppendefinition auf eine untergeordnete Datensatzgruppendefinition.

Das PageRelatedField-Objekt ist Mitglied der PageRelatedFields-Auflistung.

Verwenden des PageRelatedField-Objekts

Die Item-Eigenschaft des PageRelatedFields-Objekts gibt ein PageRelatedField-Objekt zurück.


PageRelatedFields-Auflistungsobjekt

Die Auflistung von PageRelatedField-Objekten, die einer bestimmten Datensatzgruppendefinition angehören. Diese Auflistung wird automatisch ausgefüllt, wenn die Definition einer Datensatzgruppe auf Basis der SchemaRelatedFields-Auflistung erstellt wird.

Verwenden der PageRelatedFields-Auflistung

Die PageRelatedFields-Eigenschaft des PageRelationship-Objekts gibt ein PageRelatedFields-Objekt zurück.


PageRelationship-Objekt

Ein PageRelationship-Objekt verbindet zwei Seitenzellenquellen miteinander, entweder innerhalb einer Datensatzgruppendefinition (ein LookupRelationships-Objekt) oder zwischen Datensatzgruppendefinitionen (ein SublistRelationships-Objekt). Eine Seitenbeziehung wird aus den Informationen eines SchemaRelationship-Objekts erstellt.

Das PageRelationship-Objekt ist Mitglied der LookupRelationships oder SublistRelationships-Auflistung.

Verwenden des PageRelationship-Objekts

Die folgenden Methoden und Eigenschaften geben ein PageRelationship-Objekt zurück:

Die Add-Methode des LookupRelationships-Objekts

Die Item-Eigenschaft des LookupRelationships-Objekts

Die Add-Methode des SublistRelationships-Objekts

Die Item-Eigenschaft des SublistRelationships-Objekts


PageRowsource-Objekt

Ein PageRowsource-Objekt verweist auf eine Instanz eines SchemaRowsource-Objekts, das derzeit auf einer Datenseite verwendet wird. Eine Tabelle, Ansicht oder gespeicherte Prozedur muss als Schemazeilenquelle im Datenmodell enthalten sein, bevor sie als Seitenzeilenquelle hinzugefügt werden kann. Anschließend wird die Seitenzeilenquelle als Datenquelle für die Seite verwendet.

Das PageRowsource-Objekt ist Mitglied der PageRowsources-Auflistung.

Verwenden des PageRowsource-Objekts

Die folgenden Eigenschaften geben ein PageRowsource-Objekt zurück:

Die PageRowsource-Eigenschaft eines PageField-Objekts

Die ManySide-Eigenschaft eines PageRelationship-Objekts

Die OneSide-Eigenschaft des PageRelationship-Objekts

Die Item-Eigenschaft des PageRowsources-Objekts

Die PrimaryPageRowsource-Eigenschaft des RecordsetDef-Objekts


PageRowsources-Auflistungsobjekt

Die Auflistung von PageRowsource-Objekten im Datenmodell.

Verwenden des PageRowsources-Auflistungsobjekts

Die PageRowsources-Eigenschaft des RecordsetDef-Objekts gibt ein PageRowsources-Objekt zurück.


Pane-Objekt

Panes-Auflistung (Pane-Objekt)

Repräsentiert einen Bereich innerhalb eines Fensters. Das Pane-Objekt ist Mitglied der Panes-Auflistung.

Verwenden des Pane-Objekts

Die nachfolgenden Eigenschaften geben ein Pane-Objekt zurück.

Die Item-Eigenschaft des Panes-Objekts

Die ActivePane-Eigenschaft des Spreadsheet-Objekts


Panes-Auflistungsobjekt

Die Auflistung der Pane-Objekte für ein Tabellenblatt.

Verwenden der Panes-Auflistung

Die Panes-Eigenschaft des Worksheet-Objekts gibt eine Panes-Auflistung zurück.


ParameterValue-Objekt

Repräsentiert einen Ausdruck für einen Eingabeparameterwert. Dieser Ausdruck wird zur Ausführungszeit ausgewertet, um einen Laufzeit-Parameterwert für Zeilenquellen des Typs dscProcedure oder dscCommandText bereitzustellen.

Verwenden des ParameterValue-Objekts

Die nachfolgende Methode und die Eigenschaft geben ein ParameterValue-Objekt zurück:

Die Add-Methode des ParameterValues-Objekts

Die Item-Eigenschaft des ParameterValues-Objekts


ParameterValues-Auflistungsobjekt

Die Auflistung der ParameterValue-Objekte für eine Datensatzgruppendefinition.

Verwenden der ParameterValues-Auflistung

Die ParameterValues-Eigenschaft des RecordsetDef-Objekts gibt ein ParameterValues-Objekt zurück.


PivotAggregate-Objekt

Repräsentiert die Daten, die mit der Summe in einer PivotTable-Liste verknüpft sind. Eine Summe definiert, was dem Benutzer angezeigt wird, aber die aus der Summe resultierenden Daten werden als Aggregat oder Aggregatwerte bezeichnet. Das PivotAggregate-Objekt ist Mitglied der PivotAggregates-Auflistung.

Verwenden des PivotAggregate-Objekts

Die Item-Eigenschaft der PivotAggregates-Auflistung gibt ein PivotAggregate-Objekt zurück.


PivotAggregates-Auflistungsobjekt

Die Auflistung der PivotAggregate-Objekte für die angegebene Zelle.

Verwenden der PivotAggregates-Auflistung

Die Aggregates-Eigenschaft des PivotCell-Objekts gibt ein Objekt aus der PivotAggregates-Auflistung zurück.


PivotAxis-Objekt

Wird als Basis für die PivotDataAxis-, PivotFilterAxis- und PivotGroupAxis-Objekte verwendet. Es existieren keine Eigenschaften oder Methoden, mit deren Hilfe Sie das PivotAxis-Objekt direkt verwenden können.


PivotCell-Objekt

Repräsentiert eine Zelle (eine Gruppierung von Daten) in einer PivotTable-Liste. Eine Zelle zeigt Aggregate an, und wenn die zugrunde liegenden Detaildatensätze verfügbar sind, können Sie die Zelle ein Detailraster anzeigen lassen. Gruppierte Felder auf den Zeilen- und Spaltenachsen legen den Datenbetrag fest, den eine bestimmte Zelle repräsentiert. Sogar eine einfache Liste ohne gruppierte Felder stellt in Wirklichkeit eine einzelne Zelle dar, die ein Detailraster anzeigt.

Verwenden des PivotCell-Objekts

Die nachfolgenden Eigenschaften geben ein PivotCell-Objekt zurück:

Die Cells-Eigenschaft des PivotData-Objekts

Die BottomRight-Eigenschaft des PivotRange-Objekts

Die TopLeft-Eigenschaft des PivotRange-Objekts


PivotData-Objekt

Repräsentiert die Daten in einer PivotTable-Liste.

Verwenden des PivotData-Objekts

Die ActiveData-Eigenschaft des PivotTable-Objekts gibt ein PivotData-Objekt zurück.


PivotDataAxis-Objekt

Repräsentiert die Datenachse für eine PivotTable-Liste. Die Datenachse enthält Feldgruppen und Summen.

Verwenden des PivotDataAxis-Objekts

Die DataAxis-Eigenschaft des PivotView-Objekts gibt ein PivotDataAxis-Objekt zurück.


PivotDetailCell-Objekt

Repräsentiert eine Zelle im Detailraster einer PivotTable-Liste.

Verwenden des PivotDetailCell-Objekts

Die nachfolgenden Eigenschaften geben ein PivotDetailCell-Objekt zurück:

Die DetailCells-Eigenschaft des PivotCell-Objekts

Die BottomRight-Eigenschaft des PivotDetailRange-Objekts

Die TopLeft-Eigenschaft des PivotDetailRange-Objekts


PivotDetailRange-Objekt

Repräsentiert den Bereich von Zellen im Detailraster einer PivotTable-Liste.

Verwenden des PivotDetailRange-Objekts

Die DetailRange-Eigenschaft des PivotCell-Objekts gibt ein PivotDetailRange-Objekt zurück.


PivotField-Objekt

Repräsentiert ein einzelnes Feld in einer PivotTable-Liste. Das PivotField-Objekt ist Mitglied der PivotFields-Auflistung.

Verwenden des PivotField-Objekts

Die nachfolgenden Eigenschaften geben ein PivotField-Objekt zurück:

Die Item-Eigenschaft des PivotFields-Objekts

Die BoundField-Eigenschaft des PivotFieldSet-Objekts

Die Field-Eigenschaft des PivotMember-Objekts

Die Field-Eigenschaft des PivotTotal-Objekts

Die Field-Eigenschaft des PivotDetailCell-Objekts


PivotFields-Auflistungsobjekt

Die Auflistung der PivotField-Objekte in der angegebenen Feldgruppe.

Verwenden der PivotFields-Auflistung

Die Fields-Eigenschaft des PivotFieldSet-Objekts gibt ein Objekt aus der PivotFields-Auflistung zurück.


PivotFieldSet-Objekt

Repräsentiert eine Gruppe von Feldern, die in Gestalt einer Hierarchie fest miteinander verbunden sind. Zum Beispiel könnten für eine Feldgruppe Geographie die Felder Kontinent, Land, Bundesstaat und Stadt lauten, in dieser Reihenfolge. Normalerweise enthält eine Feldgruppe nur ein einziges Feld, wenn die Datenquelle eine Datensatzgruppe ist. Das PivotFieldSet-Objekt ist Mitglied der PivotFieldSets-Auflistung.

Verwenden des PivotFieldSet-Objekts

Die nachfolgenden Eigenschaften geben ein PivotFieldSet-Objekt zurück:

Die Fieldset-Eigenschaft des PivotField-Objekts

Die Item-Eigenschaft des PivotFieldSets-Objekts


PivotFieldSets-Auflistungsobjekt

Die Auflistung der PivotFieldSet-Objekte auf der angegebenen Achse oder in der angegebenen Ansicht.

Verwenden der PivotFieldSets-Auflistung

Die nachfolgenden Eigenschaften geben ein Objekt aus der PivotFieldSets-Auflistung zurück:

Die Fieldsets-Eigenschaft des PivotAxis-Objekts

Die FieldSets-Eigenschaft des PivotDataAxis-Objekts

Die FieldSets-Eigenschaft des PivotFilterAxis-Objekts

Die FieldSets-Eigenschaft des PivotGroupAxis-Objekts

Die FieldSets-Eigenschaft des PivotView-Objekts


PivotFilterAxis-Objekt

Repräsentiert die Filterachse in einer PivotTable-Liste.

Verwenden des PivotFilterAxis-Objekts

Die FilterAxis-Eigenschaft des PivotView-Objekts gibt ein PivotFilterAxis-Objekt zurück.


PivotFont-Objekt

Enthält die Zeichenformatierungen (Schriftartenname, Schriftgrad, Farbe usw.) für das angegebene Objekt.

Verwenden des PivotFont-Objekts

Die nachfolgenden Eigenschaften geben ein PivotFont-Objekt zurück:

Die DetailFont-Eigenschaft des PivotField-Objekts

Die SubtotalFont-Eigenschaft des PivotField-Objekts

Die Font-Eigenschaft des PivotLabel-Objekts

Die FieldLabelFont-Eigenschaft des PivotView-Objekts

Die MemberFont-Eigenschaft des PivotView-Objekts

Die TotalFont-Eigenschaft des PivotView-Objekts


PivotGroupAxis-Objekt

Repräsentiert die Gruppenachse in einer PivotTable-Liste.

Verwenden des PivotGroupAxis-Objekts

Die nachfolgenden Eigenschaften geben ein PivotGroupAxis-Objekt zurück:

Die ColumnAxis-Eigenschaft des PivotView-Objekts

Die RowAxis-Eigenschaft des PivotView-Objekts


PivotLabel-Objekt

Repräsentiert die Beschriftung für das angegebene Objekt. Enthält Zeichenformatierungen (Vordergrundfarbe, Hintergrundfarbe, Schriftart usw.).

Verwenden des PivotLabel-Objekts

Die nachfolgenden Eigenschaften geben ein PivotLabel-Objekt zurück:

Die Label-Eigenschaft des PivotAxis-Objekts

Die Label-Eigenschaft des PivotDataAxis-Objekts

Die Label-Eigenschaft des PivotFilterAxis-Objekts

Die Label-Eigenschaft des PivotGroupAxis-Objekts

Die Label-Eigenschaft des PivotView-Objekts

Die TitelBar-Eigenschaft des PivotView-Objekts


PivotMember-Objekt

Repräsentiert die für ein gruppiertes Feld angezeigten Werte. Das PivotMember-Objekt ist Mitglied der PivotMembers-Auflistung.

Verwenden des PivotMember-Objekts

Die nachfolgenden Eigenschaften geben ein PivotMember-Objekt zurück:

Die ColumnMember-Eigenschaft des PivotCell-Objekts

Die RowMember-Eigenschaft des PivotCell-Objekts

Die Left-Eigenschaft des PivotData-Objekts

Die Top-Eigenschaft des PivotData-Objekts

Die ParentMember-Eigenschaft des PivotMember-Objekts

Die Item-Eigenschaft des PivotMembers-Objekts

Die TotalMember-Eigenschaft des PivotMembers-Objekts


PivotMembers-Auflistungsobjekt

Eine Auflistung von PivotMember-Objekten.

Verwenden der PivotMembers-Auflistung

Die nachfolgenden Eigenschaften geben ein Objekt aus der PivotMembers-Auflistung zurück:

Die ColumnMembers-Eigenschaft des PivotData-Objekts

Die RowMembers-Eigenschaft des PivotData-Objekts

Die Members-Eigenschaft des PivotFieldSet-Objekts

Die ChildMembers-Eigenschaft des PivotMember-Objekts


PivotRange-Objekt

Repräsentiert einen Bereich von Zellen in einer PivotTable-Liste.

Verwenden des PivotRange-Objekts

Die Range-Eigenschaft des PivotData-Objekts gibt ein PivotRange-Objekt zurück.


PivotTable-Objekt

Repräsentiert den Container für eine PivotTable-Liste.

Verwenden des PivotTable-Objekts

Sie können entweder die CreateObject-Methode oder das Schlüsselwort New verwenden, um ein neues PivotTable-Objekt zu erstellen.

Die Objekt-ID einer PivotTable-Liste auf einer HTML-Seite gibt ein PivotTable-Objekt zurück. Der programminterne Bezeichner des DataSourceControl-Objekts lautet CLSID:0002E520-0000-0000-C000-000000000046. Im nachfolgenden Beispiel wird eine PivotTable-Liste mit Namen "PivotTable1" auf einer HTML-Seite erstellt.

<object id=PivotTable1 classid=CLSID:0002E520-0000-0000-C000-000000000046></object>


PivotTotal-Objekt

Repräsentiert eine Summe in einer PivotTable-Liste. Eine Summe ist ein Aggregatwert, der an Stelle des Inhalts einer einzelnen Zelle angezeigt wird. Das PivotTotal-Objekt ist Mitglied der PivotTotals-Auflistung.

Verwenden des PivotTotal-Objekts

Die nachfolgenden Eigenschaften und Methoden geben ein PivotTotal-Objekt zurück:

Die Item-Eigenschaft des PivotTotals-Objekts

Die AddTotal-Methode des PivotView-Objekts

Die SortOn-Eigenschaft des PivotField-Objekts


PivotTotals-Auflistungsobjekt

Die Auflistung der PivotTotal-Objekte auf der angegebenen Achse oder in der angegebenen Ansicht.

Verwenden der PivotTotals-Auflistung

Die nachfolgenden Eigenschaften geben ein Objekt aus der PivotTotals-Auflistung zurück:

Die Totals-Eigenschaft des PivotDataAxis-Objekts

Die Totals-Eigenschaft des PivotView-Objekts


PivotView-Objekt

Repräsentiert eine bestimmte Ansicht der PivotTable-Liste.

Verwenden des PivotView-Objekts

Die ActiveView-Eigenschaft des PivotTable-Objekts gibt ein PivotView-Objekt zurück.


Protection-Objekt

Enthält die Schutzeigenschaften eines Tabellenblattes.

Verwenden des Protection-Objekts

Die Protection-Eigenschaft eines Worksheet-Objekts gibt ein Protection-Objekt zurück.


Range-Objekt

Repräsentiert eine Zelle, einen Bereich von Zellen, eine Zeile oder eine Spalte auf einem Tabellenblatt.

Verwenden des Range-Objekts

Die nachfolgenden Eigenschaften und Methoden geben ein Range-Objekt zurück:

Die VisibleRange-Eigenschaft des Pane-Objekts

Die Cells-Eigenschaft des Range-Objekts

Die Columns-Eigenschaft des Range-Objekts

Die CurrentRegion-Eigenschaft des Range-Objekts

Die EntireColumn-Eigenschaft des Range-Objekts

Die EntireRow-Eigenschaft des Range-Objekts

Die Find-Methode des Range-Objekts

Die Item-Eigenschaft des Range-Objekts

Die MergeArea-Eigenschaft des Range-Objekts

Die Offset-Methode des Range-Objekts

Die Range-Eigenschaft des Range-Objekts

Die Rows-Eigenschaft des Range-Objekts

Die ActiveCell-Eigenschaft des Spreadsheet-Objekts

Die Cells-Eigenschaft des Spreadsheet-Objekts

Die Columns-Eigenschaft des Spreadsheet-Objekts

Die Intersect-Methode des Spreadsheet-Objekts

Die Range-Eigenschaft des Spreadsheet-Objekts

Die Rows-Eigenschaft des Spreadsheet-Objekts

Die Selection-Eigenschaft des Spreadsheet-Objekts

Die Union-Methode des Spreadsheet-Objekts

Die Range-Eigenschaft des SpreadsheetEventInfo-Objekts

Die Cells-Eigenschaft des Worksheet-Objekts

Die Columns-Eigenschaft des Worksheet-Objekts

Die Range-Eigenschaft des Worksheet-Objekts

Die Rows-Eigenschaft des Worksheet-Objekts

Die UsedRange-Eigenschaft des Worksheet-Objekts

Die VisibleRange-Eigenschaft des Worksheet-Objekts


RecordNavigationControl-Objekt

RecordNavigationControl-Objekt

Repräsentiert ein Steuerelement für die Datensatznavigation.

Verwenden des RecordNavigationControl-Objekts

Sie können entweder die CreateObject-Methode oder das Schlüsselwort New verwenden, um ein neues RecordNavigationControl-Objekt zu erstellen.

Die Objekt-ID eines Steuerelements für die Datensatznavigation auf einer HTML-Seite gibt ein RecordNavigationControl-Objekt zurück. Der programminterne Bezeichner des DataSourceControl-Objekts lautet CLSID:0002E531-0000-0000-C000-000000000046. Im nachfolgenden Beispiel wird ein Steuerelement für die Datensatznavigation mit Namen "RNC1" auf einer HTML-Seite erstellt.

<object id=RNC1 classid=CLSID:0002E531-0000-0000-C000-000000000046></object>


RecordsetDef-Objekt

Repräsentiert eine Datensatzdefinition.

Das RecordsetDef-Objekt ist Mitglied der RecordsetDefs-Auflistung.

Verwenden des RecordsetDef-Objekts

Die nachfolgenden Eigenschaften geben ein RecordsetDef-Objekt zurück:

Die RecordsetDef-Eigenschaft eines PageField-Objekts

Die RecordsetDef-Eigenschaft des PageRowsource-Objekts

Die ParentRecordsetDef-Eigenschaft des RecordsetDef-Objekts

Die Item-Eigenschaft des RecordsetDefs-Objekts


RecordsetDefs-Auflistungsobjekt

Die Auflistung der RecordsetDef-Objekte für das angegebene Datenquellen-Steuerelement.

Verwenden der RecordsetDefs-Auflistung

Die nachfolgenden Eigenschaften geben ein RecordsetDefs-Objekt zurück:

Die RecordsetDefs-Eigenschaft des DataSourceControl-Objekts


SchemaField-Objekt

Repräsentiert ein Feld in einer Schemazeilenquelle. Die Namen dieser Felder werden beim Erzeugen von SELECT-Anweisungen für Zeilenquellen des dscTable oder dscView-Typs erzeugt. Das SchemaField-Objekt ist Mitglied der SchemaFields-Auflistung.

Verwenden des SchemaField-Objekts

Die nachfolgenden Methoden und Eigenschaften geben ein SchemaField-Objekt zurück:

Die Add-Methode des SchemaFields-Objekts

Die Item-Eigenschaft des SchemaFields-Objekts


SchemaFields-Auflistungsobjekt

Die Auflistung aller verfügbaren SchemaField-Objekte einer Schemazeilenquelle.

Verwenden der SchemaFields-Auflistung

Die SchemaFields-Eigenschaft des SchemaRowsource-Objekts gibt ein SchemaFields-Objekt zurück.


SchemaParameter-Objekt

Repräsentiert einen einzelnen Parameter einer Schemazeilenquelle. Das SchemaParameter-Objekt ist Mitglied der SchemaParameters-Auflistung.

Verwenden des SchemaParameter-Objekts

Die nachfolgende Methode und die nachfolgende Eigenschaft geben ein SchemaParameter-Objekt zurück:

Die Add-Methode des SchemaParameters-Objekts

Die Item-Eigenschaft des SchemaParameters-Objekts


SchemaParameters-Auflistungsobjekt

Die Auflistung der SchemaParameter-Objekte der angegebenen Schemazeilenquelle.

Verwenden der SchemaParameters-Auflistung

Die SchemaParameters-Eigenschaft des SchemaRowsource-Objekts gibt ein SchemaParameters-Objekt zurück.


SchemaRelatedField-Objekt

Beschreibt die Spaltenpaare, die eine Schemabeziehung bilden. Die Namen dieser Felder werden beim Erzeugen von Verknüpfungsklauseln in SQL sowie beim Einbinden einer übergeordneten Datensatzgruppendefinition in die untergeordnete Datensatzgruppendefinition einer Unterliste verwendet. Das SchemaRelatedField-Objekt ist Mitglied der SchemaRelatedFields-Auflistung.

Verwenden von SchemaRelatedField

Die nachfolgende Methode und die nachfolgende Eigenschaft geben ein SchemaRelatedField-Objekt zurück:

Die Add-Methode des SchemaRelatedFields-Objekts

Die Item-Eigenschaft des SchemaRelatedFields-Objekts


SchemaRelatedFields-Auflistungsobjekt

Die Auflistung der SchemaRelatedField-Objekte einer Schemabeziehung.

Verwenden der SchemaRelatedFields-Auflistung

Die SchemaRelatedFields-Eigenschaft des SchemaRelationship-Objekts gibt ein SchemaRelatedFields-Objekt zurück.


SchemaRelationship-Objekt

Repräsentiert eine Schemabeziehung. Eine Schemabeziehung beschreibt, auf welche Weise Schemazeilenquellen miteinander verbunden sind. Sie besteht immer aus einer "1" und einer "n"-Seite (in einer 1:n-Beziehung). Das SchemaRelationship-Objekt ist Mitglied der SchemaRelationships-Auflistung.

Verwenden des SchemaRelationship-Objekts

Die folgenden Eigenschaften und die nachfolgende Methode geben ein SchemaRelationship-Objekt zurück:

Die Item-Eigenschaft des LookupSchemaRelationships-Objekts

Die Add-Methode des SchemaRelationships-Objekts

Die Item-Eigenschaft des SchemaRelationships-Objekts

Die Item-Eigenschaft des SublistSchemaRelationships-Objekts


SchemaRelationships-Auflistungsobjekt

Die Auflistung der SchemaRelationship-Objekte dieses Datenquellen-Steuerelements.

Verwenden der SchemaRelationships-Auflistung

Die SchemaRelationships-Eigenschaft des DataSourceControl-Objekts gibt ein SchemaRelationships-Objekt zurück.


SchemaRowsource-Objekt

Repräsentiert eine Schemazeilenquelle. Jede Tabelle, Ansicht oder in der Datenbank gespeicherte Prozedur stellt eine potenzielle Schemazeilenquelle dar. Dies gilt auch für Befehle, die ausdrücklich für das Datenquellen-Steuerelement definiert worden sind.

Das SchemaRowsource-Objekt ist Mitglied der SchemaRowsources-Auflistung.

Verwenden des SchemaRowsource-Objekts

Die nachfolgende Methode und die nachfolgende Eigenschaft geben ein SchemaRowsource-Objekt zurück:

Die Add-Methode des SchemaRowsources-Objekts

Die Item-Eigenschaft des SchemaRowsources-Objekts


SchemaRowsources-Auflistungsobjekt

Die Auflistung der SchemaRowsource-Objekte des angegebenen Datenquellen-Steuerelements. Diese Auflistung wird jedes Mal automatisch aus den Objekten in der Datenbank erstellt, wenn die Datenbank geöffnet wird.

Verwenden der SchemaRowsources-Auflistung

Die SchemaRowsources-Eigenschaft des DataSourceControl-Objekts gibt ein SchemaRowsources-Objekt zurück.


Section-Objekt

Instanz eines einzelnen Gruppenkopfes, -fußes oder -namens oder eines Navigationsbereichs.

Verwenden des Section-Objekts

Die GetContainingSection-Methode des DataSourceControl-Objekts gibt ein Section-Objekt zurück.


Spreadsheet-Objekt

Repräsentiert die Kalkulationstabelle.

Verwenden des Spreadsheet-Objekts

Sie können entweder die CreateObject-Methode oder das Schlüsselwort New verwenden, um ein neues Spreadsheet-Objekt zu erstellen.

Die Objekt-ID eines Kalkulationstabellen-Steuerelements auf einer HTML-Seite oder in einem Visual Basic-Formular gibt ein Spreadsheet-Objekt zurück.

Der programminterne Bezeichner des Spreadsheet-Objekts lautet CLSID:0002E510-0000-0000-C000-000000000046. Im nachfolgenden Beispiel wird auf einer HTML-Seite eine Kalkulationstabelle mit dem Namen "Spreadsheet1" erstellt.

<object id=Spreadsheet1 classid=CLSID:0002E510-0000-0000-C000-000000000046 style="width:49%;height:350"></object>


SpreadsheetEventInfo-Objekt

Enthält Informationen über ein Spreadsheet-Ereignis (den Bereich, in dem das Ereignis eingetreten ist, welche Tasten oder Maustasten gedrückt wurden usw.).

Verwenden des SpreadsheetEventInfo-Objekts

Alle Ereignisse des Spreadsheet-Objekts verwenden das SpreadsheetEventInfo-Objekt als einzigen Parameter. Weitere Informationen finden Sie in den Hilfethemen zu den folgenden Ereignissen:

BeforeCommand-Ereignis

CancelEdit-Ereignis

Change-Ereignis

Click-Ereignis

Command-Ereignis

DblClick-Ereignis

EndEdit-Ereignis

KeyDown-Ereignis

KeyPress-Ereignis

KeyUp-Ereignis

MouseDown-Ereignis

MouseOut-Ereignis

MouseOver-Ereignis

MouseUp-Ereignis

SelectionChange-Ereignis

SelectionChanging-Ereignis

StartEdit-Ereignis

ViewChange-Ereignis


SublistRelationships-Auflistungsobjekt

Die Auflistung der PageRelationship-Objekte des dscSublist-Typs, die alle dieselbe Datensatzgruppendefinition als ihre "1"-Seite (übergeordnete "Parent"-Seite) einer 1:n-Beziehung aufweisen. Die Datensätze auf der untergeordneten "Child"-Seite einer Unterlistenbeziehung werden nur dann abgerufen, wenn sie benötigt werden.

Verwenden der SublistRelationships-Auflistung

Die SublistRelationships-Eigenschaft des RecordsetDef-Objekts gibt ein SublistRelationships-Objekt zurück.


SublistSchemaRelationships-Auflistungsobjekt

Auflistung von SchemaRelationship-Objekten, die alle dieselbe Schemazeilenquelle wie ihre "1"-Seite (in einer 1:n.Beziehung) aufweisen.

Verwenden der SublistSchemaRelationships-Auflistung

Die SublistSchemaRelationships-Eigenschaft des SchemaRowsource-Objekts gibt ein SublistSchemaRelationships-Objekt zurück.


TitleBar-Objekt

Repräsentiert die Titelleiste der Kalkulationstabelle.

Verwenden des TitleBar-Objekts

Die TitleBar-Eigenschaft des Spreadsheet-Objekts gibt ein TitleBar-Objekt zurück.


WCAxis-Objekt

Repräsentiert eine einzelne Achse in einem Diagramm. Ein Diagramm kann bis zu acht Achsen enthalten. Das WCAxis-Objekt ist Mitglied der WCAxes-Auflistung.

Verwenden des WCAxis-Objekts

Verwenden Sie die Add-Methode des WCAxes-Objekts, um einem Diagramm eine Achse hinzuzufügen.

Die nachfolgenden Eigenschaften und Methoden geben ein WCAxis-Objekt zurück.

Die Add-Methode des WCAxes-Objekts

Die Item-Eigenschaft des WCAxes-Objekts

Die CrossingAxis-Eigenschaft des WCAxis-Objekts

Die Parent-Eigenschaft des WCGridlines-Objekts


WCAxes-Auflistungsobjekt

Auflistung von WCAxis-Objekten, welche die Achsen eines einzigen Diagramms darstellen. Jedes Diagramm kann bis zu acht Achsen enthalten.

Verwenden der WCAxes-Auflistung

Die Axes-Eigenschaft des WCChart-Objekts gibt eine WCAxes-Auflistung zurück.


WCChart-Objekt

Repräsentiert ein einzelnes Diagramm innerhalb des Diagrammarbeitsbereichs. Der Diagrammarbeitsbereich kann bis zu 16 Diagramme enthalten. Das WCChart-Objekt ist Mitglied der WCCharts-Auflistung.

Verwenden des WCChart-Objekts

Verwenden Sie die Add-Methode des WCCharts-Objekts, um dem Arbeitsbereich ein Diagramm hinzuzufügen.

Die nachfolgenden Eigenschaften und Methoden geben ein WCChart-Objekt zurück.

Die Parent-Eigenschaft des WCAxes-Objekts

Die Parent-Eigenschaft des WCAxis-Objekts

Die Add-Methode des WCCharts-Objekts

Die Item-Eigenschaft des WCCharts-Objekts

Die Parent-Eigenschaft des WCPlotArea-Objekts

Die Parent-Eigenschaft des WCSeries-Objekts

Die Parent-Eigenschaft des WCSeriesCollection-Objekts


WCCharts-Auflistungsobjekt

Die Auflistung der WCChart-Objekte des Diagrammarbeitsbereichs. Jedes WCChart-Objekt repräsentiert ein einzelnes Diagramm. Der Diagrammarbeitsbereich kann bis zu 16 Diagramme enthalten.

Verwenden der WCCharts-Auflistung

Die Charts-Eigenschaft des ChartSpace-Objekts gibt eine WCCharts-Auflistung zurück.


WCChartEventInfo-Objekt

WCChartEventInfo-Objekt

Enthält Informationen über ein Diagrammarbeitsbereichsereignis (welche Tasten oder Maustasten bei Eintreten des Ereignisses gedrückt waren usw.).

Verwenden des WCChartEventInfo-Objekts

Die nachfolgenden Diagrammarbeitsbereichsereignisse verwenden ein WCChartEventInfo-Objekt als ihren einzigen Parameter. Weitere Informationen finden Sie in den Hilfethemen zu den nachfolgenden Ereignissen:

Click-Ereignis

DblClick-Ereignis

KeyDown-Ereignis

KeyPress-Ereignis

KeyUp-Ereignis

MouseDown-Ereignis

MouseMove-Ereignis

MouseUp-Ereignis


WCDataLabel-Objekt

Repräsentiert die Datenbeschriftung für eine Trendlinie. Nur das WCTrendline-Objekt enthält ein WCDataLabel-Objekt (Datenbeschriftungen für eine Reihe werden durch ein WCDataLabels-Objekt dargestellt).

Verwenden des WCDataLabel-Objekts

Verwenden Sie die DataLabel-Eigenschaft des WCTrendline-Objekts, um das WCDataLabels-Objekt für die Trendlinie zurückzugeben. Eine Trendlinie besitzt eine Datenbeschriftung, wenn ihre IsDisplayingEquation-Eigenschaft oder IsDisplayingRSquared-Eigenschaft auf True gesetzt ist. Sonst gibt die Eigenschaft Nothing zurück.


WCDataLabels-Objekt

Repräsentiert sämtliche Datenbeschriftungen zu einer Reihe. Sie können ein angepasstes Format nicht auf eine einzelne Datenbeschriftung anwenden. Formate gelten für sämtliche Datenbeschriftungen der Reihe.

Verwenden des WCDataLabels-Objekts

Verwenden Sie die Add-Methode des WCDataLabelsCollection-Objekts, um einer Reihe Datenbeschriftungen hinzuzufügen.

Die folgende Eigenschaft und die nachfolgenden Methoden geben ein WCDataLabels-Objekt zurück.

Die Add-Methode des WCDataLabelsCollection-Objekts

Die Item-Eigenschaft des WCDataLabelsCollection-Objekts


WCDataLabelsCollection-Auflistungsobjekt

Eine Auflistung der WCDataLabels-Objekte. Beachten Sie, dass die WCDataLabelsCollection-Auflistung nur ein WCDataLabels-Objekt enthalten kann.

Verwenden der WCDataLabelsCollection-Auflistung

Die DataLabelsCollection-Eigenschaft des WCSeries-Objekts gibt eine WCDataLabelsCollection-Auflistung zurück.


WCDataSource-Objekt

Repräsentiert eine Datenquelle. Eine Datenquelle gibt eine Verbindung zu einer Kalkulationstabelle, einem Datenquellen-Steuerungselement oder einer PivotTable-Liste an. Das WCDataSource-Objekt ist Mitglied der WCDataSources-Auflistung.

Verwenden des WCDataSource-Objekts

Die folgende Eigenschaft und die nachfolgenden Methoden geben ein WCDataSource-Objekt zurück.

Die Add-Methode des WCDataSources-Objekts

Die Item-Eigenschaft des WCDataSources-Objekts


WCDataSources-Auflistungsobjekt

Die Auflistung der WCDataSource-Objekte des Diagrammarbeitsbereichs.

Verwenden der WCDataSources-Auflistung

Die ChartDataSources-Eigenschaft des ChartSpace-Objekts gibt ein WCDataSources-Objekt zurück.


WCErrorBars-Objekt

Repräsentiert die Fehlerindikatoren für eine Reihe. Fehlerindikatoren zeigen den Grad der Unsicherheit bei Diagrammdaten an. Nur Reihen in Netz-, Polar-, Bereichs-, Balken-, Säulen-, Linien- und Punktdiagrammen können Fehlerindikatoren beinhalten. Nur Reihen in Punktdiagrammen können X und Y-Fehlerindikatoren enthalten. Das WCErrorBars-Objekt ist keine Auflistung. Es existiert kein Objekt, das einen einzelnen Fehlerindikator repräsentiert. Entweder aktivieren Sie die X-Fehlerindikatoren oder die Y-Fehlerindikatoren für alle Punkte einer Reihe, oder Sie deaktivieren diese.

Das WCErrorBars-Objekt ist Mitglied der WCErrorBarsCollection-Auflistung.

Verwenden des WCErrorBars-Objekts

Verwenden Sie die Add-Methode des WCErrorBarsCollection-Objekts, um die Fehlerindikatoren einer Reihe hinzuzufügen.

Die folgenden Methoden geben ein WCErrorBars-Objekt zurück. Weitere Informationen finden Sie in den Hilfethemen zu diesen Methoden:

Die Add-Methode des WCErrorBarsCollection-Objekts

Die Item-Eigenschaft des WCErrorbarsCollection-Objekts


WCErrorBarsCollection-Auflistungsobjekt

Die Auflistung der WCErrorBars-Objekte einer einzelnen Reihe. Beachten Sie, dass diese Auflistung nur ein WCErrorBars-Objekt enthalten kann.

Verwenden der WCErrorBarsCollection-Auflistung

Die ErrorBarsCollection-Eigenschaft des WCSeries-Objekts gibt ein WCErrorBarsCollection-Objekt zurück.


WCGridlines-Objekt

Steht für große oder kleine Gitternetzlinien auf einer Diagrammachse. Gitternetzlinien ohne Achse sind nicht möglich. Gitternetzlinien erweitern die Hilfsstriche auf einer Achse, um das Lesen der Werte zu erleichtern, die mit den Datendarstellungen verknüpft sind. Dieses Objekt stellt keine Auflistung dar. Es existiert kein Objekt, das eine einzelne Gitternetzlinie repräsentiert. Es sind entweder alle Gitternetzlinien einer Achse aktiviert oder deaktiviert.

Verwenden des WCGridlines-Objekts

Die folgenden Eigenschaften geben ein WCGridlines-Objekt zurück.

Die MajorGridlines-Eigenschaften des WCAxis-Objekts

Die MinorGridlines-Eigenschaft des WCAxis-Objekts


WCLegend-Objekt

Repräsentiert einen Diagrammarbeitsbereich oder eine Diagrammlegende. Ein Diagramm oder ein Diagrammarbeitsbereich kann nur eine Legende enthalten. Das WCLegend-Objekt enthält eine WCLegendEntries-Auflistung, die eines oder mehrere WCLegendEntry-Objekte enthält.

Verwenden des WCLegend-Objekts

Verwenden Sie die HasLegend-Eigenschaft oder die HasChartspaceLegend-Eigenschaft, um die Legende zu aktivieren.

Die nachfolgenden Eigenschaften geben ein WCLegend-Objekt zurück.

Die ChartspaceLegend-Eigenschaft eines ChartSpace-Objekts

Die Legend-Eigenschaft eines WCChart-Objekts

Die Parent-Eigenschaft des WCLegendEntries-Objekts

Die Parent-Eigenschaft des WCLegendEntry-Objekts


WCLegendEntry-Objekt

Repräsentiert einen einzelnen Legendentext. Das WCLegendEntry-Objekt ist Mitglied der WCLegendEntries-Auflistung.

Verwenden des WCLegendEntry-Objekts

Die Item-Eigenschaft des WCLegendEntries-Objekts gibt ein WCLegendEntry-Objekt zurück.


WCLegendEntries-Auflistungsobjekt

Die Auflistung der WCLegendEntry-Objekte der angegebenen Legende.

Verwenden der WCLegendEntries-Auflistung

Die LegendEntries-Eigenschaft des WCLegend-Objekts gibt eine WCLegendEntries-Auflistung zurück.


WCMarker-Objekt

Repräsentiert einen Datenpunkt in einem Linien-, Punkt (XY)-, Netz- oder Polardiagramm.

Verwenden des WCMarker-Objekts

Die Marker-Eigenschaft des WCSeries-Objekts gibt ein WCMarker-Objekt zurück.


WCPlotArea-Objekt

Repräsentiert die Zeichnungsfläche in einem Diagramm (der Bereich, in dem die Diagrammdaten gezeichnet werden). Kreis-, Ring-, Radar- und Polardiagramme verfügen über keine Zeichnungsfläche. Stattdessen zeichnen diese Diagramme unmittelbar im Diagrammbereich.

Verwenden des WCPlotArea-Objekts

Die PlotArea-Eigenschaft des WCChart-Objekts gibt ein WCPlotArea-Objekt zurück.


WCPoint-Objekt

Repräsentiert einen einzelnen Datenpunkt in einer Reihe eines Diagramms. Das WCPoint-Objekt ist Mitglied der WCPoints-Auflistung. Sie enthält sämtliche Punkte einer bestimmten Reihe.

Verwenden des WCPoint-Objekts

Verwenden Sie dieses Objekt, um einzelne Datenpunkte einer Reihe zu formatieren. Oder verwenden Sie die GetValue-Methode, um einen Punktwert zurückzugeben.

Die Item-Eigenschaft eines WCPoints-Objekts gibt ein WCPoint-Objekt zurück.


WCPoints-Auflistungsobjekt

Eine Auflistung sämtlicher WCPoint-Objekte einer Reihe. Die Anzahl der Datenpunkte in einer Reihe ist nur durch die Größe des Systemarbeitsspeichers in dem verwendeten Computer begrenzt.

Verwenden der WCPoints-Auflistung

Die Points-Eigenschaft des WCSeries-Objekts gibt ein WCPoints-Objekt zurück.


WCScaling-Objekt

Enthält die Skalierungseigenschaften einer Achse, eines Diagramms oder einer Reihe.

Verwenden des WCScaling-Objekts

Die folgenden Eigenschaften geben ein WCScaling-Objekt zurück.

Die Scaling-Eigenschaft des WCAxis-Objekts

Die Scalings-Eigenschaft des WCChart-Objekts

Die Scalings-Eigenschaft des WCSeries-Objekts


WCSeries-Objekt

Repräsentiert eine Reihe in einem Diagramm. Das WCSeries-Objekt ist Mitglied der WCSeriesCollection-Auflistung.

Verwenden des WCSeries-Objekts

Verwenden Sie die Add-Methode der WCSeriesCollection-Auflistung, um eine Reihe zu einem Diagramm hinzuzufügen.

Die nachfolgenden Eigenschaften und Methoden geben ein WCSeries-Objekt zurück:

Die Parent-Eigenschaft des WCDataLabels-Objekts

Die Parent-Eigenschaft des WCDataLabelsCollection-Objekts

Die Parent-Eigenschaft des WCErrorBars-Objekts

Die Parent-Eigenschaft des WCErrorBarsCollection-Objekts

Die Parent-Eigenschaft des WCPoint-Objekts

Die Parent-Eigenschaft des WCPoints-Objekts

Die Add-Methode des WCSeriesCollection-Objekts

Die Item-Eigenschaft des WCSeriesCollection-Objekts

Die Parent-Eigenschaft des WCTrendline-Objekts

Die Parent-Eigenschaft des WCTrendlines-Objekts


WCSeriesCollection-Auflistungsobjekt

Eine Auflistung sämtlicher WCSeries-Objekte eines Diagramms. Ein Diagramm kann bis zu 255 Reihen enthalten.

Verwenden der WCSeriesCollection-Auflistung

Die SeriesCollection-Eigenschaft desWCChart-Objekts gibt eine WCSeriesCollection-Auflistung zurück.


WCTitle-Objekt

Repräsentiert den Titel eines Diagrammarbeitsbereichs, einer Achse oder eines Diagramms.

Verwenden des WCTitle-Objekts

Verwenden Sie die HasTitle- oder HasChartspaceTitle-Eigenschaft, um Titel zu aktivieren.

Die nachfolgenden Eigenschaften geben ein WCTitle-Objekt zurück.

Die ChartspaceTitle-Eigenschaft des ChartSpace-Objekts

Die Title-Eigenschaft des WCAxis-Objekts

Die Title-Eigenschaft des WCChart-Objekts


WCTrendline-Objekt

Repräsentiert eine Trendlinie in einem Diagramm. Eine Trendlinie zeigt den Trend oder die Richtung der Daten in einer Reihe an. Das WCTrendline-Objekt ist Mitglied der WCTrendlines-Auflistung.

Verwenden des WCTrendline-Objekts

Verwenden Sie die Add-Methode des WCTrendlines-Objekts, um eine Trendlinie zu einer Reihe hinzuzufügen.

Die folgende Methode und die nachfolgende Eigenschaft geben ein WCTrendline-Objekt zurück.

Die Add-Methode des WCTrendlines-Objekts

Die Item-Eigenschaft des WCTrendlines-Objekts


WCTrendlines-Auflistungsobjekt

Die Auflistung der WCTrendline-Objekte einer Reihe. Beachten Sie, dass die WCTrendlines-Auflistung nur ein WCTrendline-Objekt enthalten kann (d. h. es kann für jede Reihe nur eine Trendlinie geben).

Verwenden der WCTrendlines-Auflistung

Die Trendlines-Eigenschaft des WCSeries-Objekts gibt eine WCTrendlines-Auflistung zurück.


Worksheet-Objekt

Repräsentiert ein einzelnes Tabellenblatt in der Kalkulationstabelle. Beachten Sie, dass die Kalkulationstabelle nur ein Tabellenblatt enthalten kann.

Verwenden des Worksheet-Objekts

Die nachfolgenden Eigenschaften geben ein Worksheet-Objekt zurück.

Die Parent-Eigenschaft des Range-Objekts

Die ActiveSheet-Eigenschaft des Spreadsheet-Objekts


ActiveCell-Eigenschaft

Gibt ein Range-Objekt zurück, das die aktive Zelle repräsentiert. Schreibgeschützt.


ActiveCell-Eigenschaft: Beispiel

In diesem Beispiel wird das Zahlenformat in der aktiven Zelle des Tabellenblattes festgelegt.

Spreadsheet1.ActiveCell.NumberFormat = "0.##"


ActiveData-Eigenschaft

Gibt ein PivotData-Objekt zurück, das die Daten in der aktiven PivotTable-Liste repräsentiert. Schreibgeschützt.


ActivePane-Eigenschaft

Gibt ein Pane-Objekt zurück, welches das aktuelle Kalkulationstabellenfenster repräsentiert. Schreibgeschützt.


ActivePane-Eigenschaft: Beispiel

In diesem Beispiel wird der Wert der Zelle in der linken oberen Ecke des sichtbaren Bereichs des aktiven Fensters in der Kalkulationstabelle gesetzt.

Spreadsheet1.ActivePane.VisibleRange.Cells(1, 1).Value = "top left"


ActiveSheet-Eigenschaft

Gibt ein Worksheet-Objekt zurück, welches das Tabellenblatt repräsentiert (die Kalkulationstabelle kann nur ein Tabellenblatt enthalten). Schreibgeschützt.


ActiveSheet-Eigenschaft: Beispiel

In diesem Beispiel wird der Wert der Zelle in der linken oberen Ecke des sichtbaren Bereichs von Ausschnitt 1 in der Kalkulationstabelle gesetzt.

Spreadsheet1.ActiveSheet.Panes(1).VisibleRange.Cells(1, 1).Value = "top left"


ActiveView-Eigenschaft

Gibt ein PivotView-Objekt zurück, welches das Layout der aktiven PivotTable-Liste repräsentiert. Schreibgeschützt.


ActiveView-Eigenschaft: Beispiel

In diesem Beispiel werden zwei Feldgruppen in die aktive Ansicht eingefügt.

Set view = PivotTable1.ActiveView
view.ColumnAxis.InsertFieldSet view.FieldSets("Store Type")
view.RowAxis.InsertFieldSet view.FieldSets("Promotions")


Address-Eigenschaft

Hyperlink-Objekt: Gibt die Adresse des Zieldokuments zurück oder legt diese fest. String mit Lese-/Schreibzugriff.

Range-Objekt: Gibt die Adresse des angegebenen Bereichs (zum Beispiel A1) zurück. String schreibgeschützt.


Address-Eigenschaft: Beispiel

In diesem Beispiel wird die Adresse des angegebenen Hyperlinks festgelegt.

Spreadsheet1.Range("a22").Hyperlink.Address = "http://www.microsoft.com"

In diesem Beispiel wird die Adresse des sichtbaren Bereichs zurückgegeben.

MsgBox Spreadsheet1.ActiveSheet.VisibleRange.Address


AggregateCount-Eigenschaft

Gibt die Anzahl der Aggregate zurück. Long schreibgeschützt.


Aggregates-Eigenschaft

Gibt die PivotAggregates-Auflistung für die angegebene Zelle zurück. Schreibgeschützt.

Informationen über das Zurückgeben eines einzelnen Mitglieds einer Auflistung finden Sie im Abschnitt Zurückgeben eines Objekts aus einer Auflistung.


AllGroupingDefs-Eigenschaft

Gibt die AllGroupingDefs-Auflistung für das Datenquellen-Steuerelement zurück. Schreibgeschützt.


AllowDeletingColumns-Eigenschaft

Der Wert lautet True, wenn die Spalten des Tabellenblattes gelöscht werden können. Der Standardwert ist False. Diese Eigenschaft hat jedoch keine Auswirkungen, wenn die Enabled-Eigenschaft des Protection-Objekts auf False gesetzt worden ist. Boolean mit Lese-/Schreibzugriff.


AllowDeletingColumns-Eigenschaft: Beispiel

In diesem Beispiel werden alle Zellen der angegebenen Kalkulationstabelle gesperrt. Anschließend wird das Filtern und Sortieren von Zeilen und Spalten aktiviert, das Einfügen, Löschen oder die Größenanpassung von Zeilen und Spalten jedoch deaktiviert.

Spreadsheet1.Cells.Locked = True
Set pt = Spreadsheet1.ActiveSheet.Protection
pt.AllowDeletingColumns = False
pt.AllowDeletingRows = False
pt.AllowFiltering = True
pt.AllowInsertingColumns = False
pt.AllowInsertingRows = False
pt.AllowSizingAllColumns = False
pt.AllowSizingAllRows = False
pt.AllowSorting = True
pt.Enabled = True


AllowDeletingRows-Eigenschaft

Der Wert lautet True, wenn die Zeilen des Tabellenblattes gelöscht werden können. Der Standardwert ist False. Diese Eigenschaft hat jedoch keine Auswirkungen, wenn die Enabled-Eigenschaft des Protection-Objekts auf False gesetzt worden ist. Boolean mit Lese-/Schreibzugriff.


AllowDeletingRows-Eigenschaft: Beispiel

In diesem Beispiel werden alle Zellen der angegebenen Kalkulationstabelle gesperrt. Anschließend wird das Filtern und Sortieren von Zeilen und Spalten aktiviert, das Einfügen, Löschen oder die Größenanpassung von Zeilen und Spalten jedoch deaktiviert.

Spreadsheet1.Cells.Locked = True
Set pt = Spreadsheet1.ActiveSheet.Protection
pt.AllowDeletingColumns = False
pt.AllowDeletingRows = False
pt.AllowFiltering = True
pt.AllowInsertingColumns = False
pt.AllowInsertingRows = False
pt.AllowSizingAllColumns = False
pt.AllowSizingAllRows = False
pt.AllowSorting = True
pt.Enabled = True


AllowDetails-Eigenschaft

Der Wert lautet True, wenn der Benutzer ein inneres Mitglied der angegebenen PivotTable-Liste erweitern kann, um die Detaildatensätze anzuzeigen. Der Standardwert lautet True. Boolean mit Lese-/Schreibzugriff.

Anmerkungen

Wenn diese Eigenschaft False ist, zeigen innere Mitglieder keine Erweiterungssymbole an. Der Befehl Erweitern ist bei den meisten Aggregaten deaktiviert, und das Doppelklicken auf ein Aggregat zeigt keine Detaildaten an.

Wenn diese Eigenschaft False ist, kann der Benutzer die Details dennoch mit Hilfe des Programms anzeigen.


AllowDetails-Eigenschaft: Beispiel

In diesem Beispiel wird die Detailanzeige für die PivotTable-Liste deaktiviert.

PivotTable1.AllowDetails = False


AllowFiltering-Eigenschaft

Protection-Objekt: Der Wert lautet True, wenn die Tabellenblattfilterung für die angegebene PivotTable-Liste aktiviert ist. Diese Eigenschaft hat keine Auswirkungen, wenn die Enabled-Eigenschaft des Protection-Objekts auf False gesetzt wurde. Boolean mit Lese-/Schreibzugriff.

PivotTable-Objekt: Der Wert ist True, wenn der Benutzer die Filter verändern kann. Der Standardwert lautet True. Boolean mit Lese-/Schreibzugriff.

Wenn diese Eigenschaft auf False gesetzt wurde, sind die nachfolgenden Bedingungen wahr:

  • Der Befehl AutoFilter ist deaktiviert.

  • Der Befehl Auswahlbasierter Filter ist deaktiviert.

  • Der Befehl In Filterbereich verschieben ist deaktiviert.

  • Der Befehl In Detailbereich verschieben ist deaktiviert, wenn die Auswahl ein Feld innerhalb des Filterbereichs ist.

  • Alle AutoFilter-Dropdownfelder sind schreibgeschützt. Beachten Sie, dass der Benutzer diese Felder auch dann anzeigen kann, wenn sie deaktiviert sind.

  • Sie können Filter auch zu jeder Zeit mit Hilfe des Programms festlegen.

  • Die Mitgliedschaft im Filterbereich ist unveränderlich. Der Benutzer kann kein Feld in den Filterbereich hineinziehen oder daraus entfernen.


AllowFiltering-Eigenschaft: Beispiel

In diesem Beispiel wird das Filtern für die PivotTable-Liste deaktiviert.

PivotTable1.AllowFiltering = False


AllowGrouping-Eigenschaft

Der Wert lautet True, wenn der Benutzer dazu in der Lage ist, Felder auf der Zeilen- oder Spaltenachse der angegebenen PivotTable-Liste zu gruppieren. Wenn diese Eigenschaft auf False gesetzt ist, sind die Gruppierungsschaltflächen deaktiviert, aber der Benutzer kann Felder mit Hilfe des Programms dennoch gruppieren. Der Standardwert lautet True. Boolean mit Lese-/Schreibzugriff.

Anmerkungen

Wenn diese Eigenschaft auf False gesetzt wurde, ist das Pivotieren deaktiviert. Dies bedeutet, dass die Mitgliedschaft in den Zeilen- und Spaltenbereichen unveränderlich ist. Sie können kein Feld in diese Bereiche ziehen oder daraus entfernen. Alle Befehle, die sich auf das Gruppieren beziehen, werden deaktiviert. Dies schließt die nachfolgenden Befehle ein:

  • In Zeilenbereich verschieben

  • In Spaltenbereich verschieben

  • In Detailbereich verschieben, wenn die Auswahl ein Feld in einem Zeilen- oder Spaltenbereich ist

Das Berichtslayout wird fixiert, aber der Benutzer kann die Daten dennoch filtern.


AllowGrouping-Eigenschaft: Beispiel

In diesem Beispiel wird das Gruppieren von Feldern für die PivotTable-Liste deaktiviert.

PivotTable1.AllowGrouping = False


AllowInsertingColumns-Eigenschaft

Der Wert lautet True, wenn Tabellenblattspalten eingefügt werden können. Der Standardwert lautet False. Diese Eigenschaft hat jedoch keine Auswirkungen, wenn die Enabled-Eigenschaft des Protection-Objekts auf False gesetzt ist. Boolean mit Lese-/Schreibzugriff.


AllowInsertingColumns-Eigenschaft: Beispiel

In diesem Beispiel werden alle Zellen der angegebenen Kalkulationstabelle gesperrt. Anschließend wird das Filtern und Sortieren von Zeilen und Spalten aktiviert, das Einfügen, Löschen oder die Größenanpassung von Zeilen und Spalten jedoch deaktiviert.

Spreadsheet1.Cells.Locked = True
Set pt = Spreadsheet1.ActiveSheet.Protection
pt.AllowDeletingColumns = False
pt.AllowDeletingRows = False
pt.AllowFiltering = True
pt.AllowInsertingColumns = False
pt.AllowInsertingRows = False
pt.AllowSizingAllColumns = False
pt.AllowSizingAllRows = False
pt.AllowSorting = True
pt.Enabled = True


AllowInsertingRows-Eigenschaft

Der Wert lautet True, wenn Zeilen in das Tabellenblatt eingefügt werden können. Der Standardwert ist False. Diese Eigenschaft hat jedoch keine Auswirkungen, wenn die Protection Enabled-Eigenschaft auf False gesetzt wurde. Boolean mit Lese-/Schreibzugriff.


AllowInsertingRows-Eigenschaft: Beispiel

In diesem Beispiel werden alle Zellen der angegebenen Kalkulationstabelle gesperrt. Anschließend wird das Filtern und Sortieren von Zeilen und Spalten aktiviert, das Einfügen, Löschen oder die Größenanpassung von Zeilen und Spalten jedoch deaktiviert.

Spreadsheet1.Cells.Locked = True
Set pt = Spreadsheet1.ActiveSheet.Protection
pt.AllowDeletingColumns = False
pt.AllowDeletingRows = False
pt.AllowFiltering = True
pt.AllowInsertingColumns = False
pt.AllowInsertingRows = False
pt.AllowSizingAllColumns = False
pt.AllowSizingAllRows = False
pt.AllowSorting = True
pt.Enabled = True


AllowPropertyToolbox-Eigenschaft

Der Wert lautet True, wenn die Eigenschaftentoolbox zur Laufzeit aktiviert wird (Sie können die Eigenschaftentoolbox nicht zur Entwicklungszeit deaktivieren). Der Standardwert lautet True. Boolean mit Lese-/Schreibzugriff.


AllowPropertyToolbox-Eigenschaft: Beispiel

In diesem Beispiel wird die Eigenschaftentoolbox zur Laufzeit deaktiviert.

Spreadsheet1.AllowPropertyToolbox = False


AllowSizingAllColumns-Eigenschaft

Der Wert lautet True, wenn Tabellenblattspalten in der Größe verändert werden können. Der Standardwert lautet False. Diese Eigenschaft hat jedoch keine Auswirkungen, wenn die Enabled-Eigenschaft des Protection-Objekts auf False gesetzt ist. Boolean mit Lese-/Schreibzugriff.


AllowSizingAllColumns-Eigenschaft: Beispiel

In diesem Beispiel werden alle Zellen der angegebenen Kalkulationstabelle gesperrt. Anschließend wird das Filtern und Sortieren von Zeilen und Spalten aktiviert, das Einfügen, Löschen oder die Größenanpassung von Zeilen und Spalten jedoch deaktiviert.

Spreadsheet1.Cells.Locked = True
Set pt = Spreadsheet1.ActiveSheet.Protection
pt.AllowDeletingColumns = False
pt.AllowDeletingRows = False
pt.AllowFiltering = True
pt.AllowInsertingColumns = False
pt.AllowInsertingRows = False
pt.AllowSizingAllColumns = False
pt.AllowSizingAllRows = False
pt.AllowSorting = True
pt.Enabled = True


AllowSizingAllRows-Eigenschaft

Der Wert lautet True, wenn Tabellenblattreihen in der Größe verändert werden können. Der Standardwert lautet False. Diese Eigenschaft hat jedoch keine Auswirkungen, wenn die Enabled-Eigenschaft des Protection-Objekts auf False gesetzt ist. Boolean mit Lese-/Schreibzugriff.


AllowSizingAllRows-Eigenschaft: Beispiel

In diesem Beispiel werden alle Zellen der angegebenen Kalkulationstabelle gesperrt. Anschließend wird das Filtern und Sortieren von Zeilen und Spalten aktiviert, das Einfügen, Löschen oder die Größenanpassung von Zeilen und Spalten jedoch deaktiviert.

Spreadsheet1.Cells.Locked = True
Set pt = Spreadsheet1.ActiveSheet.Protection
pt.AllowDeletingColumns = False
pt.AllowDeletingRows = False
pt.AllowFiltering = True
pt.AllowInsertingColumns = False
pt.AllowInsertingRows = False
pt.AllowSizingAllColumns = False
pt.AllowSizingAllRows = False
pt.AllowSorting = True
pt.Enabled = True


AllowSorting-Eigenschaft

Der Wert lautet True, wenn das angegebene Tabellenblatt sortiert werden kann. Der Standardwert ist False. Diese Eigenschaft hat jedoch keine Auswirkungen, wenn die Enabled-Eigenschaft des Protection-Objekts auf False gesetzt worden ist. Boolean mit Lese-/Schreibzugriff.


AllowSorting-Eigenschaft: Beispiel

In diesem Beispiel werden alle Zellen der angegebenen Kalkulationstabelle gesperrt. Anschließend wird das Filtern und Sortieren von Zeilen und Spalten aktiviert, das Einfügen, Löschen oder die Größenanpassung von Zeilen und Spalten jedoch deaktiviert.

Spreadsheet1.Cells.Locked = True
Set pt = Spreadsheet1.ActiveSheet.Protection
pt.AllowDeletingColumns = False
pt.AllowDeletingRows = False
pt.AllowFiltering = True
pt.AllowInsertingColumns = False
pt.AllowInsertingRows = False
pt.AllowSizingAllColumns = False
pt.AllowSizingAllRows = False
pt.AllowSorting = True
pt.Enabled = True


AllPageFields-Eigenschaft

Gibt die AllPageFields-Auflistung für das Datenquellensteuerelement zurück. Schreibgeschützt.

Informationen über das Zurückgeben eines einzelnen Mitglieds einer Auflistung finden Sie im Abschnitt "Zurückgeben eines Objekts aus einer Auflistung".


AlternateDataSource-Eigenschaft

Gibt die ID der alternativen Datenquelle (eines weiteren komplexen, datengebundenen Steuerelements, das als Datenquelle verwendet wird ) zurück oder legt diese fest. String mit Lese-/Schreibzugriff.


AltKey-Eigenschaft

Der Wert lautet True, wenn die ALT-Taste gedrückt (festgehalten) wurde, während das angegebene Ereignis eintrat. Schreibgeschützter Boolean.


AltKey-Eigenschaft: Beispiel

Diese Prozedur wird immer dann ausgeführt, wenn der Benutzer mit der Maus klickt, wenn der Zeiger über dem Diagrammarbeitsbereich positioniert ist. Beachten Sie, dass die Ereignisprozedur in diesem Beispiel so deklariert wurde, wie es für Visual Basic erforderlich ist. Weitere Informationen über das Verwenden von Ereignisprozeduren finden Sie im Abschnitt "Deklarieren und Verwenden von Ereignisprozeduren in VBScript".

Private Sub ChartSpace1_Click(ByVal ChartEventInfo As OWC.WCChartEventInfo)
    If ChartEventInfo.AltKey Then
        ' Handle alt case here.
    End If
    If ChartEventInfo.CtrlKey Then
        ' Handle ctrl case here.
    End If
End Sub


Amount-Eigenschaft

Gibt den Fehlerbetrag für prozentuale Fehlerindikatoren oder Fehlerindikatoren mit festgelegtem Wert zurück oder legt ihn fest. Datengebundene Fehlerindikatorenbeträge geben Sie durch Verwenden der SetData-Methode an. Variant mit Lese-/Schreibzugriff.

Anmerkungen

Der Wert ist mathematisch korrekt. Dies bedeutet, dass 5% als 0,05 und nicht als 5 dargestellt werden. Ein Fehlerindikator mit dem festen Betrag von 5 wird zu 500%, wenn er in einen Prozentsatz umgewandelt wird.


Amount-Eigenschaft: Beispiel

In diesem Beispiel werden den angegebenen Reihen im Diagrammarbeitsbereich Fehlerindikatoren hinzugefügt. Anschließend wird der Fehlerbetrag festgelegt.

Set eb = ChartSpace1.Charts(0).SeriesCollection(0).ErrorBarsCollection.Add
eb.Amount = 0.05


AutoFilter-Eigenschaft

Gibt das AutoFilter-Objekt des angegebenen Tabellenblattes zurück.

Anmerkungen

Verwechseln Sie diese Methode nicht mit der AutoFilter-Methode. Diese Eigenschaft gibt das AutoFilter-Objekt eines bestimmten Tabellenblattes zurück, wohingegen die AutoFilter-Methode auf ein Range-Objekt angewendet wird und den AutoFilter aktiviert.


AutoFilterMode-Eigenschaft

Der Wert ist True, wenn die AutoFilter-Dropdownpfeile angezeigt werden. Boolean mit Lese-/Schreibzugriff.

Anmerkungen

Diese Eigenschaft gibt den Wert True zurück, wenn die AutoFilter-Dropdownpfeile momentan angezeigt werden. Sie können diese Eigenschaft auf False setzen, um die Pfeile auszublenden, aber Sie können sie nicht auf True setzen. Verwenden Sie die AutoFilter-Methode, um eine Liste zu filtern und die Dropdownpfeile anzuzeigen.

Wenn die AutoFilter-Dropdownpfeile angezeigt werden, aber momentan keine Zeilen gefiltert werden (alle Zeilen werden angezeigt), ist die AutoFilterMode-Eigenschaft auf True und die FilterMode-Eigenschaft auf False gesetzt.


AutoFilterMode-Eigenschaft: Beispiel

In diesem Beispiel wird AutoFilter für das aktive Tabellenblatt deaktiviert.

Spreadsheet1.ActiveSheet.AutoFilterMode = False


AutoFit-Eigenschaft

Spreadsheet oder PivotTable-Objekt: Der Wert lautet True, wenn die Gesamtgröße der Kalkulationstabellen- oder PivotTable-Liste über die Anzahl der sichtbaren Spalten und Zeilen bestimmt wird. Zeilenhöhe und Spaltenbreite können die Werte der MaxHeight- und MaxWidth-Eigenschaften der Kalkulationstabellen- oder PivotTable-Liste nicht überschreiten. Der Standardwert lautet True. Wenn die AutoFit-Eigenschaft auf False gesetzt ist, basiert die Gesamtgröße der Kalkulationstabellen- oder PivotTable-Liste auf ihren jeweiligen Width- und Height-Eigenschaften. Boolean mit Lese-/Schreibzugriff.

PivotTotal-Objekt: Der Wert lautet True, wenn die Breite automatisch festgelegt wird. Der Standardwert ist True. Wenn diese Eigenschaft auf True festgelegt ist, führen sämtliche Layoutänderungen auch zu einer Aktualisierung der Width- und Height-Eigenschaftswerte. Wenn Sie die Width- und Height-Eigenschaftswerte programmseitig ändern, wird der Wert der AutoFit-Eigenschaft auf False gesetzt. Boolean mit Lese-/Schreibzugriff.


AutoFit-Eigenschaft: Beispiel

In diesem Beispiel wird die automatische Größenänderung der PivotTable-Liste deaktiviert. Anschließend wird die Breite festgelegt.

PivotTable1.AutoFit = False
PivotTable1.Object.Width = 8000


Axes-Eigenschaft

Gibt die WCAxes-Auflistung für das angegebene Diagramm zurück. Schreibgeschützt.

Informationen über das Zurückgeben eines einzelnen Mitglieds einer Auflistung finden Sie im Abschnitt "Zurückgeben eines Objekts aus einer Auflistung".


Axes-Eigenschaft: Beispiel

In diesem Beispiel wird der Schriftartenname für die angegebene Achse im Diagrammarbeitsbereich angegeben.

Set axs = ChartSpace1.Charts(0).Axes(1)
axs.Font.Name = "Arial"


BackColor-Eigenschaft

Gibt die Hintergrundfarbe für das angegebene Objekt oder den angegebenen Bereich zurück oder legt sie fest. Variant mit Lese-/Schreibzugriff.

Anmerkungen

Wenn Sie diese Eigenschaft festsetzen, können Sie entweder einen Long-Wert, der einen RGB-Farbwert darstellt, oder einen String-Wert verwenden, der einen gültigen HTML-Farbwert bezeichnet. Um beispielsweise die Objektfarbe auf Rot zu setzen, könnten Sie den Hexadezimalwert &HFF, den Dezimalwert 255 oder die Zeichenkette red verwenden. In Microsoft Visual Basic können Sie die RGB-Funktion verwenden, um einen RGB-Wert zu erzeugen (Rot ist RGB(255,0,0)).

Diese Eigenschaft gibt die Farbe immer als Long-Wert zurück, der einen RGB-Farbwert darstellt.


BackColor-Eigenschaft: Beispiel

In diesem Beispiel werden Schriftgrad, Vorder- und Hintergrundfarbe für die Beschriftung in der PivotTable-Liste festgelegt.

Set view = PivotTable1.ActiveView
view.Label.BackColor = "DarkSalmon"
view.Label.Font.Size = 16
view.Label.ForeColor = "Sienna"


BaseName-Eigenschaft

Gibt den Basisnamen des angegebenen Feldes zurück. String schreibgeschützt.

Anmerkungen

Ein Feld kann mehrere Namen haben. Dies wird aus der nachfolgenden Tabelle ersichtlich.

Name | Beschreibung
Beschriftung | Name, der dem Benutzer angezeigt wird.
Name | Zum Identifizieren des Feldes in Code verwendeter Name.
DataField | Der Name des Feldes in der zugrunde liegenden Datensatzgruppe. (Dieser ist nicht notwendigerweise identisch mit dem Basisnamen. Sie können einen anderen Namen verwenden, wenn ein Namenskonflikt besteht, oder wenn Sie den Namen erinnerungs- und verwendungsfreundlicher machen möchten.)
BaseName | Der Name des Feldes in der ursprünglichen Quelldatenbank.


Bitmap-Eigenschaft

Gibt den Bitmap-Typ des Erweiterungssteuerelements zurück oder legt diesen fest. ExpandBitmapTypeEnum mit Lese-/Schreibzugriff.


Bold-Eigenschaft

Der Wert ist True, wenn die angegebene Schriftart fett formatiert ist.

OWCFont-Objekt: Variant mit Lese-/Schreibzugriff (gibt Null zurück, wenn einige Zellen im Bereich fett formatiert sind und andere nicht). Verwenden Sie die IsNull-Funktion, um zu ermitteln, ob der Rückgabewert Null ist.

PivotFont-Objekt: Boolean mit Lese-/Schreibzugriff.


Bold-Eigenschaft: Beispiel

In diesem Beispiel werden Schriftarteneigenschaften für die angegebene Achse im Diagrammarbeitsbereich angegeben.

Set axs = ChartSpace1.Charts(0).Axes(1)
axs.Font.Name = "Arial"
axs.Font.Size = 8
axs.Font.Bold = True


Border-Eigenschaft

Gibt ein Border-Objekt zurück, das den Rahmen des angegebenen Objekts zurückgibt. Schreibgeschützt.

Anmerkungen

Der Rahmen für eine Diagrammreihe steht für die Umrissfarbe bei Säulen-, Balken-, Ring-, Bereichs- und Höchst-Tiefst-Schluss-Diagrammen. Auf Diagrammen mit Markierungen (wie z. B. Liniendiagamme mit Markierung) stellt der Rahmen die Umrissfarbe für Markierungen dar.


Borders-Eigenschaft

Gibt eine Borders-Auflistung zurück, welche die Bereichsrahmen repräsentiert. Schreibgeschützt.


Borders-Eigenschaft: Beispiel

In diesem Beispiel wird jeder Zelle im Bereich B5:C10 der Kalkulationstabelle ein halbfetter grüner Rahmen hinzugefügt.

Set c = Spreadsheet1.Constants
Spreadsheet1.Range("b5:c10").Borders.Weight = c.owcLineWeightMedium
Spreadsheet1.Range("b5:c10").Borders.Color = "green"


BottomRight-Eigenschaft

PivotDetailRange-Objekt: Gibt ein PivotDetailCell-Objekt zurück, das die Zelle in der linken unteren Ecke des angegebenen Detailbereichs repräsentiert. Schreibgeschützt.

PivotRange-Objekt: Gibt ein PivotCell-Objekt zurück, das die Zelle in der linken unteren Ecke des angegebenen Bereichs repräsentiert. Schreibgeschützt.


BoundField-Eigenschaft

Gibt das PivotField-Objekt zurück, das für Datenbindungsinformationen verwendet wird, wenn es sich bei der Quelle um eine Datensatzgruppe handelt. Wenn die Quelle multidimensional ist, gibt diese Eigenschaft Nothing zurück. Schreibgeschützt.


BubbleScale-Eigenschaft

Gibt einen Skalierungsfaktor für sämtliche Blasenreihen im angegebenen Diagramm zurück oder legt diesen fest. Der Standardwert ist 100, der gültige Bereich liegt bei 0-300. Double mit Lese-/Schreibzugriff.

Anmerkungen

Der Wert dieser Eigenschaft gibt die Blasengröße relativ zur Standardeinstellung an. Durch Festlegen der BubbleScale-Eigenschaft auf 300 (drei mal größer als der Standardwert) erzeugen Sie ein Diagramm, dessen Blasen in der dreifachen Standardgröße angezeigt werden.


BubbleScale-Eigenschaft: Beispiel

In diesem Beispiel wird der Blasenskalierungsfaktor für das angegebene Diagramm im Diagrammarbeitsbereich festgelegt. Beachten Sie, dass sich Charts(0) auf ein Blasendiagramm beziehen muss.

ChartSpace1.Charts(0).BubbleScale = 200


BuildNumber-Eigenschaft

Gibt die Microsoft Office Web Components-Version zurück. Schreibgeschütztes Long.


BuildNumber-Eigenschaft: Beispiel

In diesem Beispiel wird die Microsoft Office Web Components-Version in der Titelleiste der Kalkulationstabelle angezeigt.

Spreadsheet1.TitleBar.Caption = "MSOWC Build " & Spreadsheet1.BuildNumber


Button-Eigenschaft

Zeigt an, welche Maustaste oder -tasten gedrückt wurden (gedrückt gehalten), als ein bestimmtes Ereignis eintrat, wie in nachfolgender Tabelle gezeigt wird. Die Rückgabewerte können gemeinsam vorkommen. Ein Rückgabewert von 3 zeigt zum Beispiel an, dass sowohl die linke als auch die rechte Taste gedrückt waren, als das Ereignis eintrat. Schreibgeschütztes Long.

Wert | Bedeutung
0 | Es waren keine Maustasten gedrückt.
1 | Die linke Maustaste war gedrückt.
2 | Die rechte Maustaste war gedrückt.
4 | Die mittlere Maustaste war gedrückt.


CanUndo-Eigenschaft

True, wenn eine vorherige Handlung zurückgenommen werden kann. Boolean schreibgeschützt.


CanUndo-Eigenschaft: Beispiel

In diesem Beispiel wird die zuletzt ausgeführte Aktion rückgängig gemacht oder ein Meldungsfeld angezeigt, falls die Aktion nicht rückgängig gemacht werden kann.

If Spreadsheet1.CanUndo Then
    Spreadsheet1.Undo
Else
    MsgBox "can't undo last action"
End If


Caption-Eigenschaft

Gibt die Beschriftung für das angegebene Objekt zurück oder legt diese fest. String mit Lese-/Schreibzugriff.


CaptionHAlignment-Eigenschaft

Gibt die horizontale Ausrichtung für die Detailfußzeilenbeschriftung in der angegebenen PivotTable-Liste zurück oder legt diese fest. PivotHAlignmentEnum mit Lese-/Schreibzugriff.

Anmerkungen

Beschriftungen können nur links neben den Aggregaten im Detailfuß angezeigt werden. Verwenden Sie die CaptionHAlignment-Eigenschaft, um die Beschriftung nahe am Aggregat (plHAlignRight) auszurichten, oder um die Beschriftung nahe an der linken Kante des Fußes (plHAlignLeft) auszurichten. Befindet sich auf der linken Seite ein weiteres Aggregat, wird die Beschriftung rechts neben diesem Aggregat angezeigt. Wenn dort nicht genug Raum für das Anzeigen der Beschriftung vorhanden ist, wird es nicht sichtbar.


CaptionHAlignment-Eigenschaft: Beispiel

In diesem Beispiel werden die Summen und ihre Beschriftungen in der PivotTable-Liste formatiert.

Set c = PivotTable1.Constants
Set view = PivotTable1.ActiveView
For Each ttl In view.DataAxis.Totals
    ttl.HAlignment = c.plHAlignRight
    ttl.CaptionHAlignment = c.plHAlignRight
Next


CaptionSection-Eigenschaft

Der Wert ist True, wenn die angegebene Gruppenebene über einen Beschriftungsbereich verfügt, der sichtbar ist. Boolean mit Lese-/Schreibzugriff.

Anmerkungen

Der Beschriftungsbereich wird auf einer Datenseite nur ein Mal und dann oberhalb aller sichtbaren Datensätze einer bestimmten Gruppenebene angezeigt. Der Beschriftungsbereich bleibt sichtbar, wenn Sie einen Bildlauf über die Datensätze durchführen.


Cell-Eigenschaft

Gibt ein PivotCell-Objekt zurück, dass den Speicherort der Aggregat- oder Detailzelle nennt. Schreibgeschützt.


Cells-Eigenschaft

Range, Spreadsheet oder Worksheet-Objekt: Gibt ein Range-Objekt zurück, das die Zellen im Objekt repräsentiert. Diese Eigenschaft hat keine Argumente, wenn sie mit einem dieser drei Objekte verwendet wird. Schreibgeschützt.

Weil die Item-Eigenschaft die Standardeigenschaft des Range-Objekts ist, können Sie die Zeilen- und Spaltenindexzahlen im Anschluss an das Cells-Schlüsselwort (es ruft eigentlich die Item-Eigenschaft des Range-Objekts auf, das von der Cells-Eigenschaft zurückgegeben wird) angeben.

PivotData-Objekt: Gibt ein PivotCell-Objekt auf Basis eines Zeilen- und Spaltenmitglieds zurück.

Syntax

Ausdruck.Cells(Row, Column)

Ausdruck Ein Ausdruck, der ein PivotData-Objekt zurückgibt.

Row Erforderliches PivotMember-Objekt. Gibt die Zeile an, welche die zurückgegebene Zelle enthält.

Column Erforderliches PivotMember-Objekt. Gibt die Spalte an, welche die zurückgegebene Zelle enthält.


Cells-Eigenschaft: Beispiel

In diesem Beispiel werden alle Zellen in der angegebenen Kalkulationstabelle gelöscht.

Spreadsheet1.Cells.Clear

Im Beispiel wird die standardmäßige Item-Eigenschaft des Range-Objekts verwendet, die von der Cells-Eigenschaft zurückgegeben wird, um auf eine einzelne Zelle zu verweisen. Das Beispiel zeigt die Spalten- und Zeilennummern für jede einzelne Zelle im Bereich A1:E5 an.

For rw = 1 To 5
    For col = 1 To 5
        Spreadsheet1.Cells(rw, col).Value = "row " & rw & " column " & col
    Next
Next


ChartDataSources-Eigenschaft

Gibt die WCDataSources-Auflistung für den angegebenen Diagrammarbeitsbereich zurück.

Informationen über das Zurückgeben eines einzelnen Mitglieds einer Auflistung finden Sie im Abschnitt Zurückgeben eines Objekts aus einer Auflistung.


ChartLayout-Eigenschaft

Gibt das Layout für sämtliche Diagramme im angegebenen Diagrammarbeitsbereich zurück oder legt es fest. ChartChartLayoutEnum mit Lese-/Schreibzugriff.

Weil der Diagrammarbeitsbereich ein oder mehrere Diagramme enthalten kann, steht Ihnen sowohl die ChartLayout als auch die ChartWrapCount-Eigenschaft zur Verfügung, um anzugeben, wie mehrere Diagramme positioniert werden. Die ChartLayout-Eigenschaft macht es möglich, angepasste Diagrammanordnungen zu erstellen, wie zum Beispiel drei Diagramme, die horizontal in einer Zeile positioniert sind.

Es sind zwei unterschiedliche Layouttypen für Diagramme vorhanden:

ChChartLayoutHorizontal Die Diagramme werden horizontal von links nach rechts angeordnet, bis die Diagrammanzahl erreicht ist, die durch die ChartWrapCount-Eigenschaft angegeben wird. Wenn dies erfolgt, wird eine neue Zeile unterhalb der aktiven Zeile erstellt und der Anordnungsprozess beginnt erneut auf der linken Seite. Diese Methode wird fortgesetzt (Umbruch bei Erreichen der ChartWrapCount-Anzahl), bis sämtliche Diagramme platziert worden sind.

ChChartLayoutVertical Die Diagramme werden vertikal von oben nach unten angeordnet, bis die Diagrammanzahl erreicht ist, die durch die ChartWrapCount-Eigenschaft angegeben wird. Wenn dies erfolgt, wird eine neue Spalte rechts neben der aktiven Zeile erstellt und die Positionierung beginnt erneut oben. Diese Methode wird fortgesetzt (Umbruch bei Erreichen der ChartWrapCount-Diagrammanzahl), bis sämtliche Diagramme platziert worden sind.


ChartLayout-Eigenschaft: Beispiel

In diesem Beispiel werden die ChartWrapCount und ChartLayout-Eigenschaften festgelegt. Anschließend werden dem angegebenen Diagrammarbeitsbereich drei zusätzliche Diagramme hinzugefügt.

Dim chts(3)

ChartSpace1.ChartWrapCount = 2
ChartSpace1.ChartLayout = ChartSpace1.Constants.chChartLayoutHorizontal
For k = 0 To 2
    Set chts(k) = ChartSpace1.Charts.Add
Next


Charts-Eigenschaft

Gibt dieWCCharts-Auflistung für den angegebenen Diagrammarbeitsbereich zurück. Schreibgeschützt.

Ein neuer Diagrammarbeitsbereich enthält standardmäßig keine Diagramme. Nachdem Sie einen neuen Diagrammarbeitsbereich erstellt haben, müssen Sie ihm ein Chart-Objekt hinzufügen, bevor Sie ein Diagramm erstellen können. Verwenden Sie die Add-Methode, um ein neues Diagramm zu erstellen.

Informationen über das Zurückgeben eines einzelnen Mitglieds einer Auflistung finden Sie im Abschnitt Zurückgeben eines Objekts aus einer Auflistung.


ChartSpaceLegend-Eigenschaft

Gibt ein WCLegend-Objekt zurück, das die Legende des Diagrammarbeitsbereichs repräsentiert. Gibt Nothing zurück, wenn der Diagrammarbeitsbereich über keine Legende verfügt. Schreibgeschützt.


ChartSpaceLegend-Eigenschaft: Beispiel

In diesem Beispiel wird der Titel des Diagrammarbeitsbereichs festgelegt, und die Legende des Diagrammarbeitsbereichs wird auf der linken Seite des Arbeitsbereichs angeordnet.

Set c = ChartSpace1.Constants
ChartSpace1.HasChartSpaceTitle = True
ChartSpace1.ChartSpaceTitle.Caption = "Monthly Sales Data"
ChartSpace1.HasChartSpaceLegend = True
ChartSpace1.ChartSpaceLegend.Position = c.chLegendPositionLeft


ChartSpaceTitle-Eigenschaft

Gibt ein WCTitle-Objekt zurück, dass den Titel des Diagrammarbeitsbereichs repräsentiert. Gibt Nothing zurück, wenn der Diagrammarbeitsbereich über keinen Titel verfügt. Schreibgeschützt.


ChartSpaceTitle-Eigenschaft: Beispiel

In diesem Beispiel wird der Titel des Diagrammarbeitsbereichs festgelegt, und die Legende des Diagrammarbeitsbereichs wird auf der linken Seite des Arbeitsbereichs angeordnet.

Set c = ChartSpace1.Constants
ChartSpace1.HasChartSpaceTitle = True
ChartSpace1.ChartSpaceTitle.Caption = "Monthly Sales Data"
ChartSpace1.HasChartSpaceLegend = True
ChartSpace1.ChartSpaceLegend.Position = c.chLegendPositionLeft


ChartWrapCount-Eigenschaft

Gibt die Anzahl der Diagramme zurück, die horizontal oder vertikal platziert werden, bevor ein Umbruch vorkommt. Umfassendere Erläuterungen zu Layout und Umbruch finden Sie im Hilfethema der ChartLayout-Eigenschaft. Long mit Lese-/Schreibzugriff.


ChartWrapCount-Eigenschaft: Beispiel

In diesem Beispiel werden die ChartWrapCount und ChartLayout-Eigenschaften festgelegt. Anschließend werden dem angegebenen Diagrammarbeitsbereich drei zusätzliche Diagramme hinzugefügt.

Dim chts(3)

ChartSpace1.ChartWrapCount = 2
ChartSpace1.ChartLayout = ChartSpace1.Constants.chChartLayoutHorizontal
For k = 0 To 2
    Set chts(k) = ChartSpace1.Charts.Add
Next


ChildLabel-Eigenschaft

Enthält die Zeichenkette, die als Beschriftung des angegebenen Steuerelements angezeigt wird. String mit Lese-/Schreibzugriff.


ChildMembers-Eigenschaft

Gibt eine PivotMembers-Auflistung zurück, welche die untergeordneten Mitglieder des angegebenen Mitglieds repräsentiert. Schreibgeschützt.

Informationen über das Zurückgeben eines einzelnen Mitglieds einer Auflistung finden Sie im Abschnitt Zurückgeben eines Objekts aus einer Auflistung.


ChildSection-Eigenschaft

Gibt ein Section-Objekt zurück, das die untergeordneten Mitglieder des angegebenen Mitglieds repräsentiert. Diese Eigenschaft ist nicht vorhanden, wenn der angegebene Bereich nicht erweitert wurde. Schreibgeschützt.


Color-Eigenschaft

Gibt die Primärfarbe für das angegebene Objekt zurück oder legt diese fest. Variant mit Lese-/Schreibzugriff.

Anmerkungen

Wenn Sie diese Eigenschaft festlegen, können Sie entweder einen Long-Wert, der einen RGB-Farbwert darstellt, oder einen String-Wert verwenden, der einen gültigen HTML-Farbwert bezeichnet. Um beispielsweise die Objektfarbe auf Rot festzulegen, könnten Sie den Hexadezimalwert &HFF, den Dezimalwert 255 oder die Zeichenkette red verwenden. In Microsoft Visual Basic können Sie die RGB-Funktion verwenden, um einen RGB-Wert zu erstellen (Rot ist RGB(255,0,0)).

Diese Eigenschaft gibt die Farbe immer als Long-Wert zurück, der einen RGB-Farbwert darstellt.

In Diagrammen können Sie auch eine der beiden folgenden Spezialkonstanten verwenden: chColorAutomatic (um die Farbe auf den Standardwert zurückzusetzen) oder chColorNone (um Keine Farbe oder Transparenz anzugeben). Es ist jedoch nicht möglich, eine Schriftartenfarbe auf chColorNone festzulegen.


Color-Eigenschaft: Beispiel

In diesem Beispiel wird allen Zellen im Bereich B5:C10 der Kalkulationstabelle ein halbfetter grüner Rahmen hinzugefügt.

Set c = Spreadsheet1.Constants
Spreadsheet1.Range("b5:c10").Borders.Weight = c.owcLineWeightMedium
Spreadsheet1.Range("b5:c10").Borders.Color = "green"


Column-Eigenschaft

Gibt die Zahl der ersten Spalte im angegebenen Bereich zurück. Schreibgeschütztes Long.


ColumnAxis-Eigenschaft

Gibt ein PivotGroupAxis-Objekt zurück, das die Spaltenachse in der angegebenen PivotTable-Liste repräsentiert. Schreibgeschützt.


ColumnAxis-Eigenschaft: Beispiel

In diesem Beispiel werden der PivotTable-Liste in der aktiven Ansicht zwei Feldgruppen hinzugefügt.

Set view = PivotTable1.ActiveView
view.ColumnAxis.InsertFieldSet view.FieldSets("Store Type")
view.RowAxis.InsertFieldSet view.FieldSets("Promotions")


ColumnCount-Eigenschaft

Gibt die Anzahl der inneren Mitglieder auf der Spaltenachse in der angegebenen PivotTable-Liste über alle Feldgruppen hinweg zurück. Long schreibgeschützt.

Anmerkungen

Die von dieser Eigenschaft zurückgegebene Zahl ist gleich der Anzahl der Zellkoordinaten auf der Spaltenachse.


ColumnFieldCount-Eigenschaft

Gibt die Anzahl der Felder auf der Spaltenachse in der angegebenen PivotTable-Liste über alle Feldgruppen hinweg zurück. Schreibgeschütztes Long.

Anmerkungen

Die durch diese Eigenschaft zurückgegebene Zahl schließt diejenigen Felder nicht ein, deren IsIncluded-Eigenschaft auf False gesetzt ist.


ColumnMember-Eigenschaft

Gibt ein PivotMember-Objekt zurück, welches das innere Mitglied auf der Spaltenachse repräsentiert, das die angegebene Zelle überschneidet. Schreibgeschützt.


ColumnMembers-Eigenschaft

Gibt eine PivotMembers-Auflistung zurück, die sämtliche Mitglieder der angegebenen Spalte repräsentiert. Schreibgeschützt.

Anmerkungen

Die Auflistung der Spaltenmitglieder schließt keine Mitglieder ein, die Sie durch das Festlegen ihrer IsFiltered-Eigenschaft auf True gefiltert haben.


Columns-Eigenschaft

Range-Objekt: Gibt ein Range-Objekt zurück, das die Spalten im angegebenen Bereich repräsentiert. Schreibgeschützt.

Spreadsheet-Objekt: Gibt ein Range-Objekt zurück, das alle Spalten des aktiven Tabellenblattes repräsentiert. Schreibgeschützt.

Worksheet-Objekt: Gibt ein Range-Objekt zurück, das alle Spalten des aktiven Tabellenblattes repräsentiert. Schreibgeschützt.


Columns-Eigenschaft: Beispiel

In diesem Beispiel wird die Schriftart für alle übrigen Spalten im sichtbaren Bereich des aktiven Tabellenblatts auf Fett festgelegt.

For Each col In Spreadsheet1.ActiveSheet.VisibleRange.Columns
    If col.Column Mod 2 = 0 Then col.Font.Bold = True
Next

In diesem Beispiel werden alle Daten in Spalte 2 des aktiven Tabellenblatts gelöscht.

Spreadsheet1.ActiveSheet.Columns(2).ClearContents


ColumnWidth-Eigenschaft

Gibt die Breite aller Spalten im angegebenen Bereich zurück oder legt diese fest. Gibt Null zurück, wenn die Spalten im Bereich nicht die gleiche Breite aufweisen. Verwenden Sie die IsNull-Funktion, um festzustellen, ob der Rückgabewert Null beträgt. Variant mit Lese-/Schreibzugriff.


ColumnWidth-Eigenschaft: Beispiel

In diesem Beispiel werden Formel, Spaltenbreite und Zahlenformat für sämtliche Zellen im Bereich A1:F10 des aktiven Tabellenblattes festgelegt.

Set rg = Spreadsheet1.ActiveSheet.Range("a1:f10")
rg.Formula = "=rand()"
rg.ColumnWidth = 100
rg.NumberFormat = "#.###"


Command-Eigenschaft

Gibt den Befehl an, der das Vorkommen des Kalkulationstabellenereignisses verursacht hat. Schreibgeschützte SheetCommandEnum.


CommandText-Eigenschaft

Gibt die Befehlszeichenkette für das angegebene Objekt zurück oder legt diese fest. String mit Lese-/Schreibzugriff.

Für den dscCommandText-Typ gibt diese Eigenschaft eine Textzeichenkette (normalerweise SQL) zurück, die eine einzelne Ergebnisgruppe vom Dienstanbieter zurückgibt, oder sie legt die Textzeichenkette fest.

Für den dscCommandFile-Typ gibt diese Eigenschaft den URL einer XML-Datei zurück, die Daten für das angegebene SchemaRowsource-Objekt enthält, oder sie legt den URL fest .


Connection-Eigenschaft

Gibt das ADO-Connection-Objekt zurück, das vom Datenquellensteuerelement verwendet wird. Schreibgeschützt.

Anmerkungen

Gehen Sie umsichtig vor, wenn Sie Methoden aufrufen oder Einstellungen für das Connection-Objekt festlegen. Sie sollten beispielsweise nicht die Close-Methode des Connection-Objekts aufrufen.


ConnectionZeichenkette-Eigenschaft

Gibt die ADO-Verbindungszeichenkette für eine zweischichtige Datenbankverbindung zurück oder legt diese fest. String mit Lese-/Schreibzugriff.

Anmerkungen

Diese Eigenschaft entspricht dem CurrentProject.BaseConnectionString in Microsoft Access. Wenn das Datenquellensteuerelement eine Verbindung herstellt, ist der Wert der ConnectionString-Eigenschaft des Datenquellensteuerelements eventuell nicht mit dem Wert identisch, der von der ConnectionString-Eigenschaft des Connection-Objekts zurückgegeben wird. Dies liegt daran, dass das Datenquellensteuerelement andere OLE-Datenbankanbieter einsetzt, um zusätzliche Dienste anzubieten. So sind zum Beispiel die nachfolgenden Ausdrücke auf einer HTML-Seite, die ein Datenquellensteuerelement mit der Kennnummer MSODSC enthält, nicht gleichwertig.

MSODSC.ConnectionString
MSODSC.Connection.ConnectionString


Constants-Eigenschaft

Gibt ein Objekt zurück, das es Benutzern ermöglicht, benannte Konstanten zu verwenden. Schreibgeschützt.

Anmerkungen

Weitere Informationen finden Sie im Abschnitt "Verwenden von benannten Konstanten in VBScript".

Diese Eigenschaft ist nur auf HTML-Seiten erforderlich. In anderen Containern (wie zum Beispiel in Visual Basic) können Sie definierte Konstanten aus dem Objektmodell direkt verwenden, ohne zunächst die Constants-Eigenschaft einzusetzen. Das Verwenden der Constants-Eigenschaft in anderen Containers funktioniert, wird aber nicht empfohlen, da es dazu führt, dass Ihr Code langsamer ausgeführt wird.


Constants-Eigenschaft: Beispiel

In diesem Beispiel wird jeder Zelle im Bereich B5:C10 der Kalkulationstabelle ein halbfetter grüner Rahmen hinzugefügt. Weil benannte Konstanten in VBScript nicht verfügbar sind, wird im Beispiel eine Variable für das Objekt festgelegt, das von der Constants-Eigenschaft zurückgegeben wird.

Set c = Spreadsheet1.Constants
Spreadsheet1.Range("b5:c10").Borders.Weight = c.owcLineWeightMedium
Spreadsheet1.Range("b5:c10").Borders.Color = "green"


ConsumesRecordset-Eigenschaft

Der Wert ist True für komplexe Steuerelemente, wenn Daten durch das Datenquellen-Steuerelement geliefert werden. Jedes datengebundene Steuerelement verfügt entweder über eine ControlSource-Eigenschaft (wird bei einfachen HTML-Steuerelementen verwendet) oder über eine ConsumesRecordset-Eigenschaft (wird bei komplexen Steuerelementen wie beispielsweise der PivotTable-Liste oder des Diagrammarbeitsbereichs) verwendet. Boolean mit Lese-/Schreibzugriff.


ControlSource-Eigenschaft

Gibt den Namen des Steuerelements zurück, an das das angegebene Steuerelement gebunden ist, oder legt es fest. String mit Lese-/Schreibzugriff.

Anmerkungen

Diese Eigenschaft gibt die Werte der Name- und Source-Eigenschaften für das Feld zurück, an das das angegebene Steuerelement gebunden ist, oder legt diese fest. Die Eigenschaftswerte werden als Zeichenkette im folgenden Format zurückgegegeben: "PageField.Name:PageField.Source", wobei die Zeichenketten in Kursivschrift durch die jeweiligen Werte der Name- und Source-Eigenschaften ersetzt werden. Wenn die Name- und Source-Eigenschaftswerte identisch sind, wird nur ein Wert zurückgegeben.

Wenn Sie diese Eigenschaft auf den Namen eines Schemafeldes in einer Schemazeilenquelle setzen, die von dem Abschnitt verwendet wird, der das angegebene Steuerelement enthält, wird das Schemafeld automatisch als Seitenfeld hinzugefügt.


Count-Eigenschaft

Gibt die Zahl der Objekte in der angegebenen Auflistung zurück. Long schreibgeschützt.


Count-Eigenschaft: Beispiel

In diesem Beispiel werden die Variablen auf die Anzahl der Spalten und die Anzahl der Zeilen im sichtbaren Bereich des aktiven Tabellenblattes gesetzt.

Set vr = Spreadsheet1.ActiveSheet.VisibleRange
cc = vr.Columns.Count
rc = vr.Rows.Count


Criteria-Eigenschaft

Gibt das Criteria-Objekt für den angegebenen Filter zurück.


Criteria-Eigenschaft: Beispiel

In diesem Beispiel wird der AutoFilter für den Bereich A1:J22 aktiviert, es werden Filter für die Spalten 1 und 3 gesetzt, und anschließend werden die Filter angewendet.

Spreadsheet1.Range("a1:j22").AutoFilter
Set af = Spreadsheet1.ActiveSheet.AutoFilter
Set filterColumnOne = af.Filters(1)
Set filterColumnThree = af.Filters(3)
filterColumnOne.Criteria.Add "blue"    ' Don't show blue in column 1.
filterColumnOne.Criteria.Add "green"    ' Don't show green in column 1.
filterColumnThree.Criteria.Add "yellow"    ' Don't show yellow in column 3.
af.Apply


Crosses-Eigenschaft

Gibt einen Wert zurück, der anzeigt, unter welchen Umständen die angegebene Achse eine andere Achse schneidet, oder legt diesen fest. Dieser kann einer der zwei ChartAxisCrossesEnum-Konstanten sein, die in der nachfolgenden Tabelle aufgelistet sind. Lese-/Schreibzugriff.

Wert | Bedeutung
chAxisCrossesAutomatic | Der Schnittpunkt der beiden Achsen wird automatisch gesetzt.
chAxisCrossesCustom | Die CrossesAtValue und CrossingAxis-Eigenschaften geben den Schnittpunkt an.


CrossesAtValue-Eigenschaft

Gibt den Schnittpunkt für die angegebene Achse an. Double mit Lese-/Schreibzugriff.

Anmerkungen

Wenn Sie diesen Wert für eine Achse setzen, legen Sie den Wert auf der anderen Achse fest, an dem die Achse, die Sie festlegen, jene andere Achse schneidet. Durch das Setzen dieser Eigenschaft für die Größenachse (Y) legen Sie beispielsweise die Kategorienummer fest, wo die Größenachse die Rubrikenachse (X) schneidet. Im nachfolgenden Beispiel führt dies dazu, dass die Größenachse die Rubrikenachse in der dritten Rubrik schneidet.

Set c = ChartSpace1.Constants
ChartSpace1.Charts(0).Axes(c.chAxisPositionLeft).CrossesAtValue = 3


CrossesAtValue-Eigenschaft: Beispiel

In diesem Beispiel wird die Rubrikenachse auf den Wert 0 (Null) im Diagrammarbeitsbereich gesetzt.

Set c = ChartSpace1.Constants
Set valueAxis = ChartSpace1.Charts(0).Axes(c.chAxisPositionLeft)
Set categoryAxis = ChartSpace1.Charts(0).Axes(c.chAxisPositionBottom)
valueAxis.CrossingAxis = categoryAxis
categoryAxis.CrossesAtValue = 0


CrossingAxis-Eigenschaft

Gibt die Schnittachse an oder legt diese fest. Wenn die Schnittachse gelöscht wird, wird diese Eigenschaft auf 0 (Null) gesetzt. Die Crosses-Eigenschaft wird auf chAxisCrossesAutomatic zurückgesetzt. WCAxis mit Lese-/Schreibzugriff.


CrossingAxis-Eigenschaft: Beispiel

In diesem Beispiel wird die Rubrikenachse auf den Wert 0 im Diagrammarbeitsbereich gesetzt.

Set c = ChartSpace1.Constants
Set valueAxis = ChartSpace1.Charts(0).Axes(c.chAxisPositionLeft)
Set categoryAxis = ChartSpace1.Charts(0).Axes(c.chAxisPositionBottom)
valueAxis.CrossingAxis = categoryAxis
categoryAxis.CrossesAtValue = 0


CSVData-Eigenschaft

Gibt Kalkulationstabellendaten in Form einer Liste mit Kommas als Trennzeichen zurück. String mit Lese-/Schreibzugriff.


CSVData-Eigenschaft: Beispiel

In diesem Beispiel werden die Werte für die Zellen A1:G1 gesetzt.

Spreadsheet1.CSVData = "1,1,2,3,5,8,13"


CSVURL-Eigenschaft

Gibt den URL (Internetadresse) der CSV-Kalkulationstabellendatendatei zurück oder legt diesen fest. String mit Lese-/Schreibzugriff.


CSVURL-Eigenschaft: Beispiel

In diesem Beispiel werden Kalkulationstabellendaten aus einer Datei auf dem Computer des Benutzers gesetzt.

Spreadsheet1.CSVURL = "file:\test.csv"


CtrlKey-Eigenschaft

Der Wert ist True, wenn die STRG-TASTE gedrückt wurde (niedergedrückt gehalten wurde), als das angegebene Ereignis eintrat. Nur bei Tastatur- und Mausereignissen verfügbar. Boolean schreibgeschützt.


CtrlKey-Eigenschaft: Beispiel

Diese Prozedur wird immer dann ausgeführt, wenn der Benutzer mit der Maus klickt und der Zeiger sich über dem Steuerelement mit dem Namen "ChartSpace1" befindet. Beachten Sie, dass die Prozedur in diesem Beispiel so deklariert wurde, wie es für Visual Basic erforderlich ist. Weitere Informationen über das Verwenden von Ereignisprozeduren finden Sie im Abschnitt "Deklarieren und Verwenden von Ereignisprozeduren in VBScript".

Private Sub ChartSpace1_Click(ByVal ChartEventInfo As OWC.WCChartEventInfo)
    If ChartEventInfo.AltKey Then
        ' handle alt case here
    End If
    If ChartEventInfo.CtrlKey Then
        ' handle ctrl case here
    End If
End Sub


CurrentRegion-Eigenschaft

Gibt ein Range-Objekt zurück, das den aktuellen Bereich repräsentiert. Der aktuelle Bereich ist ein Bereich, der durch eine beliebige Kombination aus leeren Zeilen und leeren Spalten gebunden ist. Schreibgeschützt.


CurrentRegion-Eigenschaft: Beispiel

Die Funktion in diesem Beispiel gibt den Wert True zurück, wenn der aktuelle Bereich der Zelle A1 auf dem aktiven Tabellenblatt sichtbar ist (wenn der aktuelle Bereich sich über den sichtbaren Bereich hinaus ausdehnt, gibt die Funktion False zurück).

Function IsCurrentRegionVisible()
    Set cr = Spreadsheet1.ActiveSheet.Cells(1, 1).CurrentRegion
    Set vr = Spreadsheet1.ActivePane.VisibleRange
    Set ir = Spreadsheet1.Intersect(cr, vr)
    IsCurrentRegionVisible = (ir.Address = cr.Address)
End Function


CurrentSection-Eigenschaft

Gibt ein Section-Objekt zurück, das den aktuellen Abschnitt repräsentiert (den Abschnitt, der das Steuerelement enthält, welcher momentan den Fokus hat). Schreibgeschützt.


DataAxis-Eigenschaft

Gibt ein PivotDataAxis-Objekt zurück, das die Datenachse repräsentiert. Schreibgeschützt.


DataAxis-Eigenschaft: Beispiel

In diesem Beispiel wird der PivotTable-Liste in der aktiven Ansicht eine Summe hinzugefügt. Auf der Datenachse wird eine Feldgruppe eingefügt.

Set view = PivotTable1.ActiveView
Set c = PivotTable1.Constants

Set newTotal = view.AddTotal("myTotal", view.FieldSets("Freight").Fields(0), c.plFunctionSum)
view.DataAxis.InsertTotal newTotal
view.DataAxis.InsertFieldSet view.FieldSets("OrderDate")


DataEntry-Eigenschaft

Der Wert lautet True (Wahr), wenn die angegebene Seite nur für Dateneingaben verwendet wird (False (Falsch), wenn die Seite eine ausgefüllte Datensatzgruppe enthält). Der Standardwert lautet False (Falsch). Boolean mit Lese-/Schreibzugriff.


DataField-Eigenschaft

Gibt den Namen des Feldes zurück, an das das PivotField-Objekt gebunden ist, wenn die Daten aus einer Datensatzgruppe stammen. String schreibgeschützt .


DataLabel-Eigenschaft

Gibt ein WCDataLabel-Objekt zurück, das die Datenbeschriftungen repräsentiert, die mit der angegebenen Trendlinie verknüpft sind. Schreibgeschützt.


DataLabelsCollection-Eigenschaft

Gibt ein WCDataLabelsCollection-Objekt zurück, das die Datenbeschriftungen für die angegebene Reihe enthält. Jede Reihe kann nur eine Gruppe von Datenbeschriftungen enthalten. Schreibgeschützt.

Weitere Informationen über das Zurückgeben eines einzelnen Mitglieds einer Auflistung finden Sie im Abschnitt "Zurückgeben eines Objekts aus einer Auflistung".


DataLabelsCollection-Eigenschaft: Beispiel

In diesem Beispiel werden den angegebenen Reihen im Diagrammarbeitsbereich Datenbeschriftungen hinzugefügt.

Set ch = ChartSpace1.Charts(0)
ch.SeriesCollection(0).DataLabelsCollection.Add

In diesem Beispiel wird die Schriftart für die Datenbeschriftungen der angegebenen Reihe festgelegt.

ChartSpace1.Charts(0).SeriesCollection(0).DataLabelsCollection(0).Font.Bold = True


DataMember-Eigenschaft

Gibt den Namen eines Datenmitglieds (den Namen der Datensatzgruppe, die das angegebene Steuerelement bei der Datenquelle anfordert) zurück oder legt diesen fest. DataMember mit Lese-/Schreibzugriff.

Anmerkungen

Ein DataMember ist ein besonderer Zeichenketten-Typ.


DataPage-Eigenschaft

Gibt ein DataPage-Objekt zurück, das die Datenseite für den angegebenen Abschnitt repräsentiert. Schreibgeschützt.

Anmerkungen

Eine Datenseite ist ein Gruppierung von Abschnitten, die ein gemeinsames Datensatznavigations-Steuerelement verwenden.


DataPages-Eigenschaft

Gibt die DataPages-Auflistung für das Datenquellen-Steuerelement zurück. Schreibgeschützt.


DataPageSize-Eigenschaft

Gibt die Anzahl der Datensätze zurück, die für die angegebene Anfügungsebene auf einer angefügten Datenseite angezeigt werden, oder legt diese fest. Der Standardwert ist 5 für eine angefügte Seite und 1 für eine nicht angefügte Seite. Long mit Lese-/Schreibzugriff.


DataSource-Eigenschaft

Gibt das ADO-DataSource-Objekt zurück, das die Datenquelle für das angegebene Steuerelement repräsentiert. Lese-/Schreibzugriff.


DataSourceType-Eigenschaft

Gibt den Datenquellentyp für den angegebenen Diagrammarbeitsbereich zurück oder legt ihn fest. ChartDataSourceTypeEnum mit Lese-/Schreibzugriff.


DataType-Eigenschaft

PivotField oder PageField-Objekt: Gibt den Datentyp des angegebenen Feldes zurück. Schreibgeschütztes ADO-DataTypeEnum.

SchemaField oder SchemaParameter-Objekt: Gibt den Datentyp des angegebenen Feldes zurück oder legt ihn fest. ADO-DataTypeEnum mit Lese-/Schreibzugriff.

Spreadsheet-Objekt: Gibt Datenformat und Quelle der Kalkulationstabelle an, wie dies in der nachfolgenden Tabelle gezeigt wird. String mit Lese-/Schreibzugriff.

Wert | Bedeutung
HTMLURL | Datenquelle ist der URL, der durch die HTMLURL-Eigenschaft angegeben wird.
HTMLData | Datenquelle ist die Zeichenkette, die durch die HTMLData-Eigenschaft angegeben wird.
CSVURL | Datenquelle ist der URL, der durch die CSVURL-Eigenschaft angegeben wird.
CSVData | Datenquelle ist die Zeichenkette, die durch die CSVData-Eigenschaft angegeben wird.


DefaultControlType-Eigenschaft

Gibt den standardmäßigen Steuerelementtyp für das angegebene Datenquellensteuerelement zurück oder legt diesen fest. DefaultControlTypeEnum mit Lese-/Schreibzugriff.


DefaultRecordset-Eigenschaft

Gibt das standardmäßige ADO-Recordset-Objekt für das angegebene Steuerelement zurück. Schreibgeschützt.

Anmerkungen

Sie sollten diese Eigenschaft nicht für Abschnitte verwenden, die an Datensatzgruppen gebunden sind. Verwenden Sie stattdessen die Recordset-Eigenschaft des DataPage-Objekts.


DefaultSort-Eigenschaft

Gibt das Feld (oder die Felder) zurück, nach denen die angegebene Bindungsebene sortiert wird, oder legt diese fest. Das Feld muss Teil der Bindungsebene sein. Wenn Sie diese Eigenschaft verwenden, um mehrere Felder anzugeben, müssen Sie Kommas verwenden, um die Felder voneinander zu trennen. String mit Lese-/Schreibzugriff.


DefaultValue-Eigenschaft

Gibt den Wert zurück, der jedes Mal in dem angegebenen Steuerelement platziert wird, wenn der Benutzer einen neuen Datensatz erstellt, oder legt diesen fest. Sie gilt für alle gebundenen Steuerelemente oder für beliebige Steuerelemente mit einer Value-Eigenschaft sowie für beliebige Steuerelemente, die beide Kriterien erfüllen. String mit Lese-/Schreibzugriff.


DetailAutoFit-Eigenschaft

PivotField-Objekt: Der Wert ist True (Wahr), falls die Spaltenbreite des angegebenen Feldes automatisch festgelegt wird, wenn das Feld auf der Datenachse verwendet wird. Boolean mit Lese-/Schreibzugriff.

PivotView -Objekt: Der Wert ist True, wenn die Breite des Detailrasters von der Breite der Detailfelder bestimmt wird. Die Breite des Detailrasters kann den Wert der DetailMaxWidth-Eigenschaft nicht überschreiten. Wenn die DetailAutoFit-Eigenschaft auf False (Falsch) gesetzt ist, ergibt sich die Breite des Detailrasters aus dem Wert der DetailWidth-Eigenschaft. Wenn die DetailAutoFit-Eigenschaft auf True gesetzt ist, führen sämtliche Layoutänderungen automatisch zu einer Aktualisierung der DetailWidth-Eigenschaft. Boolean mit Lese-/Schreibzugriff.


DetailBackColor-Eigenschaft

Gibt die Hintergrundfarbe für das angegebene Feld zurück oder legt diese fest, wenn das Feld in einem Detailraster angezeigt wird. Die Standardhintergrundfarbe ist weiß. Variant mit Lese-/Schreibzugriff.

Anmerkungen

Wenn Sie diese Eigenschaft festlegen, können Sie entweder einen Long-Wert, der einen RGB-Farbwert darstellt, oder einen String-Wert verwenden, der einen gültigen HTML-Farbwert bezeichnet. Um beispielsweise die Objektfarbe auf Rot zu setzen, könnten Sie den Hexadezimalwert &HFF, den Dezimalwert 255 oder die Zeichenkette red verwenden. In Microsoft Visual Basic können Sie die RGB-Funktion verwenden, um einen RGB-Wert zu erzeugen (Rot ist RGB(255,0,0)).

Diese Eigenschaft gibt die Farbe immer als Long-Wert zurück, der einen RGB-Farbwert darstellt.


DetailCells-Eigenschaft

Gibt ein PivotDetailCell-Objekt auf Grundlage einer Zeilen- und Spaltenzahl zurück.

Syntax

Ausdruck.Cell(Row, Column)

Ausdruck Ein Ausdruck, der ein PivotCell-Objekt zurückgibt.

Row Erforderliches Long. Gibt die Zeile an, welche die angegebene Zelle enthält.

Column Erforderliches Long. Gibt die Spalte an, welche die angegebene Zelle enthält.


DetailFont-Eigenschaft

Gibt ein PivotFont-Objekt zurück, das die Schriftart repräsentiert, die verwendet wird, wenn das angegebene Feld im Detailraster angezeigt wird. Schreibgeschützt.


DetailForeColor-Eigenschaft

Gibt die Vordergrundfarbe für das angegebene Feld zurück oder legt diese fest, wenn das Feld in einem Detailraster angezeigt wird. Variant mit Lese-/Schreibzugriff.

Anmerkungen

Wenn Sie diese Eigenschaft festlegen, können Sie entweder einen Long-Wert, der einen RGB-Farbwert darstellt, oder einen String-Wert verwenden, der einen gültigen HTML-Farbwert bezeichnet. Um beispielsweise die Objektfarbe auf Rot zu setzen, könnten Sie den Hexadezimalwert &HFF, den Dezimalwert 255 oder die Zeichenkette red verwenden. In Microsoft Visual Basic können Sie die RGB-Funktion verwenden, um einen RGB-Wert zu erzeugen (Rot ist RGB(255,0,0)).

Diese Eigenschaft gibt die Farbe immer als Long-Wert zurück, der einen RGB-Farbwert darstellt.


DetailHAlignment-Eigenschaft

Gibt das Verfahren zurück oder legt das Verfahren fest, das für die horizontale Anordnung von Feldwerten Verwendung findet, wenn das angegebene Feld in einem Detailraster angezeigt wird. Standardmäßig werden die Werte am linken Rand ausgerichtet. Der Wert kann einer der nummerierten PivotHAlignmentEnum-Werte sein. Lese-/Schreibzugriff.


DetailLeft-Eigenschaft

Gibt die Spalte, die im Detailraster am weitesten links angezeigt wird, zurück oder legt diese fest. Long mit Lese-/Schreibzugriff.

Syntax

Ausdruck.DetailLeft(Column)

Ausdruck Ein Ausdruck, der ein PivotData-Objekt zurückgibt.

Column Erforderliches PivotMember-Objekt. Gibt die Spalte zurück, die im Detailraster am weitesten links angezeigt wird.


DetailMaxHeight-Eigenschaft

Gibt die maximale Höhe (in Pixeln) an, die das Detailraster erreichen kann, wenn der Wert der DetailAutoFit-Eigenschaft auf True gesetzt wurde. Wenn die Höhe des Detailrasters die maximale Höhe überschreiten würde, wird eine Bildlaufleiste eingeblendet. Der Standardwert ist 250 Pixel. Diese Eigenschaft wird ignoriert, wenn die DetailAutoFit-Eigenschaft auf False gesetzt wurde. Long mit Lese-/Schreibzugriff.


DetailMaxWidth-Eigenschaft

Gibt die maximale Breite (in Pixeln) an, die das Detailraster erreichen kann, wenn der Wert der DetailAutoFit-Eigenschaft auf True gesetzt ist. Wenn die Breite des Detailrasters die maximale Breite überschreiten würde, wird die Bildlaufleiste eingeblendet. Der Standardwert ist 1024 Pixel. Diese Eigenschaft wird ignoriert, wenn die DetailAutoFit-Eigenschaft auf False gesetzt wurde. Long mit Lese-/Schreibzugriff.


DetailRange-Eigenschaft

Gibt ein PivotDetailRange-Objekt für den angegebenen Bereich zurück.

Syntax

Ausdruck.DetailRange(TopLeft, BottomRight)

Ausdruck Ein Ausdruck, der ein PivotCell-Objekt zurückgibt.

TopLeft Erforderliches PivotDetailCell-Objekt. Gibt die linke obere Zelle in einem Detailbereich an.

BottomRight Erforderliches PivotDetailCell-Objekt. Gibt die linke untere Zelle in einem Detailbereich an.


DetailRowHeight-Eigenschaft

Gibt die Zeilenhöhe für das Detailraster zurück (in Pixeln) oder legt diese fest. Der Standardwert ist 10 Pixel. Long mit Lese-/Schreibzugriff.


DetailSortOrder-Eigenschaft

Gibt die Sortierreihenfolge für Felder auf der Summenachse zurück oder legt diese fest. Variant mit Lese-/Schreibzugriff.

Anmerkungen

Felder werden in der Matrixreihenfolge sortiert. Wird für ein Feld, das in der Sortierreihenfolgenmatrix aufgenommen wurde, die SortDirection-Eigenschaft auf plSortDirectionDefault festgelegt, wird das Feld ignoriert.


DetailTop-Eigenschaft

Gibt den Index der oberen sichtbaren Zeile des Detailrasters zurück oder legt diesen fest. Long mit Lese-/Schreibzugriff.


DetailWidth-Eigenschaft

PivotField-Objekt: Gibt die Breite des angegebenen Feldes zurück (in Pixel) wenn es im Detailraster angezeigt wird, oder legt diese fest. Long mit Lese-/Schreibzugriff.

PivotView-Objekt: Gibt die Breite des Detailrasters zurück (in Pixel) oder legt diese fest. Long mit Lese-/Schreibzugriff.

Verwenden Sie die DetailRowHeight-Eigenschaft des PivotView-Objekts, um die Höhe des Detailrasters festzulegen.

Wenn die DetailAutoFit-Eigenschaft des PivotView-Objekts auf True festgelegt ist, wird die Detailbreite automatisch zurückgesetzt, wenn die PivotTable-Liste aktualisiert wird. Wenn Sie die DetailWidth-Eigenschaft programmseitig festlegen, wird die DetailAutoFit-Eigenschaft automatisch auf False festgelegt.


Direction-Eigenschaft

SchemaParameter-Objekt: Legt den Direction-Parameter für das SchemaRowSource-Objekt fest. Schreibgeschütztes ParameterDirectionEnum (ADO).

WCErrorBars-Objekt: Gibt die Fehlerindikatorenrichtung für die angegebenen Fehlerindikatoren zurück oder legt diese fest. ChartErrorBarDirectionEnum mit Lese-/Schreibzugriff.

Anmerkungen

Sie können die chErrorBarDirectionX-Konstante nur in Punkt (XY)-, Polar-, Balken- oder Blasendiagrammen verwenden.


Direction-Eigenschaft: Beispiel

In diesem Beispiel werden dem angegebenen Diagramm Fehlerindikatoren hinzugefügt, und die Fehlerindikatorenrichtung wird festgelegt. Charts(0) muss sich auf ein Punkt (XY)-, Polar-, Balken- oder Blasendiagramm beziehen.

Set eb = ChartSpace1.Charts(0).SeriesCollection(0).ErrorBarsCollection.Add
eb.Direction = ChartSpace1.Constants.chErrorBarDirectionX


Dirty-Eigenschaft

Der Wert ist True, wenn Änderungen an der Kalkulationstabelle vorgenommen worden sind, nachdem sie das letzte Mal gespeichert wurde. Boolean mit Lese-/Schreibzugriff.


Dirty-Eigenschaft: Beispiel

In diesem Beispiel wird die Kalkulationstabelle in eine Datei exportiert, wenn Änderungen vorgenommen worden sind, nachdem sie das letzte Mal gespeichert wurde.

If Spreadsheet1.Dirty Then
    Spreadsheet1.ActiveSheet.Export "sstest.xls", Spreadsheet1.Constants.ssExportActionNone
End If


DisplayAlerts-Eigenschaft

Der Wert ist True, wenn Meldungsfeldwarnungen angezeigt werden. Der Standardwert lautet True. Boolean mit Lese-/Schreibzugriff.


DisplayColHeaders-Eigenschaft

Der Wert ist True, wenn in der angegebenen Kalkulationstabelle Spaltenköpfe angezeigt werden. Der Standardwert lautet True. Boolean mit Lese-/Schreibzugriff.


DisplayColHeaders-Eigenschaft: Beispiel

In diesem Beispiel werden die Zeilen- und Spaltenköpfe der Kalkulationstabelle ausgeblendet.

Spreadsheet1.DisplayColHeaders = False
Spreadsheet1.DisplayRowHeaders = False


DisplayEmptyMembers-Eigenschaft

Wert ist True, wenn leere Mitglieder angezeigt werden, auch wenn diese nicht über Aggregate verfügen. Der Standardwert lautet False. Boolean mit Lese-/Schreibzugriff.


DisplayExpandIndicator-Eigenschaft

Der Wert ist True, wenn die Erweiterungsindikatoren für Mitglieder mit verfügbaren untergeordneten Mitgliedern oder Detaildatensätzen angezeigt werden. Wenn der Erweiterungsindikator ausgeblendet ist, wird der angezeigte Name des Mitglieds in diesem Raum angezeigt. Der Standardwert lautet True. Boolean mit Lese-/Schreibzugriff.


DisplayFieldList-Eigenschaft

Der Wert ist True, wenn die Feldliste geöffnet ist. Der Standardwert lautet False. Boolean mit Lese-/Schreibzugriff.


DisplayGridlines-Eigenschaft

Der Wert ist True, wenn in der angegebenen Kalkulationstabelle Gitternetzlinien angezeigt werden. Der Standardwert lautet True. Boolean mit Lese-/Schreibzugriff.


DisplayGridlines-Eigenschaft: Beispiel

In diesem Beispiel werden die Gitternetzlinien in der Kalkulationstabelle ausgeblendet.

Spreadsheet1.DisplayGridlines = False


DisplayHorizontalScrollBar-Eigenschaft

Der Wert ist True, wenn in der angegebenen Kalkulationstabelle die horizontale Bildlaufleiste angezeigt wird. Der Standardwert lautet True. Boolean mit Lese-/Schreibzugriff.


DisplayHorizontalScrollBar-Eigenschaft: Beispiel

In diesem Beispiel wird die horizontale Bildlaufleiste der Kalkulationstabelle ausgeblendet.

Spreadsheet1.DisplayHorizontalScrollBar = False


DisplayPropertyToolbox-Eigenschaft

Der Wert ist True, wenn die Eigenschaftentoolbox zu sehen ist. Boolean mit Lese-/Schreibzugriff.


DisplayRowHeaders-Eigenschaft

Der Wert ist True, wenn in der angegebenen Kalkulationstabelle Zeilenköpfe angezeigt werden. Der Standardwert lautet True. Boolean mit Lese-/Schreibzugriff.


DisplayRowHeaders-Eigenschaft: Beispiel

In diesem Beispiel werden die Zeilen- und Spaltenköpfe der Kalkulationstabelle ausgeblendet.

Spreadsheet1.DisplayColHeaders = False
Spreadsheet1.DisplayRowHeaders = False


DisplayTitleBar-Eigenschaft

Der Wert ist True, wenn in der angegebenen Kalkulationstabelle die Titelleiste angezeigt wird. Der Standardwert lautet True. Boolean mit Lese-/Schreibzugriff.


DisplayTitleBar-Eigenschaft: Beispiel

In diesem Beispiel wird die Titelleiste der Kalkulationstabelle ausgeblendet.

Spreadsheet1.DisplayTitleBar = False


DisplayToolbar-Eigenschaft

Der Wert ist True, wenn in der angegebenen Kalkulationstabelle oder PivotTable-Liste die Symbolleiste angezeigt wird. Der Standardwert lautet True. Boolean mit Lese-/Schreibzugriff.

Anmerkungen

Das Ausblenden der Symbolleiste ändert nicht die Höhe der PivotTable-Liste, führt aber zu einer Layoutänderung. Die Breite bleibt unverändert, es sei denn, die AutoFit-Eigenschaft wurde auf True gesetzt und die Bemaßungen der PivotTable-Liste sind zu hoch angesetzt worden, um Platz für die Symbolleiste zu schaffen.


DisplayToolbar-Eigenschaft: Beispiel

In diesem Beispiel wird die Symbolleiste der Kalkulationstabelle ausgeblendet.

Spreadsheet1.DisplayToolbar = False


DisplayVerticalScrollBar-Eigenschaft

Der Wert ist True, wenn in der angegebenen Kalkulationstabelle die vertikale Bildlaufleiste angezeigt wird. Der Standardwert lautet True. Boolean mit Lese-/Schreibzugriff.


DisplayVerticalScrollBar-Eigenschaft: Beispiel

In diesem Beispiel wird die vertikale Bildlaufleiste der Kalkulationstabelle ausgeblendet.

Spreadsheet1.DisplayVerticalScrollBar = False


EditData-Eigenschaft

Gibt die Zeichenkette zurück, die vom Benutzer im Bearbeitungsmodus eingegeben wurde. Diese Eigenschaft ist nur gültig, wenn Sie mit dem EndEdit-Ereignis verwendet wird. String schreibgeschützt.


EditData-Eigenschaft: Beispiel

Die Ereignisprozedur in diesem Beispiel wird jedes Mal ausgeführt, wenn der Benutzer Daten in eine Zelle einer Kalkulationstabelle eingibt. Wenn es sich bei den Daten nicht um Ganzzahlen zwischen 1 und 6 handelt, zeigt die Prozedur ein Meldungsfenster an und bricht die Eingabe ab. Beachten Sie, dass die Prozedur in diesem Beispiel so deklariert wurde, wie es für Visual Basic erforderlich ist. Weitere Informationen über das Verwenden von Ereignisprozeduren finden Sie im Abschnitt "Deklarieren und Verwenden von Ereignisprozeduren".

Private Sub Spreadsheet1_EndEdit(ByVal EventInfo As OWC.SpreadsheetEventInfo)
    Select Case EventInfo.EditData
        Case "1", "2", "3", "4", "5", "6"
        Case Else
            MsgBox "Please enter an integer between 1 and 6 inclusive."
            EventInfo.ReturnValue = False
    End Select
End Sub


ElementExtensions-Eigenschaft

Gibt das ElementExtensions-Objekt für das Datenquellensteuerelement zurück. Schreibgeschützt.


ElementID-Eigenschaft

Gibt das ID-Tag für das HTML-Element an, das für die angegebene Erweiterung verwendet wird. String schreibgeschützt .


EnableAutoCalculate-Eigenschaft

Der Wert ist True, wenn die angegebene Kalkulationstabelle oder das angegebene Tabellenblatt automatisch neu berechnet werden. Der Wert lautet False, wenn der Benutzer eine Neuberechnung anfordern muss. Der Standardwert lautet True. Boolean mit Lese-/Schreibzugriff.


EnableAutoCalculate-Eigenschaft: Beispiel

In diesem Beispiel wird die automatische Neuberechnung für das aktive Tabellenblatt deaktiviert.

Spreadsheet1.ActiveSheet.EnableAutoCalculate = False


EnableAutoFilter-Eigenschaft

Der Wert ist True, wenn das angegebene Tabellenblatt gefiltert werden kann. Diese Eigenschaft hat keine Auswirkungen, wenn die Protection Enabled-Eigenschaft auf False festgelegt ist. Boolean mit Lese-/Schreibzugriff.


EnableAutoFilter-Eigenschaft: Beispiel

In diesem Beispiel wird AutoFilter für das aktive Tabellenblatt deaktiviert.

Spreadsheet1.ActiveSheet.EnableAutoFilter = False
Spreadsheet1.ActiveSheet.Protection.Enabled = True


Enabled-Eigenschaft

Der Wert ist True, wenn der Tabellenblattschutz für das angegebene Tabellenblatt aktiviert ist. Wenn diese Eigenschaft auf False festgelegt ist, werden die übrigen Eigenschaften des Protection-Objekts ignoriert. Boolean mit Lese-/Schreibzugriff.


Enabled-Eigenschaft: Beispiel

In diesem Beispiel wird ein Benutzer daran gehindert, Zeilen in das aktive Tabellenblatt einzufügen.

Set pt = Spreadsheet1.ActiveSheet.Protection
pt.AllowInsertingRows = False
pt.Enabled = True


EnableEvents-Eigenschaft

Der Wert ist True, wenn Ereignisse für die Kalkulationstabelle oder den Diagrammarbeitsbereich aktiviert sind. Boolean mit Lese-/Schreibzugriff.


EnableEvents-Eigenschaft: Beispiel

In diesem Beispiel wird verhindert, dass Kalkulationstabellen-Ereignisprozeduren ausgeführt werden.

Spreadsheet1.EnableEvents = False


EnableUndo-Eigenschaft

Der Wert ist True, wenn die Undo-Funktion für die angegebene Kalkulationstabelle aktiviert ist. Boolean mit Lese-/Schreibzugriff.


EnableUndo-Eigenschaft: Beispiel

In diesem Beispiel wird ein Undo-Block erstellt, der Code enthält, mit dem Zahlenformat und Schriftart der aktiven Zelle festgelegt werden.

Spreadsheet1.EnableUndo = True
Spreadsheet1.BeginUndo
    Set ac = Spreadsheet1.ActiveCell
    ac.NumberFormat = "0.###"
    ac.Font.Color = "blue"
    ac.Font.Name = "times new roman"
Spreadsheet1.EndUndo


EndStyle-Eigenschaft

Gibt die Endlinienart für Fehlerindikatoren zurück oder legt diese fest. Die Standardkonstante ist chEndStyleCap. ChartEndStyleEnum mit Lese-/Schreibzugriff.


EndStyle-Eigenschaft: Beispiel

In diesem Beispiel werden der angegebenen Reihe Fehlerindikatoren ohne End-Caps hinzugefügt.

Set eb = ChartSpace1.Charts(0).SeriesCollection(0).ErrorBarsCollection.Add
eb.Amount = 0.1
eb.EndStyle = ChartSpace1.Constants.chEndStyleNone


EntireColumn-Eigenschaft

Gibt ein Range-Objekt zurück, das eine oder mehrere Spalte repräsentiert, die den angegebenen Bereich enthalten. Schreibgeschützt.


EntireColumn-Eigenschaft: Beispiel

In diesem Beispiel wird die Schriftfarbe für die ganze Spalte festgelegt, welche die aktive Zelle enthält.

Spreadsheet1.ActiveCell.EntireColumn.Font.Color = "green"


EntireRow-Eigenschaft

Gibt ein Range-Objekt zurück, das eine oder mehrere Zeilen repräsentiert, die den angegebenen Bereich enthalten. Schreibgeschützt.


EntireRow-Eigenschaft: Beispiel

In diesem Beispiel wird die Schriftfarbe für die ganze Zeile festgelegt, welche die aktive Zelle enthält.

Spreadsheet1.ActiveCell.EntireRow.Font.Color = "red"


Error-Eigenschaft

Gibt ein ADO- Error-Objekt zurück, das Fehlerinformationen über das angegebene Ereignis enthält. Schreibgeschützt.


ErrorBarsCollection-Eigenschaft

Gibt eine WCErrorbarsCollection-Auflistung zurück, die für jede Gruppe von Fehlerindikatoren in der angegebenen Reihe ein WCErrorBars-Objekt enthält. Eine Reihe kann nur eine Gruppe von Fehlerindikatoren enthalten, deshalb enthält die WCErrorBarsCollection-Auflistung niemals mehr als ein Objekt. Schreibgeschützt.


ErrorBarsCollection-Eigenschaft: Beispiel

In diesem Beispiel werden der angegebenen Reihe Fehlerindikatoren hinzugefügt.

Set eb = ChartSpace1.Charts(0).SeriesCollection(0).ErrorBarsCollection.Add


Expanded-Eigenschaft

PivotCell-Objekt: Der Wert ist True, wenn das Detailraster für die angegebene Zelle angezeigt wird. Wenn diese Eigenschaft auf False festgelegt ist, wird das Detailraster nicht angezeigt und Aggregate werden angezeigt, wenn sie verfügbar sind. Boolean mit Lese-/Schreibzugriff.

PivotMember-Objekt: True, wenn untergeordnete Mitglieder oder Details für das angegebene Mitglied angezeigt werden; False, wenn untergeordnete Mitglieder oder Details ausgeblendet werden. Boolean mit Lese-/Schreibzugriff.

PivotField-Objekt: Gibt den erweiterten Status aller Mitglieder des angegebenen Feldes gleichzeitig zurück oder legt diesen fest. Beim Festlegen der Expanded-Eigenschaft für das Feld wird die Expanded-Eigenschaft direkt für alle Mitglieder, die mit dem Feld verknüpft sind, festgelegt. Das Festlegen der Expanded-Eigenschaft für ein einziges Mitglied des Feldes wirkt sich nicht auf die Expanded-Eigenschaft für das Feld aus.


ExpandedByDefault-Eigenschaft

Der Wert ist True, wenn die angegebene Gruppenebene standardmäßig erweitert ist. Der Standardwert lautet False. Boolean mit Lese-/Schreibzugriff.


Explosion-Eigenschaft

Gibt den Explosionswert für die angegebene Kreis- oder Ringdiagrammscheibe zurück oder legt diese fest. Der gültige Bereich liegt zwischen 0 und 1000. Der Explosionswert entspricht einem Prozentsatz des Diagrammradius. Beachten Sie, dass ein Festlegen dieser Eigenschaft auf 100 die Spitzen der Scheiben in einen Abstand vom Zentrum des Diagramms verschiebt, der dem Radius des Diagramms entspricht. Long mit Lese-/Schreibzugriff.


Explosion-Eigenschaft: Beispiel

In diesem Beispiel werden die Spitzen des Kreis- oder Ringdiagramms in der angegebenen Reihe in einen Abstand verschoben, der einem Zehntel des Diagrammradius entspricht.

ChartSpace1.Charts(0).SeriesCollection(0).Explosion = 10


Field-Eigenschaft

Gibt ein PivotField-Objekt zurück, welches das Feld repräsentiert, das mit dem angegebenen Mitglied oder der Summe verknüpft ist. Schreibgeschützt.


FieldLabelBackColor-Eigenschaft

Gibt die Hintergrundfarbe zurück, die für Feldbeschriftungen von Zeilen, Spalten und Filtern verwendet wird, oder legt diese fest. Der Standardwert ist 25% grau. Variant mit Lese-/Schreibzugriff.

Anmerkungen

Wenn Sie diese Eigensschaft festlegen, können Sie entweder einen Long-Wert, der einen RGB-Wert repräsentiert, oder einen String-Wert verwenden, der einen gültigen HTML-Farbwert benennt.Um beispielsweise die Objektfarbe auf rot festzulegen, könnten Sie den hexadezimalen Wert &HFF, den Dezimalwert 255 oder die Zeichenkette red verwenden. In Microsoft Visual Basic können Sie die RGB-Funktion verwenden, um einen RGB-Farbwert zu erzeugen (rot entspricht RGB(255,0,0)).

Diese Eigenschaft gibt die Farbe stets als Long-Wert zurück, der einen RGB-Farbwert darstellt.


FieldLabelFont-Eigenschaft

Gibt ein PivotFont-Objekt zurück, das die Feldbeschriftungen für Zeilen, Spalten und Filter repräsentiert. Schreibgeschützt.


FieldLabelForeColor-Eigenschaft

Gibt die Vordergrundfarbe zurück, die für Feldbeschriftungen von Zeilen, Spalten und Filtern verwendet wird, oder legt diese fest. Variant mit Lese-/Schreibzugriff.

Anmerkungen

Wenn Sie diese Eigensschaft festlegen, können Sie entweder einen Long-Wert, der einen RGB-Wert repräsentiert, oder einen String-Wert verwenden, der einen gültigen HTML-Farbwert benennt.Um beispielsweise die Objektfarbe auf rot festzulegen, könnten Sie den hexadezimalen Wert &HFF, den Dezimalwert 255 oder die Zeichenkette red verwenden. In Microsoft Visual Basic können Sie die RGB-Funktion verwenden, um einen RGB-Farbwert zu erzeugen (rot entspricht RGB(255,0,0)).

Diese Eigenschaft gibt die Farbe stets als Long-Wert zurück, der einen RGB-Farbwert darstellt.


FieldLabelHeight-Eigenschaft

Gibt die Höhe der Feldbeschriftungen für Zeilen, Spalten und Filter zurück. Schreibgeschütztes Long.


Fields-Eigenschaft

Gibt die PivotFields-Auflistung für die angegebene Feldgruppe zurück. Schreibgeschützt.


FieldSet-Eigenschaft

Gibt ein PivotFieldSet-Objekt zurück, das die Feldgruppe repräsentiert, zu der das angegebene Feld gehört. Schreibgeschützt.


FieldSets-Eigenschaft

Gibt ein PivotFieldSets-Objekt zurück, das die Feldgruppen enthält, die mit der angegebenen Achse oder Ansicht verknüpft sind. Schreibgeschützt.


FieldType-Eigenschaft

Gibt den Feldtyp des angegebenen Feldes zurück. Schreibgeschütztes dscFieldTypeEnum.


Filter-Eigenschaft

Gibt die ADO-Filterzeichenkette für die Datensatzgruppe zurück, die mit der Datenseite in Verbindung steht. Variant mit Lese-/Schreibzugriff.


FilterAxis-Eigenschaft

Gibt ein PivotFilterAxis-Objekt zurück, das die Filterachse repräsentiert. Schreibgeschützt.


FilterFunction-Eigenschaft

Criteria-Objekt: Gibt zurück oder legt fest, wie die angegebenen Kriterien mit dem AutoFilter zusammenarbeiten. Wenn diese Eigenschaft auf ssFilterFunctionInclude festgelegt ist, werden die angegebenen Objekte in der gefilterten Liste angezeigt, und alle übrigen Objekte werden entfernt. Wenn diese Eigenschaft auf ssFilterFunctionExclude festgelegt ist, werden die angegebenen Objekte aus der gefilterten Liste entfernt, und alle übrigen Objekte werden angezeigt. SheetFilterFunction mit Lese-/Schreibzugriff.

PivotField-Objekt: Gibt die Filterfunktion für das angegebene Feld zurück oder legt diese fest. PivotFieldFilterFunctionEnum mit Lese-/Schreibzugriff.


FilterMember-Eigenschaft

Gibt ein Filtermitglied zurück oder legt es fest, wenn die angegebene Feldgruppe sich auf der Filterachse befindet. Der Wert dieser Eigenschaft kann der eindeutige Name eines Filtermitglieds sein (in Übereinstimmung mit der zurückgegebenen oder festgelegten UniqueName-Eigenschaft) oder ein Bezug auf das Filtermitglied-Objekt. Variant mit Lese-/Schreibzugriff.


FilterMembers-Eigenschaft

Gibt eine Liste der Mitglieder zurück, die bei einer Filteroperation zu verwenden sind, oder legt diese fest. Variant mit Lese-/Schreibzugriff.

Anmerkungen

Diese Eigenschaft kann festgelegt werden, wenn ein Feld auf der Zeilen-, Spalten- oder Datenachse verwendet wird. Wenn diese Eigenschaft auf ein Feld der Datenachse festgelegt ist, wird dieses Feld dazu verwendet, die Detailsätze, nicht jedoch die Mitglieder und Aggregate zu filtern. Wenn diese Eigenschaft auf ein Feld der Zusammenfassungsachse festgelegt ist, wird dieses Feld dazu verwendet, die Detailsätze und die Aggregate zu filtern.

Sie können diese Eigenschaft festlegen, indem Sie ein Variant-Array mit PivotMember-Objekten oder Zeichenkettenbezeichnern (abgerufen durch Verwenden der Caption-, Name- oder UniqueName-Eigenschaft) verwenden, wie es aus den nachfolgenden Beispielen ersichtlich wird.

In diesem Beispiel wird ein Array mit String-Werten verwendet.

PivotTable1.ActiveView.ColumnAxis.Fieldsets("State").Fields(0).FilterMembers = Array("WA", "OR")

In diesem Beispiel wird ein Array mit Objekten verwendet.

Set tmpMemberCol = PivotTable1.ActiveView.Fieldsets("State").Members(0).ChildMembers("WA")
Set tmpMemberRow = PivotTable1.ActiveView.Fieldsets("State").Members(0).ChildMembers("OR")
PivotTable1.ActiveView.ColumnAxis("State").FilterMembers = Array(tmpMemberCol, tmpMemberRow)


FilterMode-Eigenschaft

Der Wert ist True, wenn momentan Zeilen des Tabellenblattes durch AutoFilter-Kriterien ausgeblendet worden sind. Der Standardwert lautet False. Schreibgeschützter Boolean.

Anmerkungen

Wenn die AutoFilter-Dropdownpfeile sichtbar sind, aber momentan keine Zeilen gefiltert werden (alle Zeilen sind sichtbar), ist die AutoFilterMode-Eigenschaft auf True und die FilterMode-Eigenschaft auf False gesetzt.


Filters-Eigenschaft

Gibt das Filters-Objekt für den angegebenen Filter zurück. Die Filters-Auflistung enthält ein Filter-Objekt für jede Spalte innerhalb des gefilterten Bereichs. Schreibgeschützt.


Filters-Eigenschaft: Beispiel

In diesem Beispiel wird der AutoFilter für den Bereich A1:J22 aktiviert, es werden Filter für die Spalten 1 und 3 gesetzt, und anschließend werden die Filter angewendet.

Spreadsheet1.Range("a1:j22").AutoFilter
Set af = Spreadsheet1.ActiveSheet.AutoFilter
Set filterColumnOne = af.Filters(1)
Set filterColumnThree = af.Filters(3)
filterColumnOne.Criteria.Add "blue"    ' Don't show blue in column 1.
filterColumnOne.Criteria.Add "green"    ' Don't show green in column 1.
filterColumnThree.Criteria.Add "yellow"    ' Don't show yellow in column 3.
af.Apply


FirstSection-Eigenschaft

Gibt ein Section-Objekt zurück, das den ersten Abschnitt auf der angegebenen Datenseite repräsentiert. Schreibgeschützt.


FirstSliceAngle-Eigenschaft

Gibt den Winkel der ersten Scheibe des Kreis- oder Ringdiagramms in Grad (im Uhrzeigersinn von der Vertikalen ausgehend) zurück oder legt ihn fest. Gilt nur für Kreis- und Ringdiagramme. Long mit Lese-/Schreibzugriff.


FirstSliceAngle-Eigenschaft: Beispiel

In diesem Beispiel wird der Winkel des ersten Kreis- oder Ringdiagramms auf 45 Grad gesetzt. Charts(0) muss sich auf ein Kreis- oder Ringdiagramm beziehen.

ChartSpace1.Charts(0).FirstSliceAngle = 45


Font-Eigenschaft

Gibt ein OWCFont oder PivotFont-Objekt zurück, das die Schriftart für das angegebene Objekt repräsentiert (der zurückgegebene Objekttyp hängt von dem Objekt ab, auf das diese Eigenschaft angewendet wird). Schreibgeschützt.


FontName-Eigenschaft

Gibt den Namen der Schriftart im angegebenen Steuerelement zurück oder legt ihn fest. String mit Lese-/Schreibzugriff.

In diesem Beispiel wird der Name der Schriftart für das Steuerelement auf "Courier New" festgelegt.

RNC1.FontName = "Courier New"


ForeColor-Eigenschaft

Gibt die Vordergrundfarbe für das angegebene Objekt oder den angegebenen Bereich zurück oder legt sie fest. Variant mit Lese-/Schreibzugriff.

Anmerkungen

Wenn Sie diese Eigenschaft setzen, können Sie entweder einen Long-Wert, der einen RGB-Farbwert repräsentiert, oder einen String-Wert verwenden, der einen gültigen HTML-Farbwert benennt.Um beispielsweise die Objektfarbe auf rot zu setzen, könnten Sie den hexadezimalen Wert &HFF, den Dezimalwert 255 oder die Zeichenkette red verwenden. In Microsoft Visual Basic können Sie die RGB-Funktion einsetzen, um einen RGB-Farbwert zu erzeugen (rot entspricht RGB(255,0,0)).

Diese Eigenschaft gibt die Farbe stets als Long-Wert zurück, der einen RGB-Farbwert darstellt.


Formula-Eigenschaft

Gibt die Formel für den angegebenen Bereich an. Gibt eine leere Zeichenkette zurück, wenn der Bereich leer ist. String mit Lese-/Schreibzugriff.


FormulaLocal-Eigenschaft

Gibt die Bereichsformel in der Sprache zurück, in der der Benutzer arbeitet. String schreibgeschützt.


FormulaLocal-Eigenschaft: Beispiel

Die Ereignisprozedur in diesem Beispiel zeigt die Bereichsformel stets in der Sprache an, in der der Benutzer arbeitet, wenn dieser innerhalb der Kalkulationstabelle doppelklickt. Beachten Sie, dass die Prozedur in diesem Beispiel so deklariert wurde, wie es für Visual Basic erforderlich ist. Weitere Informationen über das Verwenden von Ereignisprozeduren finden Sie im Abschnitt "Deklarieren und Verwenden von Ereignisprozeduren".

Private Sub Spreadsheet1_DblClick(ByVal EventInfo As OWCCtl.SpreadsheetEventInfo)
    MsgBox EventInfo.Range.FormulaLocal
End Sub


FreezePanes-Eigenschaft

Der Wert ist True, wenn das angegebene Tabellenblatt fixierte Fenster enthält. Schreibgeschützter Boolean.


FreezePanes-Eigenschaft: Beispiel

In diesem Beispiel werden alle fixierten Fenster aus dem aktiven Tabellenblatt entfernt.

Set c = Spreadsheet1.Constants
If Spreadsheet1.ActiveSheet.FreezePanes Then _
    Spreadsheet1.Range("a1").FreezePanes c.ssFreezeNone


Function-Eigenschaft

Gibt die Funktion zurück, die für das Generieren von Aggregatwerten verwendet wird, oder legt diese fest. PivotTotalFunctionEnum mit Lese-/Schreibzugriff.

Anmerkungen

Der Sum-Operator ist bei nummerischen Datentypen standardmäßig. Der Count-Operator ist der Standardwert für andere Datentypen.


GapWidth-Eigenschaft

Gibt den Abstandsbetrag zwischen den Markierungen benachbarter Rubriken als Prozentsatz der Spaltenbreite zurück oder legt diesen fest. Ein Wert von null führt zu keinem Abstand zwischen benachbarten Rubrikenmarkierungen, während positive Werte einen Zwischenraum erzeugen. Long mit Lese-/Schreibzugriff.


GapWidth-Eigenschaft: Beispiel

In diesem Beispiel wird der Abstand zwischen Markierungen in benachbarten Rubriken auf 250 Punkte gesetzt.

ChartSpace1.Charts(0).GapWidth = 250


GridX-Eigenschaft

Gibt die Anzahl der gepunkteten Gitternetzlinien pro Zoll auf der X-Achse im Standardabschnitt des Datenseitenentwicklers zurück. Long mit Lese-/Schreibzugriff.


GridY-Eigenschaft

Gibt die Anzahl der gepunkteten Gitternetzlinien pro Zoll auf der Y-Achse im Standardabschnitt des Datenseitenentwicklers zurück. Long mit Lese-/Schreibzugriff.


GroupedAutoFit-Eigenschaft

Der Wert ist True, falls die Spaltenbreite des angegebenen Feldes automatisch festgelegt wird, wenn das Feld auf der Spalten- oder Zeilenachse verwendet wird. Boolean mit Lese-/Schreibzugriff.


GroupedWidth-Eigenschaft

Gibt die Breite des angegebenen Feldes (in Pixeln) zurück oder legt diese fest, wenn das Feld auf der Zeilen- oder Spaltenachse angezeigt wird. Der Standardwert ist 50 Pixel. Long mit Lese-/Schreibzugriff.


GroupFilterControl-Eigenschaft

Gibt die ID des Listen- bzw. Kombinationsfeldes zurück, das zum Festlegen der Währung verwendet wird, oder legt diese fest. String mit Lese-/Schreibzugriff.


GroupFilterField-Eigenschaft

Gibt die Filterzeichenkette zurück, die vom Gruppenfilter-Steuerelement verwendet wird (das Feld, in dem das Steuerelement die Währung einstellt), oder legt diese fest. Die Zeichenkette muss den Namen eines Seitenfeldes in der Datensatzquelle der Gruppenebene tragen. String mit Lese-/Schreibzugriff.


GroupFooter-Eigenschaft

Der Wert ist True, wenn der angegebene Abschnitt über einen Fuß verfügt. Sie können diese Eigenschaft für alle verbundenen Ebenen mit Ausnahme der ganz inneren setzen. Der Standardwert lautet False. Boolean mit Lese-/Schreibzugriff.


GroupHeader-Eigenschaft

Der Wert ist True, wenn der angegebene Abschnitt über einen Kopf verfügt. Der Standardwert lautet True. Boolean mit Lese-/Schreibzugriff.


GroupingDefs-Eigenschaft

Gibt die GroupingDefs-Auflistung für die angegebene Datensatzdefinition zurück. Diese Auflistung enthält GroupingDef-Objekte, die Gruppenebenen für die Detaildatensätze erstellen. Schreibgeschützt.

Informationen über das Zurückgeben eines einzelnen Mitglieds einer Auflistung finden Sie im Abschnitt "Zurückgeben eines Objekts aus einer Auflistung".


GroupInterval-Eigenschaft

Gibt das Gruppierungsintervall an oder legt es fest. Long mit Lese-/Schreibzugriff.


GroupLevel-Eigenschaft

Gibt das GroupLevel-Objekt für die angegebene Datenseite zurück. Ein GroupLevel-Objekt steht mit einer Datensatzgruppe in Verbindung, die aus einer Datensatzgruppen- oder Gruppierungsdefinition hervorgeht.


GroupLevels-Eigenschaft

Gibt die GroupLevels-Auflistung für das angegebene Datenquellen-Steuerelement zurück. Schreibgeschützt.

Informationen über das Zurückgeben eines einzelnen Mitglieds einer Auflistung finden Sie im Abschnitt "Zurückgeben eines Objekts aus einer Auflistung".


GroupOn-Eigenschaft

Gibt das Verfahren zurück, nach dem GroupLevel-Objekte oder PageField-Objekte gruppiert werden, oder legt es fest. dscGroupOnEnum mit Lese-/Schreibzugriff.


HAlignment-Eigenschaft

Gibt das Verfahren zurück, mit dem Daten in den angegebenen Bereichen, Beschriftungen oder Summen ausgerichtet werden, oder legt es fest. PivotHAlignmentEnum mit Lese-/Schreibzugriff für PivotLabel und PivotTotal-Objekte, Variant mit Lese-/Schreibzugriff für das Range-Objekt (dies kann eine der SheetHAlignEnum-Konstanten sein; gibt Null zurück, wenn alle Zellen des Bereichs nicht auf dieselbe Weise angeordnet sind). Verwenden Sie die IsNull-Funktion, um festzustellen, ob der Rückgabewert Null ist.


HAlignment-Eigenschaft: Beispiel

In diesem Beispiel werden die Werte im Bereich A1:F1 zentriert.

Spreadsheet1.Range("a1:f1").HAlignment = c.ssHAlignCenter


HasAutoCaption-Eigenschaft

Der Wert ist True, wenn der Name der angegebenen Trendlinie automatisch aus Trendlinientyp und Reihenindex generiert wird (beispielsweise "Poly. (Series 1)"). Durch Setzen der Caption-Eigenschaft der Trendlinie wird diese Eigenschaft auf False gesetzt . Boolean mit Lese-/Schreibzugriff.


HasAutoCaption-Eigenschaft: Beispiel

In diesem Beispiel wird die Beschriftung der angegebenen Trendlinienbeschriftung festgelegt, wenn die Beschriftung derzeit auf automatische Generierung gesetzt ist. Beachten Sie, dass SeriesCollection(0) sich auf eine Reihe beziehen muss, die bereits über eine Trendlinie verfügt.

Set sZero = ChartSpace1.Charts(0).SeriesCollection(0)
sZero.Line.Color = "red"
Set trndline = sZero.Trendlines(0)
If trndline.HasAutoCaption Then trndline.Caption = "data trend"


HasAutoMajorUnit-Eigenschaft

Der Wert ist True, wenn die Haupteinheit für die angegebene Achse automatisch ermittelt wird. Der Standardwert lautet True. Sie sollten diese Eigenschaft nur für Größenachsen verwenden. Boolean mit Lese-/Schreibzugriff.


HasAutoMajorUnit-Eigenschaft: Beispiel

In diesem Beispiel wird die Haupteinheit der angegebenen Achse gesetzt, wenn zu diesem Zeitpunkt die automatische Ermittlung der Haupteinheit eingestellt ist.

Set c = ChartSpace1.Constants
Set axs = ChartSpace1.Charts(0).Axes(c.chAxisPositionLeft)
If axs.HasAutoMajorUnit Then axs.MajorUnit = 5000


HasAutoMaximum-Eigenschaft

Der Wert ist True, wenn der maximale Skalenwert für die angegebene Achse auf automatische Ermittlung gesetzt ist. Der Standardwert lautet True. Boolean mit Lese-/Schreibzugriff.


HasAutoMaximum-Eigenschaft: Beispiel

In diesem Beispiel wird der Maximalwert für die Skalierung der angegebenen Achse gesetzt, wenn zu diesem Zeitpunkt eine automatische Ermittlung des Maximalwerts eingestellt ist.

Set c = ChartSpace1.Constants
Set axisScale = ChartSpace1.Charts(0).Axes(c.chAxisPositionLeft).Scaling
If axisScale.HasAutoMaximum Then axisScale.Maximum = 50000


HasAutoMinimum-Eigenschaft

Der Wert ist True, wenn der minimale Skalenwert für die angegebene Achse auf automatische Ermittlung gesetzt ist. Der Standardwert lautet True. Boolean mit Lese-/Schreibzugriff.


HasAutoMinimum-Eigenschaft: Beispiel

In diesem Beispiel wird der Minimalwert für die Skalierung der angegebenen Achse gesetzt, wenn zu diesem Zeitpunkt eine automatische Ermittlung des Minimalwerts eingestellt ist.

Set c = ChartSpace1.Constants
Set axisScale = ChartSpace1.Charts(0).Axes(c.chAxisPositionLeft).Scaling
If axisScale.HasAutoMinimum Then axisScale.Minimum = 10


HasAutoMinorUnit-Eigenschaft

Der Wert ist True, wenn für die Teileinheit der angegebenen Achse die automatische Ermittlung eingestellt ist. Der Standardwert lautet True. Sie sollten diese Eigenschaft nur für Größenachsen verwenden. Boolean mit Lese-/Schreibzugriff.


HasAutoMinorUnit-Eigenschaft: Beispiel

In diesem Beispiel wird die Teileinheit der angegebenen Achse auf Inkremente von 500 gesetzt, wenn zu diesem Zeitpunkt die automatische Ermittlung der Einheit eingestellt ist.

Set c = ChartSpace1.Constants
Set axs = ChartSpace1.Charts(0).Axes(c.chAxisPositionLeft)
If axs.HasAutoMinorUnit Then axs.MinorUnit = 500


HasBubbleSize-Eigenschaft

Der Wert ist True, wenn jede Datenbeschriftung für die angegebene Reihe oder das angegebene Diagramm derzeit ihre Blasengröße anzeigt. Der Standardwert lautet False. Beachten Sie, dass diese Eigenschaft nur für Blasendiagramme verfügbar ist. Boolean mit Lese-/Schreibzugriff.

Anmerkungen

Die Datenbeschriftungskomponenten werden stets in der nachfolgenden Reihenfolge angezeigt: [SeriesName] [CategoryName] [Value] [BubbleSize] [Percentage].


HasBubbleSize-Eigenschaft: Beispiel

In diesem Beispiel wird veranlasst, dass die Datenbeschriftungen für die angegebenen Reihen ihre Blasengröße anzeigen. Beachten Sie, dass Charts(0) sich auf ein Blasendiagramm beziehen muss.

Set dl = ChartSpace1.Charts(0).SeriesCollection(0).DataLabelsCollection.Add
dl.HasBubbleSize = True


HasCategoryName-Eigenschaft

Der Wert ist True, wenn jede Datenbeschriftung für die angegebene Reihe oder das angegebene Diagramm derzeit ihren Rubrikennamen oder ihre Rubrikenbeschriftung anzeigt. Der Standardwert lautet False. Boolean mit Lese-/Schreibzugriff.

Anmerkungen

Die Datenbeschriftungskomponenten werden stets in der nachfolgenden Reihenfolge angezeigt: [SeriesName] [CategoryName] [Value] [BubbleSize] [Percentage].


HasCategoryName-Eigenschaft: Beispiel

In diesem Beispiel wird veranlasst, dass die Datenbeschriftungen für die angegebenen Reihen ihre Rubrik und ihre Reihennamen anzeigen.

Set dl = ChartSpace1.Charts(0).SeriesCollection(0).DataLabelsCollection(0)
dl.HasCategoryName = True
dl.HasSeriesName = True


HasChartSpaceLegend-Eigenschaft

Der Wert ist True, wenn der angegebene Diagrammarbeitsbereich über eine Legende verfügt. Boolean mit Lese-/Schreibzugriff.

Anmerkungen

Durch Setzen dieser Eigenschaft auf False wird bewirkt, dass die Legende im Diagrammarbeitsbereich gelöscht wird. Wenn dies geschieht, gehen sämtliche Formatierungen verloren und müssen zurückgesetzt werden, wenn die Eigenschaft später auf True gesetzt wird.


HasChartSpaceLegend-Eigenschaft: Beispiel

In diesem Beispiel wird der Titel des Diagrammarbeitsbereichs festgelegt, und die Legende des Diagrammarbeitsbereichs wird auf der linken Seite des Arbeitsbereichs angeordnet.

Set c = ChartSpace1.Constants
ChartSpace1.HasChartSpaceTitle = True
ChartSpace1.ChartSpaceTitle.Caption = "Monthly Sales Data"
ChartSpace1.HasChartSpaceLegend = True
ChartSpace1.ChartSpaceLegend.Position = c.chLegendPositionLeft


HasChartSpaceTitle-Eigenschaft

Der Wert ist True, wenn der angegebene Diagrammarbeitsbereich über einen Titel verfügt. Boolean mit Lese-/Schreibzugriff.

Anmerkungen

Durch Setzen dieser Eigenschaft auf False wird bewirkt, dass der Titel im Diagrammarbeitsbereich gelöscht wird. Wenn dies geschieht, gehen sämtliche Formatierungen verloren und müssen zurückgesetzt werden, wenn die Eigenschaft später auf True gesetzt wird.


HasChartSpaceTitle-Eigenschaft: Beispiel

In diesem Beispiel wird der Titel des Diagrammarbeitsbereichs festgelegt, und die Legende des Diagrammarbeitsbereichs wird auf der linken Seite des Arbeitsbereichs angeordnet.

Set c = ChartSpace1.Constants
ChartSpace1.HasChartSpaceTitle = True
ChartSpace1.ChartSpaceTitle.Caption = "Monthly Sales Data"
ChartSpace1.HasChartSpaceLegend = True
ChartSpace1.ChartSpaceLegend.Position = c.chLegendPositionLeft


HasDetails-Eigenschaft

Der Wert ist True, wenn Detaildatensätze für eine einzelne Zelle angezeigt werden können, und False, wenn keine Detaildatensätze zur Anzeige verfügbar sind. Diese Eigenschaft wird jedes Mal automatisch zurückgesetzt, wenn die Daten erneut abgefragt werden. Wenn diese Eigenschaft auf False gesetzt ist, werden die Erweiterungsindikatoren für innere Mitglieder nicht angezeigt. Diese Eigenschaft wird immer dann auf False gesetzt, wenn der Provider multidimensional ist. Schreibgeschützter Boolean.


HasFormula-Eigenschaft

Der Wert ist True, wenn alle Zellen im Bereich Formeln enthalten, False, wenn keine Zelle Formeln enthält, und Null, wenn einige Zellen Formeln enthalten und andere nicht. Variant schreibgeschützt. Verwenden Sie die IsNull-Funktion, um festzustellen, ob der Rückgabewert Null ist.


HasFormula-Eigenschaft: Beispiel

In diesem Beispiel wird das aktive Tabellenblatt neu berechnet, wenn eine beliebige Zelle auf dem Tabellenblatt eine Formel enthält.

hf = Spreadsheet1.ActiveSheet.Cells.HasFormula
If IsNull(hf) Or hf Then Spreadsheet1.ActiveSheet.Calculate


HasLegend-Eigenschaft

Der Wert ist True, wenn das angegebene Diagramm über eine Legende verfügt. Boolean mit Lese-/Schreibzugriff.


HasLegend-Eigenschaft: Beispiel

In diesem Beispiel wird festgelegt, dass das angegebene Diagramm eine Legende besitzt.

ChartSpace1.Charts(0).HasLegend = True


HasMajorGridlines-Eigenschaft

Der Wert ist True, wenn die angegebene Achse über Hauptgitternetzlinien verfügt. Beachten Sie, dass jede beliebige Achse Gitternetzlinien aufweisen kann. Boolean mit Lese-/Schreibzugriff.


HasMajorGridlines-Eigenschaft: Beispiel

In diesem Beispiel werden die Hauptgitternetzlinien auf der angegebenen Achse deaktiviert.

Set c = ChartSpace1.Constants
ChartSpace1.Charts(0).Axes(c.chAxisPositionLeft).HasMajorGridlines = False


HasMergeCells-Eigenschaft

Der Wert ist True, wenn der Bereich Teil einer verbundenen Zelle ist, und False, wenn dies nicht der Fall ist, oder Null, wenn der Bereich sich mit einer verbundenen Zelle überschneidet (er befindet sich teilweise in einer verbundenen Zelle und teilweise nicht). Verwenden Sie die IsNull-Funktion, um festzustellen, ob der Rückgabewert Null beträgt. Variant schreibgeschützt.


HasMergeCells-Eigenschaft: Beispiel

Wenn es sich bei Zelle A7 um eine verbundene Zelle handelt, wird in diesem Beispiel der Wert der verbundenen Zelle auf 15 gesetzt.

Set ma = Spreadsheet1.Range("a7").MergeArea
If Spreadsheet1.Range("a7").HasMergeCells Then ma.Value = 15


HasMinorGridlines-Eigenschaft

Der Wert ist True, wenn die angegebene Achse über Hilfsgitternetzlinien verfügt. Beachten Sie, dass jede beliebige Achse Gitternetzlinien aufweisen kann. Boolean mit Lese-/Schreibzugriff.


HasMinorGridlines-Eigenschaft: Beispiel

In diesem Beispiel werden die Hilfsgitternetzlinien auf der angegebenen Achse deaktiviert.

Set c = ChartSpace1.Constants
ChartSpace1.Charts(0).Axes(c.chAxisPositionLeft).HasMinorGridlines = False


HasPercentage-Eigenschaft

Der Wert ist True, wenn jede Datenbeschriftung für die angegebene Reihe oder das angegebene Diagramm derzeit ihren prozentualen Wert anzeigt. Der Standardwert lautet False. Diese Eigenschaft ist nur für Kreis-, Ring- und Schichtendiagramme verfügbar. Boolean mit Lese-/Schreibzugriff.

Anmerkungen

Die Datenbeschriftungskomponenten werden stets in der nachfolgenden Reihenfolge angezeigt: [SeriesName] [CategoryName] [Value] [BubbleSize] [Percentage].


HasPercentage-Eigenschaft: Beispiel

In diesem Beispiel werden einer Reihe Datenbeschriftungen hinzugefügt. Beachten Sie, dass Charts(0) sich auf ein Kreis-, Ring- oder Schichtendiagramm beziehen muss.

Set dl = ChartSpace1.Charts(0).SeriesCollection(0).DataLabelsCollection.Add
dl.HasPercentage = True


HasSeriesName-Eigenschaft

Der Wert ist True, wenn jede Datenbeschriftung für die angegebene Reihe oder das angegebene Diagramm derzeit ihren Reihennamen anzeigt. Der Standardwert lautet False. Diese Eigenschaft ist nur für Kreis-, Ring- und Schichtendiagramme verfügbar. Boolean mit Lese-/Schreibzugriff.

Anmerkungen

Die Datenbeschriftungskomponenten werden stets in der nachfolgenden Reihenfolge angezeigt: [SeriesName] [CategoryName] [Value] [BubbleSize] [Percentage].


HasSeriesName-Eigenschaft: Beispiel

In diesem Beispiel wird veranlasst, dass die Datenbeschriftungen für die angegebenen Reihen ihre Rubrik und ihre Reihennamen anzeigen.

Set dl = ChartSpace1.Charts(0).SeriesCollection(0).DataLabelsCollection(0)
dl.HasCategoryName = True
dl.HasSeriesName = True


HasSplit-Eigenschaft

Der Wert ist True, wenn die Skalierung der angegebenen Achse einen Aufteilungspunkt aufweist, der sich zwischen dem Wert ihrer SplitMinimum-Eigenschaft und dem Wert ihrer SplitMaximum-Eigenschaft befindet. Der Standardwert lautet False. Boolean mit Lese-/Schreibzugriff.


HasSplit-Eigenschaft: Beispiel

In diesem Beispiel wird die angegebene Achse aufgeteilt, und es werden die minimalen und maximalen Aufteilungswerte gesetzt.

Set c = ChartSpace1.Constants
Set axisScale = ChartSpace1.Charts(0).Axes(c.chAxisPositionLeft).Scaling
axisScale.HasSplit = True
axisScale.SplitMinimum = 17000
axisScale.SplitMaximum = 45000


HasTickLabels-Eigenschaft

Der Wert ist True, wenn die angegebene Achse über eine Beschriftung für jeden Hauptstrich verfügt. Der Standardwert lautet True. Boolean mit Lese-/Schreibzugriff.


HasTickLabels-Eigenschaft: Beispiel

In diesem Beispiel werden die Teilstrichbeschriftungen auf der angegebenen Achse deaktiviert.

Set c = ChartSpace1.Constants
ChartSpace1.Charts(0).Axes(c.chAxisPositionLeft).HasTickLabels = False


HasTitle-Eigenschaft

Der Wert ist True, wenn das angegebene Diagramm oder die angegebene Achse über einen Titel verfügt. Der Standardwert lautet False. Boolean mit Lese-/Schreibzugriff.


HasTitle-Eigenschaft: Beispiel

In diesem Beispiel wird das Anzeigen des Titels für das angegebene Diagramm veranlasst, und die Titelschriftart wird festgelegt.

ChartSpace1.Charts(0).HasTitle = True
ChartSpace1.Charts(0).Title.Font.Name = "times new roman"


HasValue-Eigenschaft

Der Wert ist True, wenn jede Datenbeschriftung für die angegebene Reihe oder das angegebene Diagramm derzeit ihren Y-Achsenwert anzeigt. Der Standardwert lautet False. Boolean mit Lese-/Schreibzugriff.

Anmerkungen

Die Datenbeschriftungskomponenten werden stets in der nachfolgenden Reihenfolge angezeigt: [SeriesName] [CategoryName] [Value] [BubbleSize] [Percentage].

Das Setzen dieser Eigenschaft auf True in einem Punkt- oder Polardiagramm führt dazu, dass sowohl X-Achsenwerte als auch Y-Achsenwerte angezeigt werden.


HasValue-Eigenschaft: Beispiel

In diesem Beispiel werden die Datenbeschriftungen für die angegebenen Reihen so festgelegt, dass sie deren Y-Achsenwerte anzeigen.

Set dl = ChartSpace1.Charts(0).SeriesCollection(0).DataLabelsCollection(0)
dl.HasValue = True


Height-Eigenschaft

Gibt die Höhe des angegebenen Objekts in Punkt zurück oder legt diese fest. Long mit Lese-/Schreibzugriff für das PivotTable-Objekt; schreibgeschütztes Long für die PivotMember- und Range-Objekte.


HeightRatio-Eigenschaft

Gibt das Höhenverhältnis für das angegebene Diagramm im Verhältnis zu den übrigen Diagrammen im Diagrammarbeitsbereich an. Der Standardwert ist 100. Long mit Lese-/Schreibzugriff.

Anmerkungen

Durch diese Eigenschaft wird die Höhe des angegebenen Diagramms relativ zur Höhe der übrigen Diagramme im Diagrammarbeitsbereich festgelegt. Damit diese Eigenschaft sich auswirkt, muss der Diagrammarbeitsbereich mehr als ein Diagramm enthalten. Wird mehr als ein Diagramm angezeigt, werden die Diagramme in einem Gitter dargestellt (weitere Informationen finden Sie in den Hilfethemen zu den ChartLayout- und ChartWrapCount-Eigenschaften). Zu Anfang sind die HeightRatio und WidthRatio-Eigenschaften für sämtliche Diagramme im Gitter auf 100 gesetzt. Sämtliche Diagramme haben die gleiche Größe.

Um die Höhe aller Diagramme im Gitter zu ändern, passen Sie die Einstellungen der HeightRatio-Eigenschaft an. Wenn zum Beispiel jedes Diagramm in drei Zeilen angezeigt wird, gilt für sämtliche Diagramme eine anfängliche HeightRatio-Einstellung von 100. Wenn Sie möchten, dass Zeile 3 nur halb so hoch wie die verfügbare Höhe ist, setzen Sie ihre HeightRatio-Einstellung auf 200. Die verbliebene Hälfte der Diagrammhöhe wird auf die Zeilen 1 und 2 aufgeteilt. Weil die in der HeightRatio-Eigenschaft angegebene Höhe relativ ist, können Sie diese Eigenschaft für die drei Zeilen auf 1,1,2, 100,100,200 oder 20,20,40 setzen. Alle Einstellungen haben den gleichen Effekt.

Wenn der Diagrammarbeitsbereich Diagramme beinhaltet, die in mehr als einer Zeile angezeigt werden, wird die höchte HeightRatio-Einstellung in jeder Zeile dazu verwendet, die relative Höhe für die ganze Zeile festzulegen.

Diese Eigenschaft ist nützlich beim Erstellen von Preis- und Mengenkursdiagrammen, in denen das Mengendiagramm die halbe Größe des Preisdiagramms aufweist.


Hidden-Eigenschaft

Der Wert ist True, wenn der angegebene Bereich momentan ausgeblendet ist. Der Bereich muss eine vollständige Spalte oder Zeile umfassen. Boolean mit Lese-/Schreibzugriff.


Hidden-Eigenschaft: Beispiel

In diesem Beispiel wird Spalte 2 auf dem aktiven Tabellenblatt ausgeblendet.

Spreadsheet1.ActiveSheet.Columns(2).Hidden = True


HoleSize-Eigenschaft

Gibt die Innenringgröße des angegebenen Ringdiagramms zurück oder legt diese fest. Die Innenringgröße muss ein Wert von 0 bis 90 sein (der Standardwert lautet 50). Long mit Lese-/Schreibzugriff.

Anmerkungen

Durch Setzen dieser Eigenschaft auf 0 (Null) wird das Ringdiagramm zu einem Kreisdiagramm (die Type-Eigenschaft des WCChart-Objekts gibt chChartTypePieStacked zurück).


HoleSize-Eigenschaft: Beispiel

In diesem Beispiel wird die Innenringgröße des angegebenen Diagramms gesetzt. Beachten Sie, dass Charts(0) sich auf ein Ringdiagramm beziehen muss.

ChartSpace1.Charts(0).HoleSize = 25


HTMLContainer-Eigenschaft

Gibt das HTML-DIV zurück, das den angegebenen Abschnitt enthält. Schreibgeschützt.


HTMLData-Eigenschaft

Gibt Kalkulationstabellendaten in Form einer korrekt formatierten HTML-Zeichenkette zurück oder legt diese fest. String mit Lese-/Schreibzugriff.


HTMLURL-Eigenschaft

Gibt den URL (Internetadresse) der HTML-Datendatei mit der Kalkulationstabelle zurück oder legt diesen fest. String mit Lese-/Schreibzugriff.


Hyperlink-Eigenschaft

Gibt ein Hyperlink-Objekt zurück, das den Hyperlink für den angegebenen Bereich repräsentiert. Schreibgeschützt.


Hyperlink-Eigenschaft: Beispiel

In diesem Beispiel wird der Hyperlink in Zelle B15 des aktiven Tabellenblattes aufgelöst, das Zieldokument wird gedownloadet, und anschließend wird das Dokument angezeigt.

Spreadsheet1.ActiveSheet.Range("b15").Hyperlink.Follow


Include-Eigenschaft

Gibt die Fehlerindikatorenelemente zurück, die in das angegebene Diagramm aufgenommen werden, oder legt diese fest. Der Standardwert lautet chErrorBarIncludeBoth. ChartErrorBarIncludeEnum mit Lese-/Schreibzugriff.


Include-Eigenschaft: Beispiel

In diesem Beispiel werden dem angegebenen Diagramm Fehlerindikatoren hinzugefügt, und es wird festgelegt, dass die Fehlerindikatoren nur positive Werte anzeigen.

Srt c = ChartSpace1.Constants
Set eb = ChartSpace1.Charts(0).SeriesCollection(0).ErrorBarsCollection.Add
eb.Include = c.chErrorBarIncludePlusValues


Index-Eigenschaft

Gibt die Indexzahl des angegebenen Objekts aus der Auflistung oder von ähnlichen Objekten zurück. Schreibgeschütztes Long.

Sie können die Indexnummer eines Serienobjekts für ein WCSeries-Objekt festlegen. Die angegebene Reihe wird an die angegebene Stelle verschoben und die anderen Reihen werden entsprechend neu geordnet.


Index-Eigenschaft: Beispiel

Diese Ereignisprozedur wird immer dann ausgeführt, wenn der Benutzer auf einen Diagrammarbeitsbereich klickt. Wenn der Benutzer auf einen Punkt klickt, zeigt die Prozedur die Reihen und Punktindexwerte an. Beachten Sie, dass die Ereignisprozedur in diesem Beispiel so deklariert wurde, wie es für Visual Basic erforderlich ist. Weitere Informationen über das Verwenden von Ereignisprozeduren finden Sie im Abschnitt "Deklarieren und Verwenden von Ereignisprozeduren in VBScript".

Private Sub ChartSpace1_Click(ByVal ChartEventInfo As OWC.WCChartEventInfo)
    Set c = ChartSpace1.Constants
    If ChartSpace1.SelectionType = c.chSelectionPoint Then
        seriesNumber = ChartSpace1.Selection.Parent.Index
        pointNumber = ChartSpace1.Selection.Index
        MsgBox "series " & seriesNumber & " point " & pointNumber
    End If
End Sub

In diesem Beispiel wird die Reihe 1 an die vierte Indexstelle eines XY-Diagramms verschoben, in dem 6 Reihen enthalten sind. Während des Verschiebevorganges werden die Reihen 2 bis 4 als Reihen 1 bis 3 neu geordnet. Die Reihen 0 und 5 verbleiben an ihrer ursprünglichen Position.

ChartSpace1.Charts(0).SeriesCollection(1).Index = 4


Interior-Eigenschaft

Gibt ein Interior-Objekt zurück, welches das Innere des angegebenen Objekts repräsentiert. Schreibgeschützt.

Anmerkungen

Bei einer Diagrammreihe oder einem Diagrammpunkt kann die Interior-Eigenschaft dazu verwendet werden, die Füllfarbe für Spalten, Balken, Kreise, Bereiche und Markierungen zu setzen.


Interior-Eigenschaft: Beispiel

In diesem Beispiel wird die Innenfarbe für die angegebene Reihe gesetzt.

ChartSpace1.Charts(0).SeriesCollection(0).Interior.Color = "red"


IsDisplayingEquation-Eigenschaft

Der Wert ist True, wenn die Gleichung für die Trendlinie zur angegebenen Reihe im Diagramm angezeigt wird (in der gleichen Datenbeschriftung wie das Bestimmtheitsmaß). Der Standardwert lautet True. Boolean mit Lese-/Schreibzugriff.


IsDisplayingEquation-Eigenschaft: Beispiel

In diesem Beispiel wird einer angegebenen Reihe eine Trendlinie hinzugefügt. Angezeigt wird nur die Trendliniengleichung.

Set tl = ChartSpace1.Charts(0).SeriesCollection(0).Trendlines.Add
tl.IsDisplayingEquation = True
tl.IsDisplayingRSquared = False


IsDisplayingRSquared-Eigenschaft

Der Wert ist True, wenn das Bestimmtheitsmaß für die angegebene Reihe auf dem Diagramm angezeigt wird (in derselben Datenbeschriftung wie die Gleichung). Durch Setzen dieser Eigenschaft auf True werden die Datenbeschriftungen automatisch deaktiviert. Der Standardwert lautet True.Boolean mit Lese-/Schreibzugriff.


IsDisplayingRSquared-Eigenschaft: Beispiel

In diesem Beispiel wird der angegebenen Reihe eine Trendlinie hinzugefügt. Angezeigt wird nur die Trendliniengleichung.

Set tl = ChartSpace1.Charts(0).SeriesCollection(0).Trendlines.Add
tl.IsDisplayingEquation = True
tl.IsDisplayingRSquared = False


IsExpanded-Eigenschaft

Der Wert ist True, wenn der angegebene Abschnitt erweitert ist. Boolean Schreibgeschützt.


IsFiltered-Eigenschaft

Der Wert ist True, wenn der derzeitige Filter angewendet wird. Der Standardwert lautet True. Die Filtereinstellungen basieren auf den aktuellen Werten für die FilterMember-Eigenschaft des Filterachsen-Datensatzes und der FilterMembers-Eigenschaft auf der Zeilen-, Spalten- und Datenachse. Boolean mit Lese-/Schreibzugriff.


IsFilterOn-Eigenschaft

Der Wert ist True, wenn der Datenseitenfilter angewendet wird. Boolean mit Lese-/Schreibzugriff.


IsIncluded-Eigenschaft

Der Wert ist True, wenn das Feld in der angegebenen Feldgruppe enthalten und aktiv ist. Boolean mit Lese-/Schreibzugriff.

Anmerkungen

Inaktive Felder sind in der PivotTable-Liste nicht sichtbar. Eine Feldgruppe muss über mindestens ein Feld verfügen, für das die IsIncluded-Eigenschaft auf True gesetzt ist. Wenn Sie versuchen, diese Eigenschaft für das einzige Feld, bei dem sie auf True eingestellt ist, auf False zu setzen, führt dies zu einem Laufzeitfehler. Diese Eigenschaft wird ignoriert, wenn die Feldgruppe auf der Filterachse verwendet wird. Wenn der Benutzer das letzte Feld in der Benutzerschnittstelle ausblendet, wird die Feldgruppe von der Achse entfernt.


IsTotal-Eigenschaft

Der Wert ist True, wenn das angegebene Mitglied dazu verwendet wird, ein Teilergebnis anzuzeigen. Schreibgeschützter Boolean.


Italic-Eigenschaft

Der Wert lautet True, wenn der Schriftschnitt kursiv ist. Boolean mit Lese-/Schreibzugriff für das PivotFont-Objekt; Variant mit Lese-/Schreibzugriff für das OWCFont-Objekt (gibt Null zurück, wenn einige Abschnitte des Textes kursiv formatiert sind und andere nicht). Verwenden Sie die IsNull-Funktion, um festzustellen, ob der Rückgabewert Null ist.


Italic-Eigenschaft: Beispiel

In diesem Beispiel wird die Schriftart für den Inhalt von Spalte 2 auf kursiv gesetzt.

Spreadsheet1.Columns(2).Font.Italic = True


Item-Eigenschaft

Gibt ein einzelnes Objekt aus der angegebenen Auflistung zurück. Die Item-Eigenschaft ist eine Standardeigenschaft der meisten Auflistungen, deshalb ist es meistens nicht notwendig, diese Eigenschaft ausdrücklich zu verwenden. Weitere Informationen über das Zurückgeben eines einzelnen Mitglieds einer Auflistung finden Sie im Abschnitt "Zurückgeben eines Objekts aus einer Auflistung".

Syntax

Ausdruck.Item(Index)

Ausdruck Ein Ausdruck, der ein Objekt in der Gilt für-Liste zurückgibt.

Index Variant erforderlich. Der Name oder die Indexzahl des Objekts, das zurückgegeben wird.

Anmerkungen

Wenn sie auf ein Range-Objekt angewendet wird, kann die Item-Eigenschaft die Zeilen- und Spaltenindexzahlen als zwei Argumente angeben, statt die Zellenindexzahl als einziges Argument anzugeben. Wenn zwei Argumente verwendet werden, sollte das erste die Zeile angeben, welche die zurückgegebene Zelle enthält. Das zweite sollte die Spalte angeben, welche die zurückgegebene Zelle enthält.


JoinType-Eigenschaft

Gibt die Art zurück, auf die eine Abfrage formuliert wird, oder legt diese fest. dscJoinTypeEnum mit Lese-/Schreibzugriff.

Anmerkungen

Sie können diese Eigenschaft nur dann verwenden, wenn die Type-Eigenschaft des PageRelationship-Objekts auf dscLookup gesetzt ist.


KeyChar-Eigenschaft

Gibt das Tastaturzeichen der Taste zurück, die das Ereignis ausgelöst hat. Der Wert ist eine leere Zeichenkette (""), wenn es sich nicht um ein KeyDown-, KeyPress- oder KeyUp-Ereignis handelt. String schreibgeschützt.


KeyChar-Eigenschaft: Beispiel

Die Ereignisprozedur in diesem Beispiel ermöglicht es dem Benutzer, das angegebene Diagramm unter Verwendung der Zahlentasten zu drehen. Beachten Sie, dass Charts(0) sich entweder auf ein Kreis- oder ein Ringdiagramm beziehen muss. Bedenken Sie auch, dass diese Ereignisprozedur so deklariert wurde, wie es für Visual Basic erforderlich ist. Weitere Informationen über das Verwenden von Ereignisprozeduren finden Sie in Abschnitt "Deklarieren und Verwenden von Ereignisprozeduren in VBScript"

Private Sub ChartSpace1_KeyPress(ByVal ChartEventInfo As OWC.WCChartEventInfo)
    kc = Asc(ChartEventInfo.KeyChar)
    If kc > 47 And kc < 58 Then 'key was a number key
        ChartSpace1.Charts(0).FirstSliceAngle = (kc - 48) * 10
    End If
End Sub


KeyCode-Eigenschaft

Gibt den Tastaturcode der Taste zurück, die das Ereignis ausgelöst hat. Gilt nur für KeyDown- und KeyUp-Ereignisse. Schreibgeschütztes Long.


KeyCode-Eigenschaft: Beispiel

Die Ereignisprozedur in diesem Beispiel ermöglicht es dem Benutzer, das angegebene Diagramm unter Verwendung der NACH-RECHTS-TASTE und der NACH-LINKS-TASTE zu drehen. Beachten Sie, dass Charts(0) sich entweder auf ein Kreis- oder ein Ringdiagramm beziehen muss. Bedenken Sie auch, dass diese Ereignisprozedur so deklariert wurde, wie es für Visual Basic erforderlich ist. Weitere Informationen über das Verwenden von Ereignisprozeduren finden Sie in Abschnitt "Deklarieren und Verwenden von Ereignisprozeduren in VBScript"

Private Sub ChartSpace1_KeyDown(ByVal ChartEventInfo As OWC.WCChartEventInfo)
    Select Case ChartEventInfo.KeyCode
        Case 37 'left arrow
            i = -10
        Case 39 'right arrow
            i = 10
    End Select
    ChartSpace1.Charts(0).FirstSliceAngle = _
        ChartSpace1.Charts(0).FirstSliceAngle + i
End Sub


Label-Eigenschaft

Gibt ein PivotLabel-Objekt zurück, welches die Ansichten- oder die Achsenbeschriftung repräsentiert. Schreibgeschützt.


Left-Eigenschaft

PivotData-Objekt: Gibt das Mitglied direkt oberhalb der ganz links sichtbaren Spalte zurück oder legt dieses fest. PivotMember mit Lese-/Schreibzugriff.

Range-Objekt: Gibt den Abstand zwischen der linken Begrenzung der Kalkulationstabelle und der linken Begrenzung des angegebenen Bereichs zurück. Dieser Wert kann negativ sein, wenn der Bereich sich außerhalb des sichtbaren Bereichs befindet. Schreibgeschütztes Long.


Left-Eigenschaft: Beispiel

In diesem Beispiel wird ein linksgerichteter Bildlauf des Kalkulationstabellenfensters durchgeführt, um die Zelle F1 anzuzeigen, wenn diese Zelle sich momentan links des sichtbaren Bereichs befindet.

Set r = Spreadsheet1.Range("f1")
If r.Left < 0 Then Spreadsheet1.ActiveSheet.Scroll r


Legend-Eigenschaft

Gibt ein WCLegend-Objekt zurück, das die Legende für das angegebene Diagramm repräsentiert. Schreibgeschützt.


LegendEntries-Eigenschaft

Gibt eine WCLegendEntries-Auflistung für die angegebene Legende zurück. Schreibgeschützt.

Informationen über das Zurückgeben eines einzelnen Mitglieds einer Auflistung finden Sie in Abschnitt "Zurückgeben eines Objekts aus einer Auflistung".


LegendEntries-Eigenschaft: Beispiel

In diesem Beispiel wird der angegebene Legendeneintrag ausgeblendet.

ChartSpace1.Charts(0).Legend.LegendEntries(1).Visible = False


Length-Eigenschaft

Gibt die maximale Feld- oder Parameterlänge zurück oder legt diese fest. Long mit Lese-/Schreibzugriff.


Line-Eigenschaft

Gibt ein Border-Objekt zurück, das Sie verwenden können, um die Darstellung des angegebenen Diagrammelements zu verändern. Schreibgeschützt.

Anmerkungen

Sie können diese Eigenschaft verwenden, um Achsen, Trendlinien, Linien in Linien- oder Kursdiagrammen, Fehlerindikatoren und Gitternetzlinien zu formatieren.


LineStyle-Eigenschaft

Gibt die Formel für den Rahmenstil an oder legt diese fest. Dies kann eine der LineStyleEnum-Konstanten sein; gibt Null zurück, wenn die Rahmen nicht alle den gleichen Stil aufweisen. Verwenden Sie die IsNull-Funktion, um festzustellen, ob der Rückgabewert Null ist. Variant mit Lese-/Schreibzugriff.

Anmerkungen

Sie können diese Eigenschaft nicht für ein Border-Objekt festlegen, das ein Diagrammelement repräsentiert.


LineStyle-Eigenschaft: Beispiel

In diesem Beispiel wird jede Zelle des Bereichs A1:E5 von einem grünen Strichlinien-Punkt-Rahmen umgeben.

Spreadsheet1.Range("a1:e5").Borders.LineStyle = owcLineStyleDashDot
Spreadsheet1.Range("a1:e5").Borders.Color = "green"


ListBoundField-Eigenschaft

Gibt das Feld zurück, das mit der angegebenen Liste oder dem angegebenen Kombinationsfeld verbunden ist, oder legt es fest (im Unterschied zu dem Feld, das angezeigt wird). Dies gilt nur für Listen- und Kombinationsfelder. String mit Lese-/Schreibschutz.

Anmerkungen

Verwenden Sie die ListDisplayField-Eigenschaft, um das angezeigte Feld zurückzugeben oder festzulegen.

Diese Eigenschaft wird für die ListRowSource-Eigenschaft und die ListDisplayField-Eigenschaft verwendet, um zu steuern, wie Daten in einem Listen- oder Kombinationsfeld angezeigt werden. Stellen Sie sich beispielsweise ein Listenfeld vor, das Produktnamen aus einem Abschnitt mit den Namen Order Details anzeigt. Die Datensatzgruppe hinter dem Abschnitt Order Details enthält ein Feld mit dem Namen ProductID ein. Dabei handelt es sich um das Produkt zu einem einzelnen Order Details-Datensatz. Anstatt ProductID in einem Textfeld anzuzeigen, möchte der Seitenautor die Produktnamen in einem Dropdownlistenfeld anzeigen. Das Listenfeld kann mit einer Datensatzgruppendefinition mit dem Namen Products ausgefüllt werden, welche die ProdID und ProductName-Felder aus der Product-Tabelle enthält. Die Eigenschaften dieses Listenfeldelements werden so gesetzt, wie es in der nachfolgenden Tabelle erläutert ist.

Eigenschaft | Wert
ListRowSource | Products
ListBoundField | ProdID
ListDisplayField | ProductName
ControlSource | ProductID


ListDisplayField-Eigenschaft

Gibt das Feld zurück, das in der angegebenen Liste oder in dem angegebenen Kombinationsfeld angezeigt wird, oder legt es fest (im Unterschied zu dem Feld, das gebunden wird). Es kann nur ein Feld angezeigt werden. Diese Eigenschaft gilt nur für Listen- und Kombinationsfelder. String mit Lese-/Schreibschutz.

Anmerkungen

Verwenden Sie die ListBoundField-Eigenschaft, um das gebundene Feld zurückzugeben oder festzulegen.

Diese Eigenschaft wird für die ListRowSource-Eigenschaft und die ListBoundField-Eigenschaft verwendet, um zu steuern, wie Daten in einem Listen- oder Kombinationsfeld angezeigt werden. Stellen Sie sich beispielsweise ein Listenfeld vor, das Produktnamen aus einem Abschnitt mit den Namen Order Details anzeigt. Die Datensatzgruppe hinter dem Abschnitt Order Details enthält ein Feld mit dem Namen ProductID. Dabei handelt es sich um das Produkt zu einem einzelnen Order Details-Datensatz. Anstatt ProductID in einem Textfeld anzuzeigen, möchte der Seitenautor die Produktnamen in einem Dropdownlistenfeld anzeigen. Das Listenfeld kann mit einer Datensatzgruppendefinition mit dem Namen Products ausgefüllt werden, welche die ProdID und ProductName-Felder aus der Product-Tabelle enthält. Die Eigenschaften dieses Listenfeldelements werden so gesetzt, wie es in der nachfolgenden Tabelle erläutert ist.

Eigenschaft | Wert
ListRowSource | Products
ListBoundField | ProdID
ListDisplayField | ProductName
ControlSource | ProductID


ListRowSource-Eigenschaft

Gibt die Datenquellen für ein Listen- oder Kombinationsfeld an. Diese Eigenschaft gilt nur für Listen- und Kombinationsfelder. Sie muss gesetzt werden, bevor die ListBoundField oder ListDisplayField-Eigenschaft festgelegt wird. String mit Lese-/Schreibzugriff.

Anmerkungen

Diese Eigenschaft wird für die ListRowSource-Eigenschaft und die ListDisplayField-Eigenschaft verwendet, um zu steuern, wie Daten in einem Listen- oder Kombinationsfeld angezeigt werden. Stellen Sie sich beispielsweise ein Listenfeld vor, das Produktnamen aus einem Abschnitt mit den Namen Order Details anzeigt. Die Datensatzgruppe hinter dem Abschnitt Order Details enthält ein Feld mit dem Namen ProductID. Dabei handelt es sich um das Produkt zu einem einzelnen Order Details-Datensatz. Anstatt ProductID in einem Textfeld anzuzeigen, möchte der Seitenautor die Produktnamen in einem Dropdownlistenfeld anzeigen. Das Listenfeld kann mit einer Datensatzgruppendefinition mit dem Namen Products ausgefüllt werden, welche die ProdID und ProductName-Felder aus der Product-Tabelle enthält. Die Eigenschaften dieses Listenfeldelements würden so gesetzt, wie es in der nachfolgenden Tabelle erläutert wird.

Eigenschaft | Wert
ListRowSource | Products
ListBoundField | ProdID
ListDisplayField | ProductName
ControlSource | ProductID


Location-Eigenschaft

Gibt den Speicherort für die Auswertung des berechneten Feldes zurück oder legt diesen fest. dscLocationEnum mit Lese-/Schreibzugriff.

Anmerkungen

Diese Eigenschaft steuert, wo die berechneten Felder ausgewertet werden. Wenn diese Eigenschaft auf dscServer gesetzt ist, wird der Ausdruck in die SQL-Klausel aufgenommen, die an die Datenbank gesendet wird. Diese muss der SQL-Syntax für die Datenbank entsprechen. Wenn die Eigenschaft auf dscClient gesetzt ist, wird der Ausdruck auf dem Client-Computer unter Verwendung von Ausdrücken aus Visual Basic for Applications ausgewertet.


Locked-Eigenschaft

Der Wert ist True, wenn alle Zellen im angegebenen Bereich gesperrt sind, False, wenn keine der Zellen gesperrt sind, und Null, wenn einige Zellen gesperrt sind und andere nicht. Der Standardwert lautet True. Verwenden Sie die IsNull-Funktion, um festzustellen, ob der Rückgabewert Null ist. Variant mit Lese-/Schreibzugriff.


Locked-Eigenschaft: Beispiel

In diesem Beispiel werden nur die Zellen in Spalte 2 gesperrt.

Spreadsheet1.Cells.Locked = False
Spreadsheet1.Columns(2).Locked = True
Spreadsheet1.ActiveSheet.Protection.Enabled = True


LogBase-Eigenschaft

Legt die Logarithmusbasis fest, wenn Sie logarithmische Skalierungseinheiten verwenden. Wenn Sie versuchen, diesen Wert auf kleiner oder gleich 0 (Null) zu setzen, führt dies zu einem Fehler. Double mit Lese-/Schreibzugriff.


LogBase-Eigenschaft: Beispiel

In diesem Beispiel wird bewirkt, dass die angegebene Achse eine logarithmische Skalierungseinheit zur Basis 2 verwendet.

Set c = ChartSpace1.Constants
Set sc = ChartSpace1.Charts(0).Axes(c.chAxisPositionLeft).Scaling
sc.Type = c.chScaleTypeLogarithmic
sc.LogBase = 2


LookupRelationships-Eigenschaft

Gibt die LookupRelationships-Auflistung für die angegebene Seitenzeilenquelle zurück. Schreibgeschützt.

Informationen über das Zurückgeben eines einzelnen Mitglieds einer Auflistung finden Sie im Abschnitt "Zurückgeben eines Objekts aus einer Auflistung".

Anmerkungen

LookupRelationship-Objekte beziehen sich auf Zeilenquellen, die eine 1:n-Beziehung zu der angegebenen Seitenzeilenquelle aufweisen. Felder aus diesen Zeilenquellen können im gleichen Abschnitt oder der gleichen PivotTable-Liste wie Felder aus der angegebenen Zeilenquelle angezeigt werden.


LookupSchemaRelationships-Eigenschaft

Gibt die LookupSchemaRelationships-Auflistung für die angegebene Schemaseitenzeilenquelle zurück. Schreibgeschützt.

Informationen über das Zurückgeben eines einzelnen Mitglieds einer Auflistung finden Sie im Abschnitt "Zurückgeben eines Objekts aus einer Auflistung".


MajorGridlines-Eigenschaft

Gibt ein WCGridlines-Objekt zurück, das die Hauptgitternetzlinien für die angegebene Achse repräsentiert. Beachten Sie, dass Sie Gitternetzlinien auf jeder Achse verwenden können. Schreibgeschützt.


MajorGridlines-Eigenschaft: Beispiel

In diesem Beispiel werden Farbe und Linienstärke für die Hauptgitternetzlinien auf der angegebenen Achse festgelegt.

Set c = ChartSpace1.Constants
Set mg = ChartSpace1.Charts(0).Axes(c.chAxisPositionLeft).MajorGridlines
mg.Line.Color = "white"
mg.Line.Weight = 5


MajorTickMarks-Eigenschaft

Gibt den Hauptstrichtyp für die angegebene Achse zurück oder legt diese fest. ChartTickMarkEnum mit Lese-/Schreibzugriff.


MajorTickMarks-Eigenschaft: Beispiel

In diesem Beispiel werden die Hauptstriche auf der angegebenen Achse deaktiviert.

Set c = ChartSpace1.Constants
ChartSpace1.Charts(0).Axes(c.chAxisPositionLeft).MajorTickMarks = c.chTickMarkNone


MajorUnit-Eigenschaft

Gibt die Haupteinheit für die angegebene Achse an oder legt diese fest. Double mit Lese-/Schreibzugriff.


MajorUnit-Eigenschaft: Beispiel

In diesem Beispiel werden die Haupteinheiten für die angegebene Achse gesetzt.

Set c = ChartSpace1.Constants
ChartSpace1.Charts(0).Axes(c.chAxisPositionLeft).MajorUnit = 7


MajorVersion-Eigenschaft

Gibt die Hauptversion der Microsoft Office Web Components-Objektbibliothek zurück. Schreibgeschütztes Long.


ManySide-Eigenschaft

PageRelatedField-Objekt: Gibt ein PageField-Objekt zurück, welches das Feld repräsentiert, das der Seitenzeilenquelle auf der "n"-Seite der angegebenen 1:n-Beziehung entspricht. Schreibgeschützt.

PageRelationship-Objekt: Gibt ein PageRowsource-Objekt zurück, welches die Seitenzeilenquelle auf der "n"-Seite der angegebenen 1:n-Beziehung repräsentiert. Schreibgeschützt.

SchemaRelatedField-Objekt: Gibt den Namen des Schemafeldes in der Schemazeilenquelle auf der "n"-Seite der angegebenen 1:n-Beziehung zurück. String schreibgeschützt.

SchemaRelationship-Objekt: Gibt den Namen der Schemazeilenquelle auf der "n"-Seite der angegebenen 1:n-Beziehung zurück. String schreibgeschützt.


Marker-Eigenschaft

Gibt ein WCMarker-Objekt zurück, das die Markierungen für jeden Punkt in der angegebenen Reihe repräsentiert. Schreibgeschützt.


Marker-Eigenschaft: Beispiel

In diesem Beispiel wird der Diagrammtyp festgelegt und anschließend Markierungstyp und Innenfarbe für die angegebenen Reihen festgelegt.

Set c = ChartSpace1.Constants
ChartSpace1.Charts(0).Type = c.chChartTypeLineMarkers
ChartSpace1.Charts(0).SeriesCollection(0).Marker.Style = c.chMarkerStyleSquare
ChartSpace1.Charts(0).SeriesCollection(0).Interior.Color = "blue"


MaxHeight-Eigenschaft

Gibt die maximale Höhe zurück, welche die angegebene PivotTable-Liste oder Kalkulationstabelle erreichen kann, wenn der Wert der AutoFit-Eigenschaft True lautet. Wenn die verfügbare Datenmenge nicht innerhalb der maximalen Höhe angezeigt werden kann, wird eine vertikale Bildlaufleiste eingeblendet. Bei PivotTable-Listen liegt der Wert in Pixel vor. Bei Kalkulationstabellen wird der Wert in Pixel oder als ein Prozentsatz von der Höhe des Containerfensters (ausgedrückt als Zeichenkette wie "50%") angegeben. Der Standardwert beträgt 32.000 Pixel für PivotTable-Listen und 80% für Kalkulationstabellen. Long mit Lese-/Schreibzugriff für PivotTable; Variant mit Lese-/Schreibzugriff für Spreadsheet.


Maximum-Eigenschaft

Gibt den Maximalwert für die angegebene Skalierung zurück oder legt ihn fest. Double mit Lese-/Schreibzugriff.


Maximum-Eigenschaft: Beispiel

In diesem Beispiel werden die maximalen und minimalen Werte für die angegebene Achsenskalierung angegeben.

Set c = ChartSpace1.Constants
Set axisScale = ChartSpace1.Charts(0).Axes(c.chAxisPositionLeft).Scaling
axisScale.Maximum = 70
axisScale.Minimum = -10


MaxRecords-Eigenschaft

Gibt die maximale Anzahl der Datensätze an, die die Verbindung auf den lokalen Computer transportiert, oder legt diese fest. Long mit Lese-/Schreibzugriff.


MaxWidth-Eigenschaft

Gibt die maximale Breite an, welche die angegebene PivotTable-Liste oder Kalkulationstabelle erreichen kann, wenn der Wert der AutoFit-Eigenschaft True lautet. Wenn die verfügbare Datenmenge nicht innerhalb der maximalen Breite angezeigt werden kann, wird eine horizontale Bildlaufleiste eingeblendet. Bei PivotTable-Listen liegt der Wert in Pixel vor. Bei Kalkulationstabellen wird der Wert in Pixel oder als ein Prozentsatz von der Breite des Containerfensters (ausgedrückt als Zeichenkette wie "50%") angegeben. Der Standardwert beträgt 32.000 Pixel für PivotTable-Listen und 80% für Kalkulationstabellen. Long mit Lese-/Schreibzugriff für PivotTable; Variant mit Lese-/Schreibzugriff für Spreadsheet.


MemberBackColor-Eigenschaft

Gibt die Hintergrundfarbe für sämtliche Mitglieder in der angegebenen Ansicht zurück oder legt sie fest. Variant mit Lese-/Schreibzugriff.

Anmerkungen

Wenn Sie diese Eigensschaft setzen, können Sie entweder einen Long-Farbwert, der einen RGB-Wert repräsentiert, oder einen String-Wert verwenden, der einen gültigen HTML-Farbwert benennt.Um beispielsweise die Objektfarbe auf Rot zu setzen, könnten Sie den hexadezimalen Wert &HFF, den Dezimalwert 255 oder die Zeichenkette red verwenden. In Microsoft Visual Basic können Sie die RGB-Funktion einsetzen, um einen RGB-Farbwert zu erzeugen (Rot entspricht RGB(255,0,0)).

Diese Eigenschaft gibt die Farbe stets als Long-Wert zurück, der einen RGB-Farbwert darstellt.


MemberExpand-Eigenschaft

Gibt die Art zurück, auf die Mitglieder erweitert werden, wenn ihre Daten aktualisiert werden, oder legt die Art fest. PivotTableMemberExpandEnum mit Lese-/Schreibzugriff.

Anmerkungen

Wird diese Eigenschaft auf plMemberExpandAutomatic gesetzt, wird der standardmäßig erweiterte Zustand der Mitglieder über den Anbietertyp ermittelt. Wenn der Anbieter relational oder unbekannt ist, werden die Mitglieder standardmäßig erweitert. Wenn der Anbieter multidimensional ist, werden die Mitglieder standardmäßig reduziert.

Durch Setzen dieser Eigenschaft wird die Expanded-Eigenschaft unmittelbar für sämtliche Felder festgelegt.

Das Setzen der Expanded-Eigenschaft für ein Feld oder ein Mitglied wirkt sich nicht auf die MemberExpand-Eigenschaft aus.


MemberFont-Eigenschaft

Gibt ein PivotFont-Objekt zurück, das die Schrift repräsentiert, die für sämtliche Mitglieder der angegebenen Ansicht verwendet wird. Der Standardwert lautet Arial 10 Punkt Normal. Schreibgeschützt.


MemberForeColor-Eigenschaft

Gibt die Vordergrundfarbe für sämtliche Mitglieder in der angegebenen Ansicht zurück oder legt sie fest. Variant mit Lese-/Schreibzugriff.

Anmerkungen

Wenn Sie diese Eigenschaft setzen, können Sie entweder einen Long-Wert, der einen RGB-Farbwert repräsentiert, oder einen String-Wert verwenden, der einen gültigen HTML-Farbwert benennt. Um beispielsweise die Objektfarbe auf Rot zu setzen, könnten Sie den hexadezimalen Wert &HFF, den Dezimalwert 255 oder die Zeichenkette red verwenden. In Microsoft Visual Basic können Sie die RGB-Funktion einsetzen, um einen RGB-Farbwert zu erzeugen (Rot entspricht RGB(255,0,0)).

Diese Eigenschaft gibt die Farbe stets als Long-Wert zurück, der einen RGB-Farbwert darstellt.


MemberHAlignment-Eigenschaft

Gibt die horizontale Ausrichtung für Mitgliedertitel und Feldbeschriftungen an, die im Mitgliederbereich angezeigt werden, oder legt die Ausrichtung fest. PivotHAlignmentEnum mit Lese-/Schreibzugriff.


MemberHeight-Eigenschaft

Gibt die Höhe (in Pixel) von Mitgliedern an, die auf der Spaltenachse angezeigt werden. Schreibgeschütztes Long.


Members-Eigenschaft

Gibt eine PivotMembers-Auflistung zurück, die sämtliche Mitglieder der angegebenen Feldgruppe enthält. Schreibgeschützt.

Informationen über das Zurückgeben eines einzelnen Mitglieds einer Auflistung finden Sie im Abschnitt "Zurückgeben eines Objekts aus einer Auflistung".

Anmerkungen

Die Auflistung der Mitglieder ist vollständig, ganz unabhängig von den Filtern, die aktiv sind. Um festzustellen, ob ein einzelnes Mitglied gefiltert wird, prüfen Sie nach, ob es in der Auflistung enthalten ist, die von der RowMembers oder ColumnMembers-Eigenschaft zurückgegeben wird.


MergeArea-Eigenschaft

Gibt ein Range-Objekt zurück, das einen beliebigen Teil des angegebenen Bereichs repräsentiert. Der angegebene Bereich kann mehr als eine Zelle enthalten. Wenn der Bereich keine verbundenen Zellen enthält, wird er unverändert zurückgegeben. Schreibgeschützt.


MergeArea-Eigenschaft: Beispiel

In diesem Beispiel wird eine verbundene Zelle aus dem Bereich B2:C5 erstellt. Die verbundene Zelle wird mit einer breiten, roten Rahmenlinie umgeben.

Set c = Spreadsheet1.Constants
Spreadsheet1.Range("b2:c5").Merge
Spreadsheet1.Range("b2").MergeArea.Borders.Color = "red"
Spreadsheet1.Range("b2").MergeArea.Borders.Weight = c.owcLineWeightThick


Minimum-Eigenschaft

Gibt den Minimalwert für die angegebene Skalierung zurück oder legt ihn fest. Double mit Lese-/Schreibzugriff.


Minimum-Eigenschaft: Beispiel

In diesem Beispiel werden die maximalen und minimalen Werte für die angegebene Achsenskalierung angegeben.

Set c = ChartSpace1.Constants
Set axisScale = ChartSpace1.Charts(0).Axes(c.chAxisPositionLeft).Scaling
axisScale.Maximum = 70
axisScale.Minimum = -10


MinorGridlines-Eigenschaft

Gibt ein WCGridlines-Objekt zurück, das die Hilfsgitternetzlinien für die angegebene Achse repräsentiert. Beachten Sie, dass Sie Gitternetzlinien auf jeder Achse verwenden können. Schreibgeschützt.


MinorGridlines-Eigenschaft: Beispiel

In diesem Beispiel werden Hilfsgitternetzlinien und Hilfsstriche für die angegebene Achse aktiviert sowie die Gitternetzlinienfarbe und das Teilstrichformat festgelegt.

Set c = ChartSpace1.Constants
Set axs = ChartSpace1.Charts(0).Axes(c.chAxisPositionLeft)
axs.HasMinorGridlines = True
axs.MinorGridlines.Line.Color = "green"
axs.MinorTickMarks = c.chTickMarkOutside


MinorTickMarks-Eigenschaft

Gibt den Hilfsstrichtyp für die angegebene Achse zurück oder legt diese fest. ChartTickMarkEnum mit Lese-/Schreibzugriff.


MinorTickMarks-Eigenschaft: Beispiel

In diesem Beispiel werden Hilfsgitternetzlinien und Hilfsstriche für die angegebene Achse aktiviert sowie die Gitternetzlinienfarbe und das Teilstrichformat festgelegt.

Set c = ChartSpace1.Constants
Set axs = ChartSpace1.Charts(0).Axes(c.chAxisPositionLeft)
axs.HasMinorGridlines = True
axs.MinorGridlines.Line.Color = "green"
axs.MinorTickMarks = c.chTickMarkOutside


MinorUnit-Eigenschaft

Gibt die Hilfseinheit für die angegebene Achse an oder legt diese fest. Double mit Lese-/Schreibzugriff.

Anmerkungen

Das Festlegen dieser Eigenschaft hat zur Folge, dass die HasAutoMinorUnit-Eigenschaft auf False gesetzt wird.


MinorUnit-Eigenschaft: Beispiel

In diesem Beispiel werden die Hilfseinheiten für die angegebene Achse gesetzt.

Set c = ChartSpace1.Constants
ChartSpace1.Charts(0).Axes(c.chAxisPositionLeft).MinorUnit = 2.5


MinorVersion-Eigenschaft

Gibt die Hilfsversion der Microsoft Office Web Components-Objektbibliothek zurück. Schreibgeschütztes Long.


MoveAfterReturn-Eigenschaft

Der Wert ist True, wenn beim Drücken der EINGABETASTE der Fokus verschoben wird. Der Standardwert lautet True. Boolean mit Lese-/Schreibzugriff.


MoveAfterReturnDirection-Eigenschaft

Gibt die Richtung, in die der Fokus verschoben wird, zurück oder legt sie fest, wenn der Benutzer die EINGABETASTE drückt. SheetDirectionEnum mit Lese-/Schreibzugriff.


MoveAfterReturnDirection-Eigenschaft: Beispiel

In diesem Beispiel wird die Zelle rechts neben der aktiven Zelle ausgewählt, nachdem der Benutzer die EINGABETASTE gedrückt hat.

Set c = Spreadsheet1.Constants
Spreadsheet1.MoveAfterReturn = True
Spreadsheet1.MoveAfterReturnDirection = c.ssToRight


Name-Eigenschaft

Gibt den Namen des angegebenen Objekts zurück oder legt ihn fest. Variant mit Lese-/Schreibzugriff beim OWCFont-Objekt; String mit Lese-/Schreibzugriff bei den Hyperlink, PivotFont, WCAxis, WCChart- und WCTrendline-Objekten; String schreibgeschützt für alle anderen Objekte, auf die diese Eigenschaft zutrifft.


Name-Eigenschaft: Beispiel

In diesem Beispiel wird der Name des angegebenen Diagramms gesetzt.

ChartSpace1.Charts(0).Name = "Line Chart"

Nachdem der Diagrammname festgelegt worden ist, können Sie über den Namen auf das Diagramm Bezug nehmen, wie es im nachfolgenden Beispiel gezeigt wird.

ChartSpace1.Charts("Line Chart").HasLegend = True


NextSection-Eigenschaft

Gibt ein Section-Objekt zurück, das den nächsten physischen Abschnitt auf der angegebenen Seite repräsentiert, wobei gleichgeordnete und übergeordnete Abschnitte unberücksichtigt bleiben. Diese Eigenschaft schlägt im letzten Abschnitt auf der Seite fehl. Schreibgeschützt.


NextSibling-Eigenschaft

Gibt ein Section-Objekt zurück, das den nächsten gleichgeordneten Abschnitt auf der aktuellen Seite repräsentiert. Dadurch kann veranlasst werden, dass die nächste Seite mit Datensätzen automatisch erstellt wird. Diese Eigenschaft überschreitet keine übergeordneten Abschnitte und schlägt für den letzten gleichgeordneten Abschnitt der aktuellen Datenseite fehl. Schreibgeschützt.


NumberFormat-Eigenschaft

Gibt das Zahlenformat für das angegebene Objekt an oder legt das Zahlenformat fest. Variant mit Lese-/Schreibzugriff für das Range-Objekt; String mit Lese-/Schreibzugriff für die PivotField, PivotTotal, WCAxis und WCDataLabels-Objekte.


NumberFormat-Eigenschaft: Beispiel

Im nachfolgenden Beispiel wird das Zahlenformat für die Bereiche A1:E10 und F1:F10 auf dem aktiven Tabellenblatt festgelegt.

Spreadsheet1.ActiveSheet.Range("a1:e10").NumberFormat = "0.###"
Spreadsheet1.ActiveSheet.Range("f1:f10").NumberFormat = "Currency"


NumericScale-Eigenschaft

Gibt die maximale Anzahl der Stellen an, die sich bei numerischen Typen rechts vom Dezimalkomma befinden können. Schreibgeschütztes Long.


OneSide-Eigenschaft

PageRelatedField-Objekt: Gibt ein PageField-Objekt zurück, welches das Feld repräsentiert, das der Seitenzeilenquelle auf der "1"-Seite der angegebenen 1:n-Beziehung entspricht. Schreibgeschützt.

PageRelationship-Objekt: Gibt ein PageRowsource-Objekt zurück, welches die Seitenzeilenquelle auf der "1"-Seite der angegebenen 1:n-Beziehung repräsentiert. Schreibgeschützt.

SchemaRelatedField-Objekt: Gibt den Namen des Schemafeldes in der Schemazeilenquelle auf der "1"-Seite der angegebenen 1:n-Beziehung zurück. String schreibgeschützt.

SchemaRelationship-Objekt: Gibt den Namen der Schemazeilenquelle auf der "1"-Seite der angegebenen 1:n-Beziehung zurück. String schreibgeschützt.


Order-Eigenschaft

Gibt die Polynomordnung für die angegebene Trendlinie zurück oder legt diese fest (ein ganzzahliger Wert größer 1). Wenn Sie diese Eigenschaft für eine lineare Trendlinie festlegen, wird diese zu einer Polynomtrendlinie. Long mit Lese-/Schreibzugriff.


Order-Eigenschaft: Beispiel

In diesem Beispiel wird die Ordnung für die angegebene Trendlinie festgelegt.

ChartSpace1.Charts(0).SeriesCollection(0).Trendlines(0).Order = 2


Orientation-Eigenschaft

PivotFieldSet-Objekt: Gibt die Feldgruppenorientierung zurück. Eine Feldgruppe kann sich gleichzeitig sowohl auf der Summenachse als auch auf der Spalten-, Zeilen- oder Filterachse befinden. Schreibgeschütztes PivotFieldSetOrientationEnum.

WCScaling-Objekt: Gibt die Skalierungsorientierung zurück oder legt diese fest. Durch Verändern dieser Eigenschaft wird das Diagramm gespiegelt. ChartScaleOrientationEnum mit Lese-/Schreibzugriff.


Orientation-Eigenschaft: Beispiel

In diesem Beispiel wird die Skalierungsorientierung für die angegebene Achse festgelegt.

Set c = ChartSpace1.Constants
ChartSpace1.Charts(0).Axes(1).Scaling.Orientation = c.chScaleOrientationMaxMin


Overlap-Eigenschaft

Gibt den Betrag der Überlappung zwischen Markierungen innerhalb einer einzigen Rubrik zurück oder legt ihn fest. Positive Werte führen dazu, dass die Markierungen sich überlappen. Negative Werte bewirken, dass die Markierungen voneinander getrennt werden. Der Standardwert lautet 0 (Null), und der gültige Bereich reicht von -100 bis 100. Long mit Lese-/Schreibzugriff.


Overlap-Eigenschaft: Beispiel

In diesem Beispiel wird der Überlappungswert für das angegebene Diagramm festgelegt.

ChartSpace1.Charts(0).Overlap = 25


PageFields-Eigenschaft

Gibt die PageFields-Auflistung für die angegegebene Datensatzgruppendefinition zurück. Schreibgeschützt.

Informationen über das Zurückgeben eines einzelnen Mitglieds einer Auflistung finden Sie im Abschnitt "Zurückgeben eines Objekts aus einer Auflistung".


PageRelatedFields-Eigenschaft

Gibt die PageRelatedFields-Auflistung für die angegebene Seitenbeziehung zurück. Schreibgeschützt.

Informationen über das Zurückgeben eines einzelnen Mitglieds einer Auflistung finden Sie im Abschnitt "Zurückgeben eines Objekts aus einer Auflistung".


PageRowsource-Eigenschaft

Gibt das PageRowsource-Objekt für das angegebene Seitenfeld zurück. Schreibgeschützt.


PageRowsources-Eigenschaft

Gibt die PageRowsource-Auflistung für die angegebene Datensatzgruppendefinition zurück.


Panes-Eigenschaft

Gibt die Panes-Auflistung für das angegebene Tabellenblatt zurück. Schreibgeschützt.

Informationen über das Zurückgeben eines einzelnen Mitglieds einer Auflistung finden Sie im Abschnitt "Zurückgeben eines Objekts aus einer Auflistung".


Panes-Eigenschaft: Beispiel

In diesem Beispiel wird eine Variable für den sichtbaren Bereich des angegebenen Fensters gesetzt.

Set vr = Spreadsheet1.ActiveSheet.Panes(1).VisibleRange


ParameterValues-Eigenschaft

Gibt die ParameterValues-Auflistung für die angegebene Datensatzgruppendefinition zurück. Schreibgeschützt.

Informationen über das Zurückgeben eines einzelnen Mitglieds einer Auflistung finden Sie im Abschnitt "Zurückgeben eines Objekts aus einer Auflistung".


Parent-Eigenschaft

Gibt das übergeordnete Objekt des angegebenen Objekts zurück. Schreibgeschützt.


ParentMember-Eigenschaft

Gibt ein PivotMember-Objekt zurück, welches das übergeordnete Mitglied des angegebenen Mitglieds darstellt.


ParentRecordsetDef-Eigenschaft

Gibt ein RecordsetDef-Objekt zurück, welches das übergeordnete Objekt der angegebenen Datensatzgruppendefinition darstellt. Schreibgeschützt.


ParentSection-Eigenschaft

Gibt ein Section-Objekt zurück, das den übergeordneten Abschnitt des angegebenen Abschnitts darstellt. Schreibgeschützt.


PlotArea-Eigenschaft

Gibt ein WCPlotArea-Objekt zurück, das die Zeichnungsfläche im angegebenen Diagramm repräsentiert. Beachten Sie, dass Kreis-, Ring-, Netz- und Polardiagramme keine Zeichnungsflächen besitzen. Schreibgeschützt.


PlotArea-Eigenschaft: Beispiel

In diesem Beispiel wird die Innenfarbe für die Zeichnungsfläche des angegebenen Diagramms festgelegt.

ChartSpace1.Charts(0).PlotArea.Interior.Color = &HD0D0D0


Points-Eigenschaft

Gibt die WCPoints-Auflistung für die angegebene Reihe zurück.

Informationen über das Zurückgeben eines einzelnen Mitgliedes einer Auflistung erhalten Sie unter Zurückgeben eines Objektes aus einer Auflistung..


Points-Eigenschaft: Beispiel

In diesem Beispiel wird die Innenfarbe für Punkt 2 der angegebenen Reihe festgelegt.

ChartSpace1.Charts(0).SeriesCollection(0).Points(2).Interior.Color = "green"


Position-Eigenschaft

Gibt die Position des Objekts zurück oder legt diese fest. ChartAxisPositionEnum mit Lese-/Schreibzugriff für das WCAxis-Objekt, ChartDataLabelPositionEnum mit Lese-/Schreibzugriff für das WCDataLabels-Objekt, ChartLegendPositionEnum mit Lese-/Schreibzugriff für das WCLegend-Objekt und ChartTitlePositionEnum mit Lese-/Schreibzugriff für das WCTitle-Objekt.


Position-Eigenschaft: Beispiel

In diesem Beispiel wird die Legende für das angegebene Diagramm links neben der Zeichnungsfläche eingefügt.

Set c = ChartSpace1.Constants
ChartSpace1.Charts("Line Chart").HasLegend = True
ChartSpace1.Charts(0).Legend.Position = c.chLegendPositionLeft


Precision-Eigenschaft

Gibt die maximale Anzahl von Stellen zurück, die Sie für numerische Typen verwenden können. Schreibgeschütztes Long.


PreviousSection-Eigenschaft

Gibt ein Section-Objekt zurück, das den vorherigen physischen Abschnitt auf der angegebenen Seite repräsentiert, wobei gleichgeordnete und übergeordnete Abschnitte unberücksichtigt bleiben. Diese Eigenschaft schlägt im ersten Abschnitt auf der Seite fehl. Schreibgeschützt.


PreviousSibling-Eigenschaft

Gibt ein Section-Objekt zurück, das den vorherigen gleichgeordneten Abschnitt auf der momentanten Datenseite repräsentiert. Diese Eigenschaft schlägt für den ersten gleichgeordneten Abschnitt auf der Seite fehl. Schreibgeschützt.


PrimaryPageRowsource-Eigenschaft

Gibt ein PageRowsource-Objekt zurück, das die primäre Seitenzeilenquelle für die angegebene Datensatzgruppendefinition repräsentiert. Beim Erstellen einer Datensatzgruppendefinition wird die Zeilenquelle, die in der Add oder AddNew-Methode genannt wird, zur primären Seitenzeilenquelle. Schreibgeschützt.


Protection-Eigenschaft

Gibt ein Protection-Objekt zurück, das die Schutzeigenschaften für das angegebene Tabellenblatt enthält. Die Schutzeigenschaften werden ignoriert, wenn die Enabled-Eigenschaft auf False gesetzt ist. Schreibgeschützt.


Protection-Eigenschaft: Beispiel

In diesem Beispiel werden die Zellen in Spalte 2 gesperrt.

Spreadsheet1.Columns(2).Locked = True
Spreadsheet1.ActiveSheet.Protection.Enabled = True


ProviderType-Eigenschaft

Gibt den Anbietertyp für das Datenquellensteuerelement oder die PivotTable-Liste zurück. ProviderType ist schreibgeschützt.


Range-Eigenschaft

SpreadsheetEventInfo-Objekt: Gibt ein Range-Objekt zurück, das den Bereich repräsentiert, in dem das angegebene Ereignis eingetreten ist. Weitere Informationen finden Sie in den einzelnen Ereignisthemen. Diese Eigenschaft besitzt keine Argumente, wenn sie mit dem SpreadsheetEventInfo-Objekt verwendet wird. Schreibgeschützt.

PivotData-Objekt (Syntax 1): Gibt ein PivotRange-Objekt zurück, das eine Zelle oder einen Zellenbereich repräsentiert. Schreibgeschützt.

Range, Spreadsheet oder Worksheet-Objekt (Syntax 2): Gibt ein Range-Objekt zurück, das eine Zelle oder einen rechteckigen Bereich von Zellen repräsentiert. Es ist nicht möglich, einen nicht rechteckigen Bereich oder einen Bereich zu erstellen, der aus unzusammenhängenden Bereichen besteht. Schreibgeschützt.

Syntax 1 (PivotData-Objekt)

Ausdruck.Range(TopLeft, BottomRight)

Ausdruck Ein Ausdruck, der ein PivotData-Objekt zurückgibt.

TopLeft Erforderliches PivotCell-Objekt. Gibt die linke obere Zelle im angegebenen Bereich an.

BottomRight Erforderliches PivotCell-Objekt. Gibt die rechte untere Ecke im angegebenen Bereich an.

Syntax 2 (Range, Spreadsheet oder Worksheet-Objekt)

Ausdruck.Range(Cell1, Cell2)

Ausdruck Ein Ausdruck, der ein Range, Spreadsheet oder Worksheet-Objekt zurückgibt.

Cell1 Variant erforderlich. Gibt den vollständigen Bereich in Gestalt eines A1-Bezugs (zum Beispiel A1:C3) an. Der Bezug kann den Bereichsoperator (einen Doppelpunkt), den Schnittmengenoperator (ein Leerzeichen) oder den Vereinigungsoperatur (ein Komma) beinhalten. Außerdem kann er Dollarzeichen enthalten. Sie werden jedoch ignoriert. Der Bezug kann die Zelle in der oberen linken Ecke des Bereichs auch als Range-Objekt angeben, das eine einzelne Zelle, eine ganze Spalte oder eine ganze Zeile enthält. Er kann auch eine Zeichenkette angeben, die eine einzelne Zelle benennt. Wenn Cell1 die linke obere Zelle eines Bereichs angibt, ist Cell2 erforderlich.

Cell2 Variant optional. (Ist erforderlich, wenn Cell1 die linke obere Zelle im angegebenen Bereich angibt.) Legt die Zelle in der unteren rechten Ecke des Bereichs fest. Dies kann ein Range-Objekt sein, das eine einzelne Zelle, eine ganze Spalte oder eine ganze Zeile enthält. Es kann sich auch eine Zeichenkette handeln, die eine einzelne Zelle benennt.

Anmerkungen

Wenn diese Eigenschaft auf ein Range-Objekt angewendet wird, geben die Argumente die Zellen relativ zu dem Bereich an. In dem nachfolgenden Beispiel wird eine Variable auf ein Range-Objekt gesetzt, das die Zelle B5 repräsentiert.

Set tempRange = Spreadsheet1.Range("b5:b10").range("a1")


Range-Eigenschaft: Beispiel

In diesem Beispiel wird die Zeilenhöhe für die Zeilen 1 bis 10 auf 15 Punkt festgelegt.

Spreadsheet1.Range("a1:a10").RowHeight = 15

In diesem Beispiel wird innerhalb des Bereichs CurrentRegion der Zelle A1 eine Variable auf einen Bereich gesetzt, der in den Spalten 3 und 4 von der zweiten bis zur letzten Zeile reicht.

Set curRegion = Spreadsheet1.Range("a1").CurrentRegion
Set tempRange = curRegion.Range(curRegion.Cells(2, 3), _
    curRegion.Cells(curRegion.Rows.Count, 4))


RecordNavigationSection-Eigenschaft

Der Wert ist True, wenn zu jedem Bindungsabschnittt ein Navigationsabschnitt existiert. Der Standardwert lautet True. Boolean mit Lese-/Schreibzugriff.


Recordset-Eigenschaft

PivotCell-Objekt: Gibt ein an ADO-Recordset-Objekt zurück, das die Detaildatensätze für die Zelle enthält, falls diese verfügbar sind. Schreibgeschützt.

DataPage-Objekt: Gibt ein ADODB-Recordset-Objekt für die angegebene Datenzugriffsseite zurück. Schreibgeschützt.


RecordsetDef-Eigenschaft

Gibt ein RecordsetDef-Objekt für das angegebene Seitenfeld oder die angegebene Seitenzeilenquelle zurück. Schreibgeschützt.


RecordsetDefs-Eigenschaft

Gibt die RecordsetDefs-Auflistung für das Datenquellensteuerelement zurück. Schreibgeschützt.

Informationen über das Zurückgeben eines einzelnen Mitglieds einer Auflistung finden Sie im Abschnitt "Zurückgeben eines Objekts aus einer Auflistung".


RecordsetLabel-Eigenschaft

Gibt eine Datensatzgruppenbeschriftung für das Datensatznavigationssteuerelement zurück oder legt diese fest. String mit Lese-/Schreibzugriff.


RecordsetType-Eigenschaft

Gibt den Datensatzgruppentyp für das angegebene Datenquellensteuerelement zurück. dscRecordsetTypeEnum ist schreibgeschützt.


RecordSource-Eigenschaft

Gibt die Datensatzquelle (Name der Datensatzgruppendefinition oder Gruppierungsdefinition) für den Abschnitt zurück oder legt diese fest. Gilt nur für DIV-Abschnitte. String mit Lese-/Schreibzugriff.


ResyncCommand-Eigenschaft

Gibt einen SQL-Befehl an, der Schlüsselfeldwerte aus der Unique-Tabelle der angegebenen Datensatzgruppe als Parameter verwendet, so dass der Befehl genau einen Datensatz zurückgibt. Der Resync-Befehl wird ausgeführt, um eine Zeile nach dem Durchführen einer Aktualisierung oder einer Einfügung zu reparieren. String mit Lese-/Schreibzugriff.

Sie müssen diese Eigenschaft bei jedem Formular festlegen, das auf einer gespeicherten Prozedur basiert, die eine Verknüpfung oder eine Ausdrucksspalte enthält. In allen anderen Fällen kann Microsoft Access Tabellen automatisch reparieren. Wenn Sie diese Eigenschaft nicht festlegen, sehen die Benutzer nach einer Aktualisierung oder Einfügung keine reparierten Feldwerte. Die Aktualisierung oder Einfügung wird aber dennoch korrekt ausgeführt.


ReturnValue-Eigenschaft

Gibt den Rückgabewert für das angegebene Ereignis zurück oder legt ihn fest. Sie können die Standardaktion bei einigen Ereignissen abbrechen, indem Sie diese Eigenschaft auf False festlegen. Boolean mit Lese-/Schreibzugriff.


ReturnValue-Eigenschaft: Beispiel

In diesem Beispiel wird ein Meldungsfeld angezeigt, wenn der Benutzer versucht, die angegebene Kalkulationstabelle zu exportieren. Im Anschluss daran wird der Befehl abgebrochen. Beachten Sie, dass die Ereignisprozedur in diesem Beispiel so deklariert wurde, wie es für Visual Basic erforderlich ist. Weitere Informationen über das Verwenden von Ereignisprozeduren finden Sie im Abschnitt "Deklarieren und Verwenden von Ereignisprozeduren".

Private Sub Spreadsheet1_BeforeCommand(ByVal EventInfo As OWC.SpreadsheetEventInfo)
    Set c = Spreadsheet1.Constants
    If EventInfo.Command = c.ssExport Then
        MsgBox "you cannot export this spreadsheet"
        EventInfo.ReturnValue = False
    End If
End Sub


RevisionNumber-Eigenschaft

Gibt die Microsoft Office Web Components-Version zurück. String schreibgeschützt.


RightToLeft-Eigenschaft

Der Wert ist True, wenn die "Von rechts nach links"-Sprachunterstützung aktiviert ist. Das Festlegen dieser Eigenschaft auf True bewirkt beispielsweise, dass links Bildlaufleisten angezeigt werden. Boolean mit Lese-/Schreibzugriff.


Row-Eigenschaft

Gibt die Zahl der ersten Zeile im angegebenen Bereich zurück. Schreibgeschütztes Long.


RowAxis-Eigenschaft

Gibt ein PivotGroupAxis-Objekt zurück, das die Zeilenachse repräsentiert. Schreibgeschützt.


RowCount-Eigenschaft

Gibt die Anzahl der Innenmitglieder auf der Zeilenachse quer über alle Feldgruppen hinweg zurück. Die Anzahl der innersten Mitglieder ist gleich der Anzahl der Zellenkoordinaten auf der Achse. Schreibgeschütztes Long.


RowFieldCount-Eigenschaft

Gibt die Anzahl der Felder auf der Zeilenachse quer über alle Feldgruppen hinweg zurück. Diese Zahl schließt nicht diejenigen Felder ein, bei denen die IsIncluded-Eigenschaft auf False gesetzt ist. Schreibgeschütztes Long.


RowHeight-Eigenschaft

Gibt die Höhe (in Punkt) aller Zeilen im angegebenen Bereich zurück oder legt diese fest. Gibt Null zurück, wenn die Zeilen nicht die gleiche Höhe aufweisen. Verwenden Sie die IsNull-Funktion, um festzustellen, ob der Rückgabewert Null beträgt. Variant mit Lese-/Schreibzugriff.


RowHeight-Eigenschaft: Beispiel

In diesem Beispiel wird die Zeilenhöhe für die Zeilen 1 bis 10 auf 15 Punkt festgelegt.

Spreadsheet1.Range("a1:a10").RowHeight = 15


RowMember-Eigenschaft

Gibt ein PivotMember-Objekt zurück, welches das innere Mitglied auf derjenigen Zeilenachse repräsentiert, welche die angegebene Zelle schneidet. Schreibgeschützt.


RowMembers-Eigenschaft

Gibt eine PivotMembers-Auflistung zurück, in der die Mitglieder auf der Zeilenachse enthalten sind. Schreibgeschützt.

Informationen über das Zurückgeben eines einzelnen Mitglieds einer Auflistung finden Sie im Abschnitt "Zurückgeben eines Objekts aus einer Auflistung".


Rows-Eigenschaft

Range-Objekt: Gibt ein Range-Objekt zurück, das alle Zeilen im angegebenen Bereich repräsentiert. Schreibgeschützt.

Spreadsheet-Objekt: Gibt ein Range-Objekt zurück, das alle Zeilen des aktiven Tabellenblattes repräsentiert. Schreibgeschützt.

Worksheet-Objekt: Gibt ein Range-Objekt zurück, das alle Zeilen des aktiven Tabellenblattes repräsentiert. Schreibgeschützt.


Rows-Eigenschaft: Beispiel

In diesem Beispiel werden die Variablen für die Anzahl der Spalten und Zeilen im sichtbaren Bereich gesetzt.

Set vr = Spreadsheet1.ActiveSheet.VisibleRange
cc = vr.Columns.Count
rc = vr.Rows.Count

In diesem Beispiel wird jede zweite Zeile im derzeitigen Bereich für Zelle A1 fett formatiert.

For Each rw In Spreadsheet1.Cells(1, 1).CurrentRegion.Rows
    If rw.Row Mod 2 = 0 Then rw.Font.Bold = True
Next

In diesem Beispiel wird Zeile 2 fett formatiert.

Spreadsheet1.Rows(2).Font.Bold = True


Scaling-Eigenschaft

Gibt das WCScaling-Objekt für die angegebene Achse zurück. Schreibgeschützt.


Scalings-Eigenschaft

Gibt ein WCScaling-Objekt für das angegebene Diagramm oder die angegebene Reihe zurück. Schreibgeschützt.

Syntax

Ausdruck.Scalings(Index)

Ausdruck Ein Ausdruck, der ein WCChart oder WCSeries-Objekt zurückgibt.

Index Erforderliches ChartDimensionsEnum-Objekt. Gibt das WCScaling-Objekt an, das zurückgegeben werden soll.


Scalings-Eigenschaft: Beispiel

In diesem Beispiel wird der Minimalwert für das angegebene WCScaling-Objekt gesetzt.

Set c = ChartSpace1.Constants
ChartSpace1.Charts(0).SeriesCollection(0).Scalings(c.chDimCategories).Minimum = -10


SchemaFields-Eigenschaft

Gibt die SchemaFields-Auflistung für die angegebene Schemazeilenquelle zurück. Schreibgeschützt.

Informationen über das Zurückgeben eines einzelnen Mitglieds einer Auflistung finden Sie im Abschnitt "Zurückgeben eines Objekts aus einer Auflistung".


SchemaParameters-Eigenschaft

Gibt die SchemaParameters-Auflistung für die angegebene Schemazeilenquelle zurück. Schreibgeschützt.

Informationen über das Zurückgeben eines einzelnen Mitglieds einer Auflistung finden Sie im Abschnitt "Zurückgeben eines Objekts aus einer Auflistung".


SchemaRelatedFields-Eigenschaft

Gibt die SchemaRelatedFields-Auflistung für die angegegebene Schemabeziehung zurück. Schreibgeschützt.

Informationen über das Zurückgeben eines einzelnen Mitglieds einer Auflistung finden Sie im Abschnitt "Zurückgeben eines Objekts aus einer Auflistung".


SchemaRelationships-Eigenschaft

Gibt die SchemaRelationships-Auflistung für das Datenquellen-Steuerelement zurück. Schreibgeschützt.


SchemaRowsources-Eigenschaft

Gibt die SchemaRowsources-Auflistung für das Datenquellen-Steuerelement zurück. Schreibgeschützt.

Informationen über das Zurückgeben eines einzelnen Mitglieds einer Auflistung finden Sie im Abschnitt "Zurückgeben eines Objekts aus einer Auflistung".

Anmerkungen

Im Entwurfsmodus wird diese Auflistung automatisch mit Informationen aus der Datenbank erstellt. In der Datenblattansicht enthält diese Auflistung alle Schemaobjekte, die auf der angegebenen Seite verwendet werden, sowie jene, die vom Benutzer ausdrücklich hinzugefügt worden sind.


ScreenUpdating-Eigenschaft

Der Wert ist True, wenn die Bildschirmaktualisierung aktiviert ist. Der Standardwert lautet True. Boolean mit Lese-/Schreibzugriff.

Anmerkungen

Das Setzen dieser Eigenschaft auf False führt dazu, dass eine Neuanzeige von Diagrammarbeitsbereich oder Kalkulationstabelle unterbunden wird. Um Bildschirmflimmern zu verhindern oder dem Benutzer das Sehen von einzelnen Aktualisierungen zu ersparen, setzen Sie diese Eigenschaft auf False, führen Ihre Aktualisierungsoperationen durch und setzen die Eigenschaft anschließend wieder auf True.


ScreenUpdating-Eigenschaft: Beispiel

In diesem Beispiel wird die Bildschirmaktualisierung deaktiviert.

Spreadsheet1.ScreenUpdating = False


Section-Eigenschaft

Gibt ein Section-Objekt zurück, das den Abschnitt repräsentiert, wo das angegebene Ereignis eingetreten ist. Schreibgeschützt.


Selection-Eigenschaft

Gibt das ausgewählte Objekt zurück. Verwenden Sie die SelectionType-Eigenschaft oder die TypeName-Funktion, um den Typ des ausgewählten Objekts zu ermitteln. Schreibgeschützt.


SelectionType-Eigenschaft

Gibt eine Konstante zurück, die den Typ des Objekts repräsentiert, der zurzeit im Diagrammarbeitsbereich ausgewählt ist. Schreibgeschütztes ChartSelectionsEnum.


SelectionType-Eigenschaft: Beispiel

Die Prozedur in diesem Beispiel wird immer dann ausgeführt, wenn sich die Auswahl im Diagrammarbeitsbereich ändert. Wenn der Benutzer eine Achse auswählt, zeigt die Prozedur die Minimal- und Maximalwerte für die Achse an.

Private Sub ChartSpace1_SelectionChange()
    Set c = ChartSpace1.Constants
    If ChartSpace1.SelectionType = c.chSelectionAxis Then
        minval = ChartSpace1.Selection.Scaling.Minimum
        maxval = ChartSpace1.Selection.Scaling.Maximum
        MsgBox "minimum = " & minval & " maximum = " & maxval
    End If
End Sub


Separator-Eigenschaft

Gibt die Zeichenkette zurück, mit der die Datenbeschriftungskomponenten in der angegebenen Reihe oder dem angegebenen Diagramm voneinander getrennt werden, oder legt sie fest. String mit Lese-/Schreibzugriff.


Separator-Eigenschaft: Beispiel

In diesem Beispiel werden die Datenbeschriftungstrennzeichen für die angegebene Reihe geändert.

Set dl = ChartSpace1.Charts(0).SeriesCollection(0).DataLabelsCollection.Add
dl.HasCategoryName = True
dl.Separator = ":"


SeriesCollection-Eigenschaft

Gibt die WCSeriesCollection-Auflistung für das angegebene Diagramm zurück. Schreibgeschützt.

Informationen über das Zurückgeben eines einzelnen Mitglieds einer Auflistung finden Sie im Abschnitt "Zurückgeben eines Objekts aus einer Auflistung".


SeriesCollection-Eigenschaft: Beispiel

In diesem Beispiel wird die Linienfarbe für die angegebene Reihe auf Rot festgelegt.

ChartSpace1.Charts(0).SeriesCollection(0).Line.Color = "red"


ServerFilter-Eigenschaft

Gibt die Serverfilter-Zeichenkette für das angegebene RecordsetDef-Objekt zurück oder legt diese fest.

Anmerkungen

Ein Serverfilter ist ein Kriterium zur Angabe des Typs oder der Typen von Datensätzen, die von dem Server abgerufen werden sollen. Im Datenmodell wird die Serverfilter-Zeichenkette der WHERE-Klausel in der SQL-Anweisung hinzugefügt, die es generiert. Sie können einen Serverfilter nur für Datensatzgruppen setzen, die über eine primäre Zeilenquelle des dscTable oder dscView-Typs verfügen.


ShiftKey-Eigenschaft

Der Wert lautet True, wenn die UMSCHALTTASTE gedrückt (festgehalten) wurde, während das angegebene Ereignis eintrat. Schreibgeschützter Boolean.


ShiftKey-Eigenschaft: Beispiel

Die Ereignisprozedur in diesem Beispiel zeigt jedes Mal die Version von Microsoft Office Web Components an, wenn der Benutzer auf den Diagrammarbeitsbereich doppelklickt und dabei die UMSCHALTTASTE gedrückt hält. Beachten Sie, dass die Ereignisprozedur in diesem Beispiel so deklariert wurde, wie es für Visual Basic erforderlich ist. Weitere Informationen über das Verwenden von Ereignisprozeduren finden Sie im Abschnitt "Deklarieren und Verwenden von Ereignisprozeduren".

Private Sub ChartSpace1_DblClick(ByVal ChartEventInfo As OWC.WCChartEventInfo)
    If ChartEventInfo.ShiftKey Then
        vers = ChartSpace1.MajorVersion & "." & ChartSpace1.MinorVersion & _
            " build " & ChartSpace1.BuildNumber
        MsgBox vers, Title:="MSOWC Version"
    End If
End Sub


ShowAll-Eigenschaft

Die AutoFilter-Kriterien werden gelöscht, wenn diese Eigenschaft auf True festgelegt ist. Durch Hinzufügen von Kriterien wird diese Eigenschaft auf False festgelegt. Wenn keine Kriterien vorhanden sind und diese Eigenschaft auf False festgelegt ist, werden keine Daten angezeigt. Boolean mit Lese-/Schreibzugriff.


ShowAll-Eigenschaft: Beispiel

In diesem Beispiel werden die AutoFilter-Kriterien für Spalte 1 auf dem aktiven Tabellenblatt gelöscht. Anschließend wird der AutoFilter dem Tabellenblatt erneut zugewiesen.

Set af = Spreadsheet1.ActiveSheet.AutoFilter
af.Filters(1).Criteria.ShowAll = True
af.Apply


ShowDelButton-Eigenschaft

Der Wert ist True, wenn die Schaltfläche Löschen (Steuerelement zur Datensatznavigation) angezeigt wird. Der Standardwert lautet True. Boolean mit Lese-/Schreibzugriff.


ShowFilterBySelectionButton-Eigenschaft

Der Wert ist True, wenn die Schaltfläche Auswahlbasierter Filter (Steuerelement zur Datensatznavigation) angezeigt wird. Der Standardwert lautet True. Boolean mit Lese-/Schreibzugriff.


ShowFirstButton-Eigenschaft

Der Wert ist True, wenn die Schaltfläche First (Steuerelement zur Datensatznavigation) angezeigt wird. Der Standardwert lautet True. Boolean mit Lese-/Schreibzugriff.


ShowHelpButton-Eigenschaft

Der Wert ist True, wenn die Schaltfläche Hilfe (Steuerelement zur Datensatznavigation) angezeigt wird. Der Standardwert lautet True. Boolean mit Lese-/Schreibzugriff.


ShowLabel-Eigenschaft

Der Wert ist True, wenn die Beschriftung des Steuerelements für die Datensatznavigation angezeigt wird. Der Standardwert lautet True. Boolean mit Lese-/Schreibzugriff.


ShowLastButton-Eigenschaft

Der Wert ist True, wenn die Schaltfläche Last (Steuerelement zur Datensatznavigation) angezeigt wird. Der Standardwert lautet True. Boolean mit Lese-/Schreibzugriff.


ShowNewButton-Eigenschaft

Der Wert ist True, wenn die Schaltfläche Neu (Steuerelement zur Datensatznavigation) angezeigt wird. Der Standardwert lautet True. Boolean mit Lese-/Schreibzugriff.


ShowNextButton-Eigenschaft

Der Wert ist True, wenn die Schaltfläche Weiter (Steuerelement zur Datensatznavigation) angezeigt wird. Der Standardwert lautet True. Boolean mit Lese-/Schreibzugriff.


ShowPrevButton-Eigenschaft

Der Wert ist True, wenn die Schaltfläche Zurück (Steuerelement zur Datensatznavigation) angezeigt wird. Der Standardwert lautet True. Boolean mit Lese-/Schreibzugriff.


ShowSaveButton-Eigenschaft

Der Wert ist True, wenn die Schaltfläche Speichern (Steuerelement zur Datensatznavigation) angezeigt wird. Der Standardwert lautet True. Boolean mit Lese-/Schreibzugriff.


ShowSortAscendingButton-Eigenschaft

Der Wert ist True, wenn die Schaltfläche Aufsteigend sortieren (Steuerelement zur Datensatznavigation) angezeigt wird. Der Standardwert lautet True. Boolean mit Lese-/Schreibzugriff.


ShowSortDescendingButton-Eigenschaft

Der Wert ist True, wenn die Schaltfläche Absteigend sortieren (Steuerelement zur Datensatznavigation) angezeigt wird. Der Standardwert lautet True. Boolean mit Lese-/Schreibzugriff.


ShowToggleFilterButton-Eigenschaft

Der Wert ist True, wenn die Schaltfläche Filter ein/aus (Steuerelement zur Datensatznavigation) angezeigt wird. Der Standardwert lautet True. Boolean mit Lese-/Schreibzugriff.


ShowUndoButton-Eigenschaft

Der Wert ist True, wenn die Schaltfläche Rückgängig (Steuerelement zur Datensatznavigation) angezeigt wird. Der Standardwert lautet True. Boolean mit Lese-/Schreibzugriff.


Size-Eigenschaft

Gibt die Schriftart- oder Markierungsgröße (in Punkt) zurück oder legt sie fest. Gibt Null zurück, wenn sie für einen Bereich verwendet wird, in dem die Zeichen nicht alle die gleiche Größe aufweisen. Verwenden Sie die IsNull-Funktion, um festzustellen, ob der Rückgabewert Null ist. Long mit Lese-/Schreibzugriff für die PivotFont und WCMarker-Objekte; Variant mit Lese-/Schreibzugriff für das OWCFont-Objekt.


SizeRepresents-Eigenschaft

Gibt die Blasengröße in einem Blasendiagramm zurück, oder legt diese fest. ChartSizeRepresentsEnum mit Lese-/Schreibzugriff.


SizeRepresents-Eigenschaft: Beispiel

In diesem Beispiel wird die SizeRepresents-Eigenschaft für das angegebene Blasendiagramm festgelegt.

ChartSpace1.Charts(0).SizeRepresents = chSizeIsArea


SortDirection-Eigenschaft

Gibt die Richtung zurück, in der das angegebene Feld sortiert werden soll, oder legt diese fest. PivotFieldSortDirectionEnum mit Lese-/Schreibzugriff.

Anmerkungen

Das Feld wird auf Grundlage der Sortierregeln des zugrunde liegenden Datenanbieters sortiert. Ein Datenanbieter könnte beispielsweise die Datumsangaben alphanumerisch (April, Dezember usw.) oder in chronologischer Monatsfolge (Januar, Februar usw.) sortieren.


SortOn-Eigenschaft

Gibt die Summe zurück, die zum Sortieren des angegebenen Feldes verwendet wird, oder legt sie fest. PivotTotal mit Lese-/Schreibzugriff.


SortOnScope-Eigenschaft

Gibt die Zeichenkettenmatrix zurück, die zum Einschränken des Sortierungsbereichs für das angegebene Feld verwendet wird oder legt sie fest.Variant mit Lese-/Schreibzugriff.


Source-Eigenschaft

Gibt die Quelle für das angegebene Seitenfeld oder die angegebene Seitenzeilenquelle zurück. String mit Lese-/Schreibzugriff.


SplitMaximum-Eigenschaft

Wenn das angegebene WCScaling-Objekt eine Aufteilung aufweist, gibt diese Eigenschaft den Maximalwert für die Aufteilung zurück oder legt ihn fest. Dieser Wert sollte größer als der Wert der SplitMinimum-Eigenschaft sein. Double mit Lese-/Schreibzugriff.


SplitMaximum-Eigenschaft: Beispiel

In diesem Beispiel wird die angegebene Achse aufgeteilt, und es werden die Minimal- und Maximalwerte für die Aufteilung festgelegt.

Set c = ChartSpace1.Constants
Set sc = ChartSpace1.Charts(0).Axes(c.chAxisPositionLeft).Scaling
sc.HasSplit = True
sc.SplitMinimum = 100
sc.SplitMaximum = 500


SplitMinimum-Eigenschaft

Wenn das angegebene WCScaling-Objekt eine Aufteilung aufweist, gibt diese Eigenschaft den Minimalwert für die Aufteilung zurück oder legt ihn fest. Dieser Wert sollte kleiner als der Wert der SplitMaximum-Eigenschaft sein. Double mit Lese-/Schreibzugriff.


SplitMinimum-Eigenschaft: Beispiel

In diesem Beispiel wird die angegebene Achse aufgeteilt, und es werden die Minimal- und Maximalwerte für die Aufteilung festgelegt.

Set c = ChartSpace1.Constants
Set sc = ChartSpace1.Charts(0).Axes(c.chAxisPositionLeft).Scaling
sc.HasSplit = True
sc.SplitMinimum = 100
sc.SplitMaximum = 500


Style-Eigenschaft

Gibt oder setzt den Markierungsstil für die angegebene Reihe oder das angegebene Diagramm zurück. ChartMarkerStyleEnum mit Lese-/Schreibzugriff.


Style-Eigenschaft: Beispiel

In diesem Beispiel wird der Markierungsstil für die angegebene Reihe gesetzt.

Set c = ChartSpace1.Constants
ChartSpace1.Charts(0).SeriesCollection(0).Marker.Style = c.chMarkerStyleStar


Subaddress-Eigenschaft

Gibt den Speicherort (innerhalb des Dokuments) zurück, der mit dem Hyperlink verknüpft ist (der Zeichenkette rechts neben dem "#"-Symbol in der Hyperlinkadresse), oder legt den Speicherort fest. String mit Lese-/Schreibzugriff.


Subaddress-Eigenschaft: Beispiel

In diesem Beispiel wird die Adresse und die Unteradresse für den entsprechenden Hyperlink angegeben.

Set hyp = Spreadsheet1.Range("a12").Hyperlink
hyp.Address = "http://www.microsoft.com/ExcelDev/e-tips.htm"
hyp.Subaddress = "top"


SublistRelationships-Eigenschaft

Gibt die SublistRelationships-Auflistung für die angegebene Datensatzgruppendefinition zurück. Schreibgeschützt.

Informationen über das Zurückgeben eines einzelnen Mitglieds einer Auflistung finden Sie im Abschnitt "Zurückgeben eines Objekts aus einer Auflistung".

Anmerkungen

Eine Unterlistenbeziehung bezieht sich auf eine Zeilenquelle in einer anderen Datensatzgruppendefinition, die eine n:1-Beziehung mit der primären Seitenzeilenquelle in der angegebenen Datensatzgruppendefinition aufweist.


SublistSchemaRelationships-Eigenschaft

Gibt die SublistSchemaRelationships-Auflistung für die angegebene Datensatzgruppendefinition zurück. Schreibgeschützt.

Informationen über das Zurückgeben eines einzelnen Mitglieds einer Auflistung finden Sie im Abschnitt "Zurückgeben eines Objekts aus einer Auflistung".


SubtotalBackColor-Eigenschaft

Gibt die Hintergrundfarbe für das Teilergebnis in dem angegebenen Feld zurück oder legt diese fest. Bei Teilergebnissen deaktiviert die Einstellung dieser Eigenschaft die Einstellung der TotalBackColor-Eigenschaft. Variant mit Lese-/Schreibberechtigung..

Anmerkungen

Wenn Sie diese Eigensschaft setzen, können Sie entweder einen Long-Wert, der einen RGB-Wert repräsentiert, oder einen String-Wert verwenden, der einen gültigen HTML-Farbwert benennt. Um beispielsweise die Objektfarbe auf Rot zu setzen, könnten Sie den hexadezimalen Wert &HFF, den Dezimalwert 255 oder die Zeichenkette red verwenden. In Microsoft Visual Basic können Sie die RGB-Funktion einsetzen, um einen RGB-Farbwert zu erzeugen (Rot entspricht RGB(255,0,0)).

Diese Eigenschaft gibt die Farbe stets als Long-Wert zurück, der einen RGB-Farbwert darstellt.


SubtotalFont-Eigenschaft

Gibt ein PivotFont-Objekt zurück, das die Schriftart für Teilergebnisse repräsentiert. Schreibgeschützt.


SubtotalForeColor-Eigenschaft

Gibt die Vordergrundfarbe für das Teilergebnis in dem angegebenen Feld zurück oder legt diese fest. Bei Teilergebnissen deaktiviert die Einstellung dieser Eigenschaft die Einstellung der TotalForeColor-Eigenschaft. Variant mit Lese-/Schreibberechtigung..

Anmerkungen

Wenn Sie diese Eigensschaft setzen, können Sie entweder einen Long-Wert, der einen RGB-Wert repräsentiert, oder einen String-Wert verwenden, der einen gültigen HTML-Farbwert benennt. Um beispielsweise die Objektfarbe auf Rot zu setzen, könnten Sie den hexadezimalen Wert &HFF, den Dezimalwert 255 oder die Zeichenkette red verwenden. In Microsoft Visual Basic können Sie die RGB-Funktion einsetzen, um einen RGB-Farbwert zu erzeugen (Rot entspricht RGB(255,0,0)).

Diese Eigenschaft gibt die Farbe stets als Long-Wert zurück, der einen RGB-Farbwert darstellt.


Subtotals-Eigenschaft

Der Wert ist True (Wahr), wenn das Teilergebnis für das angegebene Feld angezeigt wird. Boolean mit Lese-/Schreibzugriff.

Syntax

Ausdruck.Subtotals(Subtotals)

Ausdruck Ein Ausdruck, der ein PivotField-Objekt zurückgibt. Das Feld muss sich auf einer Zeilen- oder Spaltenachse befinden.

Subtotals Erforderliches Long. Gibt das Teilergebnis an. Muss 1 sein.


Text-Eigenschaft

PivotAggregate oder PivotDetailCell-Objekt: Gibt den angegebenen Wert als Zeichenkette zurück, die auf der Einstellung der derzeitigen NumberFormat-Eigenschaft beruht. String schreibgeschützt.

Range-Objekt: Gibt den formatierten Wert zurück, der in der angegebenen Zelle angezeigt wird. Gibt Null zurück, wenn der Bereich mehr als eine Zelle einschließt und die Zellen nicht alle den gleichen Wert enthalten. Verwenden Sie die IsNull-Funktion, um festzustellen, ob der Rückgabewert Null ist. Variant schreibgeschützt.


Text-Eigenschaft: Beispiel

In diesem Beispiel wird eine Variable für den formatierten Wert von Zelle A1 gesetzt.

txt = Spreadsheet1.Range("a1").Text


TickLabelSpacing-Eigenschaft

Gibt die Anzahl der Rubriken zwischen Teilstrichbeschriftungen der angegebenen Achse zurück oder legt die Anzahl fest. Gilt nur für Rubrikenachsen. Long mit Lese-/Schreibzugriff.


TickLabelSpacing-Eigenschaft: Beispiel

In diesem Beispiel wird die Anzahl der Rubriken zwischen Teilstrichbeschriftungen der angegebenen Achse auf 2 gesetzt.

ChartSpace1.Charts(0).Axes(1).TickLabelSpacing = 2


TickMarkSpacing-Eigenschaft

Gibt die Anzahl der Rubriken zwischen Teilstrichen der angegebenen Achse zurück oder legt die Anzahl fest. Gilt nur für Rubrikenachsen. Verwenden Sie die MajorUnit und MinorUnit-Eigenschaften, um die Teilstrichabstände auf Werteachsen festzulegen. Long mit Lese-/Schreibzugriff.


TickMarkSpacing-Eigenschaft: Beispiel

In diesem Beispiel wird die Anzahl der Rubriken zwischen Teilstrichen der angegebenen Achse auf 2 gesetzt.

ChartSpace1.Charts(0).Axes(1).TickMarkSpacing = 2


Title-Eigenschaft

Gibt ein WCTitle-Objekt zurück, das den Titel der angegebenen Achse oder des angegebenen Diagramms repräsentiert. Schreibgeschützt.


TitleBar-Eigenschaft

PivotView-Objekt: Gibt ein PivotLabel-Objekt zurück, das den Titel der angegebenen Ansicht repräsentiert. Schreibgeschützt.

Spreadsheet-Objekt: Gibt ein TitleBar-Objekt zurück, das den Titel der angegebenen Kalkulationstabelle repräsentiert. Schreibgeschützt.


TitleBar-Eigenschaft: Beispiel

In diesem Beispiel wird die Titelbeschriftung für die Kalkulationstabelle festgelegt.

Spreadsheet1.TitleBar.Caption = "Monthly Sales"


Top-Eigenschaft

PivotData-Objekt: Gibt das Mitglied links neben der obersten sichtbaren Hauptzeile zurück oder legt es fest. PivotMember mit Lese-/Schreibzugriff.

Range-Objekt: Gibt den Abstand zwischen der oberen Begrenzung des Kalkulationstabellenfensters und der oberen Begrenzung des angegebenen Bereichs zurück. Schreibgeschütztes Long. Dieser Wert kann eine negative Zahl sein, wenn der angegebene Bereich sich oberhalb des sichtbaren Bereichs befindet.


TopLeft-Eigenschaft

PivotDetailRange-Objekt: Gibt ein PivotDetailCell-Objekt zurück, das die obere linke Zelle im Detailbereich repräsentiert. Schreibgeschützt.

PivotRange-Objekt: Gibt ein PivotCell-Objekt zurück, das die obere linke Zelle im angegebenen Bereich repräsentiert. Schreibgeschützt.


Total-Eigenschaft

Gibt ein PivotTotal-Objekt zurück, das die Summe für das angegebene Aggregat repräsentiert. Schreibgeschützt.


TotalAllMembers-Eigenschaft

Der Wert ist True (Wahr), wenn gefilterte Mitglieder in Teilergebnisse aufgenommen werden.Wenn diese Eigenschaft auf False (Falsch) gesetzt ist, enthalten Teilergebnisse keine Mitglieder, die aus der Ansicht herausgefiltert worden sind. Der Standardwert lautet False. Boolean mit Lese-/Schreibzugriff.


TotalBackColor-Eigenschaft

Gibt die Hintergrundfarbe für sämtliche Summen zurück oder legt sie fest. Variant mit Lese-/Schreibberechtigung.

Anmerkungen

Wenn Sie diese Eigensschaft setzen, können Sie entweder einen Long-Wert, der einen RGB-Wert repräsentiert, oder einen String-Wert verwenden, der einen gültigen HTML-Farbwert benennt. Um beispielsweise die Objektfarbe auf Rot zu setzen, könnten Sie den hexadezimalen Wert &HFF, den Dezimalwert 255 oder die Zeichenkette red verwenden. In Microsoft Visual Basic können Sie die RGB-Funktion einsetzen, um einen RGB-Farbwert zu erzeugen (Rot entspricht RGB(255,0,0)).

Diese Eigenschaft gibt die Farbe stets als Long-Wert zurück, der einen RGB-Farbwert darstellt.


TotalFont-Eigenschaft

Gibt ein PivotFont-Objekt zurück, das die Schriftart repräsentiert, die für Aggregate verwendet wird, die in einer Zelle oder in einer Detailrasterfußzeile angezeigt werden. Schreibgeschützt.


TotalForeColor-Eigenschaft

Gibt die Vordergrundfarbe für sämtliche Summen zurück oder legt sie fest. Variant mit Lese-/Schreibberechtigung.

Anmerkungen

Wenn Sie diese Eigensschaft setzen, können Sie entweder einen Long-Wert, der einen RGB-Wert repräsentiert, oder einen String-Wert verwenden, der einen gültigen HTML-Farbwert benennt. Um beispielsweise die Objektfarbe auf Rot zu setzen, könnten Sie den hexadezimalen Wert &HFF, den Dezimalwert 255 oder die Zeichenkette red verwenden. In Microsoft Visual Basic können Sie die RGB-Funktion einsetzen, um einen RGB-Farbwert zu erzeugen (Rot entspricht RGB(255,0,0)).

Diese Eigenschaft gibt die Farbe stets als Long-Wert zurück, der einen RGB-Farbwert darstellt.


TotalMember-Eigenschaft

Gibt ein PivotMember-Objekt zurück, welches das Mitglied repräsentiert, das zum Anzeigen von Teilergebnissen verwendet wird. Schreibgeschützt.


TotalOrientation-Eigenschaft

Gibt die Orientierung zurück, die zum Anzeigen von Gesamtergebnissen verwendet wird, wenn mehr als eine Summe vorliegt, oder legt die Orientierung fest. PivotViewTotalOrientationEnum mit Lese-/Schreibzugriff.


Totals-Eigenschaft

PivotDataAxis-Objekt: Gibt eine PivotTotals-Auflistung zurück, die sämtliche PivotTotal-Objekte auf der Summenachse enthält. Die Summen werden im Summenbereich für jede Zelle angezeigt. Schreibgeschützt.

PivotView-Objekt: Gibt eine PivotTotals-Auflistung zurück, die alle Summen in der aktuellen Ansicht enthält. Schreibgeschützt.

Informationen über das Zurückgeben eines einzelnen Mitglieds einer Auflistung finden Sie im Abschnitt "Zurückgeben eines Objekts aus einer Auflistung".


TotalType-Eigenschaft

Gibt den Typ der Summe zurück oder legt ihn fest. dscTotalTypeEnum mit Lese-/Schreibzugriff.

Anmerkungen

Andere Werte als dscNone sind nur bei Seitenfeldern des dscGrouping-Typs gültig.


Trendlines-Eigenschaft

Gibt die WCTrendlines-Auflistung für die angegebene Reihe zurück. Beachten Sie, dass eine Reihe nur eine Trendlinie besitzen kann.

Informationen über das Zurückgeben eines einzelnen Mitglieds einer Auflistung finden Sie im Abschnitt "Zurückgeben eines Objekts aus einer Auflistung".


Trendlines-Eigenschaft: Beispiel

In diesem Beispiel wird der angegebenen Reihe eine Trendlinie hinzugefügt. Anschließend wird das Bestimmtheitsmaß der Trendlinie ausgeblendet.

ChartSpace1.Charts(0).SeriesCollection(0).Trendlines.Add
ChartSpace1.Charts(0).SeriesCollection(0).Trendlines(0).IsDisplayingRSquared = False


Type-Eigenschaft

Gibt den Objekttyp für das angegebene Objekt zurück, wie es in der nachfolgenden Tabelle gezeigt wird.

Objekt | Konstante | Lese-/Schreibzugriffs- oder Schreibschutz-Status
PageRelationship | dscPageRelTypeEnum | Schreibgeschützt
PivotField | PivotFieldTypeEnum | Schreibgeschützt
PivotFieldSet | PivotFieldSetTypeEnum | Schreibgeschützt
PivotTotal | PivotTotalTypeEnum | Schreibgeschützt
SchemaRowsource | dscRowsourceTypeEnum | Lese-/Schreibzugriff
Section | SectTypeEnum | Schreibgeschützt
WCAxis | ChartAxisTypeEnum | Schreibgeschützt
WCChart | ChartChartTypeEnum | Lese-/Schreibzugriff
WCDataSource | ChartDataSourceTypeEnum | Lese-/Schreibzugriff
WCErrorBars | ChartErrorBarTypeEnum | Lese-/Schreibzugriff
WCScaling | ChartScaleTypeEnum | Lese-/Schreibzugriff
WCSeries | ChartChartTypeEnum | Lese-/Schreibzugriff
WCTrendline | ChartTrendlineTypeEnum | Lese-/Schreibzugriff


Type-Eigenschaft: Beispiel

In diesem Beispiel wird der Diagrammtyp für das angegebene Diagramm festgelegt.

Set c = ChartSpace1.Constants
ChartSpace1.Charts(0).Type = c.chChartTypeLineMarkers


Underline-Eigenschaft

Gibt das Unterstrich-Format für den angegebenen Bereich zurück oder legt es fest. UnderlineStyleEnum mit Lese-/Schreibzugriff für das PivotFont-Objekt; Variant mit Lese-/Schreibzugriff für das OWCFont-Objekt (gibt Null zurück, wenn die Zeichen der Schriftart nicht alle das gleiche Unterstrich-Format aufweisen; anderenfalls gibt sie eine der UnderlineStyleEnum-Konstanten zurück). Verwenden Sie die IsNull-Funktion, um festzustellen, ob der Rückgabewert Null ist.


Underline-Eigenschaft: Beispiel

In diesem Beispiel wird allen Zellenwerten in Spalte 1 ein einfacher Unterstrich hinzugefügt.

Set c = Spreadsheet1.Constants
Spreadsheet1.Rows(1).Font.Underline = c.owcUnderlineStyleSingle


UniqueName-Eigenschaft

Gibt den eindeutigen Namen des PivotMember-Objekts zurück (der eindeutige Mitgliederbezug, der vom Anbieter zurückgegeben wird). Gibt Null zurück, wenn die Mitgliederquelle ein RecordsetDef-Objekt ist. String schreibgeschützt.


UniqueTable-Eigenschaft

Gibt den Namen der aktualisierbaren Tabelle an, wenn ein Formular an eine Mehrtabellenansicht oder eine gespeicherte Prozedur gebunden ist. String mit Lese-/Schreibzugriff.


UsedRange-Eigenschaft

Gibt ein Range-Objekt zurück, das den verwendeten Bereich auf dem angegebenen Tabellenblatt repräsentiert. Schreibgeschützt.


UsedRange-Eigenschaft: Beispiel

In diesem Beispiel wird die Zeilenhöhe und -breite für den verwendeten Bereich auf dem aktiven Tabellenblatt angepasst, um die enthaltenen Daten in den Bereich einzupassen.

Set ur = Spreadsheet1.ActiveSheet.UsedRange
ur.AutoFitRows
ur.AutoFitColumns


UseRemoteProvider-Eigenschaft

Der Wert ist True (Wahr), wenn das Datenquellen-Steuerelement einen Remote-Anbieter verwendet. Boolean mit Lese-/Schreibzugriff.

Anmerkungen

Wen diese Eigenschaft auf True (Wahr) gesetzt ist, verwendet das Datenquellen-Steuerelement den Microsoft Remote Data Services-Anbieter für Datenverbindungen. Sie können diese Eigenschaft nur für Seiten verwenden, die von einem Microsoft Internet Information Server unter Verwendung einer HTTP oder HTTPS-Adresse gelesen werden. Der Microsoft Remote Data Services-Anbieter ruft die Daten ab, indem er HTTP oder HTTPS-Anforderungen an den IIS sendet, der dann wiederum eine OLE DB-Verbindung mit der Datenbank herstellt.


VAlignment-Eigenschaft

Gibt die Art zurück, auf die Daten im angegebenen Bereich angeordnet werden oder legt sie fest. Kann sich um eine der SheetVAlignEnum-Konstanten handeln. Gibt Null zurück, wenn die Zellen im Bereich nicht alle gleich angeordnet sind. Verwenden Sie die IsNull-Funktion, um festzustellen, ob der Rückgabewert Null lautet. Variant mit Lese-/Schreibzugriff.


VAlignment-Eigenschaft: Beispiel

In diesem Beispiel wird eine verbundene Zelle erstellt, der Wert wird in der Zelle platziert, und anschließend wird der Wert innerhalb der Zelle zentriert.

Spreadsheet1.Range("a1:c3").Merge
Spreadsheet1.Range("a1").Value = "Monday"
Set c = Spreadsheet1.Constants
Spreadsheet1.Range("a1").VAlignment = c.ssVAlignCenter
Spreadsheet1.Range("a1").HAlignment = c.ssHAlignCenter


Value-Eigenschaft

Gibt den Wert für das angegebene Objekt zurück oder legt ihn fest. Variant mit Lese-/Schreibzugriff für PivotAggregate und PivotDetailCell-Objekte; Variant mit Lese-/Schreibzugriff für ParameterValue und Range-Objekte.

Anmerkungen

Wenn der angegebene Bereich mehr als eine Zelle enthält, gibt diese Eigenschaft eine Matrix zurück, das die Werte für sämtliche Zellen enthält.


Value-Eigenschaft: Beispiel

In diesem Beispiel wird eine verbundene Zelle aus dem angegebenen Bereich erstellt. Anschließend wird ein Wert in der verbundenen Zelle platziert.

Spreadsheet1.Range("a1:c3").Merge
Spreadsheet1.Range("a1").Value = "Monday"


Version-Eigenschaft

Gibt die Microsoft Office Web Components-Version zurück. String schreibgeschützt.


ViewableRange-Eigenschaft

Gibt den Bereich von Zellen zurück, die der Benutzer anzeigen kann, oder legt ihn fest. Hierdurch haben Sie die Möglichkeit, Tabellenblattzellen auszublenden (eventuell möchten Sie Zellen ausblenden, die zum Beispiel Zwischenberechnungen enthalten). String mit Lese-/Schreibzugriff.

Anmerkungen

Verwechseln Sie diese Eigenschaft nicht mit der VisibleRange-Eigenschaft, die ein Range-Objekt zurückgibt, das sämtliche Zellen repräsentiert, die momentan sichtbar sind.


ViewableRange-Eigenschaft: Beispiel

In diesem Beispiel wird der sichtbare Bereich der Kalkulationstabelle festgelegt.

Spreadsheet1.ViewableRange = "a1:g20"


Visible-Eigenschaft

Der Wert ist True (Wahr), wenn das angegebene Objekt zu sehen ist. Boolean mit Lese-/Schreibzugriff.


VisibleRange-Eigenschaft

Gibt ein Range-Objekt zurück, das sämtliche Zellen repräsentiert, die momentan sichtbar sind. Schreibgeschützt.

Anmerkungen

Verwechseln Sie diese Eigenschaft nicht mit der ViewableRange-Eigenschaft. Sie gibt eine Zeichenkette zurück, die den Bereich angibt, den der Benutzer sehen kann (ein Teil dieses Bereichs ist momentan eventuell nicht zu sehen).


VisibleRange-Eigenschaft: Beispiel

In diesem Beispiel wird die Schriftart für alle übrigen Spalten im sichtbaren Bereich des aktiven Tabellenblattes auf Fett gesetzt.

For Each col In Spreadsheet1.ActiveSheet.VisibleRange.Columns
    If col.Column Mod 2 = 0 Then col.Font.Bold = True
Next

Die Funktion in diesem Beispiel gibt True zurück, wenn der gesamte aktuelle Bereich für Zelle A1 sichtbar ist (wenn der aktuelle Bereich außerhalb des sichtbaren Bereichs liegt, gibt die Funktion False wieder).

Function IsCurrentRegionVisible()
    Set cr = Spreadsheet1.ActiveSheet.Cells(1, 1).CurrentRegion
    Set vr = Spreadsheet1.ActiveSheet.VisibleRange
    Set ir = Spreadsheet1.Intersect(cr, vr)
    IsCurrentRegionVisible = (ir.Address = cr.Address)
End Function


Weight-Eigenschaft

Gibt die Stärke des angebenen Rahmens oder der angegebenen Linie zurück oder legt sie fest. Kann eine der LineWeightEnum-Konstanten oder auch Null sein, wenn die Rahmen nicht alle die gleiche Stärke haben. Variant mit Lese-/Schreibzugriff.


Weight-Eigenschaft: Beispiel

In diesem Beispiel werden Diagrammarbeitsbereich und Achsenstärke festgelegt.

Set c = ChartSpace1.Constants
ChartSpace1.Charts(0).Axes(c.chAxisPositionLeft).Line.Weight = owcLineWeightThick
ChartSpace1.Border.Weight = c.owcLineWeightThick


Width-Eigenschaft

Gibt die Breite des angegebenen Objekts (in Punkt) zurück oder legt diese fest. Long schreibgeschützt für Range-Objekte; Long mit Lese-/Schreibzugriff für alle übrigen Objekte, für die diese Eigenschaft gültig ist.


WidthRatio-Eigenschaft

Gibt das Breitenverhältnis für das angegebene Diagramm im Verhältnis zu den übrigen Diagrammen im Diagrammarbeitsbereich an oder legt es fest. Der Standardwert ist 100. Long mit Lese-/Schreibzugriff.

Anmerkungen

Durch diese Eigenschaft wird die Breite des angegebenen Diagramms relativ zur Breite der übrigen Diagramme im Diagrammarbeitsbereich festgelegt. Damit diese Eigenschaft eine Auswirkung hat, müssen Sie über mehr als ein Diagramm im Diagrammarbeitsbereich verfügen. Wird mehr als ein Diagramm angezeigt, werden die Diagramme in einem Gitter angezeigt (Weitere Informationen finden Sie in den Hilfethemen zu den ChartLayout- und ChartWrapCount-Eigenschaften). Zu Anfang sind die HeightRatio und WidthRatio-Eigenschaften für sämtliche Diagramme im Gitter auf 100 gesetzt. Sämtliche Diagramme haben die gleiche Größe.

Um die Breite sämtlicher Diagramme im Gitter zu ändern, passen Sie die Einstellungen der WidthRatio-Eigenschaft an. Wenn zum Beispiel jedes Diagramm in drei Spalten angezeigt wird, gilt für sämtliche Diagramme eine anfängliche WidthRatio-Einstellung von 100. Wenn Sie möchten, dass Spalte 3 nur halb so breit wie die verfügbare Spaltenbreite ist, setzen Sie ihre WidthRatio-Einstellung auf 200. Die übrige Hälfte der Diagrammbreite wird auf die Spalten 1 und 2 aufgeteilt. Weil die in der WidthRatio-Eigenschaft angegebene Breite relativ ist, können Sie diese Eigenschaft für die drei Spalten auf 1,1,2 oder 100,100,200 oder 20,20,40 setzen. Alle Einstellungen haben den gleichen Effekt.

Wenn der Diagrammarbeitsbereich Diagramme beinhaltet, die in mehr als einer Spalte angezeigt werden, wird die höchste WidthRatio-Einstellung in jeder Spalte dazu verwendet, um die relative Breite für die ganze Spalte festzulegen.

Diese Eigenschaft ist nützlich beim Erstellen von Preis- und Mengenkursdiagrammen, in denen das Mengendiagramm die halbe Größe des Preisdiagramms aufweist.


X-Eigenschaft

Gibt den Abstand (in Pixel) zwischen der linken Begrenzung der Kalkulationstabelle oder des Diagrammarbeitsbereichs und dem Mauszeiger an, als das Ereignis eintrat. Schreibgeschütztes Long.


XMLData-Eigenschaft

Gibt die XML-Daten zurück oder legt diese fest. String mit Lese-/Schreibzugriff.


Y-Eigenschaft

Gibt den Abstand (in Pixel) zwischen der oberen Begrenzung der Kalkulationstabelle oder des Diagrammarbeitsbereichs und dem Mauszeiger an, als das Ereignis eintrat. Schreibgeschütztes Long.


ChartAxisCrossesEnum-Konstanten

Konstante | Wert
chAxisCrossesAutomatic | 0
chAxisCrossesCustom | 3


ChartAxisPositionEnum-Konstanten

Konstante | Wert
chAxisPositionCircular | -6
chAxisPositionRadial | -5
chAxisPositionRight | -4
chAxisPositionLeft | -3
chAxisPositionBottom | -2
chAxisPositionTop | -1


ChartAxisTypeEnum-Konstanten

Konstante | Wert
chCategoryAxis | 0
chValueAxis | 1


ChartChartLayoutEnum-Konstanten

Konstante | Wert
chChartLayoutAutomatic | 0
chChartLayoutHorizontal | 1
chChartLayoutVertical | 2


ChartChartTypeEnum-Konstanten

Konstante | Wert
chChartTypeCombo | -1
chChartTypeColumnClustered | 0
chChartTypeColumnStacked | 1
chChartTypeColumnStacked100 | 2
chChartTypeBarClustered | 3
chChartTypeBarStacked | 4
chChartTypeBarStacked100 | 5
chChartTypeLine | 6
chChartTypeLineMarkers | 7
chChartTypeLineStacked | 8
chChartTypeLineStackedMarkers | 9
chChartTypeLineStacked100 | 10
chChartTypeLineStacked100Markers | 11
chChartTypeSmoothLine | 12
chChartTypeSmoothLineMarkers | 13
chChartTypeSmoothLineStacked | 14
chChartTypeSmoothLineStackedMarkers | 15
chChartTypeSmoothLineStacked100 | 16
chChartTypeSmoothLineStacked100Markers | 17
chChartTypePie | 18
chChartTypePieExploded | 19
chChartTypePieStacked | 20
chChartTypeScatterMarkers | 21
chChartTypeScatterSmoothLineMarkers | 22
chChartTypeScatterSmoothLine | 23
chChartTypeScatterLineMarkers | 24
chChartTypeScatterLine | 25
chChartTypeScatterLineFilled | 26
chChartTypeBubble | 27
chChartTypeBubbleLine | 28
chChartTypeArea | 29
chChartTypeAreaStacked | 30
chChartTypeAreaStacked100 | 31
chChartTypeDoughnut | 32
chChartTypeDoughnutExploded | 33
chChartTypeRadarLine | 34
chChartTypeRadarLineMarkers | 35
chChartTypeRadarLineFilled | 36
chChartTypeRadarSmoothLine | 37
chChartTypeRadarSmoothLineMarkers | 38
chChartTypeStockHLC | 39
chChartTypeStockOHLC | 40
chChartTypePolarMarkers | 41
chChartTypePolarLine | 42
chChartTypePolarLineMarkers | 43
chChartTypePolarSmoothLine | 44
chChartTypePolarSmoothLineMarkers | 45


ChartColorIndexEnum-Konstanten

Konstante | Wert
chColorNone | -2
chColorAutomatic | -1


ChartDataGroupingFunctionEnum-Konstanten

Konstante | Wert
chDataGroupingFunctionMinimum | 0
chDataGroupingFunctionMaximum | 1
chDataGroupingFunctionSum | 2
chDataGroupingFunctionAverage | 3


ChartDataLabelPositionEnum-Konstanten

Konstante | Wert
chLabelPositionAutomatic | 0
chLabelPositionCenter | 1
chLabelPositionInsideEnd | 2
chLabelPositionInsideBase | 3
chLabelPositionOutsideEnd | 4
chLabelPositionOutsideBase | 5
chLabelPositionLeft | 6
chLabelPositionRight | 7
chLabelPositionTop | 8
chLabelPositionBottom | 9


ChartDataSourceTypeEnum-Konstanten

Konstante | Wert
chDataSourceTypeUnknown | 0
chDataSourceTypeSpreadsheet | 1
chDataSourceTypeRecordset | 2
chDataSourceTypePivotlist | 3


ChartDimensionsEnum-Konstanten

Konstante | Wert
chDimSeriesNames | 0
chDimCategories | 1
chDimValues | 2
chDimYValues | 3
chDimXValues | 4
chDimOpenValues | 5
chDimCloseValues | 6
chDimHighValues | 7
chDimLowValues | 8
chDimBubbleValues | 9
chDimRValues | 10
chDimThetaValues | 11


ChartEndStyleEnum-Konstanten

Konstante | Wert
chEndStyleNone | 1
chEndStyleCap | 2


ChartErrorBarCustomValuesEnum-Konstanten

Konstante | Wert
chErrorBarPlusValues | 12
chErrorBarMinusValues | 13


ChartErrorBarDirectionEnum-Konstanten

Konstante | Wert
chErrorBarDirectionY | 0
chErrorBarDirectionX | 1


ChartErrorBarIncludeEnum-Konstanten

Konstante | Wert
chErrorBarIncludePlusValues | 0
chErrorBarIncludeMinusValues | 1
chErrorBarIncludeBoth | 2


ChartErrorBarTypeEnum-Konstanten

Konstante | Wert
chErrorBarTypeFixedValue | 0
chErrorBarTypePercent | 1
chErrorBarTypeCustom | 2


ChartFillStyleEnum-Konstanten

Konstante | Wert
chNone | -1
chSolid | 0


ChartLegendPositionEnum-Konstanten

Konstante | Wert
chLegendPositionAutomatic | 0
chLegendPositionTop | 1
chLegendPositionBottom | 2
chLegendPositionLeft | 3
chLegendPositionRight | 4


ChartMarkerStyleEnum-Konstanten

Konstante | Wert
chMarkerStyleNone | 0
chMarkerStyleSquare | 1
chMarkerStyleDiamond | 2
chMarkerStyleTriangle | 3
chMarkerStyleX | 4
chMarkerStyleStar | 5
chMarkerStyleDot | 6
chMarkerStyleDash | 7
chMarkerStyleCircle | 8
chMarkerStylePlus | 9


ChartPivotDataReferenceEnum-Konstanten

Konstante | Wert
chPivotRowAggregates | -4
chPivotColAggregates | -3
chPivotRows | -2
chPivotColumns | -1


ChartScaleOrientationEnum-Konstanten

Konstante | Wert
chScaleOrientationMinMax | 0
chScaleOrientationMaxMin | 1


ChartScaleTypeEnum-Konstanten

Konstante | Wert
chScaleTypeLinear | 0
chScaleTypeLogarithmic | 1


ChartSelectionsEnum-Konstanten

Konstante | Wert
chSelectionNone | -1
chSelectionAxis | 0
chSelectionChart | 1
chSelectionPlotArea | 2
chSelectionDataLabels | 3
chSelectionErrorbars | 4
chSelectionGridlines | 5
chSelectionLegend | 6
chSelectionLegendEntry | 7
chSelectionPoint | 8
chSelectionSeries | 9
chSelectionTitle | 10
chSelectionTrendline | 11
chSelectionWebChart | 12


ChartSeriesByEnum-Konstanten

Konstante | Wert
chSeriesByRows | 0
chSeriesByColumns | 1


ChartSeriesScalingsEnum-Konstanten

Konstante | Wert
chCategoryScaling | 0
chValueScaling | 1
chValueScaling1 | 2
chValueScaling2 | 3


ChartSizeRepresentsEnum-Konstanten

Konstante | Wert
chSizeIsWidth | 0
chSizeIsArea | 1


ChartSpecialDataSourcesEnum-Konstanten

Konstante | Wert
chDataNone | -2
chDataLiteral | -1


ChartTickMarkEnum-Konstanten

Konstante | Wert
chTickMarkAutomatic | 0
chTickMarkNone | 1
chTickMarkInside | 2
chTickMarkOutside | 3
chTickMarkCross | 4


ChartTitlePositionEnum-Konstanten

Konstante | Wert
chTitlePositionAutomatic | 0
chTitlePositionTop | 1
chTitlePositionBottom | 2
chTitlePositionLeft | 3
chTitlePositionRight | 4


ChartTrendlineTypeEnum-Konstanten

Konstante | Wert
chTrendlineTypeExponential | 0
chTrendlineTypeLinear | 1
chTrendlineTypeLogarithmic | 2
chTrendlineTypePolynomial | 3
chTrendlineTypePower | 4


ChartWizardTypeEnum-Konstanten

Konstante | Wert
chWizardFull | 0
chWizardChartType | 1
chWizardSourceData | 2


DaPivotLocationEnum-Konstanten

Konstante | Wert
dplRowArea | 1
dplColumnArea | 2
dplFilterArea | 3
dplDataArea | 4
dplDetails | 5


DefaultControlTypeEnum-Konstanten

Konstante | Wert
ctlTypeTextBox | 0
ctlTypeBoundHTML | 1


DscAdviseTypeEnum-Konstanten

Konstante | Wert
dscAdd | 1
dscDelete | 2
dscMove | 3
dscLoad | 4
dscChange | 5
dscDeleteComplete | 6


DscDropLocationEnum-Konstanten

Konstante | Wert
dscAbove | 1
dscWithin | 2
dscBelow | 3


DscDropTypeEnum-Konstanten

Konstante | Wert
dscDefault | 0
dscGrid | 1
dscFields | 2


DscFetchTypeEnum-Konstanten

Konstante | Wert
dscFull | 1
dscParameterized | 2


DscFieldTypeEnum-Konstanten

Konstante | Wert
dscParameter | -1
dscOutput | 1
dscCalculated | 2
dscGrouping | 3


DscGroupOnEnum-Konstanten

Konstante | Wert
dscNoGrouping | -1
dscEachValue | 0
dscPrefix | 1
dscYear | 2
dscQuarter | 3
dscMonth | 4
dscWeek | 5
dscDay | 6
dscHour | 7
dscMinute | 8
dscInterval | 9


DscHyperlinkPartEnum-Konstanten

Konstante | Wert
dschlDisplayedValue | 0
dschlDisplayText | 1
dschlAddress | 2
dschlSubAddress | 3
dschlScreenTip | 4
dschlFullAddress | 5


DscJoinTypeEnum-Konstanten

Konstante | Wert
dscInnerJoin | 1
dscLeftOuterJoin | 2
dscRightOuterJoin | 3


DscLocationEnum-Konstanten

Konstante | Wert
dscSystem | -1
dscClient | 0
dscServer | 1


DscObjectTypeEnum-Konstanten

Konstante | Wert
dscobjUnknown | -1
dscobjSchemaRowsource | 1
dscobjSchemaField | 2
dscobjSchemaRelationship | 4
dscobjRecordsetDef | 8
dscobjPageRowsource | 16
dscobjPageField | 32
dscobjSublistRelationship | 64
dscobjLookupRelationship | 128
dscobjGroupingDef | 256
dscobjDatamodel | 512
dscobjPageRelatedField | 1024
dscobjParameterValue | 2048
dscobjSchemaRelatedField | 4096
dscobjSchemaParameter | 8192


DscPageRelTypeEnum-Konstanten

Konstante | Wert
dscSublist | 1
dscLookup | 2


DscRecordsetTypeEnum-Konstanten

Konstante | Wert
dscSnapshot | 1
dscUpdatableSnapshot | 2


DscRowsourceTypeEnum-Konstanten

Konstante | Wert
dscTable | 1
dscView | 2
dscCommandText | 3
dscProcedure | 4
dscCommandFile | 5


DscTotalTypeEnum-Konstanten

Konstante | Wert
dscNone | 0
dscSum | 1
dscAvg | 2
dscMin | 3
dscMax | 4
dscCount | 5
dscAny | 6
dscStdev | 7


ExpandBitmapTypeEnum-Konstanten

Konstante | Wert
ecBitmapPlusMinus | 0
ecBitmapUpDownArrow | 1
ecBitmapOpenCloseFolder | 2


LineStyleEnum-Konstanten

Konstante | Wert
owcLineStyleNone | 0
owcLineStyleAutomatic | 1
owcLineStyleSolid | 2
owcLineStyleDash | 3
owcLineStyleDot | 4
owcLineStyleDashDot | 5
owcLineStyleDashDotDot | 6


LineWeightEnum-Konstanten

Konstante | Wert
owcLineWeightHairline | 0
owcLineWeightThin | 1
owcLineWeightMedium | 2
owcLineWeightThick | 3


NavButtonEnum-Konstanten

Konstante | Wert
navbtnMoveFirst | 0
navbtnMovePrev | 1
navbtnMoveNext | 2
navbtnMoveLast | 3
navbtnNew | 4
navbtnDelete | 5
navbtnSave | 6
navbtnUndo | 7
navbtnSortAscending | 8
navbtnSortDescending | 9
navbtnApplyFilter | 10
navbtnToggleFilter | 11
navbtnHelp | 12


PivotExportActionEnum-Konstanten

Konstante | Wert
plExportActionNone | 0
plExportActionOpenInExcel | 1


PivotFieldFilterFunctionEnum-Konstanten

Konstante | Wert
plFilterFunctionNone | 0
plFilterFunctionInclude | 1
plFilterFunctionExclude | 2


PivotFieldGroupOnEnum-Konstanten

Konstante | Wert
plGroupOnEachValue | 0
plGroupOnPrefixChar | 1
plGroupOnYears | 2
plGroupOnQtrs | 3
plGroupOnMonths | 4
plGroupOnWeeks | 5
plGroupOnDays | 6
plGroupOnHours | 7
plGroupOnMinutes | 8
plGroupOnSeconds | 9
plGroupOnInterval | 10


PivotFieldSetOrientationEnum-Konstanten

Konstante | Wert
plOrientationNone | 0
plOrientationColumnAxis | 1
plOrientationRowAxis | 2
plOrientationFilterAxis | 4
plOrientationDataAxis | 8


PivotFieldSetTypeEnum-Konstanten

Konstante | Wert
plFieldSetTypeTime | 1
plFieldSetTypeOther | 2
plFieldSetTypeUnknown | 3
plFieldSetTypeUserDefined | 4


PivotFieldSortDirectionEnum-Konstanten

Konstante | Wert
plSortDirectionDefault | 0
plSortDirectionAscending | 1
plSortDirectionDescending | 2


PivotFieldTypeEnum-Konstanten

Konstante | Wert
plTypeRegular | 1
plTypeCalculated | 2
plTypeTime | 3
plTypeTimeYears | 4
plTypeTimeHalfYears | 5
plTypeTimeQuarters | 6
plTypeTimeMonths | 7
plTypeTimeWeeks | 8
plTypeTimeDays | 9
plTypeTimeHours | 10
plTypeTimeMinutes | 11
plTypeTimeSeconds | 12
plTypeTimeUndefined | 13
plTypeUnknown | 14
plTypeUserDefined | 15


PivotHAlignmentEnum-Konstanten

Konstante | Wert
plHAlignAutomatic | 0
plHAlignLeft | 1
plHAlignCenter | 2
plHAlignRight | 3


PivotQueryReasonEnum-Konstanten

Konstante | Wert
plQueryReasonInsertFieldSet | 0
plQueryReasonRemoveFieldSet | 1
plQueryReasonInsertTotal | 2
plQueryReasonRemoveTotal | 3
plQueryReasonAllowDetailsChange | 4
plQueryReasonSortDirectionChange | 5
plQueryReasonSortOnChange | 6
plQueryReasonSortOnScopeChange | 7
plQueryReasonFilterFunctionChange | 8
plQueryReasonFilterMemberChange | 9
plQueryReasonIsIncludedChange | 10
plQueryReasonExpressionChange | 11
plQueryReasonDisplayEmptyMembersChange | 12
plQueryReasonTotalFunctionChange | 13
plQueryReasonUser | 14
plQueryReasonDataSourceChange | 15
plQueryReasonDataMemberChange | 16
plQueryReasonGroupOnChange | 17
plQueryReasonUnknown | 18
plQueryReasonGroupOffsetChange | 19
plQueryReasonGroupIntervalChange | 20
plQueryReasonIsFilteredChange | 21


PivotTableMemberExpandEnum-Konstanten

Konstante | Wert
plMemberExpandAutomatic | 0
plMemberExpandAlways | 1
plMemberExpandNever | 2


PivotTableReasonEnum-Konstanten

Konstante | Wert
plPivotTableReasonTotalAdded | 0
plPivotTableReasonTotalDeleted | 1
plPivotTableReasonFieldSetAdded | 2
plPivotTableReasonFieldSetDeleted | 3
plPivotTableReasonFieldAdded | 4


PivotTotalFunctionEnum-Konstanten

Konstante | Wert
plFunctionSum | 1
plFunctionCount | 2
plFunctionMin | 3
plFunctionMax | 4


PivotTotalTypeEnum-Konstanten

Konstante | Wert
plTotalTypeIntrinsic | 1
plTotalTypeUserDefined | 2


PivotViewReasonEnum-Konstanten

Konstante | Wert
plViewReasonSelectionChange | 0
plViewReasonSubtotalsChange | 1
plViewReasonSystemColorChange | 2
plViewReasonQuery | 3
plViewReasonFontNameChange | 4
plViewReasonFontSizeChange | 5
plViewReasonFontBoldChange | 6
plViewReasonFontItalicChange | 7
plViewReasonFontUnderlineChange | 8
plViewReasonMemberExpandedChange | 9
plViewReasonCellExpandedChange | 10
plViewReasonDetailRowHeightChange | 11
plViewReasonFieldDetailWidthChange | 12
plViewReasonFieldGroupedWidthChange | 13
plViewReasonViewDetailWidthChange | 14
plViewReasonFieldSetWidthChange | 15
plViewReasonTotalWidthChange | 16
plViewReasonForeColorChange | 17
plViewReasonBackColorChange | 18
plViewReasonAlignmentChange | 19
plViewReasonNumberFormatChange | 20
plViewReasonDetailTopChange | 21
plViewReasonDetailLeftChange | 22
plViewReasonTopChange | 23
plViewReasonLeftChange | 24
plViewReasonRightToLeftChange | 25
plViewReasonTotalOrientationChange | 26
plViewReasonDisplayOutlineChange | 27
plViewReasonFieldCaptionChange | 28
plViewReasonFieldSetCaptionChange | 29
plViewReasonLabelCaptionChange | 30
plViewReasonMemberCaptionChange | 31
plViewReasonTotalCaptionChange | 32
plViewReasonAllowFilteringChange | 33
plViewReasonAllowGroupingChange | 34
plViewReasonWidthChange | 35
plViewReasonHeightChange | 36
plViewReasonLabelVisibleChange | 37
plViewReasonDisplayToolbarChange | 38
plViewReasonMaxHeightChange | 39
plViewReasonMaxWidthChange | 40
plViewReasonAutoFitChange | 41
plViewReasonFieldExpandedChange | 42
plViewReasonCellsExpandedChange | 43
plViewReasonDetailMaxWidthChange | 44
plViewReasonDetailMaxHeightChange | 45


PivotViewTotalOrientationEnum-Konstanten

Konstante | Wert
plTotalOrientationRow | 1
plTotalOrientationColumn | 2


ProviderType-Konstanten

Konstante | Wert
providerTypeUnknown | 1
providerTypeRelational | 2
providerTypeMultidimensional | 3


SectTypeEnum-Konstanten

Konstante | Wert
sectTypeNone | 0
sectTypeCaption | 1
sectTypeHeader | 2
sectTypeFooter | 3
sectTypeRecNav | 4


SheetBorderTypeEnum-Konstanten

Konstante | Wert
ssEdgeAll | 0
ssEdgeBottom | 1
ssEdgeLeft | 2
ssEdgeRight | 3
ssEdgeTop | 4
ssInsideHorizontal | 5
ssInsideVertical | 6


SheetCommandEnum-Konstanten

Konstante | Wert
ssCalculate | 0
ssInsertRows | 2
ssInsertColumns | 3
ssDeleteRows | 4
ssDeleteColumns | 5
ssCut | 6
ssCopy | 7
ssPaste | 8
ssExport | 9
ssUndo | 10
ssSortAscending | 11
ssSortDescending | 12
ssFind | 13
ssClear | 14
ssAutoFilter | 15
ssProperties | 16
ssHelp | 17


SheetDirectionEnum-Konstanten

Konstante | Wert
ssDown | 0
ssToLeft | 1
ssToRight | 2
ssUp | 3


SheetExportActionEnum-Konstanten

Konstante | Wert
ssExportActionNone | 0
ssExportActionOpenInExcel | 1


SheetFilterFunction-Konstanten

Konstante | Wert
ssFilterFunctionInclude | 1
ssFilterFunctionExclude | 2


SheetFindLookAtEnum-Konstanten

Konstante | Wert
ssPart | 0
ssWhole | 1


SheetFindLookInEnum-Konstanten

Konstante | Wert
ssFormulas | 0
ssValues | 1


SheetFreezePanesEnum-Konstanten

Konstante | Wert
ssFreezeLeft | 1
ssFreezeRight | 2 (für zukünftige Verwendungen vorgesehen)
ssFreezeTop | 4
ssFreezeBottom | 8 (für zukünftige Verwendungen vorgesehen)
ssFreezeNone | 16


SheetHAlignEnum-Konstanten

Konstante | Wert
ssHAlignGeneral | 0
ssHAlignLeft | 1
ssHAlignCenter | 2
ssHAlignRight | 3


SheetSearchDirectionEnum-Konstanten

Konstante | Wert
ssNext | 0
ssPrevious | 1


SheetSearchOrderEnum-Konstanten

Konstante | Wert
ssByColumns | 0
ssByRows | 1


SheetSortOrderEnum-Konstanten

Konstante | Wert
ssAscending | 0
ssDescending | 1


SheetTriStateEnum-Konstanten

Konstante | Wert
ssAuto | -1
ssOff | 0
ssOn | 1


SheetVAlignEnum-Konstanten

Konstante | Wert
ssVAlignBottom | 0
ssVAlignCenter | 1
ssVAlignTop | 2


SheetYesNoGuessEnum-Konstanten

Konstante | Wert
ssGuess | 0
ssYes | 1
ssNo | 2


UnderlineStyleEnum-Konstanten

Konstante | Wert
owcUnderlineStyleNone | 0
owcUnderlineStyleSingle | 1
owcUnderlineStyleDouble | 2
owcUnderlineStyleSingleAccounting | 3
owcUnderlineStyleDoubleAccounting | 4


Erstellen eines Diagramms unter Verwendung von Daten, die als Matrix angegeben werden

In diesem Beispiel wird ein Diagramm erstellt, das Daten verwendet, die als Matrix angegeben sind. Diese Matrizes werden auf die Rubriken- und Größendaten umgesetzt. Anschließend werden die Matrizes mit der SetData-Methode behandelt, um die Diagrammdaten festzulegen.

Um dieses Beispiel auszuführen, kopieren Sie den Rest des Textes zu diesem Thema auf eine HTML-Seite.

<object id=ChartSpace1 classid=CLSID:0002E500-0000-0000-C000-000000000046 style="width:100%;height:350"></object>

<script language=vbs>
Sub Window_OnLoad()
Dim categories(3), values(3)

    ' Create a column chart with three series and four categories, showing the
    ' percentage of voters for the 1992 presidential election by race/ethic group.

    ' Create an array of strings representing the categories.
    ' The categories will be the same for all three series.
    categories(0) = "White"
    categories(1) = "Black"
    categories(2) = "Asian"
    categories(3) = "Latino"

    ' Clear the contents of the chart workspace. This removes
    ' any old charts that may already exist and leaves the chart workspace
    ' completely empty. One chart object is then added.
    ChartSpace1.Clear
    ChartSpace1.Charts.Add
    Set c = ChartSpace1.Constants

    ' Add three series to the chart.
    ChartSpace1.Charts(0).SeriesCollection.Add
    ChartSpace1.Charts(0).SeriesCollection.Add
    ChartSpace1.Charts(0).SeriesCollection.Add

    ' Series one contains election data for Perot.
    ' Set the series caption (the text that appears in the legend).
    ChartSpace1.Charts(0).SeriesCollection(0).Caption = "Perot"

    ' Set the categories for the first series (this collection is zero-based)
    ChartSpace1.Charts(0).SeriesCollection(0).SetData c.chDimCategories, c.chDataLiteral, categories

values(0) = 0.2 ' The White value.
values(1) = 0.06 ' The Black value.
values(2) = 0.17 ' The Asian value.
values(3) = 0.13 ' The Latino value.

ChartSpace1.Charts(0).SeriesCollection(0).Caption = "Perot"
ChartSpace1.Charts(0).SeriesCollection(0).SetData c.chDimCategories, c.chDataLiteral, categories
ChartSpace1.Charts(0).SeriesCollection(0).SetData c.chDimValues, c.chDataLiteral, values

    ' Series two contains election data for Clinton.
    ' Update the values array, then set the chart data.
    values(0) = 0.38 ' The White value.
    values(1) = 0.82 ' The Black value.
    values(2) = 0.28 ' The Asian value.
    values(3) = 0.62 ' The Latino value.

    ChartSpace1.Charts(0).SeriesCollection(1).Caption = "Clinton"
    ChartSpace1.Charts(0).SeriesCollection(1).SetData c.chDimCategories, c.chDataLiteral, categories
    ChartSpace1.Charts(0).SeriesCollection(1).SetData c.chDimValues, c.chDataLiteral, values

    ' Series two contains election data for Bush.
    ' Update the values array, and then set the chart data.
    values(0) = 0.42 ' The White value.
    values(1) = 0.12 ' The Black value.
    values(2) = 0.55 ' The Asian value.
    values(3) = 0.25 ' The Latino value.

    ChartSpace1.Charts(0).SeriesCollection(2).Caption = "Bush"
    ChartSpace1.Charts(0).SeriesCollection(2).SetData c.chDimCategories, c.chDataLiteral, categories
    ChartSpace1.Charts(0).SeriesCollection(2).SetData c.chDimValues, c.chDataLiteral, values

    ' Make the chart legend visible, format the left value axis as percentage,
    ' and specify that value gridlines are at 10% intervals.
    ChartSpace1.Charts(0).HasLegend = True
    ChartSpace1.Charts(0).Axes(c.chAxisPositionLeft).NumberFormat = "0%"
    ChartSpace1.Charts(0).Axes(c.chAxisPositionLeft).MajorUnit = 0.1
End Sub
</script>


Erstellen eines Diagramms unter Verwendung von Daten aus einem Microsoft Office-Datenquellensteuerelement

In diesem Beispiel wird ein Diagramm aus Daten erstellt, die von einer SQL-Abfrage zurückgegeben werden. Ein Datenquellensteuerelement wird dazu verwendet, um eine Verbindung zur SQL-Datenbank herzustellen und die Abfrage auszuführen. Zuletzt wird die SetData-Methode verwendet, um die Diagrammrubriken und -größenwerte unter Verwendung von Feldern in der Datensatzgruppe festzulegen.

Um dieses Beispiel auszuführen, kopieren Sie den Rest des Textes zu diesem Thema auf eine HTML-Seite.

<object id=ChartSpace1 classid=CLSID:0002E500-0000-0000-C000-000000000046 style="width:100%;height:480"></object>
<object id=DataSourceControl1 classid=CLSID:0002E530-0000-0000-C000-000000000046></object>

<script language=vbs>
Sub window_onLoad()
    Dim rsd

    DataSourceControl1.ConnectionString = "DRIVER={SQL Server};SERVER=vdata;DATABASE=pubs;UID=sa;PWD=;"
    Set rsd = DataSourceControl1.RecordsetDefs.AddNew("SELECT lname, job_lvl FROM Employee ORDER BY lname DESC", 3)

    Set c = ChartSpace1.Constants
    ChartSpace1.DataSource = DataSourceControl1
    ChartSpace1.DataMember = rsd.Name
    ChartSpace1.Charts.Add
    ChartSpace1.Charts(0).Type = c.chChartTypeBarClustered
    ChartSpace1.Charts(0).SetData c.chDimCategories, 0, "lname"
    ChartSpace1.Charts(0).SetData c.chDimValues, 0, "job_lvl"
End Sub
</script>


Erstellen eines Diagramms unter Verwendung von Daten aus einer ADO-Datensatzgruppe

In diesem Beispiel wird ein Diagramm unter Verwendung von Daten aus einer ADO-Datensatzgruppe erstellt. Aus den zurückgegebenen Daten der Datensatzgruppe wird eine durch Tabulatoren unterteilte Zeichenfolge erstellt. Anschließend wird auf diese Zeichenfolge die SetData-Methode angewendet, um die Diagrammdaten festzulegen.

Um dieses Beispiel auszuführen, kopieren Sie den Rest des Textes zu diesem Thema auf eine HTML-Seite.

<object id=ChartSpace1 classid=CLSID:0002E500-0000-0000-C000-000000000046 style="width:100%;height:350"></object>
<object id=ADOConnection1 classid=CLSID:00000514-0000-0010-8000-00AA006D2EA4></object>

<script language=vbs>
Sub Window_OnLoad()
    Dim rs, categories, values

    ' This example connects to the Northwind sample database
    ' and charts the Query "Category Sales for 1995". ADO is used to open a
    ' connection to the database and return the entire recordset. The query
    ' contains two columns: Category Name and Category Sales.
    ' The records are then extracted into strings.

    categories = ""
    values = ""

    ' Open the connection and execute the query.
    ADOConnection1.Open "DRIVER={Microsoft Access Driver (*.mdb)};DBQ=c:\nwind.mdb"
    Set rs = ADOConnection1.Execute("SELECT * FROM [Category Sales for 1995]")

    ' Start at the first record and move through the entire recordset.
    ' Field 0 is the category name, Field 1 is the sales value.
    ' Create a tab-delimited string for the names and one for the values.
    rs.MoveFirst
    While Not rs.EOF
        categories = categories & rs.Fields(0).Value & Chr(9)
        values = values & rs.Fields(1).Value & Chr(9)
        rs.MoveNext
    Wend
    rs.Close
    ADOConnection1.Close

    ' Remove the leftover tab character at the end of the strings.
    categories = Left(categories, Len(categories) - 1)
    values = Left(values, Len(values) - 1)

    ' Create a chart with one series (called "Sales").
    ChartSpace1.Clear
    ChartSpace1.Charts.Add
    ChartSpace1.Charts(0).SeriesCollection.Add
    ChartSpace1.Charts(0).SeriesCollection(0).Caption = "Sales"

    'Set the series categories and values using the strings created from the recordset.
    Set c = ChartSpace1.Constants
    ChartSpace1.Charts(0).SeriesCollection(0).SetData c.chDimCategories, c.chDataLiteral, categories
    ChartSpace1.Charts(0).SeriesCollection(0).SetData c.chDimValues, c.chDataLiteral, values

    ' Set the chart type and format the axis as U.S. dollars.
    ChartSpace1.Charts(0).Type = c.chChartTypeBarClustered
    ChartSpace1.Charts(0).Axes(c.chAxisPositionBottom).NumberFormat = "$#,##0"
End Sub
</script>


Erstellen eines Diagramms unter Verwendung von Daten aus einer Microsoft Office-Kalkulationstabelle

In diesem Beispiel wird ein Diagramm aus Daten erstellt, die in einer Microsoft Office-Kalkulationstabelle angegeben wurden. Das Diagramm wird unter Verwendung der DataSource-Eigenschaft mit der Kalkulationstabelle verbunden. Anschließend wird die SetData-Methode verwendet, um die Diagrammdaten aus den Bereichen in der Kalkulationstabelle festzulegen.

Um dieses Beispiel auszuführen, kopieren Sie den Rest des Textes zu diesem Thema auf eine HTML-Seite.

<object id=ChartSpace1 classid=CLSID:0002E500-0000-0000-C000-000000000046 style="width:49%;height:350"></object>
<object id=Spreadsheet1 classid=CLSID:0002E510-0000-0000-C000-000000000046 style="width:49%;height:350"></object>
<br><small><b>Source: </b>Voters Research and Surveys</small><p>

<script language=vbs>
Sub Window_OnLoad()
    ' This example starts by putting the data into Spreadsheet1. Normally,
    ' the data would already be loaded, but this code was added for completeness.
    Spreadsheet1.ActiveSheet.Cells.Clear
    Spreadsheet1.ActiveSheet.Cells(2, 1).Value = "White"
    Spreadsheet1.ActiveSheet.Cells(3, 1).Value = "Black"
    Spreadsheet1.ActiveSheet.Cells(4, 1).Value = "Asian"
    Spreadsheet1.ActiveSheet.Cells(5, 1).Value = "Latino"

    Spreadsheet1.ActiveSheet.Cells(1, 2).Value = "Perot"
    Spreadsheet1.ActiveSheet.Cells(2, 2).Value = 0.2
    Spreadsheet1.ActiveSheet.Cells(3, 2).Value = 0.06
    Spreadsheet1.ActiveSheet.Cells(4, 2).Value = 0.17
    Spreadsheet1.ActiveSheet.Cells(5, 2).Value = 0.13

    Spreadsheet1.ActiveSheet.Cells(1, 3).Value = "Clinton"
    Spreadsheet1.ActiveSheet.Cells(2, 3).Value = 0.38
    Spreadsheet1.ActiveSheet.Cells(3, 3).Value = 0.82
    Spreadsheet1.ActiveSheet.Cells(4, 3).Value = 0.28
    Spreadsheet1.ActiveSheet.Cells(5, 3).Value = 0.62

    Spreadsheet1.ActiveSheet.Cells(1, 4).Value = "Bush"
    Spreadsheet1.ActiveSheet.Cells(2, 4).Value = 0.42
    Spreadsheet1.ActiveSheet.Cells(3, 4).Value = 0.12
    Spreadsheet1.ActiveSheet.Cells(4, 4).Value = 0.55
    Spreadsheet1.ActiveSheet.Cells(5, 4).Value = 0.25

    ' Clear the contents of the chart workspace. This removes
    ' any old charts that may already exist and leaves the chart workspace
    ' completely empty. One chart object is then added.
    ChartSpace1.Clear
    ChartSpace1.Charts.Add
    Set c = ChartSpace1.Constants

    ' Set the chart DataSource property to the spreadsheet.
    ' It is possible to specify multiple data sources, but this example uses only one.
    ChartSpace1.DataSource = Spreadsheet1

    ' Add three series to the chart.
    ChartSpace1.Charts(0).SeriesCollection.Add
    ChartSpace1.Charts(0).SeriesCollection.Add
    ChartSpace1.Charts(0).SeriesCollection.Add

    ' Connect the chart to data by specifying spreadsheet cell references
    ' for the different data dimensions. Notice that the SetData method uses
    ' a data source index of 0; this is the first data source, which was previously
    ' set to the spreadsheet. If you had created multiple data sources,
    ' you could specify the index to any item in the WCDataSources collection for the
    ' data source index. For example, if two spreadsheet controls were attached to this
    ' chart workspace, you could set data from the first control using index 0
    ' and set data from the second control using index 1.

    ' Notice that the series name is also bound to a spreadsheet cell. Changing
    ' the contents of the cell "B1" will also change the name that appears in the legend.
    ' If you don't want this behavior, set SeriesCollection(0).Caption instead of
    ' using the SetData method to bind the series name to the spreadsheet.

    ' Series one contains election data for Perot.
    ' Bind the series name, the category names, and the values.
    ChartSpace1.Charts(0).SeriesCollection(0).SetData c.chDimSeriesNames, 0, "B1"
    ChartSpace1.Charts(0).SeriesCollection(0).SetData c.chDimCategories, 0, "A2:A5"
    ChartSpace1.Charts(0).SeriesCollection(0).SetData c.chDimValues, 0, "B2:B5"

    ' Series two contains election data for Clinton.
    ChartSpace1.Charts(0).SeriesCollection(1).SetData c.chDimSeriesNames, 0, "C1"
    ChartSpace1.Charts(0).SeriesCollection(1).SetData c.chDimCategories, 0, "A2:A5"
    ChartSpace1.Charts(0).SeriesCollection(1).SetData c.chDimValues, 0, "C2:C5"

    ' Series two contains election data for Bush.
    ChartSpace1.Charts(0).SeriesCollection(2).SetData c.chDimSeriesNames, 0, "D1"
    ChartSpace1.Charts(0).SeriesCollection(2).SetData c.chDimCategories, 0, "A2:A5"
    ChartSpace1.Charts(0).SeriesCollection(2).SetData c.chDimValues, 0, "D2:D5"

    ' Make the chart legend visible, format the left value axis as percentage,
    ' and specify that value gridlines are at 10% intervals.
    ChartSpace1.Charts(0).HasLegend = True
    ChartSpace1.Charts(0).Axes(c.chAxisPositionLeft).NumberFormat = "0%"
    ChartSpace1.Charts(0).Axes(c.chAxisPositionLeft).MajorUnit = 0.1
End Sub
</script>


Erstellen eines Diagramms unter Verwendung von Daten, die als Zeichenketten angegeben werden

In diesem Beispiel wid ein Diagramm erstellt, das Daten verwendet, die in Form von Zeichenketten angegeben sind. Die durch Tabulatoren getrennten Zeichenketten werden in die Rubriken- und Größendaten umgesetzt. Anschließend wird auf diese Zeichenketten die SetData-Methode angewendet, um die Diagrammdaten festzulegen.

Um dieses Beispiel auszuführen, kopieren Sie den Rest des Textes zu diesem Thema auf eine HTML-Seite.

<object id=ChartSpace1 classid=CLSID:0002E500-0000-0000-C000-000000000046 style="width:100%;height:350"></object>
<br><small><b>Source: </b>Voters Research and Surveys</small>

<script language=vbs>
Sub Window_OnLoad()
    Dim categories, values

    ' Create a column chart with three series and four categories, showing the
    'percentage of voters for the 1992 presidential election by race/ethic group.

    ' Clear the contents of the chart workspace. This removes
    ' any old charts that may already exist and leaves the chart workspace
    ' completely empty. One chart object is then added.
    ChartSpace1.Clear
    ChartSpace1.Charts.Add
    Set c = ChartSpace1.Constants

    ' Set a tab-delimited string to the category data.
    categories = "White" & Chr(9) & "Black" & Chr(9) & "Asian" & Chr(9) & "Latino"

    ' Add three series to the chart.
    ChartSpace1.Charts(0).SeriesCollection.Add
    ChartSpace1.Charts(0).SeriesCollection.Add
    ChartSpace1.Charts(0).SeriesCollection.Add

    ' Series one contains election data for Perot.
    ' Set the series caption (the text that appears in the legend).
    ChartSpace1.Charts(0).SeriesCollection(0).Caption = "Perot"

    ' Set the categories for the first series (this collection is zero-based).
    ChartSpace1.Charts(0).SeriesCollection(0).SetData c.chDimCategories, c.chDataLiteral, categories

    ' Set a tab-delimited string to the values for Perot, and then set the series values.
    values = "0.2" & Chr(9) & "0.06" & Chr(9) & "0.17" & Chr(9) & "0.13"
    ChartSpace1.Charts(0).SeriesCollection(0).SetData c.chDimValues, c.chDataLiteral, values

    ' Series two contains election data for Clinton.
    ' Update the values string, and then set the chart data.
    values = "0.38" & Chr(9) & "0.82" & Chr(9) & "0.28" & Chr(9) & "0.62"
    ChartSpace1.Charts(0).SeriesCollection(1).Caption = "Clinton"
    ChartSpace1.Charts(0).SeriesCollection(1).SetData c.chDimCategories, c.chDataLiteral, categories
    ChartSpace1.Charts(0).SeriesCollection(1).SetData c.chDimValues, c.chDataLiteral, values

    ' Series two contains election data for Bush.
    ' Update the values string, and then set the chart data.
    values = "0.42" & Chr(9) & "0.12" & Chr(9) & "0.55" & Chr(9) & "0.25"
    ChartSpace1.Charts(0).SeriesCollection(2).Caption = "Bush"
    ChartSpace1.Charts(0).SeriesCollection(2).SetData c.chDimCategories, c.chDataLiteral, categories
    ChartSpace1.Charts(0).SeriesCollection(2).SetData c.chDimValues, c.chDataLiteral, values

    ' Make the chart legend visible, format the left value axis as percentage,
    ' and specify that value gridlines are at 10% intervals.
    ChartSpace1.Charts(0).HasLegend = True
    ChartSpace1.Charts(0).Axes(c.chAxisPositionLeft).NumberFormat = "0%"
    ChartSpace1.Charts(0).Axes(c.chAxisPositionLeft).MajorUnit = 0.1
End Sub
</script>


Ermitteln einer bestimmten Diagrammachse

Jedes Diagramm enthält die Auflistung WCAxes, die bis zu acht Rubriken- und Größenachsen enthalten kann. Diese Auflistung ist nicht geordnet, deshalb macht das Ermitteln einer bestimmten Achse eine Nummerierung der Auflistung erforderlich.

Beispiel 1: Suchen und Zurückgeben der ersten Rubrikenachse

Function FindCategoryAxis(chart)
   Dim i, c

   Set c = chart.Parent.Constants
   For i = 0 To chart.Axes.Count - 1
     If chart.Axes(i).Type = c.chCategoryAxis Then
        Set FindCategoryAxis = chart.Axes(i)
        Exit Function
     End If
   Next
   Set FindCategoryAxis = Nothing
End Function

Beispiel 2: Suchen und Zurückgeben der ersten vertikalen Werteachse

Function FindVerticalValueAxis(chart)
   Dim i, c

   Set c = chart.Parent.Constants
   For i = 0 To chart.Axes.Count - 1
     If chart.Axes(i).Type = c.chValueAxis And _
       (chart.Axes(i).Position = c.chAxisPositionLeft Or _
        chart.Axes(i).Position = c.chAxesPositionRight) Then
           Set FindVerticalValueAxis = chart.Axes(i)
           Exit Function
     End If
   Next
   Set FindVerticalValueAxis = Nothing
End Function


Erstellen eines Diagramms, das mehr als einen Diagrammtyp enthält

Sie können ein Kombinationsdiagramm erstellen, das eine Mischung aus Spalten, Zeilen und Bereichen enthält. Beachten Sie, dass die kombinierten Diagrammtypen eine kompatible Stapelmethode aufweisen müssen (d. h., dass Sie gestapelte Spalten nicht mit Zeilen kombinieren können; Sie können gestapelte Spalten nur mit gestapelten Zeilen kombinieren).

Sowohl Diagramme als auch Datenreihen verfügen über die Type-Eigenschaft. Durch Festlegen der Type-Eigenschaft für das WCChart-Objekt ändert sich der Diagrammtyp für alle Datenreihen. Das Festlegen der Type-Eigenschaft für das WCSeries-Objekt verändert nur diese Datenreihe, wenn der neue Datenreihentyp mit dem übrigen Diagramm kompatibel sein muss. Dies bedeutet, dass Sie ein kombiniertes Spalten- und Zeilendiagramm erstellen, wenn Sie in einem gruppierten Spaltendiagramm eine Datenreihe in Verbindungslinien umwandeln. Wenn Sie andererseits versuchen, eine Datenreihe in einem gruppierten Spaltendiagramm in eine Kreisdatenreihe umzuwandeln, wird das gesamte Diagramm zu einem Kreisdiagramm.


Zurückgeben eines Objekts aus einer Auflistung

Die Item-Eigenschaft gibt ein einzelnes Objekt aus einer Auflistung zurück. Im folgenden Beispiel wird die Variable thisChart auf ein WCChart-Objekt gesetzt, das Diagramm 1 repräsentiert.

Set thisChart = ChartWorkspace1.Charts.Item(1)

Die Item-Eigenschaft ist die Standardeigenschaft der meisten Auflistungen; deshalb können Sie die gleiche Aussage kürzer fassen, indem Sie das Item-Schlüsselwort weglassen.

Set thisChart = ChartWorkspace1.Charts(1)

Einige Auflistungen verwenden einen Aufzählungstyp für ihre Item-Eigenschaft, um spezifische Mitglieder der Auflistung zurückzugeben. Beispielsweise verwendet die WCAxes-Auflistung den nummerierten ChartAxisPositionEnum-Typ, wie es in dem nachfolgenden Beispiel gezeigt wird.

Set c = ChartSpace1.Constants
Set valueAxis = ChartSpace1.Charts(0).Axes.Item(c.chAxisPositionLeft)
Set categoryAxis = ChartSpace1.Charts(0).Axes.Item(c.chAxisPositionBottom)

Auch in diesem Fall können Sie das Item-Schlüsselwort weglassen, wie es im folgenden Beispiel gezeigt wird.

Set c = ChartSpace1.Constants
Set valueAxis = ChartSpace1.Charts(0).Axes(c.chAxisPositionLeft)
Set categoryAxis = ChartSpace1.Charts(0).Axes(c.chAxisPositionBottom)

Weitere Informationen zu einer bestimmten Auflistung finden Sie im Hilfethema zu dieser Auflistung.


Weshalb gibt es eine Diagrammsammlung?

Gründe für das Verwenden von mehr als einem Diagramm

Es gibt viele Fälle, in denen Sie möglicherweise mehr als ein Diagramm in einem Arbeitsbereich verwenden möchten.

  • Sie hätten gerne mehrere Kreisdiagramme.

  • Sie hätten gerne ein Kursdiagramm, das Preis und Menge anzeigt.

  • Sie möchten verwandte Informationen miteinander vergleichen, wobei sich eine Variable von Diagramm zu Diagramm ändert. Ein Beispiel hierfür ist ein Diagramm, das die SAT-Ergebnisse nach Region zeigt. Daraus ergeben sich vier Diagramme: Norden, Süden, Osten und Westen. Jedes vergleicht die Schulbezirke innerhalb der Region über den Median der Ergebnisse miteinander.


Weshalb weisen mehrere Diagramme in einem Diagrammarbeitsbereich dieselben Rubriken auf?

Der Hauptgrund, um über mehrere Diagramme innerhalb eines Diagrammarbeitsbereichs zu verfügen, besteht darin, Informationen anzuzeigen, die Bezüge zu allen Diagrammen aufweisen. Dies funktioniert am besten, wenn alle Diagramme über die gleichen Rubriken verfügen. Wenn Sie mehrere nicht miteinander verbundene Diagramme einsetzen möchten, verwenden Sie mehr als einen Diagrammarbeitsbereich.


Add-Methode (LookupRelationships-Auflistung)

Erstellt eine neue Lookup-Join-Beziehung. Gibt ein PageRelationship-Objekt zurück.

Syntax

Ausdruck.Add(PageRowsource, SchemaRelationship)

Ausdruck Ein Ausdruck, der ein LookupRelationships-Objekt zurückgibt.

PageRowsource Erforderliches PageRowsource-Objekt. Gibt die Seitenzeilenquelle auf der "1"-Seite einer 1:n-Seitenbeziehung an.

SchemaRelationship Erforderliches SchemaRelationship-Objekt. Beschreibt die verbindenden Felder zwischen der übergeordneten Seitenzeilenquelle auf der "n"-Seite der 1:n-Beziehung und der in dieser Methode angegebenen Seitenzeilenquelle.


Add-Methode (PageFields-Auflistung)

Erstellt ein neues Seitenfeld. Gibt ein PageField-Objekt zurück.

Syntax

Ausdruck.Add(Source, FieldType, Name, TotalType, Index)

Ausdruck Ein Ausdruck, der ein PageFields-Objekt zurückgibt.

Source Variant erforderlich. Gibt die Quelle für das neue Seitenfeld an. Bei neuen Feldern des dscOutput-Typs gibt dieses Argument ein SchemaField-Objekt oder den Namen eines Schemafeldes an. Bei Feldern des dscCalculated-Typs gibt dieses Argument den Ausdruck für das berechnete Feld an. Bei neuen Feldern des dscGrouping-Typs gibt dieses Argument ein PageField-Objekt oder den Namen eines Seitenfeldes an, auf dem diese Gruppierung basiert.

FieldType Variant optional. Gibt den neuen Feldtyp an. Der Standardwert und die zulässigen Werte hängen vom übergeordneten Objekt ab, das mit dieser Methode verwendet wird. Weitere Informationen finden Sie im Abschnitt "Hinweise" dieses Themas.

Name Variant optional. Gibt den Namen des neuen Seitenfeldes an. Wenn Sie dieses Argument nicht angeben, ist der Name des Ausgabefeldes identisch mit dem Schemafeld, auf dem es basiert, und der Name des Gruppierungsfelds lautet "By<pagefieldname>" oder "<aggfunction>of<pagefieldname>". Der Name des berechneten Feldes lautet "Expr". In allen Fällen werden automatisch Ziffern angehängt, um den Namen eindeutig zu machen, falls erforderlich.

TotalType Optionales dscTotalTypeEnum-Objekt. Der Standardwert ist dscNone.

Index Variant optional. Gibt die Reihenfolgeposition, den Namen oder die aktuelle Objektreferenz für das Seitenfeld an, bevor die neue Seite hinzugefügt wird. Wenn Sie dieses Argument nicht angeben, wird die neue Seite am Ende der Auflistung hinzugefügt. Verwenden Sie dieses Argument ausschließlich in Zusammenhang mit der PageFieldsAuflistung eines GroupingDef-Objekts. Weitere Informationen finden Sie im Anschluss an diesen Absatz.

Anmerkungen

Die PageFields-Auflistung verfügt über drei verschiedene übergeordnete Objekte: RecordsetDef, PageRowsource und GroupingDef. Verwenden Sie die gleiche Add-Methode für alle diese übergeordneten Objekte. Es gibt jedoch einige Unterschiede bei den Standardwerten und den zulässigen Werten in Abhängigkeit von dem übergeordneten Objekt, das Sie verwenden.

  • Bei RecordsetDef.PageFields.Add ist dscOutput der Standardwert für FieldType. Andere zulässige FieldType-Werte sind dscCalculated und dscGrouping. Wenn FieldType auf dscOutput lautet, wird das angegebene Quellfeld der primären Seitenzeilenquelle in der Datensatzgruppendefinition hinzugefügt. Deshalb muss das Quellfeld in der entsprechenden Schemazeilenquelle vorhanden sein. Wenn FieldType auf dscGrouping lautet, muss der TotalType-Wert anders als dscNone sein (ein nichtaggregiertes Gruppierungsfeld kann nur in einer Gruppierungsdefinition existieren, nicht in einer Datensatzgruppendefinition). Sie können das Index-Argument in diesem Szenario nicht verwenden.

  • Bei PageRowsource.PageFields.Add lautet der Standardwert und einzig zulässige Wert für FieldType auf dscOutput. Der einzige zulässige Wert für TotalType lautet dscNone. Sie können das Index-Argument in diesem Szenario nicht verwenden. Durch Verwenden der Add-Methode können Sie Ausgabefelder hinzufügen, um nach Zeilenquellen zu suchen.

  • Bei GroupingDef.PageFields.Add lautet der Standardwert für FieldType auf dscOutput. Der andere zulässige FieldType-Wert ist dscCalculated. Sie können das Index-Argument in diesem Szenario verwenden (Reihenfolge ist wichtig bei der Gruppierung von Definitionen).


Add-Methode (ParameterValues-Auflistung)

Erstellt einen neuen Parameterwert. Gibt ein ParameterValue-Objekt zurück.

Syntax

Ausdruck.Add(ParameterName, Value)

Ausdruck Ein Ausdruck, der eine ParameterValues-Auflistung zurückgibt.

ParameterName String erforderlich. Gibt den Parameternamen an.

Value Variant optional. Gibt den Wert des Parameters an.


Add-Methode (RecordsetDefs-Auflistung)

Erstellt eine neue Datensatzgruppendefinition. Gibt ein RecordsetDef-Objekt zurück.

Syntax

Ausdruck.Add(SchemaRowsource, Name)

Ausdruck Ein Ausdruck, der ein RecordsetDefs-Objekt zurückgibt.

SchemaRowsource Variant erforderlich. Gibt die Schemareihenquelle an, die zum Erstellen der neuen Datensatzgruppendefinition verwendet wird. Dieses Argument kann entweder ein SchemaRowsource-Objekt oder der Name einer vorhandenen Schemazeilenquelle sein.

Name Variant optional.Name Variant optional. Gibt den Namen der neuen Datensatzgruppendefinition an. Wenn Sie dieses Argument nicht angeben, trägt die neue Datensatzdefinition den gleichen Namen wie die Schemareihenquelle, die im SchemaRowsource-Argument angegeben ist. Wenn es erforderlich ist, werden automatisch Ziffern an den neuen Namen angehängt, um ihn eindeutig zu machen.

Anmerkungen

Durch Verwenden eines einzelnen AddNew-Methodenaufrufs können Sie eine Datensatzgruppendefinition, Seitenzeilenquelle und Schemazeilenquelle erstellen.


Add-Methode (SchemaFields-Auflistung)

Erstellt ein neues Schemafeld. Gibt ein SchemaField-Objekt zurück.

Syntax

Ausdruck.Add(Name, DataType, Length)

Ausdruck Ein Ausdruck, der ein SchemaFields-Objekt zurückgibt.

Name String erforderlich. Gibt den Namen des neuen Schemafeldes an.

DataType Erforderliches DataTypeEnum-ADO. Gibt den Datentyp des neuen Schemafeldes an.

Length Variant optional. Gibt die Länge des neuen Schemafeldes an.

Anmerkungen

Im Entwurfsmodus von Microsoft Access wird die SchemaFields-Auflistung automatisch aus den verfügbaren Schemafeldern erstellt.


Add-Methode (SchemaParameters-Auflistung)

Erstellt einen neuen Schemaparameter. Gibt ein SchemaParameter-Objekt zurück.

Syntax

Ausdruck.Add(Name, DataType, Size, Scale, Precision, Direction)

Ausdruck Ein Ausdruck, der ein SchemaParameters-Objekt zurückgibt.

Name String erforderlich. Gibt den Namen des neuen Schemaparameters an.

DataType Variant optional. Gibt den Datentyp des neuen Schemaparameters an. Kann eine der DataTypeEnum-ADO-Konstanten sein.

Size Variant optional. Gibt die maximale Länge des neuen Parameterfeldes an.

Scale Variant optional. Gibt die maximale Anzahl der Ziffern rechts vom Dezimalpunkt an.

Precision Variant optional. Gibt die maximale Anzahl der Ziffern an, die für den Parameter verwendet werden.

Direction Variant optional. Gibt an, ob der Parameter ein Eingabeparameter, ein Ausgabeparameter, sowohl ein Eingabe- als auch ein Ausgabeparameter oder ein Prozedurrückgabewert ist. Weil nur Eingabeparameter unterstützt werden, sollten Sie dieses Argument nicht angeben.

Anmerkungen

Im Entwurfsmodus von Microsoft Access wird die SchemaParameters-Auflistung automatisch aus den verfügbaren Schemafeldern erstellt.


Add-Methode (SchemaRelatedFields-Auflistung)

Erstellten einer neuen Beziehung zwischen zwei Feldern.. Gibt ein SchemaRelatedField-Objekt zurück.

Syntax

Ausdruck.Add(ManySchemaField, OneSchemaField)

Ausdruck Ein Ausdruck, der ein SchemaRelatedFields-Objekt zurückgibt.

ManySchemaField String erforderlich. Gibt den Namen des Schemafeldes auf der "1"-Seite der 1:n-Beziehung an.

OneSchemaField String erforderlich. Gibt den Namen des Schemafeldes auf der "n"-Seite der 1:n-Beziehung an.

Anmerkungen

Ein SchemaRelatedField-Objekt beschreibt die Zeilenpaare, die ein SchemaRelationship-Objekt bilden. Die Namen dieser Felder werden beim Erstellen von Verknüpfungsklauseln in SQL und für Über-/Unterordnungsbeziehungen in einer Hierarchie verwendet.

Anmerkungen

Im Entwurfsmodus von Microsoft Access wird die SchemaFields-Auflistung automatisch aus den verfügbaren Schemafeldern erstellt.


Add-Methode (SchemaRelationships-Auflistung)

Erstellt eine neue Schema-Beziehung. Gibt ein SchemaRelationship-Objekt zurück.

Syntax

Ausdruck.Add(Name, ManySchemaRowsource, OneSchemaRowsource, ManySchemaField, OneSchemaField)

Ausdruck Ein Ausdruck, der ein SchemaRelationships-Objekt zurückgibt.

Name String erforderlich. Gibt den Namen der neuen Schemabeziehung an.

ManySchemaField String erforderlich. Gibt den Namen der Zeilenquelle auf der "n"-Seite dieser 1:n-Beziehung an.

OneSchemaField String erforderlich. Gibt den Namen der Zeilenquelle auf der "1"-Seite dieser 1:n-Beziehung an.

ManySchemaField String erforderlich. Gibt den Namen des Schemafeldes auf der "n"-Seite dieser 1:n-Beziehung an.

OneSchemaField String erforderlich. Gibt den Namen des Schemafeldes auf der "1"-Seite dieser 1:n-Beziehung an.

Anmerkungen

Im Entwurfsmodus von Microsoft Access wird die SchemaRelationships-Auflistung automatisch aus den verfügbaren Schemabeziehungen erstellt.


Add-Methode (SchemaRowsources-Auflistung)

Erstellt eine neue Schemazeilenquelle. Gibt ein SchemaRowSource-Objekt zurück.

Syntax

Ausdruck.Add(Name, RowsourceType, CommandText)

Ausdruck Ein Ausdruck, der ein SchemaRowsources-Objekt zurückgibt.

Name String erforderlich. Gibt den Namen der neuen Zeilenquelle an.

RowsourceType Erforderliches dscRowsourceTypeEnum-Objekt. Gibt den Typ der neuen Zeilenquelle an.

CommandText Variant optional. Der Schemazeilenquellen-Befehlstext. Weitere Informationen finden Sie im Hilfethema der CommandText-Eigenschaft.

Anmerkungen

Im Entwurfsmodus von Microsoft Access wird die SchemaRowsources-Auflistung automatisch aus den verfügbaren Zeilenquellen erstellt.


Add-Methode (SublistRelationships-Auflistung)

Erstellt eine neue Sublistenbeziehung. Gibt ein PageRelationship-Objekt zurück.

Syntax

Ausdruck.Add(PageRowsource, SchemaRelationship)

Ausdruck Ein Ausdruck, der ein SublistRelationships-Objekt zurückgibt.

PageRowsource Erforderliches PageRowsource-Objekt.

SchemaRelationship Erforderliches SchemaRelationship-Objekt.

Anmerkungen

Die SublistRelationships-Auflistung enthält PageRelationship-Objekte des dscSublist-Typs, für den ein RecordsetDef-Objekt die "1"-Seite ("Parent") einer 1:n-Beziehung darstellt.


Add-Methode (WCAxes-Auflistung)

Fügt einem Diagramm eine Achse hinzu. Erstellt ein neues, nicht initialisiertes WCAxis-Objekt, bei dem alle Eigenschaften auf Automatic festgelegt sind. Sie müssen Skalierung, Position und Typ für jede hinzugefügte Achse angeben.

Syntax

Ausdruck.Add(Scaling, Pos, Type)

Ausdruck Ein Ausdruck, der ein WCAxes-Objekt zurückgibt.

Scaling Erforderliches WCScaling-Objekt. Ein Scaling-Objekt einer anderen Achse oder Reihe.

Pos Erforderliches ChartAxisPositionEnum-Objekt. Gibt die Position der neuen Achse an. Weitere Informationen finden Sie im Abschnitt über die Position-Eigenschaft des WCAxis-Objekts.

Type Erforderliches ChartAxisTypeEnum-Objekt. Gibt den Typ der neuen Achse an. Weitere Informationen finden Sie im Abschnitt über die Type-Eigenschaft des WCAxis-Objekts.

Anmerkungen

Ein Diagramm kann nicht mehr als acht Achsen enthalten.


Add-Methode (WCAxes-Auflistung): Beispiel

In diesem Beispiel wird der rechten Seite des Diagramms eine zweite Größenachse hinzugefügt.

Set c = ChartSpace1.Constants
Set cht = ChartSpace1.Charts(0)
cht.Axes.Add cht.Axes(c.chAxisPositionLeft).Scaling, c.chAxisPositionRight, c.chValueAxis


Add-Methode (WCCharts-Auflistung)

Erstellt ein neues, leeres Diagramm. Gibt ein WCChart-Objekt zurück.

Syntax

Ausdruck.Add(Index)

Ausdruck Ein Ausdruck, der ein WCCharts-Objekt zurückgibt.

Index Optionales Long. Gibt die Position des neuen Diagramms an. Durch Angeben von 0 (Null) wird das Diagramm am Beginn der Auflistung eingefügt. Wenn Sie dieses Argument nicht angeben, wird das neue Diagramm am Ende der Auflistung eingefügt.


Add-Methode (WCCharts-Auflistung): Beispiel

In diesem Beispiel wird dem Diagrammarbeitsbereich ein Diagramm hinzugefügt.

Set cht = ChartSpace1.Charts.Add


Add-Methode (WCDataLabelsCollection-Auflistung)

Fügt der angegebenen Reihe Datenbeschriftungen hinzu. Erstellt ein neues, nicht initialisiertes WCDataLabels-Objekt und fügt es der angegebenen WCDataLabelsCollection-Auflistung ein. Eine Reihe kann nur über einen Satz von Datenbeschriftungen verfügen. Diese Methode schlägt fehl, wenn die WCDataLabelsCollection-Auflistung bereits ein WCDataLabels-Objekt enthält.

Syntax

Ausdruck.Add

Ausdruck Ein Ausdruck, der ein WCDataLabelsCollection-Objekt zurückgibt.


Add-Methode (WCDataLabelsCollection-Auflistung): Beispiel

In diesem Beispiel werden den angegebenen Reihen im Diagrammarbeitsbereich Datenbeschriftungen hinzugefügt.

Set ch = ChartSpace1.Charts(0)
ch.SeriesCollection(0).DataLabelsCollection.Add


Add-Methode (WCDataSources-Auflistung)

Erstellt ein neues, nicht initialisiertes WCDataSource-Objekt und fügt es am Ende der angegebenen WCDataSources-Auflistung hinzu.

Syntax

Ausdruck.Add

Ausdruck Ein Ausdruck, der eine WCDataSources-Auflistung zurückgibt.


Add-Methode (WCErrorbarsCollection-Auflistung)

Fügt einer Reihe Fehlerindikatoren hinzu. Erstellt ein neues, nicht initialisiertes WCErrorBars-Objekt und fügt es der angegebenen WCErrorBarsCollection-Auflistung hinzu. Ein Diagramm kann nur einen Satz Fehlerindikatoren enthalten. Dies bedeutet, dass ein XY-Punktdiagramm entweder einen Fehlerindikator für die X-Achse oder einen für die Y-Achse enthält, jedoch nicht für beide.

Syntax

Ausdruck.Add

Ausdruck Ein Ausdruck, der ein WCErrorbarsCollection-Objekt zurückgibt.


Add-Methode (WCErrorbarsCollection-Auflistung): Beispiel

In diesem Beispiel werden den angegebenen Reihen im Diagrammarbeitsbereich Fehlerindikatoren hinzugefügt.

Set eb = ChartSpace1.Charts(0).SeriesCollection(0).ErrorBarsCollection.Add


Add-Methode (WCSeriesCollection-Auflistung)

Fügt einem Diagramm eine Reihe hinzu. Erstellt ein neues, leeres WCSeries-Objekt an der angegebenen Position in der WCSeriesCollection-Auflistung.

Syntax

Ausdruck.Add(Index)

Ausdruck Ein Ausdruck, der ein WCSeriesCollection-Objekt zurückgibt.

Index Optionales Long. Gibt die Position der neuen Reihe innerhalb der Auflistung an. Durch Angeben von 0 (Null) wird die neue Reihe an den Anfang der Auflistung platziert. Wenn Sie dieses Argument nicht angeben, wird die neue Serie am Ende der Auflistung platziert.


Add-Methode (WCSeriesCollection-Auflistung): Beispiel

In diesem Beispiel wird dem angegebenen Diagramm im Diagrammarbeitsbereich eine neue Reihe hinzugefügt. Anschließend werden die Werte für die neue Reihe festgelegt.

Dim values(7)

values(0) = 0
values(1) = 1
values(2) = 10
values(3) = 25
values(4) = 30
values(5) = 40
values(6) = 60

Set s2 = ChartSpace1.Charts(0).SeriesCollection.Add
Set c = ChartSpace1.Constants
s2.SetData c.chDimValues, c.chDataLiteral, values


Add-Methode (WCTrendlines-Auflistung)

Fügt einer Reihe eine Trendlinie hinzu. Erstellt ein neues, nicht initialisiertes WCTrendline-Objekt und fügt es am Ende der angegebenen WCTrendlines-Auflistung ein. Jede Reihe kann nur eine Trendlinie enthalten.

Syntax

Ausdruck.Add

Ausdruck Ein Ausdruck, der ein WCTrendlines-Objekt zurückgibt.


Add-Methode (WCTrendlines-Auflistung): Beispiel

In diesem Beispiel wird den angegebenen Reihen im Diagrammarbeitsbereich eine Trendlinie hinzugefügt.

Set trndline = ChartSpace1.Charts(0).SeriesCollection(0).Trendlines.Add


Clear-Methode: Beispiel

In diesem Beispiel werden sämtliche Diagramme im angegebenen Diagrammarbeitsbereich gelöscht.

ChartSpace1.Clear


Delete-Methode: Beispiel

In diesem Beispiel werden die Datenbeschriftungen in den angegebenen Reihen des Diagrammarbeitsbereichs gelöscht.

ChartSpace1.Charts(0).SeriesCollection(0).DataLabelsCollection.Delete 0


Export-Methode: Beispiel

In diesem Beispiel wird das aktuelle Tabellenblatt in die angegebene Datei exportiert.

set  c = Spreadsheet1.Constants
Spreadsheet1.ActiveSheet.Export "ssheet1.htm", c.ssExportActionNone


Load-Methode: Beispiel

In diesem Beispiel wird die angegebene XML-Datendatei geladen.

ChartSpace1.Load "chart.xml"


Show-Methode: Beispiel

In diesem Beispiel wird ein Bildlauf mit dem Tabellenblatt durchgeführt, bis die Zelle P75 zu sehen ist.

Spreadsheet1.Range("p75").Show


AutoFilter-Eigenschaft: Beispiel

In diesem Beispiel wird der AutoFilter für den Bereich A1:J22 aktiviert, es werden Filter für die Spalten 1 und 3 gesetzt, und anschließend werden die Filter angewendet.

Spreadsheet1.Range("a1:j22").AutoFilter
Set af = Spreadsheet1.ActiveSheet.AutoFilter
Set filterColumnOne = af.Filters(1)
Set filterColumnThree = af.Filters(3)
filterColumnOne.Criteria.Add "blue"    ' Don't show blue in column 1.
filterColumnOne.Criteria.Add "green"    ' Don't show green in column 1.
filterColumnThree.Criteria.Add "yellow"    ' Don't show yellow in column 3.
af.Apply


Border-Eigenschaft: Beispiel

In diesem Beispiel wird die Linienstärke für den Rahmen der angegebenen Reihe im Diagrammarbeitsbereich festgelegt.

Set c = ChartSpace1.Constants
ChartSpace1.Charts(0).SeriesCollection(0).Border.Weight = c.owcLineWeightMedium


Caption-Eigenschaft: Beispiel

In diesem Beispiel wird die Microsoft Office Web Components-Version in der Titelleiste der Kalkulationstabelle angezeigt.

Spreadsheet1.TitleBar.Caption = "MSOWC Build " & Spreadsheet1.BuildNumber


Charts-Eigenschaft: Beispiel

In diesem Beispiel werden die Schriftarteigenschaften für die angegebene Achse festgelegt.

Set axs = ChartSpace1.Charts(0).Axes(1)
axs.Font.Name = "Arial"
axs.Font.Size = 8
axs.Font.Bold = True

In diesem Beispiel wird dem angegebenen Diagrammarbeitsbereich ein Diagramm hinzugefügt.

Set cht = ChartSpace1.Charts.Add


Column-Eigenschaft: Beispiel

In diesem Beispiel wird die Schriftart für alle übrigen Spalten im sichtbaren Bereich des aktiven Tabellenblattes auf Fett festgelegt.

For Each col In Spreadsheet1.ActiveSheet.VisibleRange.Columns
    If col.Column Mod 2 = 0 Then col.Font.Bold = True
Next


Command-Eigenschaft: Beispiel

Diese Ereignisprozedur wird immer dann ausgeführt, wenn der Benutzer einen Kalkulationstabellenbefehl ausführt. Wenn der Benutzer versucht, Spalten in die angegebene Kalkulationstabelle einzufügen, zeigt die Prozedur ein Nachrichtenfeld an und bricht den Befehl ab. Beachten Sie, dass die Prozedur in diesem Beispiel so deklariert wurde, wie es für Visual Basic erforderlich ist. Weitere Informationen über das Verwenden von Ereignisprozeduren finden Sie im Abschnitt "Deklarieren und Verwenden von Ereignisprozeduren".

Private Sub Spreadsheet1_BeforeCommand(ByVal EventInfo As OWC.SpreadsheetEventInfo)
    Set c = Spreadsheet1.Constants
    If EventInfo.Command = c.ssInsertColumns Then
        MsgBox "you cannot insert columns on this sheet"
        EventInfo.ReturnValue = False
    End If
End Sub


Crosses-Eigenschaft: Beispiel

In diesem Beispiel wird die Rubrikenachse so festgelegt, dass Sie die Größenachse beim Wert 0 (Null) im Diagrammarbeitsbereich schneidet, wenn ein angepasster Schnittpunkt für die Rubrikenachse noch nicht festgelegt wurde.

Set c = ChartSpace1.Constants
Set valueAxis = ChartSpace1.Charts(0).Axes(c.chAxisPositionLeft)
Set categoryAxis = ChartSpace1.Charts(0).Axes(c.chAxisPositionBottom)
If categoryAxis.Crosses = c.chAxisCrossesAutomatic Then
    valueAxis.CrossingAxis = categoryAxis
    categoryAxis.CrossesAtValue = 0
End If


DataLabel-Eigenschaft: Beispiel

In diesem Beispiel wird den angegebenen Reihen im Diagrammarbeitsbereich eine Trendlinie hinzugefügt, die Schriftart für die Datenbeschriftung wird auf Fett gesetzt, und die Trendlinie so eingerichtet, dass sie nur ihre Gleichung anzeigt (das Bestimmtheitsmaß wird nicht angezeigt).

Set trndline = ChartSpace1.Charts(0).SeriesCollection(0).Trendlines.Add
trndline.DataLabel.Font.Bold = True
trndline.IsDisplayingRSquared = False


DataSource-Eigenschaft: Beispiel

In diesem Beispiel wird ein Diagramm erstellt, das an ein Tabellenblatt gebunden ist. Der Serienname befindet sich in Zelle B1, die Rubrikennamen befinden sich in den Zellen B2:B28, und die Werte befinden sich in den Zellen B2:B28.

Set c = ChartSpace1.Constants
Set ChartSpace1.DataSource = Spreadsheet1.Object
ChartSpace1.Charts.Add
ChartSpace1.Charts(0).Type = c.chChartTypeLineMarkers
ChartSpace1.Charts(0).SetData c.chDimCategories, 0, "a2:a28"
ChartSpace1.Charts(0).SetData c.chDimSeriesNames, 0, "b1"
ChartSpace1.Charts(0).SeriesCollection(0).SetData c.chDimValues, 0, "b2:b28"


Font-Eigenschaft: Beispiel

In diesem Beispiel werden Zahlenformat und Schriftart der aktiven Zelle gesetzt.

Set ac = Spreadsheet1.ActiveCell
ac.NumberFormat = "0.###"
ac.Font.Color = "blue"
ac.Font.Name = "times new roman"


Formula-Eigenschaft: Beispiel

In diesem Beispiel werden Formel, Spaltenbreite und Zahlenformat für den Bereich A1:F10 des aktiven Tabellenblattes festgelegt.

Set rg = Spreadsheet1.ActiveSheet.Range("a1:f10")
rg.Formula = "=5*rand()"
rg.ColumnWidth = 100
rg.NumberFormat = "#.###"


Height-Eigenschaft: Beispiel

In diesem Beispiel wird die Höhe der PivotTable-Liste auf 36 Punkt festgelegt.

PivotTable1.Object.Height = 36


Legend-Eigenschaft: Beispiel

In diesem Beispiel wird veranlasst, dass die Legende des angegebenen Diagramms angezeigt und die Legendenschriftart festgelegt wird.

ChartSpace1.Charts(0).HasLegend = True
ChartSpace1.Charts(0).Legend.Font.Name = "times new roman"


Line-Eigenschaft: Beispiel

In diesem Beispiel wird die Linienfarbe für die angegebene Reihe gesetzt.

ChartSpace1.Charts(0).SeriesCollection(0).Line.Color = "red"


MoveAfterReturn-Eigenschaft: Beispiel

In diesem Beispiel bleibt die aktive Zelle ausgewählt, nachdem der Benutzer die EINGABETASTE gedrückt hat.

Spreadsheet1.MoveAfterReturn = False


Parent-Eigenschaft: Beispiel

Die Ereignisprozedur in diesem Beispiel wird immer dann ausgeführt, wenn der Benutzer auf einen Diagrammarbeitsbereich klickt. Wenn der Benutzer einen Punkt anklickt, zeigt die Prozedur die Reihen und Punktindexwerte an. Beachten Sie, dass diese Prozedur so deklariert wurde, wie es für Visual Basic erforderlich ist. Weitere Informationen über das Verwenden von Ereignisprozeduren finden Sie im Abschnitt "Deklarieren und Verwenden von Ereignisprozeduren in VBScript".

Private Sub ChartSpace1_Click(ByVal ChartEventInfo As OWC.WCChartEventInfo)
    Set c = ChartSpace1.Constants
    If ChartSpace1.SelectionType = c.chSelectionPoint Then
        seriesNumber = ChartSpace1.Selection.Parent.Index    ' Point parent is series.
        pointNumber = ChartSpace1.Selection.Index
        MsgBox "series " & seriesNumber & " point " & pointNumber
    End If
End Sub


Row-Eigenschaft: Beispiel

In diesem Beispiel wird jede zweite Zeile im derzeitigen Bereich für Zelle A1 grün dargestellt.

For Each rw In Spreadsheet1.Cells(1, 1).CurrentRegion.Rows
    If rw.Row Mod 2 = 0 Then rw.Interior.Color = "lightgreen"
Next


Scaling-Eigenschaft: Beispiel

In diesem Beispiel wird der rechten Seite des angegebenen Diagramms eine zweite Größenachse (Y-Achse) hinzugefügt. Die zweite Achse verwendet dieselbe Skala wie die primäre Größenachse.

Set c = ChartSpace1.Constants
Set axisScale = ChartSpace1.Charts(0).Axes(c.chAxisPositionLeft).Scaling
ChartSpace1.Charts(0).Axes.Add axisScale, c.chAxisPositionRight, c.chValueAxis


Selection-Eigenschaft: Beispiel

Die Prozedur in diesem Beispiel wird immer dann ausgeführt, wenn sich die Auswahl im Diagrammarbeitsbereich ändert. Wenn der Benutzer eine Achse auswählt, zeigt die Prozedur die Minimal- und Maximalwerte für die Achse an.

Private Sub ChartSpace1_SelectionChange()
    Set c = ChartSpace1.Constants
    If ChartSpace1.SelectionType = c.chSelectionAxis Then
        minval = ChartSpace1.Selection.Scaling.Minimum
        maxval = ChartSpace1.Selection.Scaling.Maximum
        MsgBox "minimum = " & minval & " maximum = " & maxval
    End If
End Sub


Size-Eigenschaft: Beispiel

In diesem Beispiel wird der Schriftgrad für die angegebene Achse auf 6 Punkt festgelegt.

Set c = ChartSpace1.Constants
ChartSpace1.Charts(0).Axes(c.chAxisPositionLeft).Font.Size = 6


Title-Eigenschaft: Beispiel

In diesem Beispiel wird festgelegt, dass das angegebene Diagramm einen Titel tragen soll. Anschließend wird der Titeltext festgelegt.

ChartSpace1.Charts(0).HasTitle = True
ChartSpace1.Charts(0).Title.Caption = "Satisfaction Data"


Top-Eigenschaft: Beispiel

In diesem Beispiel wird eine Variable für den Abstand zwischen der oberen Begrenzung des Kalkulationstabellenfensters und Zelle A35 gesetzt.

t2 = Spreadsheet1.Range("a35").Top


Visible-Eigenschaft: Beispiel

In diesem Beispiel wird die Legende für das angegebene Diagramm angezeigt, und der angegebene Legeneintrag wird ausgeblendet.

ChartSpace1.Charts(0).HasLegend = True
ChartSpace1.Charts(0).Legend.LegendEntries(1).Visible = False


Objektmodell des Diagrammarbeitsbereichs

ChartSpace-Objekt

Legende

Gelbes Feld Objekt und Auflistung
Blaues Feld Nur Objekt

Nach-Rechts-Pfeil Klicken Sie auf den roten Pfeil, um das Diagramm zu erweitern.


Objektmodell des Datenquellen-Steuerelements

Legende

Gelbes Feld Objekt und Auflistung
Blaues Feld Nur Objekt

Nach-Rechts-Pfeil Klicken Sie auf den roten Pfeil, um das Diagramm zu erweitern.


Objektmodell der PivotTable-Liste

PivotTable-Objekt

Pivot Fields-Auflistung (PivotField-Objekt)

Legende

Gelbes Feld Objekt und Auflistung
Blaues Feld Nur Objekt

Nach-Rechts-Pfeil Klicken Sie auf den roten Pfeil, um das Diagramm zu erweitern.


Objektmodell der Kalkulationstabelle

Legende

Gelbes Feld Objekt und Auflistung
Blaues Feld Nur Objekt

Nach-Rechts-Pfeil Klicken Sie auf den roten Pfeil, um das Diagramm zu erweitern.