
ForceWare Graphics Drivers
NVIDIA 3D Stereo User’s 
Guide
(for Release 70)

Revision 7.0

NVIDIA Corporation
March 10, 2005



NVIDIA Drivers NVIDIA 3D Stereo User’s Guide Revision 7.0

Published by
NVIDIA Corporation 
2701 San Tomas Expressway
Santa Clara, CA 95050

Notice
ALL NVIDIA DESIGN SPECIFICATIONS, REFERENCE BOARDS, FILES, DRAWINGS, DIAGNOSTICS, 
LISTS, AND OTHER DOCUMENTS (TOGETHER AND SEPARATELY, “MATERIALS”) ARE BEING 
PROVIDED “AS IS.” NVIDIA MAKES NO WARRANTIES, EXPRESSED, IMPLIED, STATUTORY, OR 
OTHERWISE WITH RESPECT TO THE MATERIALS, AND EXPRESSLY DISCLAIMS ALL IMPLIED 
WARRANTIES OF NONINFRINGEMENT, MERCHANTABILITY, AND FITNESS FOR A PARTICULAR 
PURPOSE.

Information furnished is believed to be accurate and reliable. However, NVIDIA Corporation assumes no 
responsibility for the consequences of use of such information or for any infringement of patents or other rights of 
third parties that may result from its use. No license is granted by implication or otherwise under any patent or patent 
rights of NVIDIA Corporation. Specifications mentioned in this publication are subject to change without notice. 
This publication supersedes and replaces all information previously supplied. NVIDIA Corporation products are not 
authorized for use as critical components in life support devices or systems without express written approval of 
NVIDIA Corporation.

Trademarks
NVIDIA, the NVIDIA logo, 3DFX, 3DFX INTERACTIVE, the 3dfx Logo, STB, STB Systems and Design, the STB 
Logo, the StarBox Logo, NVIDIA nForce, GeForce, NVIDIA Quadro, NVDVD, NVIDIA Personal Cinema, 
NVIDIA Soundstorm, Vanta, TNT2, TNT, RIVA, RIVA TNT, VOODOO, VOODOO GRAPHICS, WAVEBAY, 
Accuview Antialiasing, the Audio & Nth Superscript Design Logo, CineFX, the Communications & Nth Superscript 
Design Logo, Detonator, Digital Vibrance Control, DualNet, FlowFX, ForceWare, GIGADUDE, Glide, GOFORCE, 
the Graphics & Nth Superscript Design Logo, Intellisample, M-BUFFER, nfiniteFX, NV, NVChess, nView, 
NVKeystone, NVOptimizer, NVPinball, NVRotate, NVSensor, NVSync, the Platform & Nth Superscript Design 
Logo, PowerMizer, Quincunx Antialiasing, Sceneshare, See What You've Been Missing, StreamThru, SuperStability, 
T-BUFFER, The Way It's Meant to be Played Logo, TwinBank, TwinView and the Video & Nth Superscript Design 
Logo are registered trademarks or trademarks of NVIDIA Corporation in the United States and/or other countries. 
Other company and product names may be trademarks or registered trademarks of the respective owners with which 
they are associated.

Intel, Indeo, and Pentium are registered trademarks of Intel Corporation. Microsoft, Windows, Windows NT, 
Direct3D, DirectDraw, and DirectX are trademarks or registered trademarks of Microsoft Corporation. OpenGL is a 
registered trademark of Silicon Graphics Inc.

Other company and product names may be trademarks or registered trademarks of the respective owners with which 
they are associated.

Copyright
© 2003–2005 by NVIDIA Corporation. All rights reserved.



NVIDIA 3D Stereo User’s Guide Revision 7.0

Table of Contents

1.Introduction to the NVIDIA 3D Stereo Driver

About the NVIDIA 3D Stereo Driver .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  1
How the Driver Works  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  1
Driver Features.  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  1
System Requirements  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  3

Safety - Read Before Using!   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  4
Maximizing Safe Use.  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  4
Epilepsy   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  5

2.Using the NVIDIA 3D Stereo Driver
Getting Started   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  7

Step 1: Install the Drivers and the Stereo Viewing Hardware   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  8
Step 2: Choose Page Flipped or Anaglyph Stereo Mode   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  9
Step 3: Enable the Stereo Function  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  9
Step 4: Set Up Basic Stereo Parameters   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .12
Step 5: Play Games in Stereo  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .15

Game Ratings for Stereo  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .16
Understanding the Game Ratings  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .16
Viewing the Game Ratings .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .16

Stereo Test and Refresh Rate Setup  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .17
Controlling the Refresh Rate .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .17
Testing Display Combinations  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .19

3D Stereo Laser Sight .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .20

3.Using the Game Configuration Feature
The Purpose of Game Configurations.  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .22

Characteristics of Good Stereo Viewing  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .22
What the NVIDIA 3D Stereo Driver Provides   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .22

Creating and Modifying Game Configurations   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .23
Hints to Keep In Mind   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .23
To View the Current Configuration .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .23
To Perform In-Game Configuring:  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .24
Configuration Guidelines .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .25
About the Configuration Hot Key Functions  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .26

Assigning Configurations to Games.  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .28

4.Using the NVIDIA Stereo Viewer
Capturing Images .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .30
Viewing Images  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .30

Using the Stereo Viewer  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .31
Reversing Left and Right Page Flipped Images  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .35
Viewing Page Flipped Images as Anaglyphs   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .35

Setting Resolution and Gamma .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .36
Viewing a Set of Images as a Slide Show.  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .37
Moving the Image Files  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .38
Summary of Stereo Viewer Hot Keys  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .39

Hot Keys Enabled in Windowed View  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .39
Hot Keys Enabled in Full-Screen Stereo View .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .39
Hot Keys Always Enabled  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .39

5.Tips and Troubleshooting
Stereo Viewing Tips .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .41
NVIDIA Corporation i CONFIDENTIAL



NVIDIA 3D Stereo User’s Guide Revision 7.0
Viewing Practices that Effect Stereo Quality .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .41
System and Game Settings that Effect Stereo Quality .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .42

Troubleshooting .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .44
Game Playing  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .44
Stereo Viewer   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .49
NVIDIA Corporation ii CONFIDENTIAL



C H A P T E R

INTRODUCTION TO THE NVIDIA 3D STEREO
DRIVER

About the NVIDIA 3D Stereo Driver

The NVIDIA 3D Stereo Driver, when used with compatible hardware, allows full-screen 
stereo1 viewing of many Direct3D® or OpenGL® based games2. No other stereoscopic 
driver software is required.

How the Driver Works

When 3D games are played and the driver is enabled, the driver converts the image to 3D 
stereo and displays it on the screen. You can set up the driver to use either the page 
flipping or anaglyph method of stereo imaging. With compatible viewing hardware, 
you’ll see the image with the perception of depth.

Driver Features

Stereo Game Playing

The NVIDIA 3D Stereo Driver comes with a number of controls for use with games. 

• Stereo Separation Adjustment to suit individual adaptation to stereo viewing

• Hot keys for in-game stereo control

1. For brevity, the term “stereo” in this manual pertains to stereoscopic viewing of images and games.
2. Actual stereo quality depends on each game. NVIDIA has rated most games for stereo viewing quality. 
NVIDIA Corporation 1
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Introduction to the NVIDIA 3D Stereo Driver
• 3D Laser Sight for added realism in first-person shooter games

• Stereo Test for determining the best screen mode to use

• Custom Game Configurations for tailoring 3D stereo to a wide range of games

The list includes hundreds of games that NVIDIA has evaluated for stereo viewing. 
Where possible, NVIDIA has preset a number of stereo parameters for these games in 
order to optimize the 3D stereo experience.

Stereo Image Viewing

The NVIDIA 3D Stereo Driver also includes functions for viewing still images in stereo.

• Stereo Image Capture Utility takes a screen shot of a stereo game and stores the image 
on your hard drive.

• Stereo Viewer Application takes a stereo formatted image file and displays the stereo 
image on the screen. Supported file types include

• JPS, PNS, or H3D side-by-side formatted images 

• JPG or PNG anaglyph formatted images

For Developers—API Support

The ForceWare 3D Stereo Driver includes support for DirectX 8 and DirectX 9 
implementations of the StereoBLT API and Stereo API for developers.
2 NVIDIA 3D Stereo User’s Guide – Revision 7.0



CHAPTER 1
Introduction to the NVIDIA 3D Stereo Driver
System Requirements

• 3D Accelerator Card using one of the following NVIDIA GPU product families:

• TNT (including any TNT2 and Vanta products)3

• GeForce (including any GeForce256, GeForce2, GeForce3, GeForce FX, and GeForce 
6 products.) 

GeForce2 Go and GeForce 4xxx Go products require an external monitor that meets 
the requirements for page flip stereo viewing.

• Quadro (including any Quadro2 or Quadro FX products)

Quadro2 Go and Quadro4 GoGL products require an external monitor that meets 
the requirements for page flip stereo viewing.

• Multiscan monitor4 5capable of at least a 100 Hz vertical sync refresh rate at 640x480. 
(Requirement for page flip stereo)

• Pentium® 90 MHz or greater, but also refer to specific game requirements.

• 8 MB System Memory, but also refer to specific game requirements.

• Windows® 2000, Windows® XP, Windows 98, or Windows® Me, with DirectX® 8 or 
later runtime installed.

• The NVIDIA ForceWareTM graphics driver must be installed. 

• Compatible Stereoscopic Viewing System 

• Page Flip Stereo - The NVIDIA 3D Stereo Driver can be used with a number of 
stereo eyewear models as well as certain auto-stereoscopic LCD or flat panel 
displays. 

• Anaglyph Stereo - The NVIDIA 3D Stereo Driver can be configured for anaglyph 
stereo viewing. The default orientation and color is left-eye-red and right-eye-blue. 

Some eyewear may require additional configuring of its hardware in order to work 
properly. Consult the manufacturer’s Web site and documentation for instructions on 
how to configure the hardware to work with the NVIDIA 3D Stereo Driver.

A list of compatible viewing products can be found at the NVIDIA website 
www.nvidia.com, in the 3D Stereo section under driver downloads. The listed 
products have been tested and verified by NVIDIA to work without requiring 
additional hardware configuring. 

3. OpenGL stereo is not supported on the TNT family of products.
4. The 3D Stereo Driver in page flip mode is not designed for LCDs or flat panel displays, with the excep-
tion of those that are auto-stereoscopic or the Sharp 3D display. For other notebooks, an external monitor
can be connected and used to view page flip mode stereo.
5. With the 3D Stereo Driver in anaglyph mode, stereo images can be viewed on a flat panel LCD. 
NVIDIA Corporation 3
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Safety - Read Before Using!

! WARNING!
Do not wear stereo glasses in any situations that require unimpaired visual 
perception. 

Maximizing Safe Use

Under normal conditions, stereo viewing is safe for any duration that you would 
normally view your PC monitor. However, some people may experience discomfort. To 
minimize the potential for experiencing visual problems or any adverse symptoms: 

• Adjust the monitor refresh rate to the highest possible setting, preferably over 120Hz. 
Consult your monitor manual for instructions.

• Take the stereo medical test to verify your ability so see stereo images. 

• Take regular breaks, at least 5 minutes after every hour of stereo viewing.

• If you experience any of the following symptoms—

• nausea, dizziness, or queasiness,

• headache, or eyestrain,

• blurry vision, 

• double vision that lasts longer than a few seconds,

refer to “Tips and Troubleshooting” on page 40 for suggestions on how to correct the 
problem. 

Do not engage in any potentially hazardous activity (for example, driving a vehicle) 
until your symptoms have completely gone away.

If symptoms persist, discontinue use and do not resume stereo viewing without 
discussing your symptoms with a physician.
4 NVIDIA 3D Stereo User’s Guide – Revision 7.0
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Epilepsy 

! WARNING!
If you or any member of your family has a history of epilepsy, consult a 
physician before using computer game products.

A small percentage of the population may experience epileptic seizures when viewing 
certain types of TV images or video games that contain flashing patterns of light. 

The following people should consult a physician before viewing in stereo: 

• Children under 5 years of age

• Anyone with a history of epilepsy, or who has a family member with a history of 
epilepsy

• Anyone who has ever experienced epileptic seizures or sensory disturbances 
triggered by flashing light effects.

! WARNING!
Some light patterns may induce seizures in persons with no prior history of 
epilepsy. Discontinue stereo use if you experience any of the following 
symptoms while viewing stereo images:

• Involuntary movements, eye or muscle twitching

• Muscle cramps

• Nausea, dizziness, or queasiness

• Convulsions 

• Disorientation, confusion, or loss of awareness of your surroundings 

• Do not engage in any potentially hazardous activity (for example, driving a vehicle) 
until your symptoms have completely gone away. 

• Do not resume stereo viewing without discussing the symptoms with your physician.
NVIDIA Corporation 5



C H A P T E R

USING THE NVIDIA 3D STEREO DRIVER

This chapter describes the basic functions of the 3D Stereo Driver Control Panel, and 
contains the following sections:

• “Getting Started” on page 7

describes how to install the 3D stereo driver and how to use the control panel to play 
3D games in stereo.

• “Game Ratings for Stereo” on page 16

describes how to determine if your game is suitable for viewing in stereo.

• “Stereo Test and Refresh Rate Setup” on page 17

describes how to test different color depth, resolution, and refresh rate combinations to 
determine the best display modes to use when playing games in stereo.

• “3D Stereo Laser Sight” on page 20

describes how to use the NVIDIA laser sight feature for first-person shooter games.
NVIDIA Corporation 6
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Using the NVIDIA 3D Stereo Driver
Getting Started

Perform the following steps to use the NVIDIA 3D Stereo Driver. Each step is explained in 
greater detail later in this section. 

• Step 1: Install the Drivers and the Stereo Viewing Hardware.

Make sure the NVIDIA ForceWare Graphics driver is installed, then install the NVIDIA 
3D Stereo Driver.

The NVIDIA 3D Stereo driver version must match the NVIDIA Forceware driver 
version. For example, if you installed the NVIDIA driver version 71.84, then you must 
install the NVIDIA 3D Stereo version 71.84 for proper operation.

• Step 2: Choose Page Flipped or Anaglyph Stereo Mode

In the Stereo Properties sheet, click either Page Flipped or Anaglyph stereo type, 
depending on the type of stereo glasses you have.

• Step 3: Enable the Stereo Function.

In the Stereo Properties sheet, under Stereo Enable Mode, select either Enabled or 
Enabled by Hot Key, then click Apply. Be sure to take the stereo medical test.

• Step 4: Set Up Basic Stereo Parameters

• Verify the Hot Keys.

Under Display Properties > Stereo Properties, click Additional Properties, then set 
up or verify setup of the six hot keys—Toggle Stereo On/Off, Less Stereo Separation, 
More Stereo Separation, Save Image, Increase Gamma, and Decrease Gamma.

• Adjust the Stereo Separation.

Under Stereo Properties, click Stereo Setup & Test, then in the Monitor Size section 
of the Stereo Setup & Test page move the bar to your monitor size. In the Stereo 
Properties sheet, preselect the stereo separation using the Stereo Separation slide 
bar. 

• Adjust the Stereo Gamma Setting

The default setting should be adequate for all games, but can be adjusted by moving 
the Stereo Gamma slide bar in the Stereo Properties sheet. 

• Step 5: Play Games in Stereo.

Under the Stereo Properties > Stereo Setup & Test sheet, set the stereo refresh rate you 
want to use for your games, then start the game in full-screen mode and use the hot 
keys to control the stereo display. 
NVIDIA Corporation 7
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Step 1: Install the Drivers and the Stereo Viewing Hardware 

Install Drivers and Hardware

1 Install the NVIDIA ForceWare graphics drivers (v56.56 or later).

Refer to the installation instructions that came with the new drivers or the display card. 

2 Install the NVIDIA 3D Stereo Driver. 

If downloaded to your hard drive, or on a CD, locate the executable stereo file, double-
click the file, then follow the instructions to complete the installation.. 

The version indicated in the executable file name must match the ForceWare graphics 
driver version. For example, if the executable file name is  
71.84_win2kxp_stereo.exe, then the system must have ForceWare v71.84 installed. 

3 Install the stereo viewing hardware.

Refer to the documentation that came with your stereo eyewear for instructions.

Access the Stereo Control Panel

1 Right click on the Desktop, then choose Properties, or click Start > Settings > Control 
Panel and double-click Display from the Control Panel window. 

2 Click the Settings tab, then click Advanced from the Settings page and click the 
NVIDIA graphics card tab.

The main NVIDIA panel appears, with a slide out tray showing other NVIDIA pages.

Figure 2.1 NVIDIA Control Panel–Main Page
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3 Click the Stereo Properties tree item from the slide-out tray. 

Figure 2.2 Stereo Properties Control Panel—Stereo Setup Controls

Step 2: Choose Page Flipped or Anaglyph Stereo Mode

1 In the Stereo Type section, click the list arrow and then choose the method that 
corresponds to the type of glasses you will use to view stereo. (See Figure 2.2.)

2 Click Apply. 

Step 3: Enable the Stereo Function 

1 Choose the Stereo Enable Mode. (See Figure 2.2)

Click either the Enabled or Enabled by Hot Key radio button, then click Apply. 

• Enabled: If you select Enabled, stereo turns on as soon as the game starts. Some 
programs start with simple startup screens that are best viewed with stereo off. The 
driver attempts to detect this case and waits until the “triangle rich” game starts 
before turning stereo on. 

Hot keys are functional when Enabled is selected.

• Enabled by Hot Key: If you select Enabled by Hot Key, you must use the hot keys to 
turn stereo ON or OFF after starting a game. This is useful if you want to view game 
menus and setup screens in non-stereo mode. 

Note: The pages for anaglyph-only versions 

Stereo Enable Setup

Medical Test Button

Stereo Type Setup

differ slightly from the examples shown. 
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2 Take the stereo medical test.

Each user should take the stereo medical test before playing games in stereo for the first 
time. 

a To launch the test, click Medical Test Image.

When you click Apply after enabling stereo for the first time, the test launches 
automatically.

The Medical Test Image appears on the screen. 

Figure 2.3 Medical Test Image

b Follow the instructions on the screen.

• If you do not see the image immediately, allow a few seconds for your eyes to adjust, 
while changing your viewing distance from the screen.

• If the page flipping method is used and the image is blurred, verify that the stereo 
eyewear is functioning. 

The view through the eyewear should darken because each eye view is cycling on 
and off. If the eyewear does not darken, check the hardware installation and setup.
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c Press ESC when you are finished viewing the image.

The Stereo Test Result dialog box asks whether you can see the image in stereo.

d Confirm your ability to see the image in stereo. 

• If you are able to see the image, click Yes. Stereo is now enabled.

• If you are not able to see the image, click No. 

Any further attempts to enable stereo launches the Medical Test Image again.

Inability to see the Medical Test image in stereo might be due to 

• Adjustments needed for improved stereo viewing

See “Stereo Test and Refresh Rate Setup” on page 17 for instructions in setting 
optimal refresh rates and resolutions for stereo.

• Hardware problems or visual problems 

See “Possible Cause: Eyewear Hardware Not Set Up Properly or Eyewear Driver 
Support not Installed Properly” on page 46 in the Troubleshooting chapter for help 
in diagnosing a problem with the eyewear setup or driver installation.

Consult a physician if you suspect a physical problem seeing stereo. 
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Step 4: Set Up Basic Stereo Parameters 

Adjust the Stereo Separation

Stereo separation refers to the difference in horizontal position between the right and left 
images. The greater the stereo separation, the greater the stereo effect. Too much 
separation, however, can be uncomfortable if your eyes are not adjusted to stereo. 

1 Adjust separation according to the diagonal screen dimension of your monitor.

The driver calculates the maximum stereo separation (100%) based on the screen size. 

a Click the Stereo Setup & Test tree item in the slide-out tray. 

Figure 2.4 Selecting the Monitor Size

b Move the Monitor Size slide bar to a position corresponding to the diagonal screen 
dimension of your monitor. 

Do not exceed the size of your monitor, as this can result in too much stereo 
separation and cause visual problems and headaches.

2 Adjust the separation according to your stereo viewing comfort level—either using the 
property page or during gameplay.. 

• In the Stereo Properties page, under Stereo Separation (see Figure 2.5), move the 
slide bar to the expected comfort level, then click OK or Apply.

Monitor size selection, to 
establish the maximum 
stereo separation that is
appropriate for your monitor.
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A recommended starting point is at 30%. You can increase the separation over time 
as your eyes grow accustomed to stereoscopic viewing..

Figure 2.5 Stereo Separation and Stereo Gamma Setup Controls

• During gameplay, use the hot keys to adjust the stereo separation.

See “Verify the Hot Keys” on page 14 for instructions on how to verify and set the 
hot keys.

Adjust the Stereo Gamma Setting

The On/Off action of LCD shutter glasses (page flipped stereo) darkens the display. To 
compensate for this effect, you can adjust the gamma as follows: 

• In the Stereo Gamma Setting section of the Stereo Properties page (see Figure 2.5), 
move the slide bar to the desired gamma value (0.5–6.00), then click OK or Apply. 

This value is ‘added’ to the gamma that is already set by the game. 

One setting should work for all games. NVIDIA recommends a value of 1.0.

• During gameply, you can also use hot keys to adjust the stereo gamma. This is useful 
when the game has no gamma adjustment of its own.

See “Verify the Hot Keys” on page 14 for instructions on how to verify and set the hot 
keys.

Stereo Separation Setup

Stereo Gamma Setup
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Verify the Hot Keys

Make sure the hot keys are set up so you can control stereo functions during gameplay. 

1 Click the Advanced Stereo Properties tree item in the slide-out tray.  

Figure 2.6 3D Stereo Driver Hot Key Setup

2 Get familiar with the hot keys. If they are not assigned, set up each hot key as follows:

a In the section Hot Key Setup, click the list arrow and then click the action for which 
you want to verify or change hot keys.

b To assign new hot keys for the selected action, click in the adjacent box and then 
press the hot keys on your keyboard.

The keystrokes appear in the box.

c Repeat for the remaining sections, Separation and Gamma, then click Apply . 

NVIDIA recommends using the following default hot keys:

• Toggle Stereo Default On—Ctrl+T (turns 3D stereo on or off while playing a game)

• Save Image—Alt+F1

See “Capturing Images” on page 30 for an explanation of this function. 

• Increase (Stereo) Separation—Ctrl+F4

• Decrease (Stereo) Separation—Ctrl+F3

• Increase Gamma—Ctrl+G

• Decrease Gamma—Alt+G
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Step 5: Play Games in Stereo

Basic Gameplay

You can now play compatible games in stereo.

1 Determine the suitability of your game for stereo viewing.

See “Viewing the Game Ratings” on page 16.

2 Set the stereo refresh rate for your game.

For detailed information on testing the capabilities of your monitor before setting the 
stereo refresh rate, refer to “Stereo Test and Refresh Rate Setup” on page 17.

a Click the Stereo Setup & Test tree item from the slide-out tray.

b Set the color depth and resolution to correspond to the display mode of your game, 
then set the stereo refresh rate and click Set Rate for All Resolutions.

Set the refresh rate to 120 Hz if it is available, otherwise use 100 Hz as a minimum.

c Click Apply.

3 Start the 3D game and set to full-screen display mode.

For setting up the 3D laser on first-person shooter games, see “3D Stereo Laser Sight” 
on page 20. 

4 Use the hot keys to toggle 3D stereo ON or OFF, and to adjust the stereo separation to a 
comfortable level.

Advanced Features and Help

Refer to other sections of this manual for instructions on how to maximize the stereo 
display quality:

• “Creating and Modifying Game Configurations” on page 23

provides instructions for advanced users on how to adjust various stereo parameters 
such as screen depth, convergence, and backplane positioning.

• “Tips and Troubleshooting” on page 40

provides suggestions to help you successfully play games in stereo and maximize the 
stereo quality of your games. 
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Game Ratings for Stereo

The level of effective stereo viewing varies from game to game. NVIDIA has evaluated a 
number of games and provides information to help users determine how well their game 
will look in stereo. 

Understanding the Game Ratings

Ratings for each game are provided in two areas:

• Stereo Value - Indicates how much added entertainment value the game has in stereo. 
Some games are rich in 3D information while others are little more than 2D.

• Stereo Compatibility - Indicates how well the game translates to stereo. Some games 
may contain issues that interfere with good stereo viewing, such as placing objects at 
depths that are difficult to view. 
Viewing games that have a low rating can result in adverse symptoms such as 
headaches and visual problems. It is the user’s responsibility to use the information 
to decide whether to view certain games in stereo.  

Viewing the Game Ratings

Click the Stereo Game Configuration tree item from the slide-out tray, then locate your 
game from the menu and click the name.  

Figure 2.7 Game Configuration Page

Stereo Value and 

The Comments section

Compatibility Ratings

describes issues in the
game that interfere with 
good 3D stereo viewing.
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Stereo Test and Refresh Rate Setup

The Stereo Setup & Test feature allows you to:

• Test different color depth, resolution and refresh rate combinations to determine the 
limitations of your system and the optimum display mode for your games.

• Set the stereo refresh rate for your games. 

This refresh rate overrides the display adapter control panel refresh rate setting. Stereo 
must be enabled and a mode change performed for the stereo refresh rate to go into 
effect. 

Controlling the Refresh Rate 

Specifying the Refresh Rate

1 Click the Stereo Setup & Test tree item from the slide-out tray. . 

Figure 2.8 Stereo Setup & Test Page

2 Select the color depth using the Bit Depth radio buttons, then move the Resolution slide 
bar to the desired resolution. 

3 Set the refresh rate using the Stereo Refresh Rate slide bar. The best stereo image is 
achieved at high refresh rates, preferably over 100 Hz.

4 Click Apply. 
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The New Refresh Rate Behavior

You can control when the new refresh rate is applied as follows:

• Check the Always Use Stereo Refresh Rate check box to use the new refresh rate 
immediately. 

• Clear the Always Use Stereo Refresh Rate check box to use the new refresh rate when 
the corresponding resolution is set by the game, or if the resolution is set during the 
display test procedure described below. 

Each time you you change this setting, the following dialog box appears. 

Note: There must be a mode change for any refresh rate changes to go into effect. If stereo 
is disabled, the stereo refresh rate will continue until a change is made to the 
desktop resolution.
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Testing Display Combinations

This section explains how to test the mode and refresh rate capabilities of your monitor 
for 3D stereo. 

1 Click the Stereo Setup & Test tree item from the slide-out panel.

2 Choose a mode and refresh rate combination.

Method A

Choose a new bit depth, resolution, and refresh rate individually. 

Method B

a Choose the desired bit depth, then select an optimum refresh rate, such as 120 Hz.

b Click Set Rate for All Resolutions. 

This forces the selected refresh rate on all resolutions in the test. If the rate is not 
available, the driver will select the closest available refresh rate for that resolution.

3 Click Launch Test Application. (DirectX 8 is required to view the test screen.)

A blank screen appears while the refresh rate is measured, then the test screen appears..

4 To change settings while viewing the test screen

a Press F1. 

A hot key menu appears.

b Use the hot keys to adjust the refresh rate and resolution until you find the highest 
refresh rate that will pass the test, then press F6 to save this setting.

The settings will revert to a “safe” refresh rate, such as 60 Hz, after 15 seconds. Make 
sure to press F6 before the time runs out if you want to save the current settings. 
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3D Stereo Laser Sight

Cross-hair sights in first-person shooter games are usually positioned at screen depth 
when view in stereo, making it difficult to aim. To resolve this, NVIDIA provides a 
selection of 3D “laser” sights that appear on the targeted object. The NVIDIA laser sights 
work in properly configured first-person shooter games with screen-centered sights. 

1 Click the Advanced Stereo Properties tree item from the slide-out tray.

Figure 2.9 Advanced Stereo Properties Sheet

2 Enable the NVIDIA laser sight.

Select On for Configured Games.

3 Select a laser sight design.

Click the up or down arrow button to scroll through the selection of sights.

4 Move the Transparency slide bar to adjust the laser transparency—from 0% (solid laser 
sight) to 100% (almost see-through sight).

The recommended setting is at 25%. 

5 When finished, click Apply. 

The laser sight appears when stereo is turned on during a game. To avoid confusion, 
disable the sight provided by the game. Refer to the Config Values section under Stereo 
Game Configurations > Advanced Settings for any special instructions. 

You can also use the hot keys to toggle the NVIDIA laser sight on and off. See “About the 
Configuration Hot Key Functions” on page 26.

Enable NVIDIA 

Select choice of 

Adjust sight 

sight design

transparency

Laser Sight
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USING THE GAME CONFIGURATION FEATURE

This chapter describes the advanced game configuration feature of the NVIDIA 3D Stereo 
Driver. It contains these sections:

• “The Purpose of Game Configurations” on page 22

explains the purpose of the game configurations.

• “Creating and Modifying Game Configurations” on page 23

explains how to change the configuration parameters and save the changes.

• “Assigning Configurations to Games” on page 28

explains how to use demo version configurations for the full game version of a game, 
or visa versa.
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The Purpose of Game Configurations

Characteristics of Good Stereo Viewing

Optimum stereo is achieved when the game display consists of the following:

• Meaningful range of depth, or distance between the nearest and farthest objects. 

• Nearest objects which are not too close for comfortable viewing.

• Heads up displays (HUDs) which are positioned so as not to interfere with the stereo 
experience. Ideally, HUDs should be at screen depth.

The NVIDIA 3D Stereo Driver takes certain 3D information contained in the game and 
uses it to generate the stereo display. Since most games are not designed with stereo in 
mind, the resulting stereo display quality will vary from game to game. In some cases, the 
game is not viewable at all in stereo without making adjustments based on observation. 

What the NVIDIA 3D Stereo Driver Provides

Preset Configurations

For most games, NVIDIA has established settings that adjust the display to achieve 
meaningful stereo, based on the needs of each game. 

After you launch a game and enable the NVIDIA stereo support, the driver compares the 
game executable name with its own list. If the driver finds a match, it applies the 
adjustments to that game to improve the stereo display. 

You can view the list of these games in the Stereo Properties > Game Configuration sheet 
under Game Name.

Hot keys to Change or Create Configurations

The NVIDIA provided settings are designed for optimum stereo viewing, and should not 
require further adjustments. It is possible, though, to change these settings to suit 
individual tastes. 

Configuring game parameters for stereo is a complex process and should be performed 
only by persons who are thoroughly familiar with the parameters involved in creating 
stereo images.

See “Creating and Modifying Game Configurations” on page 23 for instructions on how 
to change settings for listed games and how to create settings for games that are not listed. 
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Creating and Modifying Game Configurations

You can change the stereo parameters for 3D games. When you save the changes, the 
driver uses the saved settings automatically the next time the game is launched. 

Hints to Keep In Mind

• To undo changes that have not been saved, just exit the game.

• To undo changes that have been saved, you must uninstall and then re-install the 3D 
Stereo Driver.

• To restore original configurations that have been deleted, you must uninstall and then 
re-install the 3D Stereo Driver.

To View the Current Configuration

1 Find the listed games.

Click the Stereo Game Configuration tree item from the slide-out tray, then scroll 
through the Game Name list to find your game, then click it.

2 Click Advanced Settings to open the Advanced Game Configuration page.

The Advanced Game Configuration sheet shows the current settings for the game.  

Figure 3.1 Stereo Game Configuration Page

Custom configuration data
appears here.
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To Perform In-Game Configuring:

1 Set up and get familiar with the Game Configuration Hot Keys.

a Click the Stereo Game Configuration tree item from the slide-out tray, then click 
Configure Hot Keys from the Stereo Game Configuration page.  

Figure 3.2 Game Configuration Hot Keys Page

b For each section, click the list arrow and then click the action for which you want to 
verify or change hot keys.

c To assign new hot keys for the selected action, click in the adjacent box and then 
press the hot keys on your keyboard.

The keystrokes appear in the box.

Avoid assigning hot keys that are needed by your game, or that are already assigned 
for the basic stereo functions.

d Make sure the Enable In-Game Configuration box is checked.

e Click OK or Apply when finished.

2 Use the hot keys to alter the stereo presentation while viewing the game.

See “About the Configuration Hot Key Functions” on page 26 for a description of each 
function, and “Configuration Guidelines” on page 25 for a suggested method of 
finding the optimum settings for your game.

3 To save the setting, press Ctl+F7 (or whichever hot key you chose).

The driver saves the settings in the registry, and creates a log file in the folder 
Nvstereo.log. 
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4 To delete all settings and start over, press Alt+F7.

This removes all stereo configuration settings, including the original NVIDIA settings.

Configuration Guidelines

Play a game to see how it looks in stereo. Make adjustments using Table 3.1 as a guide. 

Figure 3.3 Graphical Illustration of Stereo Parameters

Table 3.1 Stereo Improvement Suggestions

Problem Suggestion
Objects are too close Decrease Convergence (Ctl+F5)
HUD items too close Increase Screen Depth (Ctl+F10)
HUD items in the background Increase Backplane (Alt+F9)
Side borders blurred, not clear, not visible. Cycle Frustrum Adjust until borders are clear. 

(Ctl+F11)
Convergence setting not good for all parts of the game. Toggle Auto Convergence (Ctl+F8)
Stereo unclear, but not sure what needs to be adjusted.. Suggest Settings (Ctrl+F2)

No

No
Stereo

Stereo

Zero parallax

Adjust using Backplane hot keys.

Convergence

User’s View

Minimum RHW (depth information provided by the game)

“RHW Lesser @ screen”: Objects behind this depth are 

Maximum RHW (depth information provided by the game)

“RHW greater @ screen”: Objects in front of this depth are

Adjust using Screen Depth hot keys.

Adjust using Convergence hot keys.

repositioned to the screen depth.

repositioned to the screen depth.

(Screen depth)
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About the Configuration Hot Key Functions

Table 3.2 lists the functions in the Stereo Game Configuration Hot Keys page. Use the 
information in the table as well as the illustration in Figure 3.3 to gain an understanding of 
each game configuration function.  

Table 3.2 Stereo Configuration Hot Key Functions 

Label Hot Key Hot Key Action Comments
Cycle Frustum 
Adjust

Ctrl+F11 Cycle through three different 
frustum settings.
First setting: No frustrum 
adjustment.
Second setting: Expand the 
display in the x direction.
Third setting: Clear left or right 
edges of each eye view.

Use to fix problems with the left 
and right borders. 

Toggle Laser Sight Ctrl+F12 Toggle the laser sight ON or 
OFF.

Increase Screen 
Depth

Ctrl+F10 Progressively repositions 
objects to the screen depth, 
starting with the closest 
objects.
Moves the most forward plane 
(RHW greater@screen) farther 
back. 

Use if the closest objects are 
positioned inconsistently with the 
game, such as HUDs. 

Decrease Screen 
Depth

Ctrl+F9 Reverses the “Increase Screen 
Depth” action.
Moves the most forward plane 
(RHW greater@screen) closer. 

Use to maximize the range of 
depth in front of the screen.

Increase Backplane Alt+F10 Progressively repositions 
objects to the screen depth, 
starting with the farthest 
objects.
Moves the backplane (RHW 
lesser@screen) closer to the 
screen. 

Use if the farthest objects are 
positioned inconsistently with the 
rest of the game. 

Decrease Backplane Alt+F9 Reverses the “Increase 
Backplane” action.
Move backplane (RHW 
lesser@screen) away from the 
screen. 

Use to maximize the range of 
depth behind the screen.

Increase 
Convergence

Ctrl+F6 Move objects towards you. 
Maximum convergence places 
all objects “in front of” the 
screen, in user space. 

Use along with the Decrease 
Convergence hot key to achieve a 
good balance between objects in 
front of the screen and objects 
behind the screen.
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Decrease 
Convergence

Ctrl+F5 Move objects away from you. 
Minimum convergence places 
all objects “behind” the screen, 
in CRT space.

Use along with the Increase 
Convergence hot key to achieve a 
good balance between objects in 
front of the screen and objects 
behind the screen.

Toggle Auto 
Convergence

Ctrl+F8 Toggles Auto Convergence ON 
or OFF. When ON, 
dynamically adjusts the 
convergence according to the 
position of objects in the game.

Use when the range of depth varies 
quite a bit from scene to scene 
throughout the game. 

Restore Default 
Convergence

Alt+F8 Clears any convergence 
changes made by the Auto 
Convergence function. 

Use to undo changes made by Auto 
Convergence. 

Suggest Settings Ctrl+F2 Sets configurations based on 
data collected during the game.

Use as a starting point to improve 
undesirable configuration settings. 

Unsuggest Settings Alt+F2 Reverses any changes made by 
the Suggest Settings function.

Write Configuration Ctrl+F7 Saves settings to the registry. Use when you wish to use the new 
settings at another time. 

Delete 
Configuration

Alt+F7 Removes the stereo 
configuration settings from the 
registry.

CAUTION: This hot key clears all 
settings, including original 
NVIDIA provided settings.

Table 3.2 Stereo Configuration Hot Key Functions  (continued)

Label Hot Key Hot Key Action Comments
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Assigning Configurations to Games

If only one version of a game contains configuration settings, such as the demo or full 
game version, you can apply the settings to another version of the game. If the demo 
version looks good with the current configuration, the full game version should also look 
good with the same configuration. 

To use a particular configuration for another version of the game, or for another game:

1 Find the listed configuration.

a Click the Stereo Game Configuration tree item in the slide-out tray.

b In the Stereo Game Configuation page, scroll through the Game Name list to find 
the configuration you want to use, then click it.

c Click Advanced Settings to open the Advanced Game Configuration page.

2 Select the game to assign to the configuration.

a In the Advanced Game Configuration sheet, click Change.

b Locate the new game executable file and select it.

c Click Open.

The current configuration is now assigned to the chosen game.

Figure 3.4 Assigning Configurations to Unconfigured Games

Click to locate unconfigured game

Click to clear the assignment
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USING THE NVIDIA STEREO VIEWER

The NVIDIA 3D Stereo Driver comes with a Stereo Viewer application for viewing and 
manipulating static stereo images. 

The Stereo Viewer is designed to display images created using the NVIDIA stereo image 
capture utility, and can also display inmages from other source—including JPS, H3D, 
JPEG, PNG, PNS, and anaglyph JPEG images. 

The following sections describe the capabilities of the NVIDIA Stereo Viewer: 

• “Capturing Images” on page 30

• “Viewing Images” on page 30

• “Setting Resolution and Gamma” on page 36

• “Viewing a Set of Images as a Slide Show” on page 37

• “Moving the Image Files” on page 38
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Capturing Images

The NVIDIA driver includes a stereo image capture function that takes a snapshot of a 
stereo video or game. It saves page flipped images as a JPS file, and anaglyph stereo 
images as a JPEG. To capture a stereo image, press Alt+F1 while playing a game in stereo.

• The hot key for “Save Image” is defined under the Stereo Properties > Additional 
Properties sheet. 

• The driver assigns the image a sequential filename based on the original application, 
and stores it in the folder \Nvstereo.img. 

Viewing Images

Table 4.1 lists the types of files that can be viewed with the Stereo Viewer, and provides a 
brief description of applicable requirements.

Table 4.1 File Types Viewable with the Stereo Viewer 

File Type (extension) Stereo Type Comments
JPEG Stereo (.jps)
PNG Stereo (.pns)

Page Flipped Created by the Stereo Capture utility from page flipped 
stereo, or provided by an outside source. Regular JPEGs 
(or PNGs) that consist of a side by side image must be 
renamed with the .jps (or .pns) extension in order to be 
viewed as a stereo image.

JPEG (*l.jpg and *r.jpg)
PNG (*l.png and *r.png)

Page Flipped Both “left” and “right” image files are viewed as a set. 
Both filenames must be identical except for the last letter. 
When one of the files is opened (see “Viewing Images” on 
page 30) the Stereo Viewer searches for the 
complementary file in the same directory and opens both 
files. If a complementary file does not exist in that 
directory, the first file is opened without any stereoscopic 
properties. 

H3D (.h3d) Page Flipped Must be a true H3D file, and not another file type renamed 
with the .h3d extension.

JPEG (.jpg) Anaglyph Created by the Stereo Capture utility from anaglyph stereo, 
or provided by an outside source. JPEG files that are not 
anaglyphs are opened without any stereoscopic properties.
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Using the Stereo Viewer 

Starting the Viewer

Open the Stereo Viewer by clicking Stereo Viewer from the Stereo Properties page. 

Figure 4.1 Starting the Stereo Viewer

The Stereo Viewer window appears.

Figure 4.2 NVIDIA Stereo Viewer

Stereo Viewer Button
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Opening a 3D Stereo Image

You can load images into the viewer two ways:

• Use Method 1 for loading JPS, PNS, true H3D stereo files, or one of a pair of ‘1’ or ‘r’ 
JPEG or PNG files.

• Use Method 2 for loading one at a time separate left and right JPEG or PNG files that 
are stereoscopic when viewed alternately (page flipped).

Method 1: Load Both Eyes Simultaneously
1 From the NVIDIA Stereo Viewer window, do one of the following

• Click File->Open from the main menu

• Press the hot key (Ctrl+O)

• Right-click the stereo viewer window, then click Open.

The browser window opens.

2 From the browser, locate and choose a stereo file, then click Open

The Viewer displays separate left and right images..

Figure 4.3 Stereo Viewer—Windowed View

• JPS, PNS, and true H3D files are treated as page flipped stereo images, with the left 
and right images corresponding to each respective ‘page’.

• If a JPEG or PNG file is opened and the filename contains the letter ‘r’ or ‘l’ before 
the extension, the Viewer searches for a similar filename that contains the letter ‘l’ or 
‘r’. The Viewer then opens both files and treats them as a single page flipped stereo 
image.

Example filenames: NVIDIA_l.jpg and NVIDIA_r.jpg.

• Other JPEG and PNG files are not treated as stereo images, and the left and right 
images will be identical. However, you can use the stereo viewer to open and view 
anaglyph JPEGs without the need for paint programs or other graphics viewers. 
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Method 2: Load Each Eye Individually
1 Click in one of the ‘eyes’ of the Stereo Viewer window, then choose Load Eye from the 

menu.

2 Locate the file that corresponds to the ‘eye’ you clicked (left or right), select it, then click 
Open.

3 Repeat steps a and b for the other eye view.

Viewing the File in 3D Stereo 

1 Click View > Stereo View to see the full-screen stereo display of the image.

Hot Key—Ctrl+V

2 When finished viewing, press the ESC key to return to the windowed view.

If left/right “black eyes” do
not appear, resize the Viewer
window.
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Summary of How to View Different File Types 

Type of Image How to View
JPS, PNS, or H3D Image Just open the file. 

The Stereo Viewer places the left side of the 
image in the left eye position and the right side 
of the image in the right eye position.

Set of Left and Right JPEGs or PNGs—Method A If the filenames for the left and right eyes are 
identical except for the ‘l’ and ‘r’ designation 
right before the extension, then open one of the 
files with the Stereo Viewer. 
The Viewer opens both files and places the ‘l’ 
file in the left eye position and the ‘r’ file in the 
right eye position.

Set of Left and Right JPEGs or PNGs—Method B You can place any two JPEG or PNG files in the 
left and right eye positions one at a time. 
For each eye view, right click in the 
corresponding Viewer window, choose Load 
Eye from the menu, then select the file you want 
to use for that eye view. 

Anaglyph JPEG Just open the file.
Instead of opening another graphics application, 
you can use the Stereo Viewer as a graphics 
viewer for JPEGs. 
Since the left and right eye views are identical, 
the image does not have stereo properties unless 
it is an anaglyph. 

Sample filename—NVStereo.jps
or NVStereo.h3d

Sample filename Sample filename
NVStereo_l.jpg NVStereo_r.jpg

Sample filename
NVStereoleft.jpg

Sample filename
NVStereoright.jpg

Sample filename—NVStereoanaglyph.jpg
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Reversing Left and Right Page Flipped Images

Page flipped images created by the NVIDIA stereo image capture utility will display 
correctly. Images obtained from other sources, however, may be designed for cross-eyed 
viewing and will not display correctly. In this case, the left and right images must be 
switched. To do this: 
Open the stereo image, then from the main menu click View->Swap Eyes.

Hot Key—Ctrl+W

The left and right images will switch positions. This effects the display of the current 
image only, not the image file itself.

Note: The stereo viewer cannot reverse the display of JPEG images. However, anaglyph 
displays of JPS, PNS, or H3D images can be reversed. 

Viewing Page Flipped Images as Anaglyphs

To view a JPS file as an anaglyph—

1 Open the file. 

2 Switch the display type using any of the following methods: 

• From the main menu, click View->Switch Display Type.

• Press the hot keys Ctrl+T

• From the main menu, click View->Options, then in the Display Settings section of 
the the Options page choose Anaglyph and click OK or Apply. 

The viewer display changes from page flipped to anaglyph.  

3 Click View->Stereo View to view the full-screen anaglyph stereo image.

Hot Key—Ctrl+V

Note: You can convert the page flipped file to an anaglyph JPEG. While viewing the 
image in full-screen anaglyph stereo mode, save the image as an anaglyph JPEG 
using the stereo capture utility (Alt+F1). 
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Setting Resolution and Gamma 

The Stereo Viewer application contains additional viewing functions. 

Changing Display Settings 

From the main menu, click View > Options  

Figure 4.4 Stereo Viewer Options Page

• To change the display resolution

Under Display Settings click the arrow button, then choose from the list of available 
display options, then click OK. 

• To change color depth

Click the Desktop radio button to use your desktop color depth setting, or click either 
the16 bits or 32 bits radio button. 

• To adjust the display to fill your screen, check the Scale to Fit check box.

Adjusting the Brightness

To accommodate different monitor and lighting conditions, 

• press Ctrl+G to increase the gamma (brightness) of the stereo display.

• press Shift+G to decrease the gamma (brightness) of the stereo display.
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Viewing a Set of Images as a Slide Show

You can view a set of stereo images in either automatic or manual sequence.
1 Choose Automatic or Manual viewing:

a From the main menu, click View > Options.

b In the Slide Show Settings section, choose Manual or Automatic, then click OK.

If you choose Automatic, enter the length of time (in seconds) to display each frame. 

2 Locate the images to view.

a From the main menu, click View > Slide Show 

Hot Key—Ctrl+S.

The Slide Show Files window appears. 

Figure 4.5 Stereo Viewer Slide Show - Files Selection

b To view another directory, either 

• edit the entry in the directory box using the keyboard, or 

• click the drop down arrow and choose from the list of previously accessed 
directories, or 

• click the Change button, select a different directory where the files are located, then 
click OK. 

3 From the list of files, choose the files to be displayed in the slide show.

4 Click Begin to start the slide show.
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The images will appear in full-screen stereo view. 

If you chose Manual viewing, use the following hot keys to switch images:

• Next image, exit after the last image: Space bar, or left mouse button.

• Next image, repeat the cycle after the last image: Right arrow, or page down key.

• Previous image: Left arrow, page up key, or right mouse button.

Moving the Image Files

Sometimes filenames do not give a good indication of the subject matter, making it 
difficult to organize files. The Move function allows you to view the image and then 
immediately move the file to a specified folder. 
1 Set up the destination folder.

a From the main menu, click View > Options...

b From the Miscellaneous Settings section in the Options window, click Change, then 
use the Browser window to select the destination location for the file(s). 

c Click OK in the Browse for Folders window, then click OK in the Options window 

2 Open the stereo image to view it, using File > Open Stereo Image. 

Hot Key—Ctrl+O

Both left and right images will be displayed in the Viewer window. 

3 Move the file to the destination folder.

Click View->Move Image

Hot Key—Ctrl+M 

The file is now stored in the new folder.
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Summary of Stereo Viewer Hot Keys

You can also press F1 or click Help>About to see a list of the hot keys. 

Hot Keys Enabled in Windowed View

These hot keys work in the Viewer windowed view only.

Hot Keys Enabled in Full-Screen Stereo View

These hot keys work in the full-screen stereo view only.

Hot Keys Always Enabled

These hot keys work in any view. 

Function Hot Key
Open Stereo Image Ctrl+O
Display Image in Stereo Ctrl+V
Toggle Display Type Between 
Page Flip and Anaglyph

Ctrl+T

Set Up the Slide Show Ctrl+S

Function Hot Key
Increase Gamma Ctrl+G
Decrease Gamma Shift+G
Go to next slideshow image [Space bar] 
Cycle to next slideshow image Right-arrow / [Pg Dn]
Go to previous image Left arrow / [Pg Up]
Quit Viewer [Esc]

Function Hot Key
Switch Left and Right Images Ctrl+W
Move the Image File Ctrl+M
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C H A P T E R

TIPS AND TROUBLESHOOTING

Refer to this chapter for ideas on how to maximize the stereo quality, or for help if you 
have difficulty using the NVIDIA 3D Stereo Driver. This chapter covers the following 
topics:

• “Stereo Viewing Tips” on page 41 lists suggestions to help maximize the stereo quality 
of your games.

• “Troubleshooting” on page 44 lists suggestions to help you successfully play games in 
stereo.

• “Stereo Viewer” on page 49 list suggestions to help you successfully use the Stereo 
Viewer.
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Stereo Viewing Tips

Viewing Practices that Effect Stereo Quality

Stereo Separation

A recommended starting point is 30%, but always adjust the separation to a comfortable 
level. You can increase it over time as your eyes get used to stereo viewing.

Viewing Distance

Maintain a distance no closer than 2 to 2.5 feet away from the monitor. Viewing from too 
close a distance can cause too much strain on your eyes, and can reduce stereo quality.

Viewing Angle

Keep your eyes parallel to the screen. The imaginary line connecting your eyes should be 
parallel to the horizontal level of the screen. 

The stereo effect is based on side-to-side—or horizontal—displacement of each image. If 
you tilt your head side-to-side, your eyes no longer see the displacement as horizontal, 
and the stereo effect is diminished or even eliminated. While your brain may adjust to this 
viewing, it must work harder, resulting in eye strain and fatigue.

Viewing Time

Take regular breaks. As with any time spent looking at a computer screen, it is good 
practice to give your eyes a rest after a period of time. At a minimum, rest for 5 minutes 
after every hour of stereo viewing.

Viewing with Prescription Glasses

If you normally wear glasses when viewing a computer screen, keep them on during 
stereo viewing. You can put on most stereo eyewear over your regular glasses.

The sharper the image on the screen, the better the stereo quality. 
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System and Game Settings that Effect Stereo Quality

Refresh Rate

Set your monitor to the highest refresh rate possible, preferably 120 Hz or higher. The 
refresh rate for each eye should be higher than 40–60 Hz in order for flicker to be 
imperceptible. Any perceived flicker degrades the image quality and can lead to eye strain 
and fatigue.

Display Lighting

The amount of light reaching each eye is cut in half, and causes the screen to appear 
darker under stereo viewing. To compensate, be sure to set the gamma setting in the 
Stereo Properties page to an appropriate level. Adjusting the brightness and contrast 
settings of your game can also reduce screen persistence and improve stereo quality. 

Game Cursor / Cross-hair Sights

If you are using the NVIDIA 3D laser sights, be sure to turn off the sight that the game 
provides. The game sight is usually positioned at screen depth, and interferes with useful 
viewing of the NVIDIA laser sight.

Ambient Lighting

The intensity of surrounding lighting can effect stereo quality and comfort. Lighting 
conditions that improve stereo viewing vary from one person to the next, so experiment 
with brighter or darker room lighting to find what works best for you.

System Speed

Because the graphics system must generate twice the number of images, you might notice 
a decrease in game performance in slower systems. To improve game performance, 
reduce the monitor resolution for your game. 

Don’t worry about losing display quality. The display quality at any given resolution 
actually improves when viewed in stereo.
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System Memory

Because the graphics system must generate twice the number of images, you might not be 
able to play games in stereo on systems with low memory. There are a few things you can 
do to minimize the amount of memory used by the 3D stereo process.

• Reduce the resolution.

• Reduce the bit depth.

• Adjust the settings in the Stereo Compatibility page as follows:

a Click the Stereo Compatibility tree item from the slide-out tray. 

Figure 5.1 Stereo Compatibility Page

b If the game closes and returns you to the desktop when you attempt to play it in 
stereo, make sure the Force anti-aliasing always off in Stereo check box is checked.

c If the game has little or no depth or separation in stereo, check the Force HW TnL 
off check box.

Hardware Vertex Shaders

The NVIDIA 3D driver supports hardware vertex shaders. In the rare event that hardware 
vertex shaders aren’t working in 3D stereo, you can choose to use software vertex shaders 
by checking the Force software Vertex Shaders in Stereo check box from the Stereo 
Compatibility page (see Figure 5.1).
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Troubleshooting

Game Playing

Problem: No Stereo

• Possible Cause: Stereo not enabled

• Make sure stereo is enabled.

Under Stereo Properties, click either the Enabled or Enabled by Hot Key radio 
button, then click OK or Apply.

• Make sure hot keys are set up.

Click the Advanced Stereo Properties tree item in the slide-out panel, then verify 
the hot keys are defined. NVIDIA recommends using Ctrl+T for Toggle stereo on/
off, Ctrl+F3 for Less Stereo Separation, Ctrl+F4 for More Stereo Separation, Alt+F1 
for Save Image, Ctrl+G for Increase Gamma, and Alt+G for Decrease Gamma.

• Turn stereo On.

While playing the game, press Ctrl+T to toggle stereo on and off.

• Possible Cause: Stereo separation too small

• Increase the stereo separation.

Press Ctrl+F4 while in the game. Alternately, under Stereo Properties, move the 
Stereo Separation slide bar to a higher setting—towards Advanced—then click OK 
or Apply.

• Possible Cause: Problem with hardware installation

• Check to make sure the eyewear is connected and operating. Some eyewear have an 
on/off switch, or operate on batteries. 

The view through the eyewear should darken when stereo is turned on.

• Refer to the instructions for your stereoscopic viewing hardware.

• Possible Cause: Problem with driver installation

• Check driver documentation.

• Possible Cause: Game is not in full-screen mode

• Set the game to play in full-screen (not windowed) mode.
44 NVIDIA 3D Stereo User’s Guide – Revision 7.0



CHAPTER 5
Tips and Troubleshooting
• Possible Cause: Game is not configured for Direct3D or OpenGL

• Set the game to play using Direct3D or OpenGL hardware rendering. Do not use 
software rendering.

• Games which do not use Direct3D or OpenGL are not support by the NVIDIA 3D 
Stereo Driver.

Problem: Image Not Clear

• Possible Cause: Eyes not adjusted

Your eyes may take some time to adjust to stereo viewing.

• Possible Cause: Too much stereo separation

Decrease the stereo separation.

Press Ctl+F3 while in the game. Alternatively, in the Stereo Properties page, move the 
Stereo Separation slide bar to a lower setting—towards Beginner—then click OK or 
Apply.

• Possible Cause: Display mode not optimal

Adjust the stereo refresh rate.

1 Click the Stereo Setup & Test tree item from the slide-out tray, then select the Bit 
Depth and move the Resolution slide bar to correspond to the game display mode. 

2 Set the Stereo Refresh Rate slide bar to 120 Hz, then press Launch Test 
Application.

3 If the stereo image looks OK, press F6, then press the (+) key to test using a higher 
refresh rate.

4 Continue testing until an acceptable display is achieved at the highest refresh rate 
that your monitor can handle.

• Possible Cause: Game configuration—no settings exist for any version of the game

You can verify this by checking the Game Name list in the Stereo Game Configuration 
page. 

If your game is not listed, use the hot keys as defined under Stereo Game Configuration 
> Configure Hot Keys to create various stereo settings while viewing the game.

Refer to Table 3.2, “Stereo Configuration Hot Key Functions” on page 26, and Table 3.1, 
“Stereo Improvement Suggestions” on page 25.
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• Possible Cause: Game configuration—no settings exist for your game version

You can verify this by finding your game in the Game Name list in the Stereo Game 
Configuration page, then clicking Advanced Settings. 

If no ID key exists for your version of the game, refer to “Assigning Configurations to 
Games” on page 28 for instructions on how to use the configurations of the listed ID for 
your game.

• Possible Cause: Game configuration—settings exist but are not optimal 

If stereo configurations exist for your game, but the stereo image is still not clear, you 
may need to adjust the configuration settings further.

Use the hot keys as defined under Stereo Game Configurations > Configure Hot Keys 
to adjust various stereo settings while viewing the game. 

Refer to Table 3.2, “Stereo Configuration Hot Key Functions” on page 26, and Table 3.1, 
“Stereo Improvement Suggestions” on page 25.

• Possible Cause: Eyewear Hardware Not Set Up Properly or Eyewear Driver Support 
not Installed Properly

Eyewear with Left/Right Hardware Switch

Some eyewear must be manually set so that the left and right lenses correspond to the 
respective left and right screen images. If set incorrectly, stereo images may be difficult 
to see. To verify whether your stereo eyewear is switching correctly, launch the medical 
image test. 

• If the image consists of a small square hole that is cut out of a larger square—

Your eyewear left/right setup is configured incorrectly. You can confirm this by 
pressing Ctrl+W. The medical image should now display properly—as a small 
square in front of a larger square.

You will have to switch your eyewear setting when playing games. Refer to your 
eyewear documentation for instructions.

• If you cannot see a stereo image—

Press Ctrl+W. If the image can now be seen as a small square in front of the larger 
square, you will have to switch your eyewear setting when playing games. Refer to 
your eyewear documentation for instructions.
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Eyewear without Left/Right Hardware Switch

Eyewear that does not have a manual switch for left/right orientation is completely 
controlled by the NVIDIA driver to ensure left/right consistency with the screen 
image—provided the driver is configured properly. To verify, launch the medical 
image test.

• If the image consists of a small square hole that is cut out of a larger square—

The driver is configured incorrectly. You can confirm this by pressing Ctrl+W. The 
medical image should now display properly—as a small square in front of the larger 
square.

Obtain the latest stereo drivers recommended by the stereo hardware manufacturer, 
and reinstall the drivers.

• If you cannot see a stereo image—

Press Ctrl+W. If the image can now be seen as a small square in front of the larger 
square, obtain the latest stereo drivers recommended by the stereo hardware 
manufacturer, and reinstall the drivers.

• Possible Cause: Eyewear lenses are the wrong color (anaglyph viewing)

The default anaglyph configuration is for standard left-eye-red and right-eye-blue 
glasses. If the colors are reversed or different colors are used in your glasses, customize 
the anaglyph settings as follows: 

a Click the Advanced Stereo Properties tree item from the slide-out tray, then click 
Anaglyph Stereo.

The Anaglyph page appears.

Figure 5.2 Anaglyph Setup Page

b In the Anaglyph page, click the drop down menu arrow, then select Custom. 

c Click the left or right color box corresponding to the left or right lens of your glasses
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The Color Setup page appears 

Figure 5.3 Color Setup Page

d Click a Basic Color or a Custom Color, then click OK.

Problem: Eyestrain / Headache

• Possible Cause: Too much stereo separation

• Decrease the stereo separation.

Press Ctl+F3 while in the game. Alternatively, in the Stereo Properties control panel, 
move the Stereo Separation slide bar to a lower setting—towards Beginner—then 
click OK or Apply.

• Possible Cause: Too much flicker

Increase the stereo refresh rate.

1 Click the Stereo Setup & Test tree item from the slide-out tray, then select the Bit 
Depth and move the Resolution slide bar to correspond to the game display mode. 

2 Set the Stereo Refresh Rate slide bar to 120 Hz, then press Launch Test 
Application.

3 If the stereo image looks OK, press F6, then press the (+) key to test using a higher 
refresh rate.

4 Continue testing until an acceptable display is achieved at the highest refresh rate 
that your monitor can handle.

! WARNING!
If symptoms persist, discontinue viewing in stereo and consult a physician.

Creating Custom Colors:

Position cross-hair to choose
hue and saturation.

Position slider to choose
luminosity.

Enter values directly.

- or - 
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Problem: No Laser Sight

• Possible Cause: Laser sight not enabled

• Enable the laser sight.

Click the Advanced Stereo Properties tree item from the slide-out tray, then select 
On for Configured Games in the Laser Sight section.

• Possible Cause: Stereo not enabled

• Turn stereo On.

While playing the game, press Ctrl+T to toggle stereo on and off.

• Possible Cause: Transparency set too high

• Decrease the laser transparency.

Click the Advanced Stereo Properties tree item from the slide-out tray, then move 
the Transparency slide bar to a lower setting, towards the left. 

Stereo Viewer 

Problem: Stereo Image Not Clear

• Possible Cause: Side by side images are set up for “cross-eyed” viewing

• Reverse the images.

While viewing the image, press Ctrl+W, or from the Stereo Viewer window click 
View > Swap Eyes.

Problem: Image Not in Stereo

• Possible Cause: Image is a single image JPEG or PNG file.

• Use a JPS or PNS image instead.

• Possible Cause: Image is a a side-by side JPEG or PNG file.

• Rename the file using a .jps extension instead of .jpg, or using a .pns extension 
instead of .png.
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