Objekte in Microsoft Office-Servererweiterungen

Legende

Gelbes Kästchen Objekt und Auflistung
Blaues Kästchen Nur Objekt


Übersicht über Diskussionsserver und Diskussionen

In Microsoft Office können Sie mit Hilfe der Microsoft Office Servererweiterungen-(OSE-)Bibliothek Objekte in Discussions- und DiscussionServers-Auflistungen programmatisch steuern. Sie können neue Diskussionen und Diskussionsserver hinzufügen oder bestehende Diskussionen und Diskussionsserver lesen, modifizieren oder löschen.

Wichtig: Um die OSE-Bibliothek in Ihrer Programmierumgebung zu aktivieren, müssen Sie zuerst eine Referenz zur Microsoft Office Servererweiterungen 1.0-Objektbibliothek festlegen.

Das Global-Objekt ist der Ausgangspunkt zum Erkunden von Diskussionen und Diskussionsservern. Das Global-Objekt stellt eine Instanz von OSE dar und ermöglicht Ihnen, Diskussionsservern Abonnements hinzuzufügen, den Namen des aktuellen Microsoft Office-Benutzers abzurufen und die Auflistung der Diskussionsserver oder Diskussionen auf dem OSE-Host zurückzugeben.

Die DiscussionServers-Auflistung enthält ein oder mehrere DiscussionServer-Objekte. Jedes DiscussionServer-Objekt stellt einen Diskussionsserver dar, der auf dem Computer registriert ist, den Sie gegenwärtig verwenden. Ein DiscussionServer-Objekt besteht aus einem Anzeigenamen und einem Uniform Resource Locator (URL), die zusammen dem Benutzer die Verbindungsinformationen für den Diskussionsserver bereitstellen. Verwenden Sie die DiscussionServers-Methode des Global-Objekts, um die DiscussionServers-Auflistung zurückzugeben, die auf dem von Ihnen verwendeten Computer registriert ist.

Sie können die Discussions-Auflistung für einen bestimmten URL öffnen, indem Sie mit der OpenDiscussions-Methode des Global-Objekts die Discussions-Auflistung für das durch den URL angegebene Dokument zurückgeben. Diese Discussions-Auflistung kann viele Diskussionsebenen enthalten, wobei die Ebenen hierarchisch strukturiert sind. Jedes Discussion-Objekt in der Discussions-Auflistung der obersten Ebene ist ein Kommentar über das Themendokument. Jedes Discussion-Objekt kann wiederum untergeordnete Discussion-Objekte enthalten, die Antworten auf das ursprüngliche Discussion-Objekt sind. Antworten auf Antworten stellen die nächste Ebene in der Diskussionshierarchie dar usw. Sie können die Diskussionshierarchie durchlaufen, indem Sie die Discussions-Eigenschaft des Discussion-Objekts verwenden.


Add-Methode

Fügt einer Auflistung ein Objekt hinzu. Klicken Sie auf eine der folgenden Auflistungen, um eine detaillierte Beschreibung der Add-Methode für die betreffende Auflistung anzuzeigen.

Discussions

DiscussionServers


Add-Methode (DiscussionServers-Auflistung)

Fügt einer DiscussionServers-Auflistung ein DiscussionServer-Objekt hinzu.

Syntax

expression.Add(FriendlyName, ServerAddress)

expression Ein Ausdruck, der ein DiscussionServers-Objekt zurückgibt.

FriendlyName Erforderlicher String-Wert. Der Anzeigename des angegebenen Diskussionsservers.

ServerAddress Erforderlicher String-Wert. Der Uniform Resource Locator (URL) des angegebenen Diskussionsservers.

Hinweise

Der im ServerAddress-Argument angegebene URL muss einen nachgestellten Schrägstrich enthalten, wie im folgenden Beispiel mit dem URL http://samples.microsoft.com gezeigt.

dscServers.Add "Samples Folder", _
    http://samples.microsoft.com/


Beispiel für Add-Methode (DiscussionServers-Auflistung)

In diesem Beispiel wird ein neuer Diskussionsserver mit dem Anzeigenamen "Corporate Information Server" und dem URL http://samples.microsoft.com hinzugefügt.

Dim dscServers As DiscussionServers
Set dscServers = DiscussionServers
dscServers.Add "Corporate Information Server", _
    "http://samples.microsoft.com/"


Add-Methode (Discussions-Auflistung)

Fügt der angegebenen Discussions-Auflistung ein neues Discussion-Objekt hinzu.

Syntax

expression.Discussion(Subject, Text, Bookmark)

expression Ein Ausdruck, der eine Discussions-Auflistung zurückgibt.

Subject Optionaler String-Wert. Das Thema der angegebenen Diskussion.

Text Optionaler String-Wert. Der Text der angegebenen Diskussion.

Bookmark Optionaler String-Wert. Der eindeutige Bezeichner für die Position der angegebenen Diskussion innerhalb des Dokuments.

Hinweise

Die Author-Eigenschaft für die neue Diskussion wird automatisch auf den aktuellen Benutzernamen gesetzt, der durch die Microsoft Office-Hostanwendung bestimmt wird.


Beispiel für Add-Methode (Discussions-Auflistung)

In diesem Beispiel wird dem angegebenen Discussion-Objekt eine neue Antwort auf eine Diskussion hinzugefügt.

Set myResponse = dscDiscussions(1).Discussions.Add _
    ("Supply information", "Staples are here!", "Staples")


AddOfficeServerSubscription-Methode

Erstellt für die angegebene Datei oder den angegebenen Ordner ein Dokumentabonnement.

Syntax

expression.AddOfficeServerSubscription(FileURL, FolderURL, NotifyWhen, MailTo, MailFrequency, FilterOnAuthor, MatchAuthorExactly)

expression Erforderlicher Variant-Wert. Ein Ausdruck, der eine Instanz der Microsoft Office Servererweiterungen-(OSE-)Bibliothek zurückgibt.

FileURL Optionaler String-Wert. Der Uniform Resource Locator (URL) für die angegebene Datei. FileURL ist zwar ein optionales Argument, aber Sie müssen entweder FileURL oder FolderURL angeben.

FolderURL Optionaler String-Wert. Der URL für den angegebenen Ordner. FolderURL ist zwar ein optionales Argument, aber Sie müssen entweder FolderURL oder FileURL angeben.

NotifyWhen Optionaler Integer-Wert. Kann eine der folgenden OSENotifyWhen-Konstanten sein: oseNotifyWhenAnythingChanges, oseNotifyWhenDiscussionAnything, oseNotifyWhenDiscussionDeleted, oseNotifyWhenDiscussionInserted, oseNotifyWhenPageAnything, oseNotifyWhenPageCreated, oseNotifyWhenPageDeleted, oseNotifyWhenPageModified oder oseNotifyWhenPageMoved. Die Standardkonstante ist oseNotifyWhenDiscussionAnything. Abonnements, in denen alle Änderungen überwacht werden (oseNotifyWhenAnythingChanges) bzw. seitenspezifische Ereignisse (oseNotifyWhenPageAnything, oseNotifyWhenPageCreated, oseNotifyWhenPageDeleted und oseNotifyWhenPageModified) werden für Dateien auf Dateiservern unterstützt, auf denen nur OSE installiert ist.

MailTo Optionaler String-Wert. Die E-Mail-Adresse, an die E-Mail-Nachrichten gesendet werden sollen, wenn das NotifyWhen-Argument erfüllt ist.

MailFrequency Optionaler Integer-Wert. Kann eine der folgenden OSEMailFrequency-Konstanten sein: oseMailDaily, oseMailImmediately oder oseMailWeekly. Die Standardkonstante ist oseMailImmediately.

FilterOnAuthor Optionaler String-Wert. Filtert alle Nachrichten heraus, die keine Änderungen des durch dieses Argument angegebenen Autors enthalten.

MatchAuthorExactly Optionaler Boolean-Wert. True, wenn die durch dieses Argument angegebene Zeichenfolge exakt mit dem Namen des Autors übereinstimmen muss.


Beispiel für AddOfficeServerSubscription-Methode

In diesem Beispiel wird die Datei http://samples.microsoft.com abonniert und an jedem Tag, an dem der Benutzer Jim Hance eine Diskussion löscht, eine E-Mail-Nachricht an someone@microsoft.com gesendet.

AddOfficeServerSubscription _
    "http://samples.microsoft.com", , _
    oseNotifyWhenDiscussionDeleted, _
    "someone@microsoft.com", _
    oseMailDaily, "Jim Hance", True


Commit-Methode

Schreibt alle Eigenschaften des angegebenen Discussion-Objekts (einschließlich Änderungen von Eigenschaften) im Diskussionsspeicher auf dem Server fest.

Syntax

expression.Commit

expression Ein Ausdruck, der ein Discussion-Objekt zurückgibt.


Beispiel für Commit-Methode

In diesem Beispiel werden alle Eigenschaften (einschließlich Änderungen von Eigenschaften) festgeschrieben, die die angegebene Diskussion betreffen.

Dim dscDiscussions As Discussions
Set dscDiscussions = OpenDiscussions("http://samples.microsoft.com")
dscDiscussions(1).Discussions(1).Commit


Delete-Methode

Löscht das angegebene Objekt aus der Auflistung, in der es enthalten ist.

Syntax

expression.Delete

expression Ein Ausdruck, der ein Discussion- oder DiscussionServer-Objekt zurückgibt.

Hinweise

Wenn Sie die Delete-Methode verwenden, um ein Diskussionselement aus einem DiscussionServer-Objekt zu entfernen, werden alle Antworten auf dieses Diskussionselement automatisch auf die Ebene des gelöschten Elements hinaufgestuft.


Beispiel für Delete-Methode

In diesem Beispiel wird das dritte Diskussionselement aus der Discussions-Auflistung gelöscht. Alle Diskussionen, die untergeordnete Elemente der genannten Diskussion sind, werden auf die Ebene des gelöschten Elements hinaufgestuft.

dscCurrentCollection(3).Delete


DiscussionServers-Methode

Gibt die DiscussionServers-Auflistung zurück, die auf dem Computer registriert ist, den Sie gegenwärtig verwenden.

Syntax

expression.DiscussionServers

expression Ein Ausdruck, der ein Global-Objekt zurückgibt.


Beispiel für DiscussionServers-Methode

In diesem Beispiel wird die DiscussionServers-Auflistung (auf dem gegenwärtig verwendeten Computer) in der dscDiscussionServersCollection-Variablen zurückgegeben. Außerdem wird ein Meldungsfeld mit der Anzahl der Diskussionsserver angezeigt.

Dim dscDiscussionServersCollection As DiscussionServers
Set dscDiscussionServersCollection = DiscussionServers
MsgBox dscDiscussionServersCollection.Count


OpenDiscussions-Methode

Gibt die Discussions-Auflistung für das durch den Uniform Resource Locator (URL) angegebene Dokument zurück. Schreibgeschützter Object-Wert.

Syntax

expression.Discussions

expression Ein Ausdruck, der ein Microsoft Office Servererweiterungen-(OSE-)Objekt zurückgibt.


Beispiel für OpenDiscussions-Methode

In diesem Beispiel wird die Discussions-Auflistung für den Ordner http://examples.microsoft.com zurückgegeben.

Dim dscDiscussions As Discussions
Set dscDiscussions = _
    OpenDiscussions("http://examples.microsoft.com")


SetAsDefault-Methode

Legt den angegebenen Diskussionsserver als Standardserver für die Diskussions-Benutzeroberfläche und für alle nachfolgenden Aufrufe der globalen Methode OpenDiscussions fest.

Syntax

expression.SetAsDefault

expression Ein Ausdruck, der ein DiscussionServer-Objekt zurückgibt.

Hinweise

Der Standarddiskussionsserver ist stets das erste DiscussionServer-Objekt in der DiscussionServers-Auflistung. Durch die SetAsDefault-Methode werden die Elemente in der DiscussionServers-Auflistung neu geordnet, so dass der Standardserver an der Position steht, die durch Item(1) angegeben wird. Deshalb sollten nach dem Aufrufen dieser Methode alle Variablen verworfen werden, die auf veraltete DiscussionServer-Objekte gesetzt sind.


Beispiel für SetAsDefault-Methode

In diesem Beispiel wird der dritte Server in der DiscussionServers-Auflistung als Standarddiskussionsserver festgelegt.

dscServers(3).SetAsDefault


Discussion-Objekt

Stellt eine Diskussion in der Microsoft Office-Hostanwendung dar. Das Discussion-Objekt ist ein Element der Discussions-Auflistung.

Verwenden des Discussion-Objekts

Verwenden Sie Discussions(Index), um ein einzelnes Discussion-Objekt zurückzugeben, wobei Index der Index einer Diskussion ist. Im folgenden Beispiel wird die Variable dscOfficeSupplies auf die erste Diskussion in der Discussions-Auflistung gesetzt.

Set dscOfficeSupplies = dscDiscussions(1)

Verwenden Sie die AutoCommit-Eigenschaft, um den Status von Commit-Operationen festzulegen oder zurückzugeben, die steuern, ob Änderungen an Eigenschaften eines Discussion-Objekts sich sofort auf den Diskussionsspeicher auswirken. Verwenden Sie die Commit-Methode, um zu erzwingen, dass die Anwendung alle Eigenschaften des aktuellen Diskussionselements (einschließlich Änderungen an Eigenschaften) im Diskussionsspeicher auf dem Server speichert. Im folgenden Beispiel wird der Wert von AutoCommit für die angegebene Diskussion überprüft. Falls die Eigenschaft auf False gesetzt ist, werden Änderungen mit Hilfe der Commit-Methode im Diskussionsspeicher gespeichert.

If dscDiscussions(1).Discussions(4).AutoCommit = False Then
    dscDiscussions(1).Discussions(4).Commit
End If

Verwenden Sie die Author-Eigenschaft, um den Benutzernamen des Autors der aktuellen Diskussion abzurufen. Mit der LoginName-Eigenschaft rufen Sie den Microsoft Windows NT-Anmeldenamen des Autors der Diskussion ab. Verwenden Sie die Timestamp-Eigenschaft, um das Datum und die Uhrzeit der Erstellung oder der letzten Änderung der Diskussion abzurufen. Im folgenden Beispiel werden der Name des Autors, das Datum und die Uhrzeit der Erstellung oder der letzten Änderung und der Microsoft Windows NT-Anmeldename für die angegebene Diskussion angezeigt.

MsgBox dscDiscussions(1).Discussions(5).Author & _
    " created this discussion at " & _
    dscDiscussions(1).Discussions(5).Timestamp & _
    " while logged in as Windows NT user " & _
    dscDiscussions(1).Discussions(5).LoginName

Verwenden Sie die Discussions-Eigenschaft, um die Auflistung aller Diskussionselemente zurückzugeben, die Antworten auf die aktuelle Diskussion sind. Die zurückgegebene Auflistung kann auch eine Discussions-Auflistung enthalten, die aus Antworten auf eine übergeordnete Diskussion besteht, auf die Sie zugreifen können, indem Sie die Discussions-Eigenschaft für eine bestimmte Diskussion innerhalb dieser Auflistung verwenden.

Verwenden Sie die Subject-, Text- und Bookmark-Eigenschaften, um die entsprechenden Elemente für die angegebene Diskussion festzusetzen.


Discussions-Auflistung

Eine Auflistung von Discussion-Objekten, die Diskussionen darstellen, die in der Microsoft Office-Hostanwendung registriert sind.

Verwenden der Discussions-Auflistung

Verwenden Sie die OpenDiscussions-Methode des Global-Objekts, um die Discussions-Auflistung für das Dokument zurückzugeben, auf das durch den angegebenen Uniform Resource Locator (URL) zugegriffen wird. Im folgenden Beispiel wird die Discussions-Auflistung für den Ordner http://examples.microsoft.com zurückgegeben.

Set dscDiscussions = _
    OpenDiscussions("http://examples.microsoft.com")

Verwenden Sie die Add-Methode, um der Discussions-Auflistung ein neues Discussion-Objekt hinzuzufügen. Im folgenden Beispiel wird dem ersten Discussion-Objekt in der Auflistung eine neue Diskussionsantwort hinzugefügt.

Set myResponse = dscDiscussions(1).Discussions.Add _
    ("Supply information", "Staples are here!", "Staples")

Verwenden Sie die URL-Eigenschaft, um den URL für das Dokument zurückzugeben, das die angegebene Discussions-Auflistung enthält, wie im folgenden Beispiel gezeigt.

Dim dscDiscussions As Discussions
Set dscDiscussions = OpenDiscussions("http://samples.microsoft.com")
MsgBox dscDiscussions.URL

Verwenden Sie Discussions(Index), um ein einzelnes Discussion-Objekt zurückzugeben, wobei Index der Index einer Diskussion ist. Im folgenden Beispiel wird die Variable dscOfficeSupplies auf die erste Diskussion in der Discussions-Auflistung gesetzt.

Set dscOfficeSupplies = dscDiscussions(1)


DiscussionServer-Objekt

Stellt einen Diskussionsserver in der Microsoft Office-Hostanwendung dar. Das DiscussionServer-Objekt ist ein Element der DiscussionServers-Auflistung.

Verwenden des DiscussionServer-Objekts

Verwenden Sie DiscussionServers(Index), um ein einzelnes DiscussionServer-Objekt zurückzugeben, wobei Index der Index des angegebenen Diskussionsservers ist. Im folgenden Beispiel wird die Variable dscAccounting auf den dritten Server in der DiscussionServers-Auflistung gesetzt.

Set dscAccounting = dscServers(3)

Verwenden Sie die FriendlyName-Eigenschaft, um den Anzeigenamen des angegebenen Diskussionsservers festzulegen oder zurückzugeben. Im folgenden Beispiel wird der Anzeigename des ersten Servers in der Auflistung auf "Shipping Department Server" geändert.

dscServers(1).FriendlyName = _
    "Shipping Department Server"

Verwenden Sie die ServerAddress-Eigenschaft, um den Uniform Resource Locator (URL) für den angegebenen Diskussionsserver festzulegen oder zurückzugeben. Im folgenden Beispiel wird der URL des ersten Servers in der Auflistung auf http://example.microsoft.com gesetzt.

dscServers(1).ServerAddress = _
    "http://example.microsoft.com/"

Verwenden Sie die SetAsDefault-Methode, um den angegebenen Diskussionsserver als Standardserver für die Diskussions-Benutzeroberfläche und alle nachfolgenden Aufrufe der globalen Methode OpenDiscussions festzulegen. Im folgenden Beispiel wird der dritte Server in der DiscussionServers-Auflistung als Standarddiskussionsserver festgelegt.

dscServers(3).SetAsDefault


DiscussionServers-Auflistung

Eine Auflistung von DiscussionServer-Objekten, die Diskussionsserver in der Microsoft Office-Hostanwendung darstellen.

Verwenden der DiscussionServers-Auflistung

Verwenden Sie die DiscussionServers-Methode des Global-Objekts, um die DiscussionServers-Auflistung für alle auf dem verwendeten Computer registrierten Diskussionsserver zurückzugeben. Im folgenden Beispiel wird die DiscussionServers-Auflistung zurückgegeben und ein Meldungsfeld mit der Anzahl der Server in der Auflistung angezeigt.

Dim dscDiscussionServersCollection As DiscussionServers
Set dscDiscussionServersCollection = DiscussionServers
MsgBox dscDiscussionServersCollection.Count

Verwenden Sie die Add-Methode, um der Auflistung einen neuen Diskussionsserver hinzuzufügen. Im folgenden Beispiel wird ein neuer Diskussionsserver mit dem Anzeigenamen "Sample Server" und dem Uniform Resource Locator (URL) http://samples.microsoft.com hinzugefügt.

Dim dscServers As DiscussionServers
Set dscServers = DiscussionServers
dscServers.Add "Sample Server", _
    "http://samples.microsoft.com/"

Verwenden Sie DiscussionServers(Index), um ein einzelnes DiscussionServer-Objekt zurückzugeben, wobei Index der Index des angegebenen Diskussionsservers ist. Im folgenden Beispiel wird die Variable dscAccounting auf den dritten Server in der DiscussionServers-Auflistung gesetzt.

Set dscAccounting = dscServers(3)


Global-Objekt

Stellt eine Instanz der Microsoft Office Servererweiterungen-(OSE-)Bibliothek dar. Mit dem Global-Objekt können Sie Diskussionsservern Abonnements hinzufügen, den Namen des aktuellen Microsoft Office-Benutzers abrufen und die Auflistung der Diskussionsserver oder Diskussionen auf dem OSE-Host zurückgeben.

Verwenden des Global-Objekts

Verwenden Sie die AddOfficeServerSubscription-Methode, um ein Dokumentabonnement für die angegebene Datei oder den angegebenen Ordner zu erstellen. Sie können diese Methode auch verwenden, um automatisch E-Mail-Nachrichten zu senden, wenn bestimmte Ereignisse eintreten oder um benachrichtigt zu werden, wenn ein bestimmter Autor eine neue Diskussion bereitstellt oder eine vorhandene Diskussion ändert. Im folgenden Beispiel wird die Datei http://samples.microsoft.com abonniert und an jedem Tag, an dem der Benutzer Jim Hance Diskussionen löscht, eine E-Mail-Nachricht an someone@microsoft.com gesendet.

AddOfficeServerSubscription _
    "http://samples.microsoft.com", , _
    oseNotifyWhenDiscussionDeleted, _
    "someone@microsoft.com", _
    oseMailDaily, "Jim Hance", True

Verwenden Sie die CurrentUserName-Eigenschaft, um den Namen des aktuellen Microsoft Office-Benutzers zurückzugeben. Im folgenden Beispiel wird ein Meldungsfeld mit dem Namen des aktuellen Benutzers angezeigt.

MsgBox "The current Microsoft Office user is " & _
    CurrentUserName

Verwenden Sie die DiscussionServers-Methode, um die DiscussionServers-Auflistung zurückzugeben, die auf dem derzeit verwendeten Computer registriert ist. Im folgenden Beispiel wird die DiscussionServers-Auflistung zurückgegeben und ein Meldungsfeld mit der Anzahl der Diskussionsserver angezeigt.

Dim dscDiscussionServersCollection As DiscussionServers
Set dscDiscussionServersCollection = DiscussionServers
MsgBox dscDiscussionServersCollection.Count

Verwenden Sie die OpenDiscussions-Methode, um die Discussions-Auflistung für das Dokument zurückzugeben, das durch den Uniform Resource Locator (URL) angegeben wird. Im folgenden Beispiel wird die Discussions-Auflistung für den Ordner http://examples.microsoft.com zurückgegeben.

Set dscDiscussions = _
    OpenDiscussions("http://examples.microsoft.com")


Author-Eigenschaft

Ruft den Benutzernamen des Autors des aktuellen Diskussionselements ab. Schreibgeschützter String-Wert.


Beispiel für Author-Eigenschaft

In diesem Beispiel wird der boolesche Wert positiveMatch auf True gesetzt, wenn die Author-Eigenschaft den Namen “Jim Hance” zurückgibt.

Dim dscDiscussions As Discussions
Dim positiveMatch As Boolean
Set dscDiscussions = OpenDiscussions("http://samples.microsoft.com")
If dscDiscussions(1).Discussions(2).Author = "Jim Hance" Then
    positiveMatch = True
End If


AutoCommit-Eigenschaft

Gibt einen Wert zurück bzw. setzt einen Wert, der angibt, ob Änderungen an den Eigenschaften des angegebenen Discussion-Objekts sich sofort auf den Diskussionsspeicher auswirken. Boolean-Wert mit Schreib-Lese-Zugriff.

Hinweise

Wenn diese Eigenschaft auf True gesetzt ist, werden alle programmatischen Änderungen an einzelnen Eigenschaften eines Discussion-Objekts sofort im Diskussionsspeicher festgeschrieben. Hat die Eigenschaft den Wert False, werden Änderungen an Eigenschaften erst dann im Diskussionsspeicher festgeschrieben, wenn die Commit-Methode aufgerufen wird. Wird die Commit-Methode nicht vor Beenden der Sitzung aufgerufen, gehen alle noch ausstehenden Änderungen an Eigenschaften verloren. Der Standardwert ist True.

Aus Gründen der Leistungssteigerung empfiehlt es sich, AutoCommit auf False zu setzen und bei Bedarf die Commit-Methode zu verwenden.


Beispiel für AutoCommit-Eigenschaft

In diesem Beispiel wird die AutoCommit-Eigenschaft für das angegebene Discussion-Objekt auf False gesetzt.

Dim dscDiscussions As Discussions
Set dscDiscussions = OpenDiscussions("http://samples.microsoft.com")
dscDiscussions(1).Discussions(1).AutoCommit = False


Bookmark-Eigenschaft

Der eindeutige Bezeichner für die Position des angegebenen Discussion-Objekts im Dokument. String-Wert mit Schreib-Lese-Zugriff.


Beispiel für Bookmark-Eigenschaft

In diesem Beispiel wird die Textmarke für die angegebene Diskussion auf "Supplies" gesetzt.

Dim dscDiscussions As Discussions
Set dscDiscussions = OpenDiscussions("http://samples.microsoft.com")
dscDiscussions(1).Discussions(3).Bookmark = _
    "Supplies"


Count-Eigenschaft

Gibt die Anzahl der Elemente in der angegebenen Auflistung zurück. Schreibgeschützter Long-Wert.

Hinweise

Discussions(1).Count gibt die Anzahl der Elemente in der ersten Diskussion der Discussions-Auflistung zurück. Die Count-Eigenschaft zählt jedoch nicht rekursiv, und Diskussionen, die Antworten auf das Discussion(1)-Objekt sind, werden nicht mit einbezogen.


Beispiel für Count-Eigenschaft

In diesem Beispiel wird ein Meldungsfeld mit der Anzahl aller Diskussionen in der Discussions-Auflistung.

Dim dscDiscussions As Discussions
Set dscDiscussions = _
    OpenDiscussions("http://examples.microsoft.com")
dscDiscussions.Add "Supply room questions", _
    "Did anyone order staples?",
MsgBox dscDiscussions.Count


CurrentUserName-Eigenschaft

Gibt den Namen des aktuellen Microsoft Office-Benutzers zurück. Schreibgeschützter String-Wert.


Beispiel für CurrentUserName-Eigenschaft

In diesem Beispiel wird ein Meldungsfeld mit dem Namen des aktuellen Microsoft Office-Benutzers angezeigt.

MsgBox "The current Microsoft Office user is " & _
    CurrentUserName


Discussions-Eigenschaft

Gibt die Auflistung aller Discussion-Objekte zurück, die Antworten auf das angegebene Discussion-Objekt sind. Schreibgeschützter Object-Wert.

Hinweise

Die zurückgegebene Auflistung kann auch eine Discussions-Auflistung enthalten, die aus Antworten auf eine übergeordnete Diskussion besteht, und auf die Sie mit Hilfe der Discussions-Eigenschaft für ein bestimmtes Discussion-Objekt innerhalb dieser Auflistung zugreifen können. Für die Anzahl der Ebenen in Diskussionen gibt es keine funktionale Begrenzung, abgesehen von den Beschränkungen des Massenspeichers für Ihren Server.


Beispiel für Discussions-Eigenschaft

In diesem Beispiel wird mit Hilfe der Discussions-Eigenschaft eine Diskussion zurückgegeben, die eine Antwort auf die angegebene Diskussion ist. Anschließend wird das Thema der zurückgegebenen Diskussion auf "More Supply Questions" gesetzt.

Dim dscDiscussions As Discussions
Set dscDiscussions = OpenDiscussions("http://samples.microsoft.com")
dscDiscussions(1).Discussions(3).Subject = _
    "More Supply Questions


FriendlyName-Eigenschaft

Legt den Anzeigenamen des angegebenen Diskussionsservers fest bzw. gibt ihn zurück. String-Wert mit Schreib-Lese-Zugriff.


Beispiel für FriendlyName-Eigenschaft

In diesem Beispiel wird der Anzeigename des angegebenen Diskussionsservers auf "Accounting Department Information Server" geändert.

dscServers(1).FriendlyName = _
    "Accounting Department Information Server"


Index-Eigenschaft

Der Index des angegebenen Discussion-Objekts innerhalb der Discussions-Auflistung. Schreibgeschützter Integer-Wert.


Beispiel für Index-Eigenschaft

In diesem Beispiel wird die Index-Eigenschaft verwendet, um die Position des angegebenen Discussion-Objekts in der Discussions-Auflistung zu ermitteln.

Set myResponse = dscDiscussions(1).Discussions.Add _
    ("Supply information", "Staples are here!", "Staples")
MsgBox myResponse.Index


Item-Eigenschaft

Gibt ein Discussion-Objekt aus einer Discussions-Auflistung bzw. ein DiscussionServer-Objekt aus einer DiscussionServers-Auflistung zurück.

Syntax

expression.Item(Index)

expression Erforderlich. Ein Ausdruck, der ein Discussion- oder DiscussionServer-Objekt zurückgibt.

Index Erforderlicher Variant-Wert. Der Index der Diskussion bzw. des Diskussionsservers, die bzw. der zurückgegeben wird.


Beispiel für Item-Eigenschaft

In diesem Beispiel wird mit Hilfe der Item-Eigenschaft ein Meldungsfeld angezeigt, das den Namen des Autors der zweiten Antwort auf die fünfte Diskussion in der aktuellen Datei bzw. im aktuellen Ordner angibt.

MsgBox dscDiscussions.Item(5).Discussions.Item(2).Author


LoginName-Eigenschaft

Der Microsoft Windows NT-Alias des Autors des angegebenen Discussion-Objekts. Schreibgeschützter String-Wert.

Hinweise

Der Anmeldename ist in der Regel der gleiche Name wie der E-Mail-Alias des Benutzers.


Beispiel für LoginName-Eigenschaft

In diesem Beispiel wird ein Meldungsfeld mit dem Anmeldenamen des aktuellen Microsoft Windows NT-Benutzers angezeigt.

MsgBox dscDiscussions(1).LoginName


Parent-Eigenschaft

Gibt das übergeordnete Objekt für das angegebene Objekt an. Schreibgeschützter Object-Wert.


ServerAddress-Eigenschaft

Legt den Uniform Resource Locator (URL) für den angegebenen Diskussionsserver fest bzw. gibt ihn zurück. Schreibgeschützter String-Wert.


Beispiel für ServerAddress-Eigenschaft

In diesem Beispiel wird der URL des angegebenen Diskussionsservers auf http://example.microsoft.com geändert.

dscServers(1).ServerAddress = _
    "http://example.microsoft.com/"


Subject-Eigenschaft

Gibt das Thema des angegebenen Discussion-Objekts zurück bzw. legt es fest. String-Wert mit Schreib-Lese-Zugriff.


Beispiel für Subject-Eigenschaft

In diesem Beispiel wird das Thema der angegebenen Diskussion auf "More Supply Questions" gesetzt.

Dim dscDiscussions As Discussions
Set dscDiscussions = OpenDiscussions("http://samples.microsoft.com")
dscDiscussions(1).Discussions(3).Subject = _
    "More Supply Questions"


Text-Eigenschaft

Gibt den Textkörper des angegebenen Discussion-Objekts zurück bzw. legt ihn fest. String-Wert mit Schreib-Lese-Zugriff.

Hinweise

Eine Diskussion kann bis zu 64 KB Text enthalten.


Beispiel für Text-Eigenschaft

In diesem Beispiel wird der Text der angegebenen Diskussion auf "Who do I see to get more staples?" gesetzt.

Dim dscDiscussions As DiscussionsSet dscDiscussions = OpenDiscussions("http://samples.microsoft.com")

dscDiscussions(1).Discussions(3).Text = _
    "Who do I see to get more staples?"


Timestamp-Eigenschaft

Gibt das Datum und die Uhrzeit der Erstellung oder der letzten Änderung des Discussion-Objekts zurück. Schreibgeschützter Date-Wert.


Beispiel für Timestamp-Eigenschaft

In diesem Beispiel wird das Datum und die Uhrzeit der Erstellung oder der letzten Änderung der angegebenen Diskussion angezeigt.

MsgBox dscDiscussions(1).Timestamp


URL-Eigenschaft

Gibt den Uniform Resource Locator (URL) für das Dokument zurück, das die angegebene Discussions-Auflistung enthält. Schreibgeschützter String-Wert.


Beispiel für URL-Eigenschaft

In diesem Beispiel wird der URL für die angegebene Discussions-Auflistung angezeigt.

Dim dscDiscussions As Discussions
Set dscDiscussions = OpenDiscussions("http://samples.microsoft.com")
MsgBox dscDiscussions.URL


Zurückgeben eines Objekts aus einer Auflistung

Die Item-Eigenschaft gibt ein einziges Objekt aus einer Auflistung zurück. Im folgenden Beispiel wird die dscSupplies-Variable auf ein Discussion-Objekt gesetzt, das die erste Diskussion in der Discussions-Auflistung darstellt.

Dim dscDiscussions As Discussions
Set dscDiscussions = _
    OpenDiscussions("http://samples.microsoft.com")
Dim dscSupplies As Discussion
Set dscSupplies = dscDiscussions.Item(1)

Da die Item-Eigenschaft die Standardeigenschaft für die meisten Auflistungen ist, können Sie die gleiche Anweisung knapper formulieren, indem Sie das Item-Schlüsselwort weglassen.

Set dscSupplies = dscDiscussions(1)

Weitere Informationen über eine bestimmte Auflistung finden Sie im Hilfethema zu der betreffenden Auflistung oder zu der Item-Eigenschaft der Auflistung.